Re: [PATCH 4/6] drm/amdkfd: Separate mqd allocation and initialization

2019-06-06 Thread Kuehling, Felix
On 2019-06-06 5:40 p.m., Zeng, Oak wrote: > Introduce a new mqd allocation interface and split the original > init_mqd function into two functions: allocate_mqd and init_mqd. > Also renamed uninit_mqd to free_mqd. This is preparation work to > fix a circular lock dependency. > > Change-Id:

[PATCH 4/6] drm/amdkfd: Separate mqd allocation and initialization

2019-06-06 Thread Zeng, Oak
Introduce a new mqd allocation interface and split the original init_mqd function into two functions: allocate_mqd and init_mqd. Also renamed uninit_mqd to free_mqd. This is preparation work to fix a circular lock dependency. Change-Id: I26e53ee1abcdd688ad11d35b433da77e3fa1bee7 Signed-off-by: Oak

Re: [PATCH 4/6] drm/amdkfd: Separate mqd allocation and initialization

2019-06-06 Thread Kuehling, Felix
On 2019-06-06 2:25 p.m., Zeng, Oak wrote: > Introduce a new mqd allocation interface and split the original > init_mqd function into two functions: allocate_mqd and init_mqd. > Also renamed uninit_mqd to free_mqd. This is preparation work to > fix a circular lock dependency. > > Change-Id:

[PATCH 4/6] drm/amdkfd: Separate mqd allocation and initialization

2019-06-06 Thread Zeng, Oak
Introduce a new mqd allocation interface and split the original init_mqd function into two functions: allocate_mqd and init_mqd. Also renamed uninit_mqd to free_mqd. This is preparation work to fix a circular lock dependency. Change-Id: I26e53ee1abcdd688ad11d35b433da77e3fa1bee7 Signed-off-by: Oak

Re: [PATCH 4/6] drm/amdkfd: Separate mqd allocation and initialization

2019-06-05 Thread Kuehling, Felix
Nice. Surprisingly this actually resulted in slightly fewer lines of code. Some suggestions: Let's also rename uninit_mqd to free_mqd, as it is the counterpart to allocate_mqd, not init_mqd. And unless I'm missing something, init_mqd and update_mqd cannot fail now that allocate_mqd has been

[PATCH 4/6] drm/amdkfd: Separate mqd allocation and initialization

2019-06-05 Thread Zeng, Oak
Introduce a new mqd allocation interface and split the original init_mqd function into two functions: allocate_mqd and init_mqd. This is preparation work to fix a circular lock dependency. Change-Id: I26e53ee1abcdd688ad11d35b433da77e3fa1bee7 Signed-off-by: Oak Zeng ---

[PATCH 4/6] drm/amdkfd: Separate mqd allocation and initialization

2019-06-03 Thread Zeng, Oak
Introduce a new mqd allocation interface and split the original init_mqd function into two functions: allocate_mqd and init_mqd. This is preparation work to fix a circular lock dependency. Change-Id: I26e53ee1abcdd688ad11d35b433da77e3fa1bee7 Signed-off-by: Oak Zeng ---