Re: [PATCH] drm/amdgpu/powerplay: drop a redundant NULL check

2016-11-15 Thread Colin Ian King
On 15/11/16 16:47, Alex Deucher wrote: > Left over from an earlier rev of the patch. > > Cc: Dan Carpenter > Cc: Colin King > Signed-off-by: Alex Deucher > --- > drivers/gpu/drm/amd/powerplay/hwmgr/smu7_hwmgr.c | 2

Re: [PATCH] drm/amdgpu/powerplay: drop a redundant NULL check

2016-11-15 Thread Colin Ian King
-EINVAL; > sclk_table = > table_info->vdd_dep_on_sclk; > > for (j = 1; j < sclk_table->count; j++) > { > Thanks Alex. Acked-by: Colin Ian King <colin.k...@canonical.com> ___ amd-gfx mailing list amd-gfx@lists.freedesktop.org https://lists.freedesktop.org/mailman/listinfo/amd-gfx

Re: [PATCH][next] drm/amd/pp: initialized result to zero before or'ing in data

2018-06-07 Thread Colin Ian King
On 06/06/18 13:18, Colin King wrote: > From: Colin Ian King > > The current use of result is or'ing in values and checking for > a non-zero result, however, result is not initialized to zero > so it potentially contains garbage to start with. Fix this by > initializing it t

Re: [PATCH][next] drm/amdgpu/psp: fix incorrect logic when checking asic_type

2019-07-04 Thread Colin Ian King
On 04/07/2019 17:22, walter harms wrote: > > > Am 04.07.2019 16:23, schrieb Colin King: >> From: Colin Ian King >> >> Currently the check of the asic_type is always returning true because >> of the use of ||. Fix this by using && instead. Also b

Re: [PATCH][next[ drm/amd/display: fix a couple of spelling mistakes

2019-06-26 Thread Colin Ian King
On 26/06/2019 14:25, Daniel Stone wrote: > Hi Colin, > > On Wed, 26 Jun 2019 at 14:24, Colin King wrote: >> There are a couple of spelling mistakes in dm_error messages and >> a comment. Fix these. > > Whilst there, you might fix the '[next[' typo in the commit message. Ugh, fickle fingers.

Re: [PATCH] drm/amdgpu/powerplay: fix spelling mistake "unsuported" -> "unsupported"

2019-08-13 Thread Colin Ian King
[drm-next] On 13/08/2019 11:33, Colin King wrote: > From: Colin Ian King > > There is a spelling mistake in a pr_err error message. Fix it. Also > add a space after a comma to clean up a checkpatch warning. > > Signed-off-by: Colin Ian King > --- > drivers/gpu/drm/a

re: drm/amd/display: Add HDCP module - static analysis bug report

2019-10-03 Thread Colin Ian King
Hi, Static analysis with Coverity has detected a potential issue with function validate_bksv in drivers/gpu/drm/amd/display/modules/hdcp/hdcp1_execution.c with recent commit: commit ed9d8e2bcb003ec94658cafe9b1bb3960e2139ec Author: Bhawanpreet Lakha Date: Tue Aug 6 17:52:01 2019 -0400

Re: [PATCH] drm/amdkfd: add missing void argument to function kgd2kfd_init

2019-10-05 Thread Colin Ian King
On 05/10/2019 19:10, Randy Dunlap wrote: > On 10/5/19 10:58 AM, Colin King wrote: >> From: Colin Ian King >> >> Function kgd2kfd_init is missing a void argument, add it >> to clean up the non-ANSI function declaration. >> >> Signed-off-by: Colin Ian King &

re: drm/amd/display: make PSR static screen entry within 30 ms

2020-01-17 Thread Colin Ian King
Hi, Static analysis with Coverity has detected a division by zero in the following commit: commit 5b5abe9526073ccbf3032d27b5864520829cdd9c Author: Anthony Koo Date: Mon Dec 9 17:26:34 2019 -0500 drm/amd/display: make PSR static screen entry within 30 ms Specifically: unsigned

NAK: [PATCH][next] drm/amd/display: fix spelling mistake "Usupported" -> "Unsupported"

2020-08-04 Thread Colin Ian King
On 04/08/2020 18:34, Colin King wrote: > From: Colin Ian King > > There are spelling mistakes in two DRM_ERROR error messages. Fix them. > > Signed-off-by: Colin Ian King > --- > drivers/gpu/drm/amd/display/amdgpu_dm/amdgpu_dm.c | 4 ++-- > 1 file changed, 2 in

Re: [PATCH] drm/amdgpu: fix spelling mistake "Falied" -> "Failed"

2020-08-05 Thread Colin Ian King
On 05/08/2020 22:27, Alex Deucher wrote: > On Wed, Aug 5, 2020 at 4:53 PM Joe Perches wrote: >> >> On Wed, 2020-08-05 at 16:01 -0400, Alex Deucher wrote: >>> On Wed, Aug 5, 2020 at 7:35 AM Colin King wrote: >>>> From: Colin Ian King >>>> >>

Re: [PATCH][next] drm/amdgpu: Add missing BOOTUP_DEFAULT to profile_name[]

2021-01-15 Thread Colin Ian King
On 15/01/2021 10:07, Christophe JAILLET wrote: > Le 15/01/2021 à 10:37, Colin Ian King a écrit : >> On 12/01/2021 10:07, Dan Carpenter wrote: >>> On Mon, Jan 11, 2021 at 11:46:38AM +, Colin King wrote: >>>> From: Colin Ian King >>>> >>>

Re: [PATCH][next] drm/amdgpu: Add missing BOOTUP_DEFAULT to profile_name[]

2021-01-15 Thread Colin Ian King
On 12/01/2021 10:07, Dan Carpenter wrote: > On Mon, Jan 11, 2021 at 11:46:38AM +, Colin King wrote: >> From: Colin Ian King >> >> A recent change added a new BOOTUP_DEFAULT power profile mode >> to the PP_SMC_POWER_PROFILE enum but omitted updating the >>

re: drm/amdgpu/acpi: unify ATCS handling (v2) [uninitialized variable error]

2021-05-20 Thread Colin Ian King
Hi, Static analysis on linux-next with Coverity has detected an issue in drivers/gpu/drm/amd/amdgpu/amdgpu_acpi.c with the following commit: commit c1c4d8efdddec8a0ccc8525b29740640bd652ce8 Author: Alex Deucher Date: Wed May 19 15:47:42 2021 -0400 drm/amdgpu/acpi: unify ATCS handling (v2)

re: drm/amdkfd: implement counters for vm fault and migration

2021-07-06 Thread Colin Ian King
Hi, Static analysis with Coverity on linux-next has found a potential null pointer dereference in function svm_range_restore_pages in drivers/gpu/drm/amd/amdkfd/kfd_svm.c from the following commit: commit d4ebc2007040a0aff01bfe1b194085d3867328fd Author: Philip Yang Date: Tue Jun 22 00:12:32

re: drm/ttm: switch to per device LRU lock

2021-03-25 Thread Colin Ian King
Hi, Static analysis with Coverity in linux-next has detected an issue in drivers/gpu/drm/ttm/ttm_bo.c with the follow commit: commit a1f091f8ef2b680a5184db065527612247cb4cae Author: Christian König Date: Tue Oct 6 17:26:42 2020 +0200 drm/ttm: switch to per device LRU lock Instead of

re: drm/amd/display: Implement dmub trace event

2021-03-03 Thread Colin Ian King
Hi, Static analysis on linux-next wit Coverity has found a potential null pointer dereference in commit: commit 70732504c53b2d3aae2cebc457515a304672d5bb Author: Yongqiang Sun Date: Fri Feb 19 14:50:23 2021 -0500 drm/amd/display: Implement dmub trace event The analysis is as follows:

[PATCH] drm/amdgpu: Fix spelling mistake "regiser" -> "register"

2022-03-15 Thread Colin Ian King
There is a spelling mistake in a dev_error error message. Fix it. Signed-off-by: Colin Ian King --- drivers/gpu/drm/amd/amdgpu/amdgpu_virt.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/drivers/gpu/drm/amd/amdgpu/amdgpu_virt.c b/drivers/gpu/drm/amd/amdgpu/amdgpu_virt.c

[PATCH][next] drm/amdgpu: Fix missing assignment to variable r

2022-02-25 Thread Colin Ian King
/amdgpu_benchmark.c:168:7: warning: variable 'r' is uninitialized when used here [-Wuninitialized] Fixes: 9645c9c9fb15 ("drm/amdgpu: plumb error handling though amdgpu_benchmark()") Signed-off-by: Colin Ian King --- drivers/gpu/drm/amd/amdgpu/amdgpu_benchmark.c | 2 +- 1 file changed, 1 inser

[PATCH][next] drm/amdgpu: Fix a couple of spelling mistakes

2022-01-28 Thread Colin Ian King
There are two spelling mistakes in dev_err messages. Fix them. Signed-off-by: Colin Ian King --- drivers/gpu/drm/amd/amdgpu/amdgpu_virt.c | 4 ++-- 1 file changed, 2 insertions(+), 2 deletions(-) diff --git a/drivers/gpu/drm/amd/amdgpu/amdgpu_virt.c b/drivers/gpu/drm/amd/amdgpu/amdgpu_virt.c

[PATCH][next] drm/amd/display: fix spelling mistake: synatpics -> synaptics

2022-01-28 Thread Colin Ian King
There are quite a few spelling mistakes in various function names and error messages. Fix these. Signed-off-by: Colin Ian King --- .../amd/display/amdgpu_dm/amdgpu_dm_helpers.c | 32 +-- 1 file changed, 16 insertions(+), 16 deletions(-) diff --git a/drivers/gpu/drm/amd/display

[PATCH] drm/radeon: remove redundant assignment to reg

2022-01-19 Thread Colin Ian King
[deadcode.DeadStores] Signed-off-by: Colin Ian King --- drivers/gpu/drm/radeon/radeon_object.c | 1 - 1 file changed, 1 deletion(-) diff --git a/drivers/gpu/drm/radeon/radeon_object.c b/drivers/gpu/drm/radeon/radeon_object.c index 56ede9d63b12..87536d205593 100644 --- a/drivers/gpu/drm/radeon

[PATCH][next] drm/amd/display: Fix a handful of spelling mistakes in dml_print output

2023-10-17 Thread Colin Ian King
There are a few spelling mistakes and an minor grammatical issue in some dml_print messages. Fix these. Signed-off-by: Colin Ian King --- drivers/gpu/drm/amd/display/dc/dml2/display_mode_core.c | 6 +++--- 1 file changed, 3 insertions(+), 3 deletions(-) diff --git a/drivers/gpu/drm/amd/display

[PATCH][next] drm/amd: Fix spelling mistake "throtting" -> "throttling"

2023-08-23 Thread Colin Ian King
There is a spelling mistake in variable throtting_events, rename it to throttling_events. Signed-off-by: Colin Ian King --- drivers/gpu/drm/amd/pm/swsmu/smu11/arcturus_ppt.c| 6 +++--- drivers/gpu/drm/amd/pm/swsmu/smu13/aldebaran_ppt.c | 6 +++--- drivers/gpu/drm/amd/pm/swsmu/smu13

[PATCH][next] drm/amdkfd: Fix spelling mistake "mechanim" -> "mechanism"

2022-06-23 Thread Colin Ian King
There is a spelling mistake in a pr_debug message. Fix it. Signed-off-by: Colin Ian King --- drivers/gpu/drm/amd/amdgpu/amdgpu_amdkfd_gpuvm.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/drivers/gpu/drm/amd/amdgpu/amdgpu_amdkfd_gpuvm.c b/drivers/gpu/drm/amd/amdgpu

[PATCH][next] drm/amdgpu/display: Fix spelling mistake "supporing" -> "supporting"

2022-06-23 Thread Colin Ian King
There is a spelling mistake in a dml_print message. Fix it. Signed-off-by: Colin Ian King --- drivers/gpu/drm/amd/display/dc/dml/dcn32/display_mode_vba_32.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/drivers/gpu/drm/amd/display/dc/dml/dcn32/display_mode_vba_32.c b

[PATCH][next] drm/amd/display: Fix spelling mistake "supporing" -> "supporting"

2022-07-14 Thread Colin Ian King
There is a spelling mistake in a dml_print message. Fix it. Signed-off-by: Colin Ian King --- .../gpu/drm/amd/display/dc/dml/dcn314/display_mode_vba_314.c| 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/drivers/gpu/drm/amd/display/dc/dml/dcn314/display_mode_vba_314.c b

[PATCH][next] drm/amdkfd: Fix spelling mistake "detroyed" -> "destroyed"

2022-09-14 Thread Colin Ian King
There is a spelling mistake in a pr_debug message. Fix it. Signed-off-by: Colin Ian King --- drivers/gpu/drm/amd/amdkfd/kfd_migrate.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/drivers/gpu/drm/amd/amdkfd/kfd_migrate.c b/drivers/gpu/drm/amd/amdkfd/kfd_migrate.c index

[PATCH] drm/amd/display: Fix spelling mistake: "dram_clk_chanage" -> "dram_clk_change"

2022-12-08 Thread Colin Ian King
There is a spelling mistake in the struct field dram_clk_chanage. Fix it. Signed-off-by: Colin Ian King --- drivers/gpu/drm/amd/display/dc/dcn10/dcn10_hubbub.c | 8 drivers/gpu/drm/amd/display/dc/dcn10/dcn10_hw_sequencer.c | 2 +- .../drm/amd/display/dc/dcn10

[PATCH][next] drm/amd/pm: Fix spelling mistake "aquire" -> "acquire"

2023-04-17 Thread Colin Ian King
There is a spelling mistake in the smu_i2c_bus_access prototype. Fix it. Signed-off-by: Colin Ian King --- drivers/gpu/drm/amd/pm/powerplay/inc/hwmgr.h | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/drivers/gpu/drm/amd/pm/powerplay/inc/hwmgr.h b/drivers/gpu/drm/amd/pm

[PATCH][next] drm/amd/display: Fix spelling mistakes of function name in error message

2023-02-09 Thread Colin Ian King
The function name is being reported as dc_link_contruct when it is actually dc_link_construct_phy. Fix this by using %s and the __func__ for the function name. Signed-off-by: Colin Ian King --- drivers/gpu/drm/amd/display/dc/link/link_factory.c | 4 ++-- 1 file changed, 2 insertions(+), 2

[PATCH][next] drm/amdgpu: Fix a couple of spelling mistakes in info and debug messages

2023-05-22 Thread Colin Ian King
There are a couple of spelling mistakes, one in a dev_info message and the other in a dev_debug message. Fix them. Signed-off-by: Colin Ian King --- drivers/gpu/drm/amd/amdgpu/amdgpu_psp.c | 2 +- drivers/gpu/drm/amd/amdgpu/amdgpu_xcp.c | 2 +- 2 files changed, 2 insertions(+), 2 deletions

[PATCH] drm/amd/display: remove redundant initialization of variable remainder

2023-12-19 Thread Colin Ian King
Variable remainder is being initialized with a value that is never read, the assignment is redundant and can be removed. Also add a newline after the declaration to clean up the coding style. Signed-off-by: Colin Ian King --- drivers/gpu/drm/amd/display/dc/basics/conversion.c | 3 ++- 1 file

[PATCH][next] drm/amd/display: Fix spelling mistake "SMC_MSG_AllowZstatesEntr" -> "SMC_MSG_AllowZstatesEntry"

2023-12-07 Thread Colin Ian King
There is a spelling mistake in a smu_print message. Fix it. Signed-off-by: Colin Ian King --- drivers/gpu/drm/amd/display/dc/clk_mgr/dcn35/dcn35_smu.c | 8 1 file changed, 4 insertions(+), 4 deletions(-) diff --git a/drivers/gpu/drm/amd/display/dc/clk_mgr/dcn35/dcn35_smu.c b/drivers

[PATCH][next] drm/amdgpu: Fix spelling mistake "PRORITY" -> "PRIORITY"

2024-04-25 Thread Colin Ian King
There are spelling mistakes in a literal string and enums, fix these. Currently there are no uses of the enums that got renamed in this fix. Signed-off-by: Colin Ian King --- drivers/gpu/drm/amd/amdgpu/mes_v11_0.c| 2 +- drivers/gpu/drm/amd/include/mes_api_def.h | 2 +- drivers/gpu

[PATCH][next] drm/amd/display: Fix spelling various spelling mistakes

2024-04-25 Thread Colin Ian King
There are various spelling mistakes in dml2_printf messages, fix them. Signed-off-by: Colin Ian King --- .../dc/dml2/dml21/src/dml2_core/dml2_core_dcn4_calcs.c | 6 +++--- .../display/dc/dml2/dml21/src/dml2_core/dml2_core_shared.c | 6 +++--- 2 files changed, 6 insertions(+), 6 deletions