Re: Problems with DEFSYSTEM-DEPENDS-ON

2018-04-09 Thread Robert Goldman
I think Xach and I are trying to cope with essentially the same problem: lack of resources for a community project. On the one hand, Xach wants to stick with and old ASDF because it's a lot of trouble to maintain it, and he's afraid of breakage. OTOH, we don't have the resources to maintain

Re: Problems with DEFSYSTEM-DEPENDS-ON

2018-04-09 Thread Faré
On Mon, Apr 9, 2018 at 12:22 PM, Robert Goldman wrote: > On 9 Apr 2018, at 11:17, Attila Lendvai wrote: > >>> A cheesy fix would simply be to wrap it in IGNORE-ERRORS. But it might >>> cause >>> errors in its present form. >> >> >> >> i've learned, painfully, that

Re: Problems with DEFSYSTEM-DEPENDS-ON

2018-04-09 Thread Robert Goldman
On 9 Apr 2018, at 11:17, Attila Lendvai wrote: A cheesy fix would simply be to wrap it in IGNORE-ERRORS. But it might cause errors in its present form. i've learned, painfully, that indiscriminate ignore-errors will almost always bite you back (in the form of wasted debugging time), no

Re: Problems with DEFSYSTEM-DEPENDS-ON

2018-04-09 Thread Attila Lendvai
> A cheesy fix would simply be to wrap it in IGNORE-ERRORS. But it might cause > errors in its present form. i've learned, painfully, that indiscriminate ignore-errors will almost always bite you back (in the form of wasted debugging time), no matter how innocent they look. > This really is

Re: Problems with DEFSYSTEM-DEPENDS-ON

2018-04-09 Thread Robert Goldman
On 7 Apr 2018, at 15:56, Robert Dodier wrote: Thanks to everyone for their interest in this topic. In reference to https://github.com/quicklisp/quicklisp-client/pull/128/, it is only a minimal stop-gap measure which I found could fix the immediate problem which I encountered. I know very

Re: Problems with DEFSYSTEM-DEPENDS-ON

2018-04-07 Thread Robert Dodier
Thanks to everyone for their interest in this topic. In reference to https://github.com/quicklisp/quicklisp-client/pull/128/, it is only a minimal stop-gap measure which I found could fix the immediate problem which I encountered. I know very little about ASDF and Quicklisp, so I certainly had no

Re: Problems with DEFSYSTEM-DEPENDS-ON

2018-04-07 Thread Robert Goldman
OK, I think I understand now. This happens when we need quicklisp not just to load, but to install and load, defsystem depends on systems. I just looked at Robert Dodier's bug fix, https://github.com/quicklisp/quicklisp-client/pull/128/ and I'm a little concerned that it could raise an error

Re: Problems with DEFSYSTEM-DEPENDS-ON

2018-04-06 Thread Mark Evenson
> On Apr 2, 2018, at 18:23, Robert Goldman wrote: > > On 1 Apr 2018, at 7:57, Mark Evenson wrote: > > On Apr 1, 2018, at 14:20, Attila Lendvai att...@lendvai.name wrote: > > The usage of DEFSYSTEM-DEPENDS-ON to specify dependencies that will be > satisfied by

Re: Problems with DEFSYSTEM-DEPENDS-ON

2018-04-02 Thread Robert Goldman
On 1 Apr 2018, at 7:57, Mark Evenson wrote: On Apr 1, 2018, at 14:20, Attila Lendvai wrote: The usage of DEFSYSTEM-DEPENDS-ON to specify dependencies that will be satisfied by QL:QUICKLOAD no longer seems to be working in asdf-3.3.1. FTR, here's the history of this

Re: Problems with DEFSYSTEM-DEPENDS-ON

2018-04-01 Thread Mark Evenson
> On Apr 1, 2018, at 14:20, Attila Lendvai wrote: > >> The usage of DEFSYSTEM-DEPENDS-ON to specify dependencies that will be >> satisfied by QL:QUICKLOAD no longer seems to be working in asdf-3.3.1. > > FTR, here's the history of this issue: > >

Re: Problems with DEFSYSTEM-DEPENDS-ON

2018-04-01 Thread Attila Lendvai
> The usage of DEFSYSTEM-DEPENDS-ON to specify dependencies that will be > satisfied by QL:QUICKLOAD no longer seems to be working in asdf-3.3.1. FTR, here's the history of this issue: https://github.com/quicklisp/quicklisp-client/pull/122#issuecomment-160419822