* NEWS: Update.

2009-03-14 Thread Ralf Wildenhues
Pushed to master and branch-1-10 similarly. Cheers, Ralf * NEWS: Update. diff --git a/NEWS b/NEWS index e08a0ce..00ea9cf 100644 --- a/NEWS +++ b/NEWS @@ -1,5 +1,9 @@ New in 1.10.2a: + - The `gnupload' script has been revamped. + + - The `depcomp' and `compile' scripts now work with

[PATCH 0/N] parallel tests execution in Automake

2009-03-14 Thread Ralf Wildenhues
[ moving from automake@ ] [ N will be a dozen or so, apologies for the mail bombing ] * Ralf Wildenhues wrote on Sat, Mar 14, 2009 at 11:33:21AM CET: I've cleaned up the patch set for parallel tests execution in Automake, and put it in a public branch for people to poke with: git clone

[PATCH 02] parallel-tests: Ensure backward-compatible semantics.

2009-03-14 Thread Ralf Wildenhues
This patch is virtually unchanged compared to the previous version. Cheers, Ralf parallel-tests: Ensure backward-compatible semantics. For each test in Automake's test suite that uses TESTS, generate an identical one that uses the `parallel-tests' option, for coverage of

[PATCH 03] New tests for `parallel-tests'.

2009-03-14 Thread Ralf Wildenhues
Compared to http://article.gmane.org/gmane.comp.sysutils.automake.patches/3228, This patch has - LAZY_TEST_SUITE testing is moved to a later patch in the series. - DISABLE_HARD_ERRORS adjusted to Benoit's semantics, - tests/*-p.test listed in MAINTAINERCLEANFILES. Cheers, Ralf New tests for

Re: [PATCH 04] Documentation for the parallel-tests driver.

2009-03-14 Thread Ralf Wildenhues
Compared to http://article.gmane.org/gmane.comp.sysutils.automake.patches/3229 this patch has - docs adjusted to DISABLE_HARD_ERRORS changes and TEST_EXTENSIONS renaming, - VERBOSE change of semantics: hint user to produce verbose tests by default, as suggested by Akim. Cheers, Ralf

Re: [PATCH 05] Overhaul of tests/README.

2009-03-14 Thread Ralf Wildenhues
Overhaul of tests/README. * tests/README: General overhaul. Mention parallel test suite execution, the test-suite.log file; document `Exit' vs. `exit', `defs' vs. `defs-p', the naming of `parallel-tests' tests. * README: Simplify, point to tests/README. diff --git

[PATCH 07] Use append mode to capture parallel test output.

2009-03-14 Thread Ralf Wildenhues
D'oh. Wonder how often we will keep encountering this. Cheers, Ralf Use append mode to capture parallel test output. * tests/lisp8.test: Use append mode for output from `make -j', to avoid dropped lines. * tests/parallel-tests3.test: Likewise. diff --git a/tests/lisp8.test

[PATCH 08] Match XFAIL_TESTS correctly with Solaris make.

2009-03-14 Thread Ralf Wildenhues
Without this patch, Solaris make did not match any XFAIL_TESTS in a VPATH setup. Cheers, Ralf Match XFAIL_TESTS correctly with Solaris make. * lib/am/check.am [PARALLEL_TESTS]: VPATH rewriting may have changed test names, so srcdir needs to be taken into account explicitly

[PATCH 10] Fix parallel-tests with empty $(TESTS) for BSD make.

2009-03-14 Thread Ralf Wildenhues
TESTS= TEST_LOGS=$(TESTS:=.log) would otherwise barf with an error that the file `.log' could not be remade. Since this file name also looks like a single suffix rule, there is no way to portably write a rule to ignore it. So in this case we have to overwrite TESTS. Cheers, Ralf Fix

Re: [PATCH 11] Fix LAZY_TEST_SUITE handling and $(TEST_SUITE_LOG) recreation.

2009-03-14 Thread Ralf Wildenhues
Oh, what a joyful patch; cost me most brains. Here's why: It would have been cool if make check LAZY_TEST_SUITE=yes on an up to date test directory would have no work to do at all. Well. Couple of things wrong with the prior semantics: - there would be no summary output on stdout in that

proposed patch: parallel-tests: also record logs of SKIPped tests.

2009-03-14 Thread Ralf Wildenhues
This is a patch that I don't know whether I want it or not. Package authors may be interested in SKIPs and why they happen, or not. (Could also be solved with leaving the choice to the package author and/or user, by some TEST_RECORD_SKIPS variable or so). Comments appreciated. Thanks, Ralf

proposed patch: parallel-tests: per-extension test driver: ext_COMPILE.

2009-03-14 Thread Ralf Wildenhues
This needs some thinking about the naming scheme to use. Here's why: The current Automake default compile naming scheme has the assumption that file extensions have only one default processing output. For example, .c and .cpp become .$(OBJEXT), .y become .c, and so on. Texinfo is an exception,

Re: [PATCH 07] Use append mode to capture parallel test output.

2009-03-14 Thread Akim Demaille
Le 14 mars 09 à 11:56, Ralf Wildenhues a écrit : D'oh. Wonder how often we will keep encountering this. Hi Ralf, I have not understood what's going on here. Are these files running concurrently in the same pwd? Cheers, Ralf Use append mode to capture parallel test output. *

Re: [PATCH 07] Use append mode to capture parallel test output.

2009-03-14 Thread Ralf Wildenhues
* Akim Demaille wrote on Sat, Mar 14, 2009 at 01:24:28PM CET: Le 14 mars 09 à 11:56, Ralf Wildenhues a écrit : D'oh. Wonder how often we will keep encountering this. I have not understood what's going on here. Are these files running concurrently in the same pwd? No. The issue is

Re: [PATCH 11] Fix LAZY_TEST_SUITE handling and $(TEST_SUITE_LOG) recreation.

2009-03-14 Thread Akim Demaille
Le 14 mars 09 à 12:01, Ralf Wildenhues a écrit : Oh, what a joyful patch; cost me most brains. Here's why: It would have been cool if make check LAZY_TEST_SUITE=yes on an up to date test directory would have no work to do at all. Well. Couple of things wrong with the prior semantics: -

Re: proposed patch: parallel-tests: per-extension test driver: ext_COMPILE.

2009-03-14 Thread Akim Demaille
Le 14 mars 09 à 12:08, Ralf Wildenhues a écrit : Corollary: the test driver may not be called CXXCOMPILE. General: For extension `.ext', we cannot use `EXTCOMPILE' as driver. ext_COMPILE or extCOMPILE seem awkward to me too, as these do not allow for generalization either, and the

Re: [PATCH 11] Fix LAZY_TEST_SUITE handling and $(TEST_SUITE_LOG) recreation.

2009-03-14 Thread Akim Demaille
Le 14 mars 09 à 13:39, Akim Demaille a écrit : I often use STRICT_TEST_LOGS = $(shell $(LIST_FAILED_TEST_LOGS)) which makes all failing test strict. In other words, successful tests are not rerun by make check, but failing tests are. This is because our test suite sometimes hits

Re: [PATCH 11] Fix LAZY_TEST_SUITE handling and $(TEST_SUITE_LOG) recreation.

2009-03-14 Thread Akim Demaille
Le 14 mars 09 à 14:46, Ralf Wildenhues a écrit : * Akim Demaille wrote on Sat, Mar 14, 2009 at 02:25:03PM CET: FWIW, I also noticed that we sometimes had tests that were removed/ renamed that were still marked as XFAILs. So I use this in some of my test suites: Why are these not simply