Re: [B.A.T.M.A.N.] [PATCH] batman-adv: Remove declaration of only locally used functions

2012-02-07 Thread Marek Lindner
On Tuesday, February 07, 2012 06:11:53 Sven Eckelmann wrote: The blaII code removed references to two functions outside of the own source file. route_unicast_packet can be marked as static since 9c11509d3bbf914060be1bcb4448ea69d571fcb9 and tt_global_del since

[B.A.T.M.A.N.] B.A.T.M.A.N. V - the next steps

2012-02-07 Thread Marek Lindner
Hi folks, after having the B.A.T.M.A.N. IV routing code moved into one single file, a preliminary routing protocol API and an easy to use routing protocol switch it is time to move forward with B.A.T.M.A.N. V. B.A.T.M.A.N. V is going to split the various tasks handled by the B.A.T.M.A.N. IV

[B.A.T.M.A.N.] [PATCH 1/8] batman-adv: move ogm initialization into the proper function

2012-02-07 Thread Marek Lindner
Signed-of-by: Marek Lindner lindner_ma...@yahoo.de --- hard-interface.c |8 +++- 1 files changed, 7 insertions(+), 1 deletions(-) diff --git a/hard-interface.c b/hard-interface.c index 612f2c8..e16c996 100644 --- a/hard-interface.c +++ b/hard-interface.c @@ -337,7 +337,6 @@ int

[B.A.T.M.A.N.] [PATCH 4/8] batman-adv: add iface_disable() callback to routing API

2012-02-07 Thread Marek Lindner
Signed-off-by: Marek Lindner lindner_ma...@yahoo.de --- bat_iv_ogm.c |7 +++ hard-interface.c |3 +-- main.c |1 + types.h |2 ++ 4 files changed, 11 insertions(+), 2 deletions(-) diff --git a/bat_iv_ogm.c b/bat_iv_ogm.c index 4ac2d1d..98c41f5 100644

[B.A.T.M.A.N.] [PATCH 5/8] batman-adv: handle routing code initialization properly

2012-02-07 Thread Marek Lindner
Signed-off-by: Marek Lindner lindner_ma...@yahoo.de --- bat_iv_ogm.c | 11 ++- hard-interface.c | 14 ++ types.h |2 +- 3 files changed, 17 insertions(+), 10 deletions(-) diff --git a/bat_iv_ogm.c b/bat_iv_ogm.c index 98c41f5..d944a0b 100644 ---

[B.A.T.M.A.N.] [PATCH 6/8] batman-adv: refactoring API: find generalized name for bat_ogm_init_primary callback

2012-02-07 Thread Marek Lindner
Signed-off-by: Marek Lindner lindner_ma...@yahoo.de --- bat_iv_ogm.c |4 ++-- hard-interface.c |2 +- main.c |2 +- types.h |4 ++-- 4 files changed, 6 insertions(+), 6 deletions(-) diff --git a/bat_iv_ogm.c b/bat_iv_ogm.c index d944a0b..b82a772 100644 ---

[B.A.T.M.A.N.] [PATCH 7/8] batman-adv: rename BATMAN_OGM_LEN to BATMAN_OGM_HLEN

2012-02-07 Thread Marek Lindner
Using BATMAN_OGM_LEN leaves one with the impression that this is the full packet size which is not the case. Therefore the variable is renamed. Signed-off-by: Marek Lindner lindner_ma...@yahoo.de --- bat_iv_ogm.c | 12 ++-- packet.h |2 +- routing.c|2 +- send.c |

[B.A.T.M.A.N.] [PATCH 8/8] batman-adv: mark existing ogm variables as batman iv

2012-02-07 Thread Marek Lindner
The coming protocol changes also will have a part called OGM. That makes it necessary to introduce a distinction in the code base. Signed-off-by: Marek Lindner lindner_ma...@yahoo.de --- bat_iv_ogm.c |4 ++-- hard-interface.c |2 +- packet.h |4 ++-- 3 files changed, 5

Re: [B.A.T.M.A.N.] [PATCH 3/8] batman-adv: randomize initial seqno to avoid collision

2012-02-07 Thread Marek Lindner
On Tuesday, February 07, 2012 17:33:14 Martin Hundebøll wrote: On 2012-02-07 10:20, Marek Lindner wrote: Signed-off-by: Marek Lindnerlindner_ma...@yahoo.de --- bat_iv_ogm.c |5 + 1 files changed, 5 insertions(+), 0 deletions(-) diff --git a/bat_iv_ogm.c b/bat_iv_ogm.c

Re: [B.A.T.M.A.N.] [PATCH 3/8] batman-adv: randomize initial seqno to avoid collision

2012-02-07 Thread Martin Hundebøll
On 2012-02-07 12:10, Marek Lindner wrote: + unsigned long random_seqno; + + /* randomize initial seqno to avoid collision */ + get_random_bytes(random_seqno, sizeof(unsigned long)); + atomic_set(hard_iface-seqno, (uint32_t)random_seqno); Wouldn't it be better to

Re: [B.A.T.M.A.N.] [PATCH 3/8] batman-adv: randomize initial seqno to avoid collision

2012-02-07 Thread Marek Lindner
On Tuesday, February 07, 2012 19:13:27 Martin Hundebøll wrote: On 2012-02-07 12:10, Marek Lindner wrote: + unsigned long random_seqno; + + /* randomize initial seqno to avoid collision */ + get_random_bytes(random_seqno, sizeof(unsigned long)); +

Re: [B.A.T.M.A.N.] [PATCH 3/8] batman-adv: randomize initial seqno to avoid collision

2012-02-07 Thread Andrew Lunn
On Tue, Feb 07, 2012 at 05:20:46PM +0800, Marek Lindner wrote: Signed-off-by: Marek Lindner lindner_ma...@yahoo.de --- bat_iv_ogm.c |5 + 1 files changed, 5 insertions(+), 0 deletions(-) diff --git a/bat_iv_ogm.c b/bat_iv_ogm.c index 3eff7f0..4ac2d1d 100644 --- a/bat_iv_ogm.c

Re: [B.A.T.M.A.N.] [PATCH 3/8] batman-adv: randomize initial seqno to avoid collision

2012-02-07 Thread Marek Lindner
On Tuesday, February 07, 2012 20:12:00 Andrew Lunn wrote: Does this sequence number have any security relevance? Does it make sense to use the TCP sequence number generation code? There is no security relevance I know of. The idea was simply to start with random number. Random is a bit better

Re: [B.A.T.M.A.N.] [PATCH 3/8] batman-adv: randomize initial seqno to avoid collision

2012-02-07 Thread Andrew Lunn
On Tue, Feb 07, 2012 at 08:21:55PM +0800, Marek Lindner wrote: On Tuesday, February 07, 2012 20:12:00 Andrew Lunn wrote: Does this sequence number have any security relevance? Does it make sense to use the TCP sequence number generation code? There is no security relevance I know of. The

[B.A.T.M.A.N.] [PATCH] batctl: add bridge loop avoidance code and remove softif_neigh stuff

2012-02-07 Thread Simon Wunderlich
Signed-off-by: Simon Wunderlich s...@hrz.tu-chemnitz.de --- debug.c |6 +++--- debug.h |4 ++-- main.c | 50 -- man/batctl.8 |7 +-- sys.c| 12 sys.h|2 ++ 6 files changed, 52