Re: [B.A.T.M.A.N.] [PATCHv2 3/6] batman-adv: register batman ogm receive function during protocol init

2012-03-05 Thread Simon Wunderlich
Hey Marek, this looks much cleaner. Thanks! Simon Acked-by: Simon Wunderlich s...@hrz.tu-chemnitz.de On Sun, Mar 04, 2012 at 04:56:25PM +0800, Marek Lindner wrote: The B.A.T.M.A.N. IV OGM receive function still was hard-coded although it is a routing protocol specific function. This

Re: [B.A.T.M.A.N.] [PATCH 1/6] batman-adv: introduce is_single_hop_neigh variable to increase readability

2012-03-05 Thread Marek Lindner
On Thursday, March 01, 2012 15:35:16 Marek Lindner wrote: Signed-off-by: Marek Lindner lindner_ma...@yahoo.de --- bat_iv_ogm.c | 16 +--- 1 files changed, 9 insertions(+), 7 deletions(-) Applied in revision 94df16a. Regards, Marek

Re: [B.A.T.M.A.N.] [PATCH 2/6] batman-adv: introduce packet type handler array for incoming packets

2012-03-05 Thread Marek Lindner
On Thursday, March 01, 2012 15:35:17 Marek Lindner wrote: The packet handler array replaces the growing switch statement, thus dealing with incoming packets in a more efficient way. It also adds to possibility to register packet handlers on the fly. Applied in revision 1887248. Regards, Marek

Re: [B.A.T.M.A.N.] [PATCHv2 3/6] batman-adv: register batman ogm receive function during protocol init

2012-03-05 Thread Marek Lindner
On Sunday, March 04, 2012 16:56:25 Marek Lindner wrote: The B.A.T.M.A.N. IV OGM receive function still was hard-coded although it is a routing protocol specific function. This patch takes advantage of the dynamic packet handler registration to remove the hard-coded function calls. Applied in

Re: [B.A.T.M.A.N.] [PATCH 4/6] batman-adv: rename last_valid to last_seen

2012-03-05 Thread Marek Lindner
On Thursday, March 01, 2012 15:35:19 Marek Lindner wrote: Signed-off-by: Marek Lindner lindner_ma...@yahoo.de --- bat_iv_ogm.c |8 originator.c | 16 types.h |8 3 files changed, 16 insertions(+), 16 deletions(-) Applied in revision

Re: [B.A.T.M.A.N.] [PATCH 5/6] batman-adv: replace HZ calculations with jiffies_to_msecs()

2012-03-05 Thread Marek Lindner
On Thursday, March 01, 2012 15:35:20 Marek Lindner wrote: Signed-off-by: Marek Lindner lindner_ma...@yahoo.de --- bat_debugfs.c |4 ++-- originator.c | 15 ++- send.c|2 +- 3 files changed, 13 insertions(+), 8 deletions(-) Applied in revision bfe9936.

Re: [B.A.T.M.A.N.] [PATCH 6/6] batman-adv: split neigh_new function into generic and batman iv specific parts

2012-03-05 Thread Marek Lindner
On Thursday, March 01, 2012 15:35:21 Marek Lindner wrote: Signed-off-by: Marek Lindner lindner_ma...@yahoo.de --- bat_iv_ogm.c | 40 ++-- originator.c | 27 ++- originator.h |6 ++ 3 files changed, 46 insertions(+), 27

Re: [B.A.T.M.A.N.] [PATCH] batman-adv: avoid ap_isolated check for broadcast packet

2012-03-05 Thread Antonio Quartulli
On Tue, Mar 06, 2012 at 03:52:46AM +0800, Marek Lindner wrote: On Monday, March 05, 2012 15:51:51 Antonio Quartulli wrote: in case of a broadcast packet, the result of the ap_isolated check is always false (since we have no ff:ff:ff:ff:ff:ff client to check for TT_CLIENT_WIFI), therefore we