[PATCH 08/11] mmc: sdio: Move SDIO IDs from ath10k driver to common include file

2020-05-22 Thread Pali Rohár
Also replace generic MANUFACTURER macros by proper SDIO IDs macros. Checks for device IDs are slightly modified to use SDIO device IDs. This allows removal of all custom MANUFACTURER macros from ath10k. Signed-off-by: Pali Rohár --- drivers/net/wireless/ath/ath10k/sdio.c | 25

[PATCH 07/11] mmc: sdio: Move SDIO IDs from ath6kl driver to common include file

2020-05-22 Thread Pali Rohár
Also replace generic MANUFACTURER macros by proper SDIO IDs macros. Check for "AR6003 or later" is slightly modified to use SDIO device IDs. This allows removal of all custom MANUFACTURER macros from ath6kl. Signed-off-by: Pali Rohár --- drivers/net/wireless/ath/ath6kl/h

[PATCH 10/11] mmc: sdio: Fix Cypress SDIO IDs macros in common include file

2020-05-22 Thread Pali Rohár
to be consistent with all other values. Signed-off-by: Pali Rohár --- drivers/net/wireless/broadcom/brcm80211/brcmfmac/bcmsdh.c | 6 +++--- drivers/net/wireless/broadcom/brcm80211/brcmfmac/sdio.c | 4 ++-- include/linux/mmc/sdio_ids.h | 6 +++--- 3 files changed, 8 insertions

[PATCH 11/11] mmc: sdio: Sort all SDIO IDs in common include file

2020-05-22 Thread Pali Rohár
Fix ordering of SDIO IDs to conform to the comment above, which says vendor first, device next. Signed-off-by: Pali Rohár --- include/linux/mmc/sdio_ids.h | 43 ++-- 1 file changed, 22 insertions(+), 21 deletions(-) diff --git a/include/linux/mmc/sdio_ids.h b

[PATCH 05/11] mmc: sdio: Move SDIO IDs from btmtksdio driver to common include file

2020-05-22 Thread Pali Rohár
Define appropriate macro names for consistency with other macros. Signed-off-by: Pali Rohár --- drivers/bluetooth/btmtksdio.c | 4 ++-- include/linux/mmc/sdio_ids.h | 2 ++ 2 files changed, 4 insertions(+), 2 deletions(-) diff --git a/drivers/bluetooth/btmtksdio.c b/drivers/bluetooth

[PATCH 06/11] mmc: sdio: Move SDIO IDs from smssdio driver to common include file

2020-05-22 Thread Pali Rohár
Define appropriate macro names for consistency with other Siano macros. Signed-off-by: Pali Rohár --- drivers/media/mmc/siano/smssdio.c | 10 +- include/linux/mmc/sdio_ids.h | 5 + 2 files changed, 10 insertions(+), 5 deletions(-) diff --git a/drivers/media/mmc/siano

[PATCH 04/11] mmc: sdio: Move SDIO IDs from btmrvl driver to common include file

2020-05-22 Thread Pali Rohár
Define appropriate macro names for consistency with other Marvell macros. Signed-off-by: Pali Rohár --- drivers/bluetooth/btmrvl_sdio.c | 18 +- include/linux/mmc/sdio_ids.h| 8 2 files changed, 17 insertions(+), 9 deletions(-) diff --git a/drivers/bluetooth

[PATCH 03/11] mmc: sdio: Move SDIO IDs from mwifiex driver to common include file

2020-05-22 Thread Pali Rohár
Add _WLAN suffix to macro names for consistency with other Marvell macros. These IDs represents wlan function of combo bt/wlan cards. Other functions of these cards have different IDs. Signed-off-by: Pali Rohár --- drivers/net/wireless/marvell/mwifiex/sdio.c | 38 + include

[PATCH 09/11] mmc: sdio: Move SDIO IDs from b43-sdio driver to common include file

2020-05-22 Thread Pali Rohár
Define appropriate macro names for consistency with other macros. Signed-off-by: Pali Rohár --- drivers/net/wireless/broadcom/b43/sdio.c | 4 ++-- include/linux/mmc/sdio_ids.h | 4 2 files changed, 6 insertions(+), 2 deletions(-) diff --git a/drivers/net/wireless/broadcom/b43

[PATCH 00/11] mmc: sdio: Move SDIO IDs from drivers to common include file

2020-05-22 Thread Pali Rohár
to the common include file. Also some macro names are changed to follow existing naming conventions. Pali Rohár (11): mmc: sdio: Fix macro name for Marvell device with ID 0x9134 mmc: sdio: Change macro names for Marvell 8688 modules mmc: sdio: Move SDIO IDs from mwifiex driver to common include

[PATCH 01/11] mmc: sdio: Fix macro name for Marvell device with ID 0x9134

2020-05-22 Thread Pali Rohár
-by: Pali Rohár --- drivers/mmc/core/quirks.h| 2 +- include/linux/mmc/sdio_ids.h | 2 +- 2 files changed, 2 insertions(+), 2 deletions(-) diff --git a/drivers/mmc/core/quirks.h b/drivers/mmc/core/quirks.h index 3dba15bccce2..472fa2fdcf13 100644 --- a/drivers/mmc/core/quirks.h +++ b/drivers/mmc

[PATCH 02/11] mmc: sdio: Change macro names for Marvell 8688 modules

2020-05-22 Thread Pali Rohár
Add underscore as separator in Marvell 8688 macro names for better readability and consistency. Signed-off-by: Pali Rohár --- drivers/net/wireless/marvell/libertas/if_sdio.c | 2 +- include/linux/mmc/sdio_ids.h| 4 ++-- 2 files changed, 3 insertions(+), 3 deletions(-) diff