Re: qemu arm vexpress / virt32 support

2020-01-14 Thread Wesley Chow
Thanks, -next works! Also since 2020.10.0 cut right after I wrote this email, I just tested head (4cce60b7fe2798e81b04c5d9ad79dc9b443635a8) and the 2020.10.0 release. Both work. I no longer know what githash I was on at the time of my original email. FWIW, I think in my previous testing 2019.12.0

Re: [RFC 2/5] WIP: MIPS: implement dma mapping functions

2020-01-14 Thread Antony Pavlov
On Mon, 13 Jan 2020 09:26:36 +0100 Oleksij Rempel wrote: > On 09.01.20 08:28, Antony Pavlov wrote: > > TODO: fix warnings > > > > arch/mips/include/asm/dma-mapping.h: In function ‘dma_free_coherent’: > > arch/mips/include/asm/dma-mapping.h:31:21: warning: passing argument 1 of > >

Re: qemu arm virt64 hangs

2020-01-14 Thread Lucas Stach
Hi Wesley, Am Dienstag, den 14.01.2020, 12:36 -0500 schrieb Wesley Chow: > hi all! > > 64 bit virt doesn't appear to be working. > > $ ARCH=arm CROSS_COMPILE=/usr/bin/aarch64-linux-gnu- make > qemu_virt64_defconfig > ... > $ qemu-system-aarch64 -M virt -cpu cortex-a57 -nographic -kernel >

[PATCH] ARM: qemu-virt64: convert to assembly entry

2020-01-14 Thread Lucas Stach
The C entry function isn't naked, so tries to push to the stack in the function prologue. This doesn't work on QEMU where there is no valid SP on entry. Convert the lowlevel entry to the assembly facilities provided for this case. Signed-off-by: Lucas Stach ---

qemu arm virt64 hangs

2020-01-14 Thread Wesley Chow
hi all! 64 bit virt doesn't appear to be working. $ ARCH=arm CROSS_COMPILE=/usr/bin/aarch64-linux-gnu- make qemu_virt64_defconfig ... $ qemu-system-aarch64 -M virt -cpu cortex-a57 -nographic -kernel barebox (qemu hangs) I see here that at some point aarch64 had issues, but do these remain

Re: [RFC PATCH 0/7] usb: dwc2 host driver

2020-01-14 Thread Jules Maselbas
On Tue, Jan 14, 2020 at 03:27:04PM +0100, Sascha Hauer wrote: > Hi Jules, > > On Tue, Jan 14, 2020 at 02:21:05PM +0100, Jules Maselbas wrote: > > Hi Sascha, > > > > I've been working on a driver for the dwc2 otg controller, for both host > > and device mode. Like you I've started from U-Boot

[PATCH] pinctrl-single: Handle "pinctrl-single, function-mask" dt property

2020-01-14 Thread Clement Leger
From: Siméon Marijon Implement linux behavior regarding "pinctrl-single,function-mask" and "pinctrl-single,bits". It allows multiple pins control per register. (linux sha1: 4e7e8017a80e1810100c9b416b86e3baef900285) Signed-off-by: Simeon Marijon --- drivers/pinctrl/pinctrl-single.c | 81

Re: [RFC PATCH 0/7] usb: dwc2 host driver

2020-01-14 Thread Sascha Hauer
Hi Jules, On Tue, Jan 14, 2020 at 02:21:05PM +0100, Jules Maselbas wrote: > Hi Sascha, > > I've been working on a driver for the dwc2 otg controller, for both host > and device mode. Like you I've started from U-Boot driver and I mixed > it with some part from Linux. For instance I've removed

barebox-2020.01.0

2020-01-14 Thread Sascha Hauer
Hi All, We have the first release in this decade ;) >From the amount of patches it seems most of the work for this release has gone into the SDHCI driver. A good bunch of the different implementations for the same functionalities has been merged to a common code base. Other than that Layerscape

[RFC PATCH 3/7] usb: dwc2: Dynamic fifo size support from Linux

2020-01-14 Thread Jules Maselbas
Signed-off-by: Jules Maselbas --- drivers/usb/dwc2/host.c | 146 ++-- drivers/usb/dwc2/regs.h | 8 --- 2 files changed, 124 insertions(+), 30 deletions(-) diff --git a/drivers/usb/dwc2/host.c b/drivers/usb/dwc2/host.c index a1f2e3ea1..84eb9b627 100644 ---

[RFC PATCH 5/7] HACK: usb: dwc2: Fix toggle reset

2020-01-14 Thread Jules Maselbas
>From USB 2.0 specification, section 9.4.5: ClearFeature(ENDPOINT_HALT) request always results in the data toggle being reinitialized to DATA0. Signed-off-by: Jules Maselbas --- drivers/usb/dwc2/host.c | 17 + 1 file changed, 17 insertions(+) diff --git

[RFC PATCH 2/7] usb: dwc2: host: Handle dma mapping errors

2020-01-14 Thread Jules Maselbas
Signed-off-by: Jules Maselbas --- drivers/usb/dwc2/host.c | 5 + 1 file changed, 5 insertions(+) diff --git a/drivers/usb/dwc2/host.c b/drivers/usb/dwc2/host.c index 4137dd3cb..a1f2e3ea1 100644 --- a/drivers/usb/dwc2/host.c +++ b/drivers/usb/dwc2/host.c @@ -154,6 +154,11 @@ static int

[RFC PATCH 4/7] usb: dwc2: Rework roothub interface

2020-01-14 Thread Jules Maselbas
Roothub requests are now decoded in one place. Signed-off-by: Jules Maselbas --- drivers/usb/dwc2/dwc2.h | 2 +- drivers/usb/dwc2/host.c | 4 +- drivers/usb/dwc2/rhub.c | 520 +++- 3 files changed, 246 insertions(+), 280 deletions(-) diff --git

[RFC PATCH 7/7] usb: dwc2: Read dr_mode from device tree

2020-01-14 Thread Jules Maselbas
Signed-off-by: Jules Maselbas --- drivers/usb/dwc2/core.c | 89 + drivers/usb/dwc2/dwc2.c | 2 + drivers/usb/dwc2/dwc2.h | 1 + 3 files changed, 92 insertions(+) diff --git a/drivers/usb/dwc2/core.c b/drivers/usb/dwc2/core.c index 9a36b0904..94ff977bb

[RFC PATCH 1/7] usb: dwc2: Add host controller driver

2020-01-14 Thread Jules Maselbas
The host driver is mostly taken from U-Boot, other part are from Linux Signed-off-by: Jules Maselbas --- drivers/usb/Kconfig | 2 + drivers/usb/Makefile | 1 + drivers/usb/dwc2/Kconfig | 4 + drivers/usb/dwc2/Makefile | 1 + drivers/usb/dwc2/core.c | 614

[RFC PATCH 6/7] usb: dwc2: Rewrite dwc2_hc_init

2020-01-14 Thread Jules Maselbas
Removed the uses of a table to convert the usb endpoint type for the controller. Signed-off-by: Jules Maselbas --- drivers/usb/dwc2/host.c | 47 +++-- 1 file changed, 27 insertions(+), 20 deletions(-) diff --git a/drivers/usb/dwc2/host.c

Re: [PATCH] MIPS: dts: rename tplink-mr3020.dts -> ar9331_tl_mr3020.dts

2020-01-14 Thread Sascha Hauer
On Thu, Jan 09, 2020 at 10:21:22AM +0300, Antony Pavlov wrote: > Linux MIPS uses _.dts board dts-file > naming scheme so use it in barebox too. > > Signed-off-by: Antony Pavlov > --- > arch/mips/boards/tplink-mr3020/lowlevel.S | 2 +- > arch/mips/dts/Makefile

[PATCH] usb: ehci: Do not use memset on dma coherent memory

2020-01-14 Thread Sascha Hauer
memset is an optimized operation that at least on ARM64 may only be called on cached memory, see 32e8842c40 ("ARM: lib64: Make string functions aware of MMU configuration"). To avoid crashes in the ehci driver we no longer call memset on memory allocated with dma_alloc_coherent(), but use a simple

Re: [PATCH 1/3] serial: cadence: move register definitions into header file

2020-01-14 Thread Sascha Hauer
On Mon, Jan 13, 2020 at 08:37:14PM +0100, Lucas Stach wrote: > Signed-off-by: Lucas Stach > --- > drivers/serial/serial_cadence.c | 41 - > include/serial/cadence.h| 37 + > 2 files changed, 42 insertions(+), 36 deletions(-) >

Re: [PATCH] ARM: zynq: zed: partially revert zynq_cpu_lowlevel_init() chnages

2020-01-14 Thread Sascha Hauer
On Mon, Jan 13, 2020 at 08:36:37PM +0100, Lucas Stach wrote: > Calling arm_cpu_lowlevel_init() from zynq_cpu_lowlevel_init() adds a stack > push/pop to the latter function which doesn't work this early in the boot. > > As the BootROM apparently hands proccessor control to us in abort(!?!) > mode,

[PATCH 1/2] PCI: layerscape: rename variable

2020-01-14 Thread Sascha Hauer
Rename 'arr' to 'msi_map' which is a better name when we add another array in the next patch. Signed-off-by: Sascha Hauer --- drivers/pci/pci-layerscape.c | 16 1 file changed, 8 insertions(+), 8 deletions(-) diff --git a/drivers/pci/pci-layerscape.c

[PATCH 2/2] PCI: layerscape: Fixup iommu-map properties

2020-01-14 Thread Sascha Hauer
The iommu-map properties are needed for proper PCI support under Linux. Signed-off-by: Sascha Hauer --- drivers/pci/pci-layerscape.c | 39 +++- 1 file changed, 38 insertions(+), 1 deletion(-) diff --git a/drivers/pci/pci-layerscape.c