[PATCH] ARM: mach-imx: Add missing ocotp dependency to protonic-imx6 platform

2022-11-02 Thread Robin van der Gracht
The protonic-imx6 board code calls imx_ocotp_read/write_field functions. Compiling without IMX_OCOTP results in a build failure. Signed-off-by: Robin van der Gracht --- arch/arm/mach-imx/Kconfig | 1 + 1 file changed, 1 insertion(+) diff --git a/arch/arm/mach-imx/Kconfig

Re: [PATCH] Kbuild: link barebox with -z noexecstack

2022-11-02 Thread Ahmad Fatoum
On 02.11.22 13:48, Ahmad Fatoum wrote: > We don't care for permission of ELF segments, but GNU ld (BFD) > does and now with binutils 2.39+, it reports: > > ld: warning: defaultenv/defaultenv-2-menu.bbenv.o: missing > .note.GNU-stack section implies executable stack > > ld: NOTE: This

[PATCH] Kbuild: link barebox with -z noexecstack

2022-11-02 Thread Ahmad Fatoum
We don't care for permission of ELF segments, but GNU ld (BFD) does and now with binutils 2.39+, it reports: ld: warning: defaultenv/defaultenv-2-menu.bbenv.o: missing .note.GNU-stack section implies executable stack ld: NOTE: This behaviour is deprecated and will be removed in a future

Re: [PATCH 14/14] imx-bbu-nand-fcb: Add fcb command

2022-11-02 Thread Sascha Hauer
On Wed, Nov 02, 2022 at 12:01:15PM +0100, Marco Felsch wrote: > On 22-11-02, Sascha Hauer wrote: > > On Wed, Nov 02, 2022 at 09:44:41AM +0100, Marco Felsch wrote: > > > > +static void dump_fcb_n(struct fcb_block **fcbs, int n) > > > > +{ > > > > + int i; > > > > + > > > > + if (!n ||

Re: [PATCH v1 4/4] ARM: boards: skov-imx6: convert all pr_ to dev_ prints

2022-11-02 Thread Sascha Hauer
On Wed, Nov 02, 2022 at 11:07:44AM +0100, Oleksij Rempel wrote: > Unify all printing messages and make use of dev_ instead of pr_. > > Signed-off-by: Oleksij Rempel > --- > arch/arm/boards/skov-imx6/board.c | 62 +++ > 1 file changed, 31 insertions(+), 31

Re: [PATCH v1 3/4] ARM: boards: skov-imx6: assigned separate MAC address to LAN2

2022-11-02 Thread Sascha Hauer
On Wed, Nov 02, 2022 at 11:07:43AM +0100, Oleksij Rempel wrote: > We have two external ports and different MAC addresses on each port. So, > assign different MAC to the LAN2. The address on LAN1 is the > system default address. > > Signed-off-by: Oleksij Rempel > --- >

Re: [PATCH v1 1/4] drivers: net: fec_imx: fix receive issue with external switch

2022-11-02 Thread Sascha Hauer
On Wed, Nov 02, 2022 at 11:07:41AM +0100, Oleksij Rempel wrote: > Enable poromisc mode by default to allow using multiple MAC address on > same FEC interfaces. s/poromisc/promiscuous/ > > We already use poromisc mode on designware stmmac, so it will make > behavior more consistent on different

Re: [PATCH 14/14] imx-bbu-nand-fcb: Add fcb command

2022-11-02 Thread Marco Felsch
On 22-11-02, Sascha Hauer wrote: > On Wed, Nov 02, 2022 at 09:44:41AM +0100, Marco Felsch wrote: > > > +static void dump_fcb_n(struct fcb_block **fcbs, int n) > > > +{ > > > + int i; > > > + > > > + if (!n || !fcbs[n]) > > > + goto skip_compare; > > > + > > > + for (i = 0; i < n; i++) { >

Re: [PATCH 14/14] imx-bbu-nand-fcb: Add fcb command

2022-11-02 Thread Sascha Hauer
On Wed, Nov 02, 2022 at 09:44:41AM +0100, Marco Felsch wrote: > > +static void dump_fcb_n(struct fcb_block **fcbs, int n) > > +{ > > + int i; > > + > > + if (!n || !fcbs[n]) > > + goto skip_compare; > > + > > + for (i = 0; i < n; i++) { > > + if (!fcbs[i] || !fcbs[n]) > >

[PATCH] ARM: rk356x: rk3568-evb: add missing new line to log message

2022-11-02 Thread Ahmad Fatoum
If ADC is available, but read out returns an error, we end up with a log line that's not new line terminated. Fix this. Signed-off-by: Ahmad Fatoum --- arch/arm/boards/rockchip-rk3568-evb/board.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git

[PATCH v1 2/4] net: dsa: fix of_device_ensure_probed*() for switch ports

2022-11-02 Thread Oleksij Rempel
Crete ports by using of_platform_device_create() in the same way as it is used by of_device_ensure_probed*(). Otherwise we are creating multiple devices for the same node. At same time we need to link dummy driver to make this logic work. Signed-off-by: Oleksij Rempel --- drivers/net/dsa.c |

[PATCH v1 3/4] ARM: boards: skov-imx6: assigned separate MAC address to LAN2

2022-11-02 Thread Oleksij Rempel
We have two external ports and different MAC addresses on each port. So, assign different MAC to the LAN2. The address on LAN1 is the system default address. Signed-off-by: Oleksij Rempel --- arch/arm/boards/skov-imx6/board.c | 47 ++- 1 file changed, 46

[PATCH v1 4/4] ARM: boards: skov-imx6: convert all pr_ to dev_ prints

2022-11-02 Thread Oleksij Rempel
Unify all printing messages and make use of dev_ instead of pr_. Signed-off-by: Oleksij Rempel --- arch/arm/boards/skov-imx6/board.c | 62 +++ 1 file changed, 31 insertions(+), 31 deletions(-) diff --git a/arch/arm/boards/skov-imx6/board.c

[PATCH v1 1/4] drivers: net: fec_imx: fix receive issue with external switch

2022-11-02 Thread Oleksij Rempel
Enable poromisc mode by default to allow using multiple MAC address on same FEC interfaces. We already use poromisc mode on designware stmmac, so it will make behavior more consistent on different systems. Signed-off-by: Oleksij Rempel --- drivers/net/fec_imx.c | 3 +++ drivers/net/fec_imx.h |

Re: [PATCH] ARM: i.MX8M: atf: prefix log messages via pr_fmt()

2022-11-02 Thread Ahmad Fatoum
On 02.11.22 09:19, Sascha Hauer wrote: > On Wed, Nov 02, 2022 at 08:58:41AM +0100, Marco Felsch wrote: >> On 22-11-01, Ahmad Fatoum wrote: >>> We have a couple of log messages in the file, so ensure they are >>> appropriately prefixed. >>> >>> Signed-off-by: Ahmad Fatoum >>> --- >>>

[PATCH] commands: uptime: add note about caveats

2022-11-02 Thread Ahmad Fatoum
Normally timer overrun is not that much of a problem, because there where it matters, we usually have an is_timeout() in the loop that reads the timer often enough. This doesn't necessarily hold for the new uptime command and basically anything can happen between subsequent calls and if

Re: [PATCH 13/14] ARM: i.MX: xload nand: Implement i.MX7 support

2022-11-02 Thread Sascha Hauer
On Wed, Nov 02, 2022 at 09:41:18AM +0100, Marco Felsch wrote: > Hi Sascha, > > On 22-11-01, Sascha Hauer wrote: > > i.MX7 xload NAND support works like on i.MX6, but the FCB is in a > > different format. The FCB page uses BCH62 ECC, has 8 ECC chunks with > > 128 bytes each with a resulting total

Re: [PATCH 14/14] imx-bbu-nand-fcb: Add fcb command

2022-11-02 Thread Marco Felsch
Hi Sascha, On 22-11-01, Sascha Hauer wrote: > The FCB on NAND has a special page layout and thus can't be read with > the normal MTD driver. Add a fcb command for printing information about > the installed FCB on the console. > > Signed-off-by: Sascha Hauer > --- > commands/Kconfig |

Re: [PATCH 13/14] ARM: i.MX: xload nand: Implement i.MX7 support

2022-11-02 Thread Marco Felsch
Hi Sascha, On 22-11-01, Sascha Hauer wrote: > i.MX7 xload NAND support works like on i.MX6, but the FCB is in a > different format. The FCB page uses BCH62 ECC, has 8 ECC chunks with > 128 bytes each with a resulting total page size of 1862 bytes. Also > the page data is written with a pseudo

Re: [PATCH 12/14] ARM: i.MX: xload nand: Move mxs_nand_mode_fcb_62bit() to header file

2022-11-02 Thread Marco Felsch
Hi Sascha, On 22-11-01, Sascha Hauer wrote: > mxs_nand_mode_fcb_62bit() can be shared between the regular MTD NAND > driver and the upcoming i.MX7 xload driver. Move to header file. > > Signed-off-by: Sascha Hauer > --- > drivers/mtd/nand/nand_mxs.c | 34 ++ >

Re: [PATCH 08/14] ARM: i.MX: xload nand: Pull ECC status checking out of read page

2022-11-02 Thread Marco Felsch
Hi Sascha, On 22-11-01, Sascha Hauer wrote: > The read page code can be reused by upcoming i.MX7 support, but the ECC > checking will be different. Pull ECC status checking out of the read > page code to make that reusable on i.MX7. > > Signed-off-by: Sascha Hauer > --- >

Re: [PATCH 1/3] include: debug_ll: define puthexc_ll

2022-11-02 Thread Sascha Hauer
On Wed, Oct 19, 2022 at 02:38:15PM +0200, Ahmad Fatoum wrote: > puthex_ll prints a single zero-padded unsigned long, which for a single > byte is not very readable, especially on 64-bit systems. Define > puthexc_ll() as well, which just accepts a byte and formats its nibbles > as hexadecimal

Re: [PATCH 03/14] ARM: i.MX: xload nand: add common readid

2022-11-02 Thread Marco Felsch
Hi Sascha, On 22-11-01, Sascha Hauer wrote: > mxs_nand_check_onfi() and mxs_nand_read_id() setup the same DMA > descriptors with only a small difference. factor out a common > read_id function from it and share the code. > > Signed-off-by: Sascha Hauer > --- >

Re: [PATCH] ARM: i.MX8M: atf: prefix log messages via pr_fmt()

2022-11-02 Thread Sascha Hauer
On Wed, Nov 02, 2022 at 08:58:41AM +0100, Marco Felsch wrote: > On 22-11-01, Ahmad Fatoum wrote: > > We have a couple of log messages in the file, so ensure they are > > appropriately prefixed. > > > > Signed-off-by: Ahmad Fatoum > > --- > > arch/arm/mach-imx/atf.c | 2 ++ > > 1 file changed, 2

Re: [PATCH] ARM: dts: i.MX8MP: increase off-on delay on the SD Vcc regulator

2022-11-02 Thread Sascha Hauer
On Tue, Nov 01, 2022 at 02:30:50PM +0100, Marco Felsch wrote: > This commit is required to fix the SD card detection mechanism. Without > this commit the SD card (auto-)detection fails when booted from this > sd-card: > > mmc1: Query interface conditions failed: -110 > mmc1: SD operation

Re: [PATCH 02/14] ARM: i.MX: xload nand: Use common register defines

2022-11-02 Thread Marco Felsch
Hi Sascha, On 22-11-01, Sascha Hauer wrote: > We have a set of GPMI register defines in include/, so use them for the > xload driver as well. > > Signed-off-by: Sascha Hauer > --- > arch/arm/mach-imx/xload-gpmi-nand.c | 66 - > 1 file changed, 17 insertions(+), 49

Re: [PATCH 01/14] mtd: nand: nand-mxs: Move register definitions to separate file

2022-11-02 Thread Marco Felsch
Hi Sascha, On 22-11-01, Sascha Hauer wrote: > The GPMI registers are needed in the MTD GPMI driver and also in the > xload-gpmi driver. So far both use their own set of register defines. > Move the MTD GPMI register defines to include/ so that we can use them > in the xload driver as well. Nit:

Re: [PATCH v2 1/2] ARM: socfpga: Fix SDRAM firewall init

2022-11-02 Thread Sascha Hauer
On Tue, Nov 01, 2022 at 11:33:26AM +0100, Vyacheslav Yurkov wrote: > From: Vyacheslav Yurkov > > Incorrect enable bits were used in initialization sequence of SDRAM > firewall. This enables the FPGA to access regions of SDRAM, which were > previously inaccessible. > > Signed-off-by: Vyacheslav

Re: [PATCH v2 1/2] commands: add new uptime command

2022-11-02 Thread Sascha Hauer
On Tue, Nov 01, 2022 at 07:37:56AM +0100, Ahmad Fatoum wrote: > We have a time command to record the delta of get_time_ns() to time > command execution, but have no command to just print get_time_ns(). > > Such a command can be useful to debug clocksources or to verify that a > system is still

Re: [PATCH] lib: string: implement mempcpy

2022-11-02 Thread Sascha Hauer
On Tue, Nov 01, 2022 at 07:43:10AM +0100, Ahmad Fatoum wrote: > mempcpy(3) is a GNU libc extension that like stpcpy returns not the > start of the destination buffer, but the first byte after its end. > > Provide it as it is useful when concatenating buffers or known-size > strings. > >

Re: [PATCH] ARM: i.MX8M: atf: prefix log messages via pr_fmt()

2022-11-02 Thread Marco Felsch
On 22-11-01, Ahmad Fatoum wrote: > We have a couple of log messages in the file, so ensure they are > appropriately prefixed. > > Signed-off-by: Ahmad Fatoum > --- > arch/arm/mach-imx/atf.c | 2 ++ > 1 file changed, 2 insertions(+) > > diff --git a/arch/arm/mach-imx/atf.c

Re: [PATCH v2] test: self: only include ramfs selftest when CONFIG_SELFTEST_FS_RAMFS=y

2022-11-02 Thread Sascha Hauer
On Tue, Nov 01, 2022 at 07:32:16AM +0100, Ahmad Fatoum wrote: > So far, we ignored the symbol and built the test always when > CONFIG_SELFTEST=y and CONFIG_FS_RAMFS=y. > > Signed-off-by: Ahmad Fatoum > --- > v1 -> v2: > - moved out of other series. No other changes. > test/self/Kconfig | 2

Re: [PATCH] net: e1000: fix s in log messages

2022-11-02 Thread Sascha Hauer
On Mon, Oct 31, 2022 at 10:33:19AM +0300, Denis Orlov wrote: > We do not have an edev.dev set up yet when we are filling in the device > structure and reading an EEPROM in probe. Besides, using hw->dev for > those messages seems more appropriate. > > Signed-off-by: Denis Orlov > --- >

Re: [PATCH] reset: add missing stub for of_reset_control_get()

2022-11-02 Thread Sascha Hauer
On Mon, Oct 31, 2022 at 10:34:29AM +0300, Denis Orlov wrote: > Every other function in reset.h has a corresponding stub that is used > when the option RESET_CONTROLLER is disabled in config. This allows for > code that uses this function to still be compilable even when the reset > controller