Re: [PATCH 4/4] of: partition: add no-fixup device tree property

2018-12-06 Thread Sascha Hauer
On Fri, Dec 07, 2018 at 07:34:37AM +0100, Ahmad Fatoum wrote: > Users can have reasons to inhibit barebox from fixing up partitions nodes > into the kernel device tree, like if it's a boot0-partitions node, which > doesn't have a kernel binding. > Allow users to specify a no-fixup property to

[PATCH 1/6] mci: core: Use alias as a devname by default

2018-12-06 Thread Andrey Smirnov
This idiom is repeatead by almost every mci driver, so move it to mci_of_parse() in order to reduce amount of duplicated code. Signed-off-by: Andrey Smirnov --- drivers/mci/mci-core.c | 5 + 1 file changed, 5 insertions(+) diff --git a/drivers/mci/mci-core.c b/drivers/mci/mci-core.c index

[PATCH 4/6] mci: omap_hsmmc: Drop explicit devname setup code

2018-12-06 Thread Andrey Smirnov
Drop explicit devname setup code. Same setup will be done by mci_of_parse(). Signed-off-by: Andrey Smirnov --- drivers/mci/omap_hsmmc.c | 6 -- 1 file changed, 6 deletions(-) diff --git a/drivers/mci/omap_hsmmc.c b/drivers/mci/omap_hsmmc.c index cbc69e408..0cee3ec22 100644 ---

[PATCH 3/6] mci: dw_mmc: Drop explicit devname setup code

2018-12-06 Thread Andrey Smirnov
Drop explicit devname setup code. Same setup will be done by mci_of_parse(). Signed-off-by: Andrey Smirnov --- drivers/mci/dw_mmc.c | 3 --- 1 file changed, 3 deletions(-) diff --git a/drivers/mci/dw_mmc.c b/drivers/mci/dw_mmc.c index e4c550c3e..f035317ef 100644 --- a/drivers/mci/dw_mmc.c +++

[PATCH 2/6] mci: tegra-sdmmc: Drop explicit devname setup code

2018-12-06 Thread Andrey Smirnov
Drop explicit devname setup code. Same setup will be done by mci_of_parse(). Signed-off-by: Andrey Smirnov --- drivers/mci/tegra-sdmmc.c | 3 --- 1 file changed, 3 deletions(-) diff --git a/drivers/mci/tegra-sdmmc.c b/drivers/mci/tegra-sdmmc.c index e465d891a..4c4791807 100644 ---

v2018.12.0

2018-12-06 Thread Sascha Hauer
Hi All, I just released v2018.12.0. Most notable this time is that we finally have Raspberry Pi 3 support. It took a while to get the patches into shape, but now they are there. Other than that we have several AT91 patches which add a SoC specific prefix to the several SoC specific defines. This

[PATCH 5/6] mci: imx-esdhc: Drop explicit devname setup code

2018-12-06 Thread Andrey Smirnov
Drop explicit devname setup code. Same setup will be done by mci_of_parse(). Signed-off-by: Andrey Smirnov --- drivers/mci/imx-esdhc.c | 4 1 file changed, 4 deletions(-) diff --git a/drivers/mci/imx-esdhc.c b/drivers/mci/imx-esdhc.c index 7f2285635..09df7945c 100644 ---

[PATCH 6/6] mci: mxs: Drop explicit devname setup code

2018-12-06 Thread Andrey Smirnov
Drop explicit devname setup code. Same setup will be done by mci_of_parse(). Signed-off-by: Andrey Smirnov --- drivers/mci/mxs.c | 6 -- 1 file changed, 6 deletions(-) diff --git a/drivers/mci/mxs.c b/drivers/mci/mxs.c index 446da8ad5..afd6a5639 100644 --- a/drivers/mci/mxs.c +++

[PATCH] lib/parameter: Fix typecases to match corresponding PARAM_TYPE_*

2018-12-06 Thread Andrey Smirnov
This change should be a no-op in terms of behavior, but it makes code less confusing when PARAM_TYPE_* matches the type used in the type cast. Signed-off-by: Andrey Smirnov --- lib/parameter.c | 4 ++-- 1 file changed, 2 insertions(+), 2 deletions(-) diff --git a/lib/parameter.c

[PATCH] nvmem: ocotp: Make use of postcore_platform_driver macro

2018-12-06 Thread Andrey Smirnov
Signed-off-by: Andrey Smirnov --- drivers/nvmem/ocotp.c | 9 + 1 file changed, 1 insertion(+), 8 deletions(-) diff --git a/drivers/nvmem/ocotp.c b/drivers/nvmem/ocotp.c index e0cf35f0b..2952988f8 100644 --- a/drivers/nvmem/ocotp.c +++ b/drivers/nvmem/ocotp.c @@ -697,11 +697,4 @@ static

[PATCH 2/3] led: core: Initialize blink_next_event with 0

2018-12-06 Thread Andrey Smirnov
A simpler way to make pattern to trigger immediately is to initialize blink_next_event to 0 instead of current time value. Save a function call and convert the code to do just that. Signed-off-by: Andrey Smirnov --- drivers/led/core.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff

[PATCH 1/3] led: core: Don't call get_time_us() twice

2018-12-06 Thread Andrey Smirnov
The code doesn't seem to be time-sensitive enough to warrant calling get_time_ns() twice instead of caching its value and using it no both places. Signed-off-by: Andrey Smirnov --- drivers/led/core.c | 5 +++-- 1 file changed, 3 insertions(+), 2 deletions(-) diff --git a/drivers/led/core.c

[PATCH 3/3] led: core: Make use of ARRAY_AND_SIZE

2018-12-06 Thread Andrey Smirnov
Signed-off-by: Andrey Smirnov --- drivers/led/core.c | 4 ++-- 1 file changed, 2 insertions(+), 2 deletions(-) diff --git a/drivers/led/core.c b/drivers/led/core.c index 34c514be8..431966d06 100644 --- a/drivers/led/core.c +++ b/drivers/led/core.c @@ -188,7 +188,7 @@ int led_blink(struct led

[PATCH] commands: boot: Remove useless code

2018-12-06 Thread Andrey Smirnov
All of those variables are already initialized in-place in the variable declaration section above to exactly the same values Signed-off-by: Andrey Smirnov --- commands/boot.c | 4 1 file changed, 4 deletions(-) diff --git a/commands/boot.c b/commands/boot.c index 5d81d79ce..0257b3dd4

[PATCH] net: lib: Make use of ETH_ALEN

2018-12-06 Thread Andrey Smirnov
Signed-off-by: Andrey Smirnov --- net/lib.c | 8 1 file changed, 4 insertions(+), 4 deletions(-) diff --git a/net/lib.c b/net/lib.c index d4343bced..d2b33132d 100644 --- a/net/lib.c +++ b/net/lib.c @@ -28,13 +28,13 @@ #include #include -int string_to_ethaddr(const char *str, u8

[PATCH] mfd: rave-sp: Make use of wait_on_timeout()

2018-12-06 Thread Andrey Smirnov
Signed-off-by: Andrey Smirnov --- drivers/mfd/rave-sp.c | 8 ++-- 1 file changed, 2 insertions(+), 6 deletions(-) diff --git a/drivers/mfd/rave-sp.c b/drivers/mfd/rave-sp.c index 469ce4cc0..cc897b122 100644 --- a/drivers/mfd/rave-sp.c +++ b/drivers/mfd/rave-sp.c @@ -314,7 +314,6 @@ int

Re: [PATCH v3 08/10] MIPS: port all mach* to multiimage

2018-12-06 Thread Oleksij Rempel
Hi Anthony, i would be happy if you can say: - this set is no go, because... or: - right now, I can't test it and if it caused some regression they will be fixed in separate patches... Am 05.12.18 um 09:50 schrieb Antony Pavlov: > On Tue, 27 Nov 2018 10:19:33 +0100 > Oleksij Rempel wrote: > >

Re: [PATCH v1] drivers: net: usb: convert drivers to spdx

2018-12-06 Thread Sascha Hauer
On Wed, Dec 05, 2018 at 08:05:57PM +0100, Oleksij Rempel wrote: > Signed-off-by: Oleksij Rempel > --- > drivers/net/usb/smsc95xx.c | 17 ++--- > drivers/net/usb/smsc95xx.h | 17 ++--- > 2 files changed, 4 insertions(+), 30 deletions(-) Applied, thanks Sascha --

Re: [PATCH v2] drivers: net: phy: convert drivers to spdx

2018-12-06 Thread Sascha Hauer
On Wed, Dec 05, 2018 at 07:57:39PM +0100, Oleksij Rempel wrote: > Reviewed-by: Roland Hieber > Signed-off-by: Oleksij Rempel > --- > drivers/net/phy/ar8327.c| 6 +- > drivers/net/phy/at803x.c| 6 +- > drivers/net/phy/davicom.c | 7 +-- >

Re: [PATCH 1/4] ARM: imx: select OFDEVICE for VF610

2018-12-06 Thread Sascha Hauer
On Thu, Dec 06, 2018 at 12:45:07PM +0100, Lucas Stach wrote: > It's a dependency for IMX_OCOTP, which is selected by VF610. > > Signed-off-by: Lucas Stach > --- > arch/arm/mach-imx/Kconfig | 1 + > 1 file changed, 1 insertion(+) Applied, thanks Sascha > > diff --git

[PATCH 4/4] of: partition: add no-fixup device tree property

2018-12-06 Thread Ahmad Fatoum
Users can have reasons to inhibit barebox from fixing up partitions nodes into the kernel device tree, like if it's a boot0-partitions node, which doesn't have a kernel binding. Allow users to specify a no-fixup property to indicate so. Signed-off-by: Ahmad Fatoum ---

[PATCH 3/4] of: partitions: make macro name more generic

2018-12-06 Thread Ahmad Fatoum
DEVFS_PARTITION_FROM_TABLE's only effect at the moment is to disable device tree fixups. Rename it accordingly, so it looks less out-of-place when using it in the next commit to implement the no-fixup property. Signed-off-by: Ahmad Fatoum --- common/partitions.c| 2 +-

[PATCH 2/4] of: partition: use NULL instead of never-read argument

2018-12-06 Thread Ahmad Fatoum
len isn't read afterward and of_get_property accepts NULL as third argument, so do it. Signed-off-by: Ahmad Fatoum --- drivers/of/partition.c | 6 +++--- 1 file changed, 3 insertions(+), 3 deletions(-) diff --git a/drivers/of/partition.c b/drivers/of/partition.c index

[PATCH 1/4] ARM: imx: select OFDEVICE for VF610

2018-12-06 Thread Lucas Stach
It's a dependency for IMX_OCOTP, which is selected by VF610. Signed-off-by: Lucas Stach --- arch/arm/mach-imx/Kconfig | 1 + 1 file changed, 1 insertion(+) diff --git a/arch/arm/mach-imx/Kconfig b/arch/arm/mach-imx/Kconfig index 69d359b8520c..5b641655d2ba 100644 --- a/arch/arm/mach-imx/Kconfig

[PATCH 3/4] ARM: at91: add architecture dependecy to KSZ9477_EVB board

2018-12-06 Thread Lucas Stach
This board is part of the SAMA5D3 architecture. Signed-off-by: Lucas Stach --- arch/arm/mach-at91/Kconfig | 1 + 1 file changed, 1 insertion(+) diff --git a/arch/arm/mach-at91/Kconfig b/arch/arm/mach-at91/Kconfig index bb8305fd1675..e6b4f99c969b 100644 --- a/arch/arm/mach-at91/Kconfig +++

[PATCH 4/4] scripts: imx-image: fix build with OpenSSL < 1.1.0

2018-12-06 Thread Lucas Stach
When adding support for OpenSSL 1.1.x it was missed that EVP_PKEY_get0_RSA is only available with that version. Earlier versions don't provide a fully equivalent function, so add it to the compatibility helpers. Fixes: 542a50d4eb (scripts: imx-image: fix build with OpenSSL 1.1.x) Signed-off-by:

[PATCH 2/4] of: remove non-existent of_match_ptr

2018-12-06 Thread Lucas Stach
It's only used in the !OFTREE stub functions, so can be safely removed. Signed-off-by: Lucas Stach --- include/of_device.h | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/include/of_device.h b/include/of_device.h index e84fc9c37775..44c1c0f54551 100644 ---

Re: [PATCH v3 08/10] MIPS: port all mach* to multiimage

2018-12-06 Thread Sascha Hauer
On Wed, Dec 05, 2018 at 02:58:12PM +0100, Oleksij Rempel wrote: > Am 05.12.18 um 09:50 schrieb Antony Pavlov: > > I suppose there is a problem with simultaneous debug_ll support for AR9344 > > and AR9331 in one binary. > > the Kconfig DEBUG_AR9331_UART and DEBUG_AR9344_UART options are mutually

Re: [PATCH 1/3] ARM: dts: phyCORE-i.MX 6UL: Enable USB host port

2018-12-06 Thread Sascha Hauer
On Wed, Dec 05, 2018 at 04:40:35PM +0100, Stefan Riedmueller wrote: > The phyBOARD-Segin baseboard of the phyCORE-i.MX 6UL features a USB > type A connector on the second USB OTG port of the i.MX 6UL. So enable this > port as a host port. > > Signed-off-by: Stefan Riedmueller > --- >

Re: issues communicating with SPI on Raspberry Pi 3

2018-12-06 Thread Sascha Hauer
On Wed, Dec 05, 2018 at 03:22:40PM +, Kai Che wrote: > Hi all, > > I'm trying to communicate with a TPM 2.0 (infineon,slb9670) over SPI on a > Raspberry Pi 3 in barebox. > > CONFIG_SPI=y > CONFIG_DRIVER_SPI_GPIO=y > CONFIG_CMD_SPI=y > > are set in the barebox configuration and > >