[PATCH] kvx: exclude dtb from malloc zone

2020-07-09 Thread Clement Leger
When dtb is provided by the FSBL (first stage bootloader), it might end up in the malloc zone initialized by barebox. While the dtb is discarded after being unflatten, if the dtb is provided right after barebox elf, then the malloc can overwrite it while unflattening it when allocating nodes. To

[PATCH v2] fixup! ARM: at91: add helpers for chain-loading barebox from SD-card

2020-07-09 Thread Ahmad Fatoum
Drop no longer accurate comment. Use c99 designated initializers. Don't force != 0 to 1. Signed-off-by: Ahmad Fatoum --- arch/arm/mach-at91/xload-mmc.c | 21 + 1 file changed, 13 insertions(+), 8 deletions(-) diff --git a/arch/arm/mach-at91/xload-mmc.c

Re: [PATCH] ARM: configs: Remove unused Kconfig symbol 'NAND_IMX_BBM'

2020-07-09 Thread Sascha Hauer
On Mon, Jul 06, 2020 at 05:54:21PM +0200, Robert Karszniewicz wrote: > This Kconfig symbol has been removed in > 2ad441bb7e78 ("mtd: nand-imx: Create BBT automatically when necessary") > > Signed-off-by: Robert Karszniewicz > --- > arch/arm/configs/eukrea_cpuimx35_defconfig| 1 - >

Re: [PATCH] ARM: layerscape: ppa: fix error propagation in ppa_init()

2020-07-09 Thread Sascha Hauer
On Mon, Jul 06, 2020 at 08:27:04AM +0200, Ahmad Fatoum wrote: > On fit_open_image, we returned PTR_ERR(fit) instead of the correct ret. > We also didn't call fit_close as we should. Fix this. > > Signed-off-by: Ahmad Fatoum > --- > arch/arm/mach-layerscape/ppa.c | 7 +++ > 1 file changed, 3

Re: [PATCH] i2c: designware: use proper type for writel argument

2020-07-09 Thread Sascha Hauer
On Mon, Jul 06, 2020 at 08:26:43AM +0200, Ahmad Fatoum wrote: > We need to write DW_IC_ENABLE_ENABLE (1 << 0) to the register to enable, > but instead we were writing true. This happens to work, but is quite > unusual. Make the code more readable. > > Signed-off-by: Ahmad Fatoum > --- >

Re: [PATCH 19/28] ARM: at91: add helpers for chain-loading barebox from SD-card

2020-07-09 Thread Sascha Hauer
On Mon, Jul 06, 2020 at 12:35:30AM +0200, Ahmad Fatoum wrote: > > > On 7/5/20 8:42 PM, Sascha Hauer wrote: > > On Wed, Jul 01, 2020 at 11:11:13AM +0200, Ahmad Fatoum wrote: > >> +static void at91_fat_start_image(struct pbl_bio *bio, > >> + void *buf, unsigned int len, >

Re: [PATCH] kbuild: add dtbs target for building all dtbs of an ARCH

2020-07-09 Thread Sascha Hauer
On Mon, Jul 06, 2020 at 12:31:09AM +0200, Ahmad Fatoum wrote: > > > On 7/5/20 7:35 PM, Sascha Hauer wrote: > > On Thu, Jul 02, 2020 at 10:59:34AM +0200, Ahmad Fatoum wrote: > >> As described in the documentation, upstream device trees extended by > >> barebox should take care to cause compile

Re: [RFC PATCH 0/4] Introduce global.bootm.root env var for booting via PARTUUID

2020-07-09 Thread Sascha Hauer
On Tue, Jun 30, 2020 at 03:48:30PM +0200, Robert Karszniewicz wrote: > This patch introduces a new env var which specifies which device > is the rootfs device to be used in Linux, passed to Linux via bootargs, > identified by the rootfs partition's PARTUUID. > > global.bootm.root supplements