Re: [base] basedb-users Digest, Vol 70, Issue 1

2015-03-12 Thread Jari Häkkinen
One source for the problem is that the underlying RMAExpressConsole 
program doesn't handle ST arrays, or maybe treats ST arrays differently. 
Have you checked with the author of RMAExpress tool?

The se.lu.thep.affymetrix for BASE plug-in and expects the output file 
from RMAExpressConsole to be rma.txt. Either RMAExpressConsole crashes 
or does not create rma.txt but rather something else.

I cannot test anything myself since we do not have any ST array data nor 
a running BASE 2 server (which is required for the affymetrix plug-in). 
I suggest that you try to run RMAExpressConsole manually on your server 
and see what the outcome is. Are ST arrays accepted by 
RMAExpressConsole, does RMAExpressConsole crash (this should be caught 
by the plug-in), is another set of output files created for ST arrays?

(Another thing to check is what files and directories are created by the 
plug-in once it is finished but unfortunately this is harder to 
accomplish since the affymetrix plug-in cleans up after it finishes.)


Jari


On 2015-03-11 01:01, Ross Chapman wrote:
 Hi Jari

 Thank you for your comments.

 I am using BASE 2.17.2 which is running on a Linux/Ubuntu server.

 I have found that RMAExpress runs perfectly with most Affymetrix files,
 but I get this error when analysing data from Affymetrix GeneChip Human
 Gene 1.0 ST or Affymetrix GeneChip Mouse Gene 1.0 ST arrays, so I
 believe that the error must lie with the configuration of the ST arrays
 within base.

 I preloaded the probes as reporters into the database from a cdf file
 for each array, and the reporters are visible in the database.

 Yet somehow the RMAExpress plugin is failing with these arrays.

 I would appreciate any comments or suggestions.

 Thanks

 Ross

 On 5 March 2015 at 00:18, basedb-users-requ...@lists.sourceforge.net
 mailto:basedb-users-requ...@lists.sourceforge.net wrote:

 Send basedb-users mailing list submissions to
 basedb-users@lists.sourceforge.net
 mailto:basedb-users@lists.sourceforge.net

 To subscribe or unsubscribe via the World Wide Web, visit
 https://lists.sourceforge.net/lists/listinfo/basedb-users
 or, via email, send a message with subject or body 'help' to
 basedb-users-requ...@lists.sourceforge.net
 mailto:basedb-users-requ...@lists.sourceforge.net

 You can reach the person managing the list at
 basedb-users-ow...@lists.sourceforge.net
 mailto:basedb-users-ow...@lists.sourceforge.net

 When replying, please edit your Subject line so it is more specific
 than Re: Contents of basedb-users digest...

 Today's Topics:

 1. Re: BASE reporter fields problem (Nicklas Nordborg)
 2. BASE 3.4 has been released (Nicklas Nordborg)
 3. RMAexpress (Ross Chapman)
 4. Re: RMAexpress (Jari H?kkinen)
 5. BASE 3.4.1 has been released (Nicklas Nordborg)
 6. (no subject) (Ross Chapman)
 7. Re: Problem with RMAexpress plugin [Was: (no subject)]
(Jari H?kkinen)


 -- Forwarded message --
 From: Nicklas Nordborg nicklas.nordb...@med.lu.se
 mailto:nicklas.nordb...@med.lu.se
 To: BASE ML basedb-users@lists.sourceforge.net
 mailto:basedb-users@lists.sourceforge.net
 Cc:
 Date: Mon, 12 Jan 2015 07:50:46 +0100
 Subject: Re: [base] BASE reporter fields problem
 On 2015-01-12 07:25, Ross Chapman wrote:

 Hi all

 I recently moved a BASE2 database to a new server by copying the
 full
 database and all installation files along with plugin files.

 When I try to run some custom plugins on the new instance, I
 receive an
 error stating that there is an unknown reporter field being
 requested in
 the new database version. The same plugins still work fine on the
 original BASE2 application.

 Can you point me to where the reporter fields are set and how I can
 correct the annotations in the new instance.


 This should be in the extended-properties.xml file that is found in
 the WEB-INF/classes directory in your BASE installation. See
 
 http://base.thep.lu.se/chrome/__site/latest/html/appendix/__extendedproperties.html
 
 http://base.thep.lu.se/chrome/site/latest/html/appendix/extendedproperties.html
 for some more information.

 /Nicklas





 -- Forwarded message --
 From: Nicklas Nordborg nicklas.nordb...@med.lu.se
 mailto:nicklas.nordb...@med.lu.se
 To: BASE ML basedb-users@lists.sourceforge.net
 mailto:basedb-users@lists.sourceforge.net, BASE dev
 basedb-de...@lists.sourceforge.net
 mailto:basedb-de...@lists.sourceforge.net,
 basedb-annou...@lists.sourceforge.net
 mailto:basedb-annou...@lists.sourceforge.net
 Cc:
 Date: Wed, 14 Jan 2015 14:41:58 +0100
 Subject: [base] BASE 3.4 has been released
 Hello all,

 After fixing a few issues with the beta version, BASE 3.4.0 has now

Re: [base] basedb-users Digest, Vol 70, Issue 1

2015-03-12 Thread Jari Häkkinen
On 2015-03-12 09:24, Jari Häkkinen wrote:
 One source for the problem is that the underlying RMAExpressConsole
 program doesn't handle ST arrays, or maybe treats ST arrays differently.

I meant to say that problem may be with RMAExpressConsole but I don't know.


Jari





--
Dive into the World of Parallel Programming The Go Parallel Website, sponsored
by Intel and developed in partnership with Slashdot Media, is your hub for all
things parallel software development, from weekly thought leadership blogs to
news, videos, case studies, tutorials and more. Take a look and join the 
conversation now. http://goparallel.sourceforge.net/
___
The BASE general discussion mailing list
basedb-users@lists.sourceforge.net
unsubscribe: send a mail with subject unsubscribe to
basedb-users-requ...@lists.sourceforge.net


Re: [base] basedb-users Digest, Vol 70, Issue 1

2015-03-10 Thread Ross Chapman
Hi Jari

Thank you for your comments.

I am using BASE 2.17.2 which is running on a Linux/Ubuntu server.

I have found that RMAExpress runs perfectly with most Affymetrix files, but
I get this error when analysing data from Affymetrix GeneChip Human Gene
1.0 ST or Affymetrix GeneChip Mouse Gene 1.0 ST arrays, so I believe that
the error must lie with the configuration of the ST arrays within base.

I preloaded the probes as reporters into the database from a cdf file for
each array, and the reporters are visible in the database.

Yet somehow the RMAExpress plugin is failing with these arrays.

I would appreciate any comments or suggestions.

Thanks

Ross

On 5 March 2015 at 00:18, basedb-users-requ...@lists.sourceforge.net
wrote:

 Send basedb-users mailing list submissions to
 basedb-users@lists.sourceforge.net

 To subscribe or unsubscribe via the World Wide Web, visit
 https://lists.sourceforge.net/lists/listinfo/basedb-users
 or, via email, send a message with subject or body 'help' to
 basedb-users-requ...@lists.sourceforge.net

 You can reach the person managing the list at
 basedb-users-ow...@lists.sourceforge.net

 When replying, please edit your Subject line so it is more specific
 than Re: Contents of basedb-users digest...

 Today's Topics:

1. Re: BASE reporter fields problem (Nicklas Nordborg)
2. BASE 3.4 has been released (Nicklas Nordborg)
3. RMAexpress (Ross Chapman)
4. Re: RMAexpress (Jari H?kkinen)
5. BASE 3.4.1 has been released (Nicklas Nordborg)
6. (no subject) (Ross Chapman)
7. Re: Problem with RMAexpress plugin [Was: (no subject)]
   (Jari H?kkinen)


 -- Forwarded message --
 From: Nicklas Nordborg nicklas.nordb...@med.lu.se
 To: BASE ML basedb-users@lists.sourceforge.net
 Cc:
 Date: Mon, 12 Jan 2015 07:50:46 +0100
 Subject: Re: [base] BASE reporter fields problem
 On 2015-01-12 07:25, Ross Chapman wrote:

 Hi all

 I recently moved a BASE2 database to a new server by copying the full
 database and all installation files along with plugin files.

 When I try to run some custom plugins on the new instance, I receive an
 error stating that there is an unknown reporter field being requested in
 the new database version. The same plugins still work fine on the
 original BASE2 application.

 Can you point me to where the reporter fields are set and how I can
 correct the annotations in the new instance.


 This should be in the extended-properties.xml file that is found in the
 WEB-INF/classes directory in your BASE installation. See
 http://base.thep.lu.se/chrome/site/latest/html/appendix/
 extendedproperties.html for some more information.

 /Nicklas





 -- Forwarded message --
 From: Nicklas Nordborg nicklas.nordb...@med.lu.se
 To: BASE ML basedb-users@lists.sourceforge.net, BASE dev 
 basedb-de...@lists.sourceforge.net, 
 basedb-annou...@lists.sourceforge.net
 Cc:
 Date: Wed, 14 Jan 2015 14:41:58 +0100
 Subject: [base] BASE 3.4 has been released
 Hello all,

 After fixing a few issues with the beta version, BASE 3.4.0 has now
 been released. One new feature is the possibility to install skins. Check
 out the example skins at
 http://baseplugins.thep.lu.se/wiki/net.sf.basedb.skincollection

 For a complete list of changes, see:
 http://base.thep.lu.se/query?milestone=BASE+3.4group=type

 Installation/upgrade instructions:
 http://base.thep.lu.se/chrome/site/latest/html/admin/installation.html

 As usual, the program can be downloaded from:
 http://base.thep.lu.se/wiki/DownloadPage

 /Nicklas




 -- Forwarded message --
 From: Ross Chapman ross.chap...@mimr-phi.org
 To: basedb-users@lists.sourceforge.net
 Cc:
 Date: Tue, 3 Feb 2015 16:55:30 +1100
 Subject: [base] RMAexpress
 Hi all

 I am having problems running the RMAexpress plug in after migrating BASE2
 to a new server.


 The plug in fails with the following error:

 java.io.IOException: Unexpected exit of RMAExpress sub-process. Return
 value: 127
 at se.lu.thep.affymetrix.RMAExpress.runBinary(RMAExpress.java:156)
 at
 se.lu.thep.affymetrix.AbstractExternalBinaryPlugin.run(AbstractExternalBinaryPlugin.java:262)
 at
 net.sf.basedb.core.PluginExecutionRequest.invoke(PluginExecutionRequest.java:116)
 at
 net.sf.basedb.core.InternalJobQueue$JobRunner.run(InternalJobQueue.java:510)
 at java.lang.Thread.run(Thread.java:745)

 Can you suggest a possible cause and solution?

 Many thanks

 Ross

 --
 Dr Ross Chapman
 Senior Bioinformatician
 MIMR-PHI Institute of Medical Research
 27-31 Wright Street, Clayton, VIC 3168

 (03) 99024766


 -- Forwarded message --
 From: Jari Häkkinen jari.hakki...@med.lu.se
 To: basedb-users@lists.sourceforge.net
 Cc:
 Date: Tue, 03 Feb 2015 14:20:45 +0100
 Subject: Re: [base] RMAexpress
 Hi,

 Did you also move the underlying RMAexpress binary to the new server? You
 probably need to recompile RMAExpress (http://rmaexpress.bmbolstad.com/)
 for your new server.


 Jari


 On