Re: [base] Tab2Mage exporter plugin

2011-06-13 Thread Irina 264

I upgrade BASE, but have anothe error message:
 
 Error: [EXPORT FAILED: Experiment - Experiment[id=27; name=Agilent IFNalpha 
time course] do not have a rawbiosay specified]. 
 
stack trace:


java.lang.Throwable
at uk.ac.ebi.nugo.plugins.Tab2MageExporter.run(Tab2MageExporter.java:331)
at 
net.sf.basedb.core.PluginExecutionRequest.invoke(PluginExecutionRequest.java:116)
at net.sf.basedb.core.InternalJobQueue$JobRunner.run(InternalJobQueue.java:510)
at java.lang.Thread.run(Thread.java:636)

 
 
Regards,
Irina
 
 
 
 Date: Fri, 10 Jun 2011 08:45:27 +0200
 From: nick...@thep.lu.se
 To: basedb-users@lists.sourceforge.net
 Subject: Re: [base] Tab2Mage exporter plugin
 
 This was fixed in BASE 2.16.1 (http://base.thep.lu.se/ticket/1553). I 
 suggest that you upgrade.
 
 
 On the other hand... the Tab2Mage plug-in may require that you specify 
 labeled extracts, extracts, samples and biosources or it may not work.
 
 /Nicklas
 
 On 2011-06-10 08:17, Irina 264 wrote:
  Dear team,
 
  I am working on ‘Tab2Mage exporter’ plugin. I created Agilent experiment
  and Validate it with following message:
 
 
  java.lang.NullPointerException on page
  /base2/common/overview/index.jsp
 
  *Version*
 
  
 
  BASE 2.16.0 (build #5472; schema #88)
 
  *Web server*
 
  
 
  Apache Tomcat/6.0.29
 
  *Database Server*
 
  
 
  MySQL 5.0.77
 
  *Database Dialect*
 
  
 
  org.hibernate.dialect.MySQLInnoDBDialect
 
  *JDBC Driver*
 
  
 
  com.mysql.jdbc.Driver (version 5.1)
 
  *Java runtime*
 
  
 
  OpenJDK Runtime Environment (1.6.0_17-b17), Sun Microsystems Inc.
  http://java.sun.com/
 
  *Operating system*
 
  
 
  Linux amd64 2.6.18-194.17.4.el5
 
  *Memory*
 
  
 
  Total: 924.8 MB
  Free: 607.6 MB
  Max: 1.8 GB
 
  *Browser*
 
  
 
  Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 5.1; Trident/4.0; .NET CLR
  1.1.4322; .NET CLR 2.0.50727; .NET CLR 3.0.4506.2152; .NET CLR
  3.5.30729; InfoPath.2; .NET4.0C)
 
  *Error message*
 
  
 
  *Stack trace*
 
  
 
 
  Version BASE 2.16.0 (build #5472; schema #88)
  Web server Apache Tomcat/6.0.29
  Database Server MySQL 5.0.77
  Database Dialect org.hibernate.dialect.MySQLInnoDBDialect
  JDBC Driver com.mysql.jdbc.Driver (version 5.1)
  Java runtime OpenJDK Runtime Environment (1.6.0_17-b17), Sun
  Microsystems Inc. http://java.sun.com/
  Operating system Linux amd64 2.6.18-194.17.4.el5
  Memory Total: 924.8 MB
  Free: 607.6 MB
  Max: 1.8 GB
  Browser Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 5.1; Trident/4.0;
  .NET CLR 1.1.4322; .NET CLR 2.0.50727; .NET CLR 3.0.4506.2152; .NET CLR
  3.5.30729; InfoPath.2; .NET4.0C)
  Error message 
  Stack trace
 
 
  Version BASE 2.16.0 (build #5472; schema #88)
  Web server Apache Tomcat/6.0.29
  Database Server MySQL 5.0.77
  Database Dialect org.hibernate.dialect.MySQLInnoDBDialect
  JDBC Driver com.mysql.jdbc.Driver (version 5.1)
  Java runtime OpenJDK Runtime Environment (1.6.0_17-b17), Sun
  Microsystems Inc. http://java.sun.com/
  Operating system Linux amd64 2.6.18-194.17.4.el5
  Memory Total: 924.8 MB
  Free: 607.6 MB
  Max: 1.8 GB
  Browser Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 5.1; Trident/4.0;
  .NET CLR 1.1.4322; .NET CLR 2.0.50727; .NET CLR 3.0.4506.2152; .NET CLR
  3.5.30729; InfoPath.2; .NET4.0C)
  Error message 
  Stack trace
 
 
  Version BASE 2.16.0 (build #5472; schema #88)
  Web server Apache Tomcat/6.0.29
  Database Server MySQL 5.0.77
  Database Dialect org.hibernate.dialect.MySQLInnoDBDialect
  JDBC Driver com.mysql.jdbc.Driver (version 5.1)
  Java runtime OpenJDK Runtime Environment (1.6.0_17-b17), Sun
  Microsystems Inc. http://java.sun.com/
  Operating system Linux amd64 2.6.18-194.17.4.el5
  Memory Total: 924.8 MB
  Free: 607.6 MB
  Max: 1.8 GB
  Browser Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 5.1; Trident/4.0;
  .NET CLR 1.1.4322; .NET CLR 2.0.50727; .NET CLR 3.0.4506.2152; .NET CLR
  3.5.30729; InfoPath.2; .NET4.0C)
  Error message 
  Stack trace 
 
 
  java.lang.NullPointerException
  ...at 
  net.sf.basedb.util.overview.validator.LabeledExtractValidator.postValidateFolder(LabeledExtractValidator.java:122)
  ...at 
  net.sf.basedb.util.overview.node.NodeFactory.postValidateFolder(NodeFactory.java:224)
  ...at 
  net.sf.basedb.util.overview.loader.BasicItemNodeLoader.postValidateFolder(BasicItemNodeLoader.java:134)
  ...at 
  net.sf.basedb.util.overview.loader.LabeledExtractLoader.createReverseNode(LabeledExtractLoader.java:230)
  ...at 
  net.sf.basedb.util.overview.loader.LabeledExtractLoader.createReverseNode(LabeledExtractLoader.java:104)
  ...at 
  net.sf.basedb.util.overview.loader.AutoChildNodeLoader.createReverseNode(AutoChildNodeLoader.java:95)
  ...at 
  net.sf.basedb.util.overview.loader.HybridizationLoader.loadReverseChildNodes(HybridizationLoader.java:187)
  ...at 
  net.sf.basedb.util.overview.loader.AbstractNodeLoader.loadChildNodesOfItemNode(AbstractNodeLoader.java:126)
 
  ...at 
  net.sf.basedb.util.overview.loader.AbstractNodeLoader.loadChildNodes(AbstractNodeLoader.java:112

Re: [base] Tab2Mage exporter plugin

2011-06-13 Thread Nicklas Nordborg
On 2011-06-13 08:51, Irina 264 wrote:
 I upgrade BASE, but have anothe error message:

 Error: [EXPORT FAILED: Experiment - Experiment[id=27; name=Agilent
 IFNalpha time course] do not have a rawbiosay specified].

Add raw bioassays to your experiment.

/Nicklas

--
EditLive Enterprise is the world's most technically advanced content
authoring tool. Experience the power of Track Changes, Inline Image
Editing and ensure content is compliant with Accessibility Checking.
http://p.sf.net/sfu/ephox-dev2dev
___
The BASE general discussion mailing list
basedb-users@lists.sourceforge.net
unsubscribe: send a mail with subject unsubscribe to
basedb-users-requ...@lists.sourceforge.net


Re: [base] Tab2Mage exporter plugin

2011-06-13 Thread Nicklas Nordborg
On 2011-06-13 09:17, Irina 264 wrote:
 Thanks, thay already there!

Have you checked that the owner of the raw bioassays is the same as the 
owner of the experiment or that everything is shared to the same project 
which must also be the active project?

/Nicklas

--
EditLive Enterprise is the world's most technically advanced content
authoring tool. Experience the power of Track Changes, Inline Image
Editing and ensure content is compliant with Accessibility Checking.
http://p.sf.net/sfu/ephox-dev2dev
___
The BASE general discussion mailing list
basedb-users@lists.sourceforge.net
unsubscribe: send a mail with subject unsubscribe to
basedb-users-requ...@lists.sourceforge.net


Re: [base] Tab2Mage exporter plugin

2011-06-10 Thread Nicklas Nordborg
This was fixed in BASE 2.16.1 (http://base.thep.lu.se/ticket/1553). I 
suggest that you upgrade.


On the other hand... the Tab2Mage plug-in may require that you specify 
labeled extracts, extracts, samples and biosources or it may not work.

/Nicklas

On 2011-06-10 08:17, Irina 264 wrote:
 Dear team,

 I am working on ‘Tab2Mage exporter’ plugin. I created Agilent experiment
 and Validate it with following message:


   java.lang.NullPointerException on page
   /base2/common/overview/index.jsp

 *Version*

   

 BASE 2.16.0 (build #5472; schema #88)

 *Web server*

   

 Apache Tomcat/6.0.29

 *Database Server*

   

 MySQL 5.0.77

 *Database Dialect*

   

 org.hibernate.dialect.MySQLInnoDBDialect

 *JDBC Driver*

   

 com.mysql.jdbc.Driver (version 5.1)

 *Java runtime*

   

 OpenJDK Runtime Environment (1.6.0_17-b17), Sun Microsystems Inc.
 http://java.sun.com/

 *Operating system*

   

 Linux amd64 2.6.18-194.17.4.el5

 *Memory*

   

 Total: 924.8 MB
 Free: 607.6 MB
 Max: 1.8 GB

 *Browser*

   

 Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 5.1; Trident/4.0; .NET CLR
 1.1.4322; .NET CLR 2.0.50727; .NET CLR 3.0.4506.2152; .NET CLR
 3.5.30729; InfoPath.2; .NET4.0C)

 *Error message*

   

 *Stack trace*

   


 Version   BASE 2.16.0 (build #5472; schema #88)
 Web serverApache Tomcat/6.0.29
 Database Server   MySQL 5.0.77
 Database Dialect  org.hibernate.dialect.MySQLInnoDBDialect
 JDBC Driver   com.mysql.jdbc.Driver (version 5.1)
 Java runtime  OpenJDK Runtime Environment (1.6.0_17-b17), Sun
 Microsystems Inc. http://java.sun.com/
 Operating system  Linux amd64 2.6.18-194.17.4.el5
 MemoryTotal: 924.8 MB
 Free: 607.6 MB
 Max: 1.8 GB
 Browser   Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 5.1; Trident/4.0;
 .NET CLR 1.1.4322; .NET CLR 2.0.50727; .NET CLR 3.0.4506.2152; .NET CLR
 3.5.30729; InfoPath.2; .NET4.0C)
 Error message 
 Stack trace


 Version   BASE 2.16.0 (build #5472; schema #88)
 Web serverApache Tomcat/6.0.29
 Database Server   MySQL 5.0.77
 Database Dialect  org.hibernate.dialect.MySQLInnoDBDialect
 JDBC Driver   com.mysql.jdbc.Driver (version 5.1)
 Java runtime  OpenJDK Runtime Environment (1.6.0_17-b17), Sun
 Microsystems Inc. http://java.sun.com/
 Operating system  Linux amd64 2.6.18-194.17.4.el5
 MemoryTotal: 924.8 MB
 Free: 607.6 MB
 Max: 1.8 GB
 Browser   Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 5.1; Trident/4.0;
 .NET CLR 1.1.4322; .NET CLR 2.0.50727; .NET CLR 3.0.4506.2152; .NET CLR
 3.5.30729; InfoPath.2; .NET4.0C)
 Error message 
 Stack trace


 Version   BASE 2.16.0 (build #5472; schema #88)
 Web serverApache Tomcat/6.0.29
 Database Server   MySQL 5.0.77
 Database Dialect  org.hibernate.dialect.MySQLInnoDBDialect
 JDBC Driver   com.mysql.jdbc.Driver (version 5.1)
 Java runtime  OpenJDK Runtime Environment (1.6.0_17-b17), Sun
 Microsystems Inc. http://java.sun.com/
 Operating system  Linux amd64 2.6.18-194.17.4.el5
 MemoryTotal: 924.8 MB
 Free: 607.6 MB
 Max: 1.8 GB
 Browser   Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 5.1; Trident/4.0;
 .NET CLR 1.1.4322; .NET CLR 2.0.50727; .NET CLR 3.0.4506.2152; .NET CLR
 3.5.30729; InfoPath.2; .NET4.0C)
 Error message 
 Stack trace   


 java.lang.NullPointerException
 ...at 
 net.sf.basedb.util.overview.validator.LabeledExtractValidator.postValidateFolder(LabeledExtractValidator.java:122)
 ...at 
 net.sf.basedb.util.overview.node.NodeFactory.postValidateFolder(NodeFactory.java:224)
 ...at 
 net.sf.basedb.util.overview.loader.BasicItemNodeLoader.postValidateFolder(BasicItemNodeLoader.java:134)
 ...at 
 net.sf.basedb.util.overview.loader.LabeledExtractLoader.createReverseNode(LabeledExtractLoader.java:230)
 ...at 
 net.sf.basedb.util.overview.loader.LabeledExtractLoader.createReverseNode(LabeledExtractLoader.java:104)
 ...at 
 net.sf.basedb.util.overview.loader.AutoChildNodeLoader.createReverseNode(AutoChildNodeLoader.java:95)
 ...at 
 net.sf.basedb.util.overview.loader.HybridizationLoader.loadReverseChildNodes(HybridizationLoader.java:187)
 ...at 
 net.sf.basedb.util.overview.loader.AbstractNodeLoader.loadChildNodesOfItemNode(AbstractNodeLoader.java:126)

 ...at 
 net.sf.basedb.util.overview.loader.AbstractNodeLoader.loadChildNodes(AbstractNodeLoader.java:112)
 ...at 
 net.sf.basedb.util.overview.loader.AutoChildNodeLoader.loadChildNodes(AutoChildNodeLoader.java:121)
 ...at 
 net.sf.basedb.util.overview.loader.AutoChildNodeLoader.createReverseNode(AutoChildNodeLoader.java:96)
 ...at 
 net.sf.basedb.util.overview.loader.ScanLoader.loadReverseChildNodes(ScanLoader.java:171)
 ...at 
 net.sf.basedb.util.overview.loader.AbstractNodeLoader.loadChildNodesOfItemNode(AbstractNodeLoader.java:126)
 ...at 
 net.sf.basedb.util.overview.loader.AbstractNodeLoader.loadChildNodes(AbstractNodeLoader.java:112)
 ...at 
 

Re: [base] tab2mage exporter plugin installation problem

2008-03-20 Thread Philippe
Hi Lisa,

I think they are a bit hidden:
try this link
http://baseplugins.thep.lu.se/svn/plugins/base2/uk.ac.ebi.tab2mage/trunk/Tab2MageImporter/lib/

Same disclaimer as yesterday (see also my message to Alessandro). You 
are using BASE2.5 and the API change with this release breaks the plugin.

Cheers

Philippe


Lisa Bishop wrote:

Hi,

I sorted out my tab2mage export. I think it was a typo but I place it in the 
plugin directory as advised and it worked.
I have another question with regard the tab2mage importer. I’m not sure which 
one to download the Tab2MageImporter – 1.0jar or the Tab2mageImporter.jar
Also the installation from the branches 
(http://baseplugins.thep.lu.se/svn/plugins/base2/uk.ac.ebi.tab2mage/branches/tab2mageimporter/)
  which states “- Place Tab2MageImporter.jar into the $BASE2_HOME/www/plugins/ 
directory on your BASE2 server. 
   - Install as new plugins uk.ac.ebi.nugo.plugins.Tab2MageImporter and 
 uk.ac.ebi.nugo.plugins.AnnotationTypeCvImporter which are both contained in 
 $BASE_HOME/www/plugins/Tab2MageImporter.jar.”


Is different from the trunk directory 
(http://baseplugins.thep.lu.se/svn/plugins/base2/uk.ac.ebi.tab2mage/trunk/Tab2MageImporter/)
 which states 
“Place Tab2MageImporter.jar, activation.jar, ebi-plugins-utils.jar, mail.jar, 
bloader.jar and AnnotationTypeCvImporter.jar into the $BASE2_HOME/www/plugins/ 
directory on your BASE2 server. 
   Install as new plugins uk.ac.ebi.nugo.plugins.Tab2MageImporter

I‘m not sure if there is a difference but I downloaded the tab2mage exporter 
from the trunk dir but the tab2mage importer from the trunk dir needs the 
activation.jar, mail.jar and bloader.jar and I can’t find these.
Any help,
Thanks,
Lisa

-
This SF.net email is sponsored by: Microsoft
Defy all challenges. Microsoft(R) Visual Studio 2008.
http://clk.atdmt.com/MRT/go/vse012070mrt/direct/01/
___
The BASE general discussion mailing list
basedb-users@lists.sourceforge.net
unsubscribe: send a mail with subject unsubscribe to
[EMAIL PROTECTED]
  



-
This SF.net email is sponsored by: Microsoft
Defy all challenges. Microsoft(R) Visual Studio 2008.
http://clk.atdmt.com/MRT/go/vse012070mrt/direct/01/
___
The BASE general discussion mailing list
basedb-users@lists.sourceforge.net
unsubscribe: send a mail with subject unsubscribe to
[EMAIL PROTECTED]


Re: [base] tab2mage exporter plugin installation problem

2008-03-19 Thread rocca
Hello Lisa,

I will start with a disclaimer. We have not tested the plugin with base2.5.
We recommend using base2.4.6. Again we are working toward upgrading it.

now regarding your installation, it seems that the path you have indicated
when configuring the plugin (i.e.
usr/local/base-2.5.0/www/plugins/tab2mage/Tab2MageExporter/Tab2mageExporter.jar)
differs from what it actually is.
From your message, it seems that the path should be:
usr/local/base-2.5.0/www/plugins/tab2mage/Tab2mageExporter.jar

let me know if this solves your pb.

cheers

Philippe


 Hi all,
 I'm having a problem with creating a new plugin in Administrate- plugins -
 definitions for the tab2mage exporter.
 i get the following error:
 JAR file not found:
 usr/local/base-2.5.0/www/plugins/tab2mage/Tab2MageExporter/Tab2mageExporter.jar
 I have downloaded the Tab2MageExporter.jar and the ebi-plugins-utils.jar
 to usr/local/base-2.5.0/www/plugins/tab2mage from this url
 http://baseplugins.thep.lu.se/svn/plugins/base2/uk.ac.ebi.tab2mage/trunk/Tab2MageExporter
 i installed
 I'm missing something but not sure what?
 Any Help.
 thanks,
 lisa Bishop


 -
 This SF.net email is sponsored by: Microsoft
 Defy all challenges. Microsoft(R) Visual Studio 2008.
 http://clk.atdmt.com/MRT/go/vse012070mrt/direct/01/
 ___
 The BASE general discussion mailing list
 basedb-users@lists.sourceforge.net
 unsubscribe: send a mail with subject unsubscribe to
 [EMAIL PROTECTED]




-
This SF.net email is sponsored by: Microsoft
Defy all challenges. Microsoft(R) Visual Studio 2008.
http://clk.atdmt.com/MRT/go/vse012070mrt/direct/01/
___
The BASE general discussion mailing list
basedb-users@lists.sourceforge.net
unsubscribe: send a mail with subject unsubscribe to
[EMAIL PROTECTED]


Re: [base] tab2mage exporter plugin installation problem

2008-03-19 Thread Nicklas Nordborg
[EMAIL PROTECTED] wrote:
 now regarding your installation, it seems that the path you have indicated
 when configuring the plugin (i.e.
 usr/local/base-2.5.0/www/plugins/tab2mage/Tab2MageExporter/Tab2mageExporter.jar)
 differs from what it actually is.
From your message, it seems that the path should be:
 usr/local/base-2.5.0/www/plugins/tab2mage/Tab2mageExporter.jar

There seems to be a general misunderstanding that plugins should be 
installed in the  basedir/www/plugins/ directory. This directory 
should only contain JSP pages and other resources (such as images, 
javascripts, etc.) that are needed by the plug-ins, not the actual 
plug-in JAR files.

This has been clarified in the documentation and since the 2.5 release 
we are recommending that plugins are installed in the basedir/plugins/ 
directory (or at least in a directory that is outside the www 
directory). The main reason is that everything in the www directory is 
accessible from the internet and since BASE doesn't provide any access 
control to anything else that JSP files, installing plug-ins in the www 
directory may lead to security problems.

/Nicklas

-
This SF.net email is sponsored by: Microsoft
Defy all challenges. Microsoft(R) Visual Studio 2008.
http://clk.atdmt.com/MRT/go/vse012070mrt/direct/01/
___
The BASE general discussion mailing list
basedb-users@lists.sourceforge.net
unsubscribe: send a mail with subject unsubscribe to
[EMAIL PROTECTED]


Re: [base] tab2mage exporter plugin installation problem

2008-03-19 Thread Nicklas Nordborg
Lisa Bishop wrote:
 hi 
 Sorry i think that was a typo.
 this is my class
 uk.ac.ebi.nugo.plugins.Tab2MageExporter
 And path
 usr/local/base-2.5.0/www/plugins/tab2mage/Tab2mageExporter.jar
 Still getting an error. for not finding the jar file
 i was wondering could the install of uk.ac.ebi.nugo.plugins.Tab2MageExporter 
 be causing my problems?

It seems like you are missing a / in the beginning of the path. 
Shouldn't it be: /usr/local...

/Nicklas

-
This SF.net email is sponsored by: Microsoft
Defy all challenges. Microsoft(R) Visual Studio 2008.
http://clk.atdmt.com/MRT/go/vse012070mrt/direct/01/
___
The BASE general discussion mailing list
basedb-users@lists.sourceforge.net
unsubscribe: send a mail with subject unsubscribe to
[EMAIL PROTECTED]