Re: [beagleboard] What to do about Denial of Service Vulnerability for Kernel version's 4.9+ ?

2018-10-22 Thread Jeff Andich
Thanks a lot Robert!!! Will fetch it, build it, deploy, and test on our image.. Regards, Jeff -- For more options, visit http://beagleboard.org/discuss --- You received this message because you are subscribed to the Google Groups "BeagleBoard" group. To unsubscribe from this group and stop

Re: [beagleboard] What to do about Denial of Service Vulnerability for Kernel version's 4.9+ ?

2018-10-22 Thread Jeff Andich
Ok thanks a lot Robert!!! On Monday, October 22, 2018 at 2:24:58 PM UTC-5, RobertCNelson wrote: > > On Mon, Oct 22, 2018 at 2:10 PM Jeff Andich > wrote: > > > > Robert, > > > > We've got a BBB where we're running, > bone-debian-9.3-console-armhf-2018-03-

Re: [beagleboard] What to do about Denial of Service Vulnerability for Kernel version's 4.9+ ?

2018-10-22 Thread Jeff Andich
? Thanks in advance!! Jeff On Tuesday, August 7, 2018 at 9:24:26 AM UTC-5, Jeff Andich wrote: > > Good to know! > > Thanks!! > > Jeff > > > On Tuesday, August 7, 2018 at 9:14:46 AM UTC-5, RobertCNelson wrote: >> >> On Tue, Aug 7, 2018 at 8:50 AM Jeff Andich w

[beagleboard] Re: Android and PRUs

2018-08-10 Thread Jeff Andich
Also, could you please cross reference the Android forum you posted to so those interested can follow the status there? Thanks!! On Friday, August 10, 2018 at 10:37:16 AM UTC-5, Jeff Andich wrote: > > TI appears to offer an Android processor SDK for the Sitara 572x (BB-X15), > bu

[beagleboard] Re: Android and PRUs

2018-08-10 Thread Jeff Andich
TI appears to offer an Android processor SDK for the Sitara 572x (BB-X15), but I don't see one for the 335X (BeagleBone Black). http://www.ti.com/tool/PROCESSOR-SDK-AM57X http://www.ti.com/tool/PROCESSOR-SDK-AM335X The 572x, 571x platform has PRU's, so I'm assuming that TI provides a way to

[beagleboard] Re: Beagleboard x15 speed

2018-08-08 Thread Jeff Andich
Well, is the usrp able to give you baseband data? I did some very very rough benchmarks for each of the 2 C66DSP's, several months ago showing Each C66DSP: Fs = 100kHz. 60, 152 tap FIR filters Close to 100% utilization for each C66 core. Assuming C66's are clocked at 750 MHz. There's also a

[beagleboard] Re: Beagleboard x15 speed

2018-08-08 Thread Jeff Andich
So then data is coming from the IQ demodulator at 40 MHz on the USB 3.0 bus from the b210, and you 'd like to have it fill up a buffer via DMA, and then generate an interrupt for one or both C66 DSP's to demodulate, filter, downsample, filter some more, perform error correction coding, until

[beagleboard] Re: Beagleboard x15 speed

2018-08-08 Thread Jeff Andich
Hi. I wish I knew the answers off hand. But am just starting to work through gnuradio, and the https://www.ettus.com/product/category/USRP-Bus-Series LOOKS like it may be a good platform for hobbying around with gnuradio, and base band/bandpass processing blocks! Albeit, it's $$$. Been

[beagleboard] Re: Beagleboard x15 speed

2018-08-08 Thread Jeff Andich
Hi Hashir. I wish I knew the answers off hand. But am just starting to work through gnuradio, and the https://www.ettus.com/product/category/USRP-Bus-Series LOOKS like it may be a good platform for hobbying around with gnuradio, and base band/bandpass processing blocks! Albeit, it's $$$.

Re: [beagleboard] eMMC flasher not working after update linux kernel

2018-08-07 Thread Jeff Andich
Would it maybe be helpful to add the above step to the kernel upgrade sections of the following procedure pages or other pages (for specific kernel versions)? https://www.digikey.com/eewiki/display/linuxonarm/BeagleBone+Black https://www.digikey.com/eewiki/display/linuxonarm/BeagleBoard-X15

Re: [beagleboard] What to do about Denial of Service Vulnerability for Kernel version's 4.9+ ?

2018-08-07 Thread Jeff Andich
Good to know! Thanks!! Jeff On Tuesday, August 7, 2018 at 9:14:46 AM UTC-5, RobertCNelson wrote: > > On Tue, Aug 7, 2018 at 8:50 AM Jeff Andich > wrote: > > > > Hello, > > > > We got an email at work about the following advisories about a denial of &

[beagleboard] What to do about Denial of Service Vulnerability for Kernel version's 4.9+ ?

2018-08-07 Thread Jeff Andich
Hello, We got an email at work about the following advisories about a denial of service vulnerability in the TCP implementation in kernel versions 4.9 and greater: https://www.kb.cert.org/vuls/id/962459. There's a patch, called out in the above link, and the patch comments describe the issue

Re: [beagleboard] Ongoing Support for OMAP Serial Driver in Future Kernel Versions

2018-08-06 Thread Jeff Andich
And following is a link to the thread showing where we're at regarding connecting the BB-X15 to the FT4232 Mini Module, development board: http://beagleboard.org/discuss?place=msg%2Fbeagleboard%2FLjrZqmp8dGA%2FciOgBxRBCgAJ On Thursday, August 2, 2018 at 9:52:08 AM UTC-5, Jeff Andich wrote

Re: [beagleboard] Ongoing Support for OMAP Serial Driver in Future Kernel Versions

2018-08-02 Thread Jeff Andich
Nelson wrote: > > On Thu, Aug 2, 2018 at 8:22 AM Jeff Andich > wrote: > > > > Hi, > > > > What's the best way to find out how long a legacy driver like the > omap-serial driver will be supported in the kernel going forward? > > It's not going anywhere till the

Re: [beagleboard] Ongoing Support for OMAP Serial Driver in Future Kernel Versions

2018-08-02 Thread Jeff Andich
on our findings/stumbling blocks here. If we can get this working, then this MAY be of interest to those looking for a quick RS 485 solution. Regards, Jeff On Thursday, August 2, 2018 at 8:37:26 AM UTC-5, RobertCNelson wrote: > > On Thu, Aug 2, 2018 at 8:22 AM Jeff Andich > wrot

[beagleboard] Ongoing Support for OMAP Serial Driver in Future Kernel Versions

2018-08-02 Thread Jeff Andich
Hi, What's the best way to find out how long a legacy driver like the omap-serial driver will be supported in the kernel going forward? We've swapped out the 8250 driver for the OMAP serial driver via the .config file, since the omap serial driver implements a 485 mode which, thus far,

[beagleboard] BeagleBone Black won't boot from SD card

2018-05-25 Thread Jeff Andich
Is your SD card correctly programmed with the image? Is there an issue with your SD card? Do you have another one to try? Did you grab the right image file for the right product? Are you able to stick that SD card containing the beaglebone image into a Linux PC via say a USB<->SD card

Re: [beagleboard] BBB: Using DMA with SPI

2018-05-17 Thread Jeff Andich
!! On Wednesday, May 16, 2018 at 5:12:40 PM UTC-5, Jeff Andich wrote: > > I ran into a similar issue when I upgraded my kernel on an existing BB-X15 > image and then attempted to run the flasher script from the SD card on a > BB-X15: > > > http://beagleboard.org/discuss?place=msg%2F

Re: [beagleboard] BBB: Using DMA with SPI

2018-05-16 Thread Jeff Andich
I ran into a similar issue when I upgraded my kernel on an existing BB-X15 image and then attempted to run the flasher script from the SD card on a BB-X15: http://beagleboard.org/discuss?place=msg%2Fbeagleboard%2Fx1mxG7c-ilg%2F2Q8OROMCAwAJ Where Robert indicated to do: (1) depmod -a (2)

[beagleboard] Re: Are console images not available from beagleboard.org?

2018-05-14 Thread Jeff Andich
I think we've wrestled with this issue as well. We're still working with Jessie console images from https://rcn-ee.com/rootfs/bb.org/testing/2018-02-01/console/, and they seem to be pretty stable, from the testing we've done to date. I'm not yet sure and am still very curious about the test

[beagleboard] Are console images not available from beagleboard.org?

2018-05-12 Thread Jeff Andich
Does this page contain what you need? https://elinux.org/Beagleboard:BeagleBoneBlack_Debian -- For more options, visit http://beagleboard.org/discuss --- You received this message because you are subscribed to the Google Groups "BeagleBoard" group. To unsubscribe from this group and stop

[beagleboard] RS485 RTS Line Toggling Available in FTDI USB<->Serial Hub Chips - Has Anyone Tried This?

2018-05-02 Thread Jeff Andich
Hi, Our custom board based on the BB-X15 has a(n) FT4232 USB<->serial hub to realize some of our serial ports. From the data sheet and programming guide, it looks like the chip supports RS485 toggling of a DE pin on a 485 chip via the chip's TXDEN line. But the data sheet and programming

Re: [beagleboard] Re: RS485 support for BBB

2018-05-02 Thread Jeff Andich
ing these delays to 0,0 Note: Temporarily experimenting with changing the pinmux in the device tree as opposed to u-boot-spl, and am aware of the glitch errata. When we're done testing, we'll update our pad configuration arrays in u-boot to keep the 5728 pinmux glitch monster at bay... On Tuesday, Mar

[beagleboard] Re: beagleboard-x15 cape fpga microcontroller adc dac sdram

2018-04-24 Thread Jeff Andich
Hi, One of my pet projects which isn’t off the ground yet is SDR with the B.B.-X15. My progress will be to slow to warrant getting one of the SDR capes for free, but I hope the free cape goes to a student, researcher, or hobbiest who will help show how all of the processors on the X15 can

Re: [beagleboard] Re: Stretch Image, debian-9.3-lxqt, for BeagleBoard-X15 Doesn't Boot Normally - Boots into initramfs

2018-04-18 Thread Jeff Andich
s. > > Regards, > John > > > > > > On Apr 18, 2018, at 6:56 AM, Jeff Andich <jeff@gmail.com > > wrote: > > Ok John, > > In the case of the 32 GB Kingston #10 card I tried yesterday, I think it's > the card, as I get the same result tod

Re: [beagleboard] Re: Stretch Image, debian-9.3-lxqt, for BeagleBoard-X15 Doesn't Boot Normally - Boots into initramfs

2018-04-18 Thread Jeff Andich
Also, it's probably worth noting that Etcher 1.3.1 successfully verified the image on the SD card which produced the above error. On Wednesday, April 18, 2018 at 8:56:34 AM UTC-5, Jeff Andich wrote: > > Ok John, > > In the case of the 32 GB Kingston #10 card I tried yesterday,

Re: [beagleboard] Re: Stretch Image, debian-9.3-lxqt, for BeagleBoard-X15 Doesn't Boot Normally - Boots into initramfs

2018-04-18 Thread Jeff Andich
@BeagleBoard-X15:~$ uname -r 4.9.78-ti-r94 On Tuesday, April 17, 2018 at 8:12:32 PM UTC-5, john3909 wrote: > > I use San Disk Ultra 32GB in my X15 and it works fine. > > Regards, > John > > > > > > On Apr 17, 2018, at 5:59 PM, Jeff Andich <jeff@gmail.c

Re: [beagleboard] Re: Stretch Image, debian-9.3-lxqt, for BeagleBoard-X15 Doesn't Boot Normally - Boots into initramfs

2018-04-17 Thread Jeff Andich
gt; > > > > On Apr 17, 2018, at 5:59 PM, Jeff Andich <jeff@gmail.com > > wrote: > > Hi, > > First run: 32GB > Second: 16GB > Third: 4GB > > Will redo the first run but with a different 32 GB SD as Etcher hung > during ver

[beagleboard] Re: Stretch Image, debian-9.3-lxqt, for BeagleBoard-X15 Doesn't Boot Normally - Boots into initramfs

2018-04-17 Thread Jeff Andich
Hi, First run: 32GB Second: 16GB Third: 4GB Will redo the first run but with a different 32 GB SD as Etcher hung during verifying that card (but subsequently Win32DiskImager didn’t complain).. That card maybe bad. However, the same result occurred on the 16 GB card...

[beagleboard] Re: Stretch Image, debian-9.3-lxqt, for BeagleBoard-X15 Doesn't Boot Normally - Boots into initramfs

2018-04-17 Thread Jeff Andich
-28 Support/FAQ: http://elinux.org/Beagleboard:BeagleBoneBlack_Debian default username:password is [debian:temppwd] BeagleBoard-X15 login: On Tuesday, April 17, 2018 at 4:30:09 PM UTC-5, Jeff Andich wrote: > > Tried it with a different SD card (first one was 32 GB and second card was

[beagleboard] Re: Stretch Image, debian-9.3-lxqt, for BeagleBoard-X15 Doesn't Boot Normally - Boots into initramfs

2018-04-17 Thread Jeff Andich
in results.. On Tuesday, April 17, 2018 at 2:26:55 PM UTC-5, Jeff Andich wrote: > > After downloading the latest image ( > bbx15-debian-9.3-lxqt-armhf-2018-01-28-4gb.img.xz) for the BB-X15 from > http://beagleboard.org/latest-images, verifying the sha256, and ripping > an SD card via

[beagleboard] Re: Stretch Image, debian-9.3-lxqt, for BeagleBoard-X15 Doesn't Boot Normally - Boots into initramfs

2018-04-17 Thread Jeff Andich
Tried it with a different SD card, and this time Etcher successfully verified the image. However, same result as before when booting off that SD card... On Tuesday, April 17, 2018 at 2:26:55 PM UTC-5, Jeff Andich wrote: > > After downloading the latest image ( > bbx15-debian-9.3-l

[beagleboard] Stretch Image, debian-9.3-lxqt, for BeagleBoard-X15 Doesn't Boot Normally - Boots into initramfs

2018-04-17 Thread Jeff Andich
After downloading the latest image ( bbx15-debian-9.3-lxqt-armhf-2018-01-28-4gb.img.xz) for the BB-X15 from http://beagleboard.org/latest-images, verifying the sha256, and ripping an SD card via Win32DiskImager (Etcher hangs on the verify step for some reason): My console on my 572xEVM Rev

[beagleboard] Cape Manager for BeagleBoard-X15 ??

2018-04-12 Thread Jeff Andich
Robert, At the ELC this year, I recall you mentioned something about a cape manager or something like a cape manager already available or in the works for the BeagleBoard-X15. Or maybe it was dynamic device tree loading, but in the u-boot overlay sense?? Could you please

Re: [beagleboard] Re: X15 - any expansion boards for GPIO access?

2018-04-12 Thread Jeff Andich
Also, I think there are 2-3 variants of the mating hirose connector. I believe the differences are in the "heights" of the connector variants, so you may need to take that into account as well.. On Thursday, April 12, 2018 at 7:56:57 AM UTC-5, Jeff Andich wrote: > > We m

Re: [beagleboard] Re: X15 - any expansion boards for GPIO access?

2018-04-12 Thread Jeff Andich
d like to design my own adapter board with > > matching connectors for my experiments. > > > > Thank you very much for your time. > > > > Best > > Naveen > > > > On Monday, November 13, 2017 at 11:45:39 PM UTC+1, gcoley1 wrote:

[beagleboard] Re: Does beaglebone-black-make-microSD-flasher-from-eMMC.sh break UDEV's Ability to See MMCBLK0P1?

2018-04-11 Thread Jeff Andich
oth blk devices and format and setup a mount point on /dev/mmcblk0p1 in the event that mmcblk1p1's label == rootfs and mmcblk0p1's label !=rootfs). ACTION=="add", TAG+="systemd", ENV{SYSTEMD_WANTS}="setup-mount-point.service" LABEL="mmc_job_storage_mount_end"

[beagleboard] Re: Does beaglebone-black-make-microSD-flasher-from-eMMC.sh break UDEV's Ability to See MMCBLK0P1?

2018-04-11 Thread Jeff Andich
mmcblk1p1's label == rootfs and mmcblk0p1's label !=rootfs). ACTION=="add", TAG+="systemd", ENV{SYSTEMD_WANTS}="setup-mount-point.service" LABEL="mmc_job_storage_mount_end" On Friday, April 6, 2018 at 1:28:34 PM UTC-5, Jeff Andich wrote: > > *

[beagleboard] Re: Does beaglebone-black-make-microSD-flasher-from-eMMC.sh break UDEV's Ability to See MMCBLK0P1?

2018-04-06 Thread Jeff Andich
*** PLEASE IGNORE THIS THREAD UNTIL i TEST THIS SAME SCENARIO ON A BB-X15 *** THIS WAS THE RESULT ON OUR CUSTOM BOARD. Film at 11.. On Friday, April 6, 2018 at 9:24:59 AM UTC-5, Jeff Andich wrote: > > Hi, > > We've got a mechanism for creating a mount point o

[beagleboard] Does beaglebone-black-make-microSD-flasher-from-eMMC.sh break UDEV's Ability to See MMCBLK0P1?

2018-04-06 Thread Jeff Andich
Hi, We've got a mechanism for creating a mount point on an SD card, specifically used for storage/logging while our main application is running from eMMC (mmcblk1p1) on a BB-X15 - like platform. The mechanism uses UDEV rules to fire on the presence of a properly formatted SD card in the slot

Re: [beagleboard] Running from eMMC will / "always" be mounted on /dev/mmcblk1p1, From SD Always/ on /dev/mmcblk0p1 ?

2018-04-05 Thread Jeff Andich
I don't THINK any of this gets called anyway for the eMMC to SD card and flasher scripts I'm running. As always, thanks for reading my novels on here!! On Tuesday, April 3, 2018 at 4:18:35 PM UTC-5, Jeff Andich wrote: > > Thanks Robert!! > > ...One of these days, I need t

Re: [beagleboard] Running from eMMC will / "always" be mounted on /dev/mmcblk1p1, From SD Always/ on /dev/mmcblk0p1 ?

2018-04-03 Thread Jeff Andich
Thanks Robert!! ...One of these days, I need to be following what's going on with the commits and the upstream... Regards, jeff On Tuesday, April 3, 2018 at 4:05:42 PM UTC-5, RobertCNelson wrote: > > On Tue, Apr 3, 2018 at 3:53 PM, Jeff Andich <jeff@gmail.com > >

[beagleboard] Running from eMMC will / "always" be mounted on /dev/mmcblk1p1, From SD Always/ on /dev/mmcblk0p1 ?

2018-04-03 Thread Jeff Andich
Hi, When Linux and our application is running from eMMC, we wish to be able to create log files on a uSD card plugged into the uSD slot on our board. I've ported some scripts which a former colleague wrote for the BeagleBone Black that create a mount point on a factory default SD card if the

Re: [beagleboard] Re: Custom Brd Kern. Boot - Get "Unable to handle kernel paging request at virtual..." Occasionaly

2018-03-26 Thread Jeff Andich
r all the failures. *pgd=8080004003 *pgd=8080007003 . . . " On Friday, March 23, 2018 at 10:26:21 AM UTC-5, Jeff Andich wrote: > > Thanks Robert! > > Will try to keep everyone updated on here or reference developments on the > "parallel" E2E thread. >

Re: [beagleboard] Re: Custom Brd Kern. Boot - Get "Unable to handle kernel paging request at virtual..." Occasionaly

2018-03-23 Thread Jeff Andich
Thanks Robert! Will try to keep everyone updated on here or reference developments on the "parallel" E2E thread. Regards, jeff On Friday, March 23, 2018 at 9:40:13 AM UTC-5, RobertCNelson wrote: > > On Fri, Mar 23, 2018 at 9:30 AM, Jeff Andich <jeff@gmail.com

Re: [beagleboard] Re: Custom Brd Kern. Boot - Get "Unable to handle kernel paging request at virtual..." Occasionaly

2018-03-23 Thread Jeff Andich
you've hit the sweet spot in terms of the optimum values?? This doesn't appear to happen very frequently, but it's probably prudent to get a handle on what makes it crop up.. On Wednesday, March 21, 2018 at 10:55:59 AM UTC-5, Jeff Andich wrote: > > Hi Robert, > > We've copied

Re: [beagleboard] Re: Custom Brd Kern. Boot - Get "Unable to handle kernel paging request at virtual..." Occasionaly

2018-03-23 Thread Jeff Andich
, 2018 at 10:55:59 AM UTC-5, Jeff Andich wrote: > > Hi Robert, > > We've copied the 572x EVM, reva3 schematic as closely as possible, but > then added some peripherals. > > Our custom board is utilizing 4, Micron, MT41K256 512 MiB DDR3 chips for > DDR3. I believe

[beagleboard] Re: Does not detect RTC (ds1307)

2018-03-22 Thread Jeff Andich
, 2018 at 5:38:03 PM UTC-5, Jeff Andich wrote: > > I'm working with the RTC (MCP794110) at the moment, but on a "BB-X15 - > like" custom board platform. > > I'm not sure I follow. your post.. What's the I2C tool? Are you talking > about attaching the RTC to the BBB

[beagleboard] Re: Does not detect RTC (ds1307)

2018-03-22 Thread Jeff Andich
he USB HUB isn't connected to the I2C3 bus... Does the USB hub device driver or the USB bus driver initialize the RTC if it's uninitialized??? Thanks!! On Thursday, March 22, 2018 at 5:38:03 PM UTC-5, Jeff Andich wrote: > > I'm working with the RTC (MCP794110) at the moment, but on a "BB

[beagleboard] Re: Does not detect RTC (ds1307)

2018-03-22 Thread Jeff Andich
I'm working with the RTC (MCP794110) at the moment, but on a "BB-X15 - like" custom board platform. I'm not sure I follow. your post.. What's the I2C tool? Are you talking about attaching the RTC to the BBB via the I2C tool or a problem with reading the RTC on the BBB? Pardon my ignorance but

[beagleboard] Re: Does not detect RTC (ds1307)

2018-03-22 Thread Jeff Andich
I'm working with the RTC (MCP794110) at the moment, but on a "BB-X15 - like" custom board platform. I'm not sure I follow. your post.. What's the I2C tool? Are you talking about attaching the RTC to the BBB via the I2C tool or a problem with reading the RTC on the BBB? Pardon my ignorance but

Re: [beagleboard] PocketBeagle and TSA :)

2018-03-22 Thread Jeff Andich
Recently on an outbound flight I traveled with the PocketBeagle attached to the Baconbits Cape in the package it came in (with a plastic window), and placed it in a bin and on the belt. No issues there. Ironically on the inbound flight, before I had the PocketBeagle, that wasn't the case.

Re: [beagleboard] Re: Custom Brd Kern. Boot - Get "Unable to handle kernel paging request at virtual..." Occasionaly

2018-03-21 Thread Jeff Andich
mm_regs(const struct dmm_lisa_map_regs **dmm_lisa_regs) { . . if ( board_is_am572x_custom() ) *dmm_lisa_regs = _x15_lisa_regs; . . } Thanks!! On Tuesday, March 20, 2018 at 8:03:55 PM UTC-5, RobertCNelson wrote: > > On Tue, Mar 20, 20

[beagleboard] Re: Custom Brd Kern. Boot - Get "Unable to handle kernel paging request at virtual..." Occasionaly

2018-03-20 Thread Jeff Andich
, best place to look??? On Tuesday, March 20, 2018 at 11:09:31 AM UTC-5, Jeff Andich wrote: > > > Hi, > > We just got our re-worked custom boards back from the fab house with the > 5728, and on one of the boards on 1/6 power-ups, I got ".. Unable to handle > ker

[beagleboard] Re: Custom Brd Kern. Boot - Get "Unable to handle kernel paging request at virtual..." Occasionaly

2018-03-20 Thread Jeff Andich
Note: I also "piggybacked"/ "pork bellied" this issue onto the TI E2E thread referenced above, but disclosing the fact that I'm running a beagleboard distro I.P.V. the TI SDK. Thanks and FYI, On Tuesday, March 20, 2018 at 11:09:31 AM UTC-5, Jeff Andich wrote: > > &g

[beagleboard] Re: ttyO4 are not working on new Beaglebone

2018-03-20 Thread Jeff Andich
When you type ls /dev/ttyO* on your new BeagleBone, what do you get?? I assume nothing... TI switched the default serial driver back in (??) from OMAP (ttyOn) to the 8250 driver, ttySn. I believe the rationalle is documented in the kernel source code for the driver and other places. You

[beagleboard] Custom Brd Kern. Boot - Get "Unable to handle kernel paging request at virtual..." Occasionaly

2018-03-20 Thread Jeff Andich
Hi, We just got our re-worked custom boards back from the fab house with the 5728, and on one of the boards on 1/6 power-ups, I got ".. Unable to handle kernel paging request at virtual address 2248 ... and at ffec." I THINK this occurs when Debian is being mounted as we normally see

Re: [beagleboard] Reading Image with Win32 Disk Imager - Why Does Boot Get Copied with Read Only Allocated Partitions

2018-03-09 Thread Jeff Andich
Mar 8, 2018 at 1:58 PM, Jeff Andich <jeff@gmail.com > > wrote: > > Hi, > > > > I was needing a utility to read/clone an SD card without copying all of > the > > additional wasted space on an SD card like the original Win32 Disk > Imager >

[beagleboard] Reading Image with Win32 Disk Imager - Why Does Boot Get Copied with Read Only Allocated Partitions

2018-03-08 Thread Jeff Andich
Hi, I was needing a utility to read/clone an SD card without copying all of the additional wasted space on an SD card like the original Win32 Disk Imager Does. From what I can tell, the latest Etcher for Windows only writes to SD card. So I just tried the latest Win32 Disk Imager which now

[beagleboard] Re: Custom Board doesnt run with Angström Image

2018-03-07 Thread Jeff Andich
I just did a 10 second google and it appears like tda998x is related to HDMI which you pulled from your board. Just a couple of basic questions: 1) Did you remove the HDMI from either/both the u-boot pinmux and/or the cape manager? 2) If you start with a console image, does this yield the

Re: [beagleboard] Re: RS485 support for BBB

2018-03-06 Thread Jeff Andich
8 GPIO_ACTIVE_HIGH>; rs485-rts-active-high; rs485-rts-delay = <0 0>; linux,rs485-enabled-at-boot-time; }; On Tuesday, March 6, 2018 at 8:12:41 AM UTC-6, Jeff Andich wrote: > > p.s. - I'm currently running a patched version of kernel version > 4.4.110..

Re: [beagleboard] Re: RS485 support for BBB

2018-03-06 Thread Jeff Andich
, 2018 at 9:12:06 AM UTC-6, Jeff Andich wrote: > > Hi, > > There have been a number of posts on here on how to switch between the > 8250 and OMAP drivers. Above in this same thread, Robert showed which > defines within the kernel defconfig file to change,

Re: [beagleboard] Re: RS485 support for BBB

2018-03-05 Thread Jeff Andich
p.s. - I'm currently running a patched version of kernel version 4.4.110... On Monday, March 5, 2018 at 9:12:06 AM UTC-6, Jeff Andich wrote: > > Hi, > > There have been a number of posts on here on how to switch between the > 8250 and OMAP drivers. Above in this same thread

Re: [beagleboard] Re: RS485 support for BBB

2018-03-05 Thread Jeff Andich
Hi, There have been a number of posts on here on how to switch between the 8250 and OMAP drivers. Above in this same thread, Robert showed which defines within the kernel defconfig file to change, and I experimented with this and was able to see and use /dev/ttyO* instead of /dev/ttyS*. I

Re: [beagleboard] Re: RS485 support for BBB

2018-03-05 Thread Jeff Andich
Hi, There have been a number of posts on here on how to switch between the 8250 and OMAP drivers. Here's one post where Robert showed which defines within the kernel defconfig file to change, and I experimented with this and was able to see and use /dev/ttyO* instead of /dev/ttyS*. I had to

[beagleboard] Re: Yocto buil for PocketBeagle

2018-02-15 Thread Jeff Andich
Don't know if the TI processor SDK (http://www.ti.com/tool/PROCESSOR-SDK-AM335X) for the BBB will run on the pocket beagle, but last-I checked the TI processor SDK follows the OE/Yocto paradigm. I apologize for forgetting the differences between Yocto and OE. The SDK contains canned build

Re: [beagleboard] Can't stat /proc/sys/vm & K Panic when Flashing eMMC while Running with a Kernel built from Source

2018-02-14 Thread Jeff Andich
Thanks Robert! Eureka it works! so long as you keep, initrd.img-4.4.110-ti-r142 in /boot it's happy.. Regards, Jeff On Wednesday, February 14, 2018 at 2:31:34 PM UTC-6, RobertCNelson wrote: > > On Wed, Feb 14, 2018 at 2:21 PM, Jeff Andich <jeff@gmail.com > > wrote: &g

Re: [beagleboard] Can't stat /proc/sys/vm & K Panic when Flashing eMMC while Running with a Kernel built from Source

2018-02-14 Thread Jeff Andich
es/attrs were not transferred (see previous errors) (code 23) a] writing to [/dev/mmcblk1] failed... On Tuesday, February 13, 2018 at 5:25:57 PM UTC-6, RobertCNelson wrote: > > Weird, for now just nuke that sysctr setting, it's not mandatory, it fixe

[beagleboard] Can't stat /proc/sys/vm & K Panic when Flashing eMMC while Running with a Kernel built from Source

2018-02-13 Thread Jeff Andich
Hi, I burned a uSD card with bbx15-debian-8.10-console-armhf-2018-01-01-1gb.img.xz which I got from elinux.org. The kernel which comes with that image is 4.4.91-ti-r141. But I have been building kernel version 4.4.110-ti-r142 from source following the instructions on eewiki.net for the

Re: [beagleboard] Is there a "Smaller Footprint" LXQT Image for BB-X15 (preferably Jessie)?

2018-02-09 Thread Jeff Andich
tried any other DVI monitors which are known to provide EDID. Thanks and FYI, Jeff On Friday, February 9, 2018 at 9:28:17 AM UTC-6, Jeff Andich wrote: > > One thing I'm noticing on my 572xEVM-Rev a3 at work (which I don't THINK I > saw on my BB-X15 (?revC?) at home last-night is the

Re: [beagleboard] Is there a "Smaller Footprint" LXQT Image for BB-X15 (preferably Jessie)?

2018-02-09 Thread Jeff Andich
sorry - half baked question... Let me pull in the correct device tree for my image and get back to you. On Friday, February 9, 2018 at 9:28:17 AM UTC-6, Jeff Andich wrote: > > > One thing I'm noticing on my 572xEVM-Rev a3 at work (which I don't THINK I > saw on my BB-X15 (?revC?)

Re: [beagleboard] Is there a "Smaller Footprint" LXQT Image for BB-X15 (preferably Jessie)?

2018-02-09 Thread Jeff Andich
t 9:02:52 PM UTC-6, Jeff Andich wrote: > > Great! Thanks! > > > > On Thursday, February 8, 2018 at 3:32:14 PM UTC-6, RobertCNelson wrote: >> >> On Thu, Feb 8, 2018 at 12:25 PM, Jeff Andich <jeff@gmail.com> wrote: >> > Hi, >> > >&

Re: [beagleboard] Is there a "Smaller Footprint" LXQT Image for BB-X15 (preferably Jessie)?

2018-02-08 Thread Jeff Andich
Great! Thanks! On Thursday, February 8, 2018 at 3:32:14 PM UTC-6, RobertCNelson wrote: > > On Thu, Feb 8, 2018 at 12:25 PM, Jeff Andich <jeff@gmail.com > > wrote: > > Hi, > > > > Is there a 2GB LXQT (or LXDE) image available for the BB-X15 some

[beagleboard] Is there a "Smaller Footprint" LXQT Image for BB-X15 (preferably Jessie)?

2018-02-08 Thread Jeff Andich
Hi, Is there a 2GB LXQT (or LXDE) image available for the BB-X15 somewhere, preferably Debian 8.x or is it better to start with a console image, and add all of the X packages (maybe something like the following FLIR Lepton example)? We have only 4GB of eMMC and looks like we need Xinit, X11,

Re: [beagleboard] Re: Pin map spreadsheet for X15

2018-02-07 Thread Jeff Andich
Thanks! I'm sure this will come in handy.. On Wednesday, February 7, 2018 at 6:32:35 PM UTC-6, gcoley1 wrote: > > > > > > *From:* beagl...@googlegroups.com [mailto: > beagl...@googlegroups.com ] *On Behalf Of *Jeff Andich > *Sent:* Wednesday, February 7, 2018 5:1

[beagleboard] Re: Pin map spreadsheet for X15

2018-02-07 Thread Jeff Andich
configuration from user space on our BB-X15/5728 here: https://e2e.ti.com/support/arm/sitara_arm/f/791/t/649900 Thanks.. Jeff On Wednesday, February 7, 2018 at 4:53:39 PM UTC-6, Jeff Andich wrote: > > Hi, > > I don't think the pinmap spreadsheet has been posted yet ( > http://beaglebo

[beagleboard] Re: Pin map spreadsheet for X15

2018-02-07 Thread Jeff Andich
Hi, I don't think the pinmap spreadsheet has been posted yet (http://beagleboard.org/discuss?place=msg%2Fbeagleboard%2FKAVSkC15EkA%2FlG4AHCoxCAAJ). A lot of this information can be found on TI's website as well. I struggled with re-configuring the expansion header pins for a while, but I

[beagleboard] Re: Getting started: Step #2 and #3 just dont work on Windows 10 (or 8, or 7)

2018-02-07 Thread Jeff Andich
Do you still get the same driver install problems on the Windows 7 PC as you see on your Windows 10 host or is that primarily a problem with accessing the URL in your web browser? On Wednesday, February 7, 2018 at 8:19:41 AM UTC-6, Jon Lundstrom wrote: > > > I just unpacked a Beaglebone Black

Re: [beagleboard] Web browser in LCD (4D) using IoT image

2018-02-07 Thread Jeff Andich
Hi someone on our team tried to run chromium on an external touchscreen/display connected to the BeagleBone Black, and noted similar slow response. Is there a way to improve performance of chromium running on BBB or are there better alternatives? Thanks! On Wednesday, February 7, 2018 at

[beagleboard] What's Going on with EEWIKI.NET?

2018-02-06 Thread Jeff Andich
It looks like eewiki.net is down. Been trying to access it since yesterday. Please advise. Thanks! -- For more options, visit http://beagleboard.org/discuss --- You received this message because you are subscribed to the Google Groups "BeagleBoard" group. To unsubscribe from this group

[beagleboard] Re: Beagle Bone black debain gpio access denied

2018-02-05 Thread Jeff Andich
Switching to root before doing sysfs operations, (e.g. sudo su), typically seems to work for me.. On Friday, February 2, 2018 at 12:01:43 PM UTC-6, Hemant Kapoor wrote: > > Hello, > > Yet another newbie question. > > I have got latest debian image on my beagle bone black. > uname - r output:

Re: [beagleboard] Re: Serial Communication on Beaglebone Black

2018-02-05 Thread Jeff Andich
ww.amazon.com/gp/product/B00HKIMBZW/ref=oh_aui_search_detailpage?ie=UTF8=1 > > > It looks, good, but I haven't tested it yet. > > > > Now, I've got a question for you guys. Has anyone been able to get > hardware flow control working on the beaglebone black in debian? >

[beagleboard] Re: HDMI not working in new BeagleboardX15

2018-01-29 Thread Jeff Andich
... Jeff On Monday, January 29, 2018 at 8:33:34 AM UTC-6, Jeff Andich wrote: > > Hi, > > I have a BB-X15 at home still with the default image (kernel 4.9.??) on > the eMMC. Regrettably, I've never tried running X on it (not even remote > desktop). > > I will test it ton

[beagleboard] Re: HDMI not working in new BeagleboardX15

2018-01-29 Thread Jeff Andich
Hi, I have a BB-X15 at home still with the default image (kernel 4.9.??) on the eMMC. Regrettably, I've never tried running X on it (not even remote desktop). I will test it tonight by plugging an HDMI cable into it.. I HAVE plugged an HDMI cable into our 572xEVM/BB-X15 at work a few

[beagleboard] Re: JTAG or OpenOCD

2018-01-16 Thread Jeff Andich
https://elinux.org/BeagleBoardJTAG >From looking at a picture of the JTAG connector on the pocket beagle ( http://uk.farnell.com/beagleboard/bb-pocket/pocket-beagle-board-arm-cortex/dp/2806159 ) , it looks like there are 7 JTAG connectors signals which appear to follow the TI signals as

[beagleboard] Re: JTAG or OpenOCD

2018-01-16 Thread Jeff Andich
Hi, (Here's a newbie answer so take that for what it's worth). Have only done limited JTAG debugging on the BB-X15 with CCS 7.x - when bringing up the SPL on a custom board with the same Sitara SOC as on the BB-X15. I THINK I recall that only a hand full of the 20 pins (like 7 maybe?)

Re: [beagleboard] Re: TI BSP failed to build kernel

2018-01-05 Thread Jeff Andich
.. On Friday, January 5, 2018 at 10:20:01 AM UTC-6, RobertCNelson wrote: > > On Fri, Jan 5, 2018 at 10:13 AM, Jeff Andich <jeff@gmail.com > > wrote: > > Ok thanks! > > > > Then when you do a full re-build, does it delete the entire local tree > and >

Re: [beagleboard] Re: TI BSP failed to build kernel

2018-01-05 Thread Jeff Andich
and the corresponding Makefile.. Maybe I should try your device tree builder... On Friday, January 5, 2018 at 8:58:40 AM UTC-6, RobertCNelson wrote: > > On Thu, Jan 4, 2018 at 9:25 AM, Jeff Andich <jeff@gmail.com > > wrote: > > Ok, so if I understand correctly, if I git th

Re: [beagleboard] Re: TI BSP failed to build kernel

2018-01-05 Thread Jeff Andich
Is the best place to look for updates to the kernel and/or patches to the kernel here? In other words, all inclusive.. https://github.com/RobertCNelson/ti-linux-kernel-dev.git Thanks! jeff On Thursday, January 4, 2018 at 9:25:13 AM UTC-6, Jeff Andich wrote: > > Ok, so if I unde

Re: [beagleboard] Re: TI BSP failed to build kernel

2018-01-04 Thread Jeff Andich
updated when either the kernel and/or patch set(s) change? What mailing lists do we need to join? Thanks!! jeff On Tuesday, January 2, 2018 at 8:48:10 AM UTC-6, RobertCNelson wrote: > > On Tue, Jan 2, 2018 at 8:41 AM, Jeff Andich <jeff@gmail.com > > wrote: > > &

Re: [beagleboard] Re: TI BSP failed to build kernel

2018-01-02 Thread Jeff Andich
Yep, wireguard was what I ended up removing from makemenuconfig.. Had no idea Streisand switched from singing/showbiz to Linux development!! On Tuesday, January 2, 2018 at 8:48:10 AM UTC-6, RobertCNelson wrote: > > On Tue, Jan 2, 2018 at 8:41 AM, Jeff Andich <jeff@gmail.com

Re: [beagleboard] Re: TI BSP failed to build kernel

2018-01-02 Thread Jeff Andich
FYI, I THINK I ran into something similar over the holidays when I tried to fetch and build the 4.4.y and 4.9.y kernels using eewiki. I tried both BBB and BB-X15. I ran into an issue with a build error in an assembly file which apparently had to do with some kind of networking package. The

[beagleboard] Re: u-boot failed to build

2018-01-01 Thread Jeff Andich
Hi, Don’t know if this is your issue but... How are you generating the .config file? When I build u-boot for the X15, I typically do a distclean, call another make command to generate the correct .config file from the appropriate defconfig , and then throw the command to build u-boot. --

[beagleboard] Re: Beagle Board X15 android

2017-12-30 Thread Jeff Andich
Hi, *There was a post on BeagleBoard.org about a year ago which referenced this website where there appear to be more recent posts on Android for BBB:. http://www.2net.co.uk/android4beagle.html *It looks like TI now has an Android TI processor SDK for BB-X15. Maybe you could compare the

[beagleboard] Re: Has Anyone Had Difficulty Outputting GPIO, UART, or I2C on the BB-X15's Expansion Header?

2017-12-14 Thread Jeff Andich
continued issues, but I'm hoping this is the end of it... ARGH On Monday, December 11, 2017 at 2:22:52 PM UTC-6, Jeff Andich wrote: > > > My comments above about configuring the pinmux in u-boot SPL vs. the > kernel device tree are somewhat misleading per the comments at the t

[beagleboard] Re: Has Anyone Had Difficulty Outputting GPIO, UART, or I2C on the BB-X15's Expansion Header?

2017-12-14 Thread Jeff Andich
And the investigation continues in the following thread on E2E: https://e2e.ti.com/support/arm/sitara_arm/f/791/p/649900/2388226#pi316653=1 Thanks and FYI, On Monday, December 11, 2017 at 2:22:52 PM UTC-6, Jeff Andich wrote: > > > My comments above about configuring the pinmux in u

Re: [beagleboard] Control de una protesis mioelectrica en BBB

2017-12-14 Thread Jeff Andich
I know nothing about myoelectric prosthesis and the processing and real time requirements for what this device is required to do. Sounds like the thesis could entail an analysis of existing myoelectric prosthesis currently available, and selection of a range of computers/processors which are

[beagleboard] Re: Problem Enable UART

2017-12-12 Thread Jeff Andich
I THINK with the 8250 driver and the beaglebone/board images, 6 UART's show up in the /dev/ directory as /dev/ttyS0... /dev/ttyS5 by default, but that doesn't mean that all of those 6 UARTs are enabled. You have to explicitly enable them. For instance, if you login as root and start poking

[beagleboard] Re: Has Anyone Had Difficulty Outputting GPIO, UART, or I2C on the BB-X15's Expansion Header?

2017-12-11 Thread Jeff Andich
), IO glitches can occur. I'm not sure what the implications of these glitches are. Also, our TI rep advised to only do pinmuxing for the 5728 while in isolation mode, except for the MMC, which has to be done in the kernel device tree. On Friday, December 8, 2017 at 6:06:04 PM UTC-6, Jeff Andich

[beagleboard] Re: Has Anyone Had Difficulty Outputting GPIO, UART, or I2C on the BB-X15's Expansion Header?

2017-12-11 Thread Jeff Andich
glitches can occur. I'm not sure what the implications of these glitches are. Also, our TI rep advised to only do pinmuxing for the 5728 while in isolation mode, except for the MMC, which has to be done in the kernel device tree. On Friday, December 8, 2017 at 6:06:04 PM UTC-6, Jeff Andich

  1   2   >