Re: [Beignet] [PATCH] buildsys: Use CMRT_LIBDIR instead of CMRT_LIBRARY_DIRS

2016-10-08 Thread Guo, Yejun
thanks Armin, the patch looks good to me. could you also send a patch to fix CMRT_INCLUDE_DIRS? thanks. thanks yejun -Original Message- From: Armin K. [mailto:kre...@email.com] Sent: Saturday, October 08, 2016 4:50 PM To: Guo, Yejun; beignet@lists.freedesktop.org Subject: Re: [Beignet]

[Beignet] [PATCH] Utests: respect existing C/CXXFLAGS

2016-10-08 Thread Rebecca N. Palmer
This extends 4be3664 to the test suite. Signed-off-by: Rebecca N. Palmer --- utests/CMakeLists.txt | 4 ++-- 1 file changed, 2 insertions(+), 2 deletions(-) diff --git a/utests/CMakeLists.txt b/utests/CMakeLists.txt index a5d8d40..8b33666 100644 --- a/utests/CMakeLists.txt +++ b/utests/CMakeLis

[Beignet] [PATCH] Utests: Allow testing cl_intel_accelerator via ICD

2016-10-08 Thread Rebecca N. Palmer
Signed-off-by: Rebecca N. Palmer --- utests/CMakeLists.txt | 4 ++-- utests/builtin_kernel_block_motion_estimate_intel.cpp | 4 2 files changed, 6 insertions(+), 2 deletions(-) diff --git a/utests/CMakeLists.txt b/utests/CMakeLists.txt index f94256c..a5d8d40

[Beignet] [PATCH] Utests: Don't end an all-tests run when one test fails

2016-10-08 Thread Rebecca N. Palmer
Signed-off-by: Rebecca N. Palmer --- utests/builtin_global_linear_id.cpp | 2 +- utests/builtin_global_size.cpp| 2 +- utests/builtin_kernel_block_motion_estimate_intel.cpp | 4 ++-- utests/builtin_local_size.cpp | 2 +- utests/bui

[Beignet] [PATCH] Utests: use clGetExtensionFunctionAddressForPlatform

2016-10-08 Thread Rebecca N. Palmer
This is required to find KHR extensions via ICD, as the loader needs to know which ICD to send the request to. If the function is not found, fail the test instead of crashing. --- utests/utest_helper.cpp | 6 +- 1 file changed, 5 insertions(+), 1 deletion(-) diff --git a/utests/utest_helper.

Re: [Beignet] [PATCH] Fix build with latest libdrm

2016-10-08 Thread Armin K.
On 8.10.2016 12:06, Rebecca N. Palmer wrote: + if (drm_intel_get_pooled_eu(driver->fd) >= 0) { Shouldn't this be >0 , not >=0? The libdrm commit message ( https://cgit.freedesktop.org/mesa/drm/commit/intel/intel_bufmgr_gem.c?id=98887140e343493f01be7a1dec721c024bcf72c7 ) says 0 means not suppor

[Beignet] [PATCH] Add clGetKernelSubGroupInfoKHR to _cl_icd_dispatch table

2016-10-08 Thread Rebecca N. Palmer
ocl-icd >= 2.2.8 has this function in its table; as the lookup process tries the dispatch table before the ICD's clGetExtensionFunctionAddress, requesting a function that is in the ICD loader's table but off the end of the ICD's table will return a garbage pointer. Signed-off-by: Rebecca N. Palmer

[Beignet] [PATCH] Docs: Spelling and grammar fixes

2016-10-08 Thread Rebecca N. Palmer
Signed-off-by: Rebecca N. Palmer --- docs/Beignet.mdwn | 20 ++-- docs/howto/cross-compiler-howto.mdwn| 4 ++-- docs/howto/stand-alone-utest-howto.mdwn | 8 utests/builtin_global_linear_id.cpp | 2 +- 4 files changed, 17 insertions(+), 17

Re: [Beignet] [PATCH] Fix build with latest libdrm

2016-10-08 Thread Rebecca N. Palmer
+ if (drm_intel_get_pooled_eu(driver->fd) >= 0) { Shouldn't this be >0 , not >=0? The libdrm commit message ( https://cgit.freedesktop.org/mesa/drm/commit/intel/intel_bufmgr_gem.c?id=98887140e343493f01be7a1dec721c024bcf72c7 ) says 0 means not supported. (>=0 works for me with libdrm 2.4.71,

[Beignet] [PATCH 7/7 V2] Modify clGetDeviceInfo using cl_get_info_helper.

2016-10-08 Thread junyan . he
From: Junyan He V2: Delete some useless macro. Signed-off-by: Junyan He --- src/CMakeLists.txt | 1 + src/cl_api.c | 14 -- src/cl_api_device_id.c | 34 src/cl_device_id.c | 441 +++-- 4 files changed, 353 insertions(+),

Re: [Beignet] [PATCH] buildsys: Use CMRT_LIBDIR instead of CMRT_LIBRARY_DIRS

2016-10-08 Thread Armin K.
On 8.10.2016 4:18, Guo, Yejun wrote: Hi Armin, thanks for your patch. We use pkg_check_modules(CMRT libcmrt) in path_of_beignet/CMakeList.txt Line 173 to detect libcmrt. CMRT_INCLUDE_DIRS and CMRT_LIBRARY_DIRS are the expected macro to use, see https://cmake.org/cmake/help/v3.0/module/FindP

[Beignet] [PATCH 4/7] Modify clGetKernelInfo using cl_get_info_helper.

2016-10-08 Thread junyan . he
From: Junyan He Signed-off-by: Junyan He --- src/cl_api.c | 35 --- src/cl_api_kernel.c | 48 ++-- src/cl_api_platform_id.c | 12 ++-- 3 files changed, 52 insertions(+), 43 deletions(-) diff --

[Beignet] [PATCH 5/7] Modify clGetCommandQueueInfo using cl_get_info_helper.

2016-10-08 Thread junyan . he
From: Junyan He Signed-off-by: Junyan He --- src/cl_api.c | 27 --- src/cl_api_command_queue.c | 37 +++-- 2 files changed, 35 insertions(+), 29 deletions(-) diff --git a/src/cl_api.c b/src/cl_api.c index 0ab03ea..0a69aca 10

[Beignet] [PATCH 6/7] Modify clGetContextInfo using cl_get_info_helper.

2016-10-08 Thread junyan . he
From: Junyan He Signed-off-by: Junyan He --- src/CMakeLists.txt | 1 + src/cl_api.c | 33 src/cl_api_context.c | 61 3 files changed, 62 insertions(+), 33 deletions(-) create mode 100644 src/cl_api_con

[Beignet] [PATCH 7/7] Modify clGetDeviceInfo using cl_get_info_helper.

2016-10-08 Thread junyan . he
From: Junyan He Signed-off-by: Junyan He --- src/CMakeLists.txt | 1 + src/cl_api.c | 14 -- src/cl_api_device_id.c | 34 src/cl_device_id.c | 417 + 4 files changed, 353 insertions(+), 113 deletions(-) create mode 1006

[Beignet] [PATCH 2/7] Modify clGetEventInfo using cl_get_info_helper.

2016-10-08 Thread junyan . he
From: Junyan He Signed-off-by: Junyan He --- src/cl_api.c | 32 src/cl_api_event.c | 39 +++ 2 files changed, 39 insertions(+), 32 deletions(-) diff --git a/src/cl_api.c b/src/cl_api.c index 1d4c5a1..5e2d4e3 100644 ---

[Beignet] [PATCH 3/7] Modify clGetPlatformInfo using cl_get_info_helper.

2016-10-08 Thread junyan . he
From: Junyan He Signed-off-by: Junyan He --- src/CMakeLists.txt | 1 + src/cl_api.c | 18 -- src/cl_api_platform_id.c | 65 src/cl_platform_id.c | 51 - src/cl_platform_id.h

[Beignet] [PATCH 1/7] Add a helper function for all information get.

2016-10-08 Thread junyan . he
From: Junyan He Signed-off-by: Junyan He --- src/CMakeLists.txt | 1 + src/cl_utils.c | 36 src/cl_utils.h | 2 ++ 3 files changed, 39 insertions(+) create mode 100644 src/cl_utils.c diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt index 5593