[Bitcoin-development] Warning message when running wallet in Windows XP (or drop support?)

2014-04-16 Thread Wladimir
Hello, Today I noticed that even my bank is warning people to not do internet banking with Windows XP. If it is no longer secure enough for online banking it's CERTAINLY not secure enough to run a wallet (for a node only it would be ok-ish as they have no keys to protect). Any opinions on what

Re: [Bitcoin-development] Warning message when running wallet in Windows XP (or drop support?)

2014-04-16 Thread Melvin Carvalho
On 16 April 2014 10:14, Wladimir laa...@gmail.com wrote: Hello, Today I noticed that even my bank is warning people to not do internet banking with Windows XP. If it is no longer secure enough for online banking it's CERTAINLY not secure enough to run a wallet (for a node only it would be

Re: [Bitcoin-development] Warning message when running wallet in Windows XP (or drop support?)

2014-04-16 Thread Wladimir
On Wed, Apr 16, 2014 at 10:45 AM, Melvin Carvalho melvincarva...@gmail.comwrote: XP with a trezor would work fine tho? Probably - but that's a very rare edge case. People that are security conscious enough to buy a Trezor will not run XP. Also I don't dare to say that there is not some way to

[Bitcoin-development] mid-term bitcoin security (Re: Warning message when running wallet in Windows XP (or drop support?))

2014-04-16 Thread Adam Back
Big picture/mid-term I think air-gaps and zero-trust ecosystem components are the only solution. (zero-trust meaning like real-time auditability, or type 2/type 3 exchanges based on atomic-swap, trustless escrow etc). Need a mass-production and air-drop of trezors :) There is one more problem

Re: [Bitcoin-development] Warning message when running wallet in Windows XP (or drop support?)

2014-04-16 Thread Kevin
On 4/16/2014 4:14 AM, Wladimir wrote: Hello, Today I noticed that even my bank is warning people to not do internet banking with Windows XP. If it is no longer secure enough for online banking it's CERTAINLY not secure enough to run a wallet (for a node only it would be ok-ish as they have

Re: [Bitcoin-development] Warning message when running wallet in Windows XP (or drop support?)

2014-04-16 Thread Pieter Wuille
On Wed, Apr 16, 2014 at 5:12 PM, Kevin kevinsisco61...@gmail.com wrote: I think we should get to the bottom of this. Should we assume that xp is not secure enough? Yes. What is this warning? Windows XP is no longer maintained. Don't use such a system for protecting your money. Who is

Re: [Bitcoin-development] Warning message when running wallet in Windows XP (or drop support?)

2014-04-16 Thread Mark Friedenbach
XP is no longer receiving security patches from Microsoft, and hasn't been for some time. There are known remote exploits that aren't going to be fixed, ever. On Apr 16, 2014 8:15 AM, Kevin kevinsisco61...@gmail.com wrote: On 4/16/2014 4:14 AM, Wladimir wrote: Hello, Today I noticed that

Re: [Bitcoin-development] Warning message when running wallet in Windows XP (or drop support?)

2014-04-16 Thread Wladimir
On Wed, Apr 16, 2014 at 5:20 PM, Pieter Wuille pieter.wui...@gmail.comwrote: On Wed, Apr 16, 2014 at 5:12 PM, Kevin kevinsisco61...@gmail.com wrote: I think we should get to the bottom of this. Should we assume that xp is not secure enough? Yes. It will quickly grow extremely insecure.

Re: [Bitcoin-development] Warning message when running wallet in Windows XP (or drop support?)

2014-04-16 Thread Kevin
On 4/16/2014 11:28 AM, Wladimir wrote: On Wed, Apr 16, 2014 at 5:20 PM, Pieter Wuille pieter.wui...@gmail.com mailto:pieter.wui...@gmail.com wrote: On Wed, Apr 16, 2014 at 5:12 PM, Kevin kevinsisco61...@gmail.com mailto:kevinsisco61...@gmail.com wrote: I think we should get to

Re: [Bitcoin-development] Warning message when running wallet in Windows XP (or drop support?)

2014-04-16 Thread Mark Friedenbach
On 04/16/2014 09:27 AM, Kevin wrote: Should we then add an alert message to wallet installers such as, Such and such will not run on windows xp? It's not really our place to police that ... plus it's perfectly safe to be running Bitcoin Core as a full node on XP. It's just the wallet

Re: [Bitcoin-development] Warning message when running wallet in Windows XP (or drop support?)

2014-04-16 Thread Chris Williams
It may not be our place to say whether XP is secure or not, but if we say that we support it then we have to run test passes against XP as a platform, and if an XP user reports a bug, then we have to do something to address it. So, it becomes a test and support issue, not a security issue.

Re: [Bitcoin-development] Warning message when running wallet in Windows XP (or drop support?)

2014-04-16 Thread Mark Friedenbach
We don't support XP. In fact we don't support *any* distribution, but I will assume you mean provide a binary which runs on X. Can you find any reference to Windows XP on the website? I can't. On 04/16/2014 09:41 AM, Chris Williams wrote: It may not be our place to say whether XP is secure or

Re: [Bitcoin-development] Warning message when running wallet in Windows XP (or drop support?)

2014-04-16 Thread Chris Williams
You’re right. That’s a huge oversight. I think any software product you’ve ever considered installing has a section that says “Hey, we want this much ram on your system, this much disk space, this processor, etc”. Otherwise, you’re just setting yourself up for a bad user experience from

Re: [Bitcoin-development] Warning message when running wallet in Windows XP (or drop support?)

2014-04-16 Thread Adam Back
Not to get snarky or OS elitist but as I understand it windows security, even during its support period has been measured in low digit number of days in the year when is NOT an outstanding known remote root compromise or combination of remote user compromise + priviledge escalation. Add in

Re: [Bitcoin-development] Warning message when running wallet in Windows XP (or drop support?)

2014-04-16 Thread Roy Badami
On Wed, Apr 16, 2014 at 05:20:41PM +0200, Pieter Wuille wrote: On Wed, Apr 16, 2014 at 5:12 PM, Kevin kevinsisco61...@gmail.com wrote: I think we should get to the bottom of this. Should we assume that xp is not secure enough? Yes. Do we need a similar warning for OS X 10.6? The EOL of

Re: [Bitcoin-development] Warning message when running wallet in Windows XP (or drop support?)

2014-04-16 Thread Laszlo Hanyecz
I think a warning like this is inappropriate. There are many reasons to use an out of date operating system and high level applications like wallets need not concern themselves with the rest of the system. Maybe the wallet can scan your browser cache and tell you to stop visiting somesite.com

Re: [Bitcoin-development] Warning message when running wallet in Windows XP (or drop support?)

2014-04-16 Thread Kevin
On 4/16/2014 5:10 PM, Laszlo Hanyecz wrote: I think a warning like this is inappropriate. There are many reasons to use an out of date operating system and high level applications like wallets need not concern themselves with the rest of the system. Maybe the wallet can scan your browser

Re: [Bitcoin-development] Warning message when running wallet in Windows XP (or drop support?)

2014-04-16 Thread Mark Friedenbach
On 04/16/2014 02:29 PM, Kevin wrote: Okay, so how about an autoupdate function which pulls a work around off the server? Sooner or later, the vulnerabilities must be faced. NO. Bitcoin Core will never have an auto-update functionality. That would be a single point of failure whose compromise

Re: [Bitcoin-development] Warning message when running wallet in Windows XP (or drop support?)

2014-04-16 Thread Pieter Wuille
On Wed, Apr 16, 2014 at 11:39 PM, Mark Friedenbach m...@monetize.io wrote: On 04/16/2014 02:29 PM, Kevin wrote: Okay, so how about an autoupdate function which pulls a work around off the server? Sooner or later, the vulnerabilities must be faced. NO. Bitcoin Core will never have an

Re: [Bitcoin-development] Warning message when running wallet in Windows XP (or drop support?)

2014-04-16 Thread Gregory Maxwell
Bringing the thread back on-topic: On Wed, Apr 16, 2014 at 1:14 AM, Wladimir laa...@gmail.com wrote: Hello, Today I noticed that even my bank is warning people to not do internet banking with Windows XP. If it is no longer secure enough for online banking it's CERTAINLY not secure enough to

[Bitcoin-development] Bitcoin Core Nightly Builds

2014-04-16 Thread Warren Togami Jr.
The Bitcoin Core developers have a desire to do a mostly bug-fix, cleanup and translation update release in v0.9.2 a few weeks from now. You do not need to be a developer to help! With these unofficial nightly builds, power users can more easily aid in testing of the master branch which will