Re: [blfs-book] [BLFS Trac] #8427: VTE-0.46.0 needs PCRE2-10.22

2016-10-17 Thread BLFS Trac via blfs-book
#8427: VTE-0.46.0 needs PCRE2-10.22
-+-
 Reporter:  timtas   |   Owner:  renodr
 Type:  defect   |  Status:  closed
 Priority:  low  |   Milestone:  7.11
Component:  BOOK | Version:  SVN
 Severity:  trivial  |  Resolution:  fixed
 Keywords:   |
-+-
Changes (by renodr):

 * status:  assigned => closed
 * resolution:   => fixed


Comment:

 Fixed by pierre (applying Samuel's patch) at r17893.

--
Ticket URL: 
BLFS Trac 
Beyond Linux From Scratch
-- 
http://lists.linuxfromscratch.org/listinfo/blfs-book
FAQ: http://www.linuxfromscratch.org/blfs/faq.html
Unsubscribe: See the above information page

Re: [blfs-book] [BLFS Trac] #8427: VTE-0.46.0 needs PCRE2-10.22

2016-10-16 Thread BLFS Trac via blfs-book
#8427: VTE-0.46.0 needs PCRE2-10.22
-+---
 Reporter:  timtas   |   Owner:  renodr
 Type:  defect   |  Status:  assigned
 Priority:  low  |   Milestone:  7.11
Component:  BOOK | Version:  SVN
 Severity:  trivial  |  Resolution:
 Keywords:   |
-+---

Comment (by Samuel):

 Thanks to Pierre for pointing out that I had not used the template.xml
 guidelines. I now have and will post the new patch on blfs-dev.

--
Ticket URL: 
BLFS Trac 
Beyond Linux From Scratch
-- 
http://lists.linuxfromscratch.org/listinfo/blfs-book
FAQ: http://www.linuxfromscratch.org/blfs/faq.html
Unsubscribe: See the above information page

Re: [blfs-book] [BLFS Trac] #8427: VTE-0.46.0 needs PCRE2-10.22

2016-10-14 Thread BLFS Trac via blfs-book
#8427: VTE-0.46.0 needs PCRE2-10.22
-+---
 Reporter:  timtas   |   Owner:  renodr
 Type:  defect   |  Status:  assigned
 Priority:  low  |   Milestone:  7.11
Component:  BOOK | Version:  SVN
 Severity:  trivial  |  Resolution:
 Keywords:   |
-+---
Changes (by Samuel):

 * Attachment "vte_pcre2_dependency.patch" added.


--
Ticket URL: 
BLFS Trac 
Beyond Linux From Scratch
-- 
http://lists.linuxfromscratch.org/listinfo/blfs-book
FAQ: http://www.linuxfromscratch.org/blfs/faq.html
Unsubscribe: See the above information page

Re: [blfs-book] [BLFS Trac] #8427: VTE-0.46.0 needs PCRE2-10.22

2016-10-14 Thread BLFS Trac via blfs-book
#8427: VTE-0.46.0 needs PCRE2-10.22
-+---
 Reporter:  timtas   |   Owner:  renodr
 Type:  defect   |  Status:  assigned
 Priority:  low  |   Milestone:  7.11
Component:  BOOK | Version:  SVN
 Severity:  trivial  |  Resolution:
 Keywords:   |
-+---

Comment (by Samuel):

 I will post the new patch on blfs-dev and attach it here. I can't figure
 out how to delete the old patch, so can someone do that for me. I created
 the patch using {{{svn diff}}} and tested applying the patch with {{{patch
 -p0 -i ../vte_pcre2_dependency.patch}}}.

--
Ticket URL: 
BLFS Trac 
Beyond Linux From Scratch
-- 
http://lists.linuxfromscratch.org/listinfo/blfs-book
FAQ: http://www.linuxfromscratch.org/blfs/faq.html
Unsubscribe: See the above information page

Re: [blfs-book] [BLFS Trac] #8427: VTE-0.46.0 needs PCRE2-10.22

2016-10-14 Thread BLFS Trac via blfs-book
#8427: VTE-0.46.0 needs PCRE2-10.22
-+---
 Reporter:  timtas   |   Owner:  renodr
 Type:  defect   |  Status:  assigned
 Priority:  low  |   Milestone:  7.11
Component:  BOOK | Version:  SVN
 Severity:  trivial  |  Resolution:
 Keywords:   |
-+---

Comment (by Samuel):

 Sorry. I'll patch vte with a required depencency on pcre2, and if you want
 I'll patch glib with a recommended dependency on pcre2.

--
Ticket URL: 
BLFS Trac 
Beyond Linux From Scratch
-- 
http://lists.linuxfromscratch.org/listinfo/blfs-book
FAQ: http://www.linuxfromscratch.org/blfs/faq.html
Unsubscribe: See the above information page

Re: [blfs-book] [BLFS Trac] #8427: VTE-0.46.0 needs PCRE2-10.22

2016-10-14 Thread BLFS Trac via blfs-book
#8427: VTE-0.46.0 needs PCRE2-10.22
-+---
 Reporter:  timtas   |   Owner:  renodr
 Type:  defect   |  Status:  assigned
 Priority:  low  |   Milestone:  7.11
Component:  BOOK | Version:  SVN
 Severity:  trivial  |  Resolution:
 Keywords:   |
-+---

Comment (by timtas):

 I can confirm this is wrong. I built glib without pcre2 without problems
 and according to Bruce (comment 2), glib doesn't even compile/link against
 pcre2, but only against pcre. vte however unconditionally needs pcre2.

--
Ticket URL: 
BLFS Trac 
Beyond Linux From Scratch
-- 
http://lists.linuxfromscratch.org/listinfo/blfs-book
FAQ: http://www.linuxfromscratch.org/blfs/faq.html
Unsubscribe: See the above information page

Re: [blfs-book] [BLFS Trac] #8427: VTE-0.46.0 needs PCRE2-10.22

2016-10-14 Thread BLFS Trac via blfs-book
#8427: VTE-0.46.0 needs PCRE2-10.22
-+---
 Reporter:  timtas   |   Owner:  renodr
 Type:  defect   |  Status:  assigned
 Priority:  low  |   Milestone:  7.11
Component:  BOOK | Version:  SVN
 Severity:  trivial  |  Resolution:
 Keywords:   |
-+---

Comment (by pierre.labastie):

 As far as I understand this thread, the patch should be for vte and not
 for glib... At least, pcre2 is not a ''required'' dependency of glib (i.e.
 the glib package can be built and run without it). It may be
 ''recommended'', though, but then, all the packages dependent on glib
 should be checked to see whether they can use pcre2. If not, then pcre has
 to be added as a dependency of that package.

 I'd suggest that for now on, we keep pcre as recommended for glib, and
 that packages needing really pcre2 be patched to have it as a dependency.
 Then, when a vast majority of packages can use pcre2, change our mind and
 recommend it for glib. Note that since there is a bundled version of pcre
 in glib, pcre is never a ''required'' dep, only ''recommended''.

--
Ticket URL: 
BLFS Trac 
Beyond Linux From Scratch
-- 
http://lists.linuxfromscratch.org/listinfo/blfs-book
FAQ: http://www.linuxfromscratch.org/blfs/faq.html
Unsubscribe: See the above information page

Re: [blfs-book] [BLFS Trac] #8427: VTE-0.46.0 needs PCRE2-10.22

2016-10-14 Thread BLFS Trac via blfs-book
#8427: VTE-0.46.0 needs PCRE2-10.22
-+---
 Reporter:  timtas   |   Owner:  renodr
 Type:  defect   |  Status:  assigned
 Priority:  low  |   Milestone:  7.11
Component:  BOOK | Version:  SVN
 Severity:  trivial  |  Resolution:
 Keywords:   |
-+---

Comment (by Samuel):

 Once someone approves this patch, I'll close this ticket.

--
Ticket URL: 
BLFS Trac 
Beyond Linux From Scratch
-- 
http://lists.linuxfromscratch.org/listinfo/blfs-book
FAQ: http://www.linuxfromscratch.org/blfs/faq.html
Unsubscribe: See the above information page

Re: [blfs-book] [BLFS Trac] #8427: VTE-0.46.0 needs PCRE2-10.22

2016-10-14 Thread BLFS Trac via blfs-book
#8427: VTE-0.46.0 needs PCRE2-10.22
-+---
 Reporter:  timtas   |   Owner:  renodr
 Type:  defect   |  Status:  assigned
 Priority:  low  |   Milestone:  7.11
Component:  BOOK | Version:  SVN
 Severity:  trivial  |  Resolution:
 Keywords:   |
-+---
Changes (by Samuel):

 * Attachment "glib_pcre2.patch" added.

 Patch for depenency

--
Ticket URL: 
BLFS Trac 
Beyond Linux From Scratch
-- 
http://lists.linuxfromscratch.org/listinfo/blfs-book
FAQ: http://www.linuxfromscratch.org/blfs/faq.html
Unsubscribe: See the above information page

Re: [blfs-book] [BLFS Trac] #8427: VTE-0.46.0 needs PCRE2-10.22

2016-10-14 Thread BLFS Trac via blfs-book
#8427: VTE-0.46.0 needs PCRE2-10.22
-+---
 Reporter:  timtas   |   Owner:  renodr
 Type:  defect   |  Status:  assigned
 Priority:  low  |   Milestone:  7.11
Component:  BOOK | Version:  SVN
 Severity:  trivial  |  Resolution:
 Keywords:   |
-+---

Comment (by Samuel):

 I have added the patch as an attachment and will post the patch on blfs-
 dev.

--
Ticket URL: 
BLFS Trac 
Beyond Linux From Scratch
-- 
http://lists.linuxfromscratch.org/listinfo/blfs-book
FAQ: http://www.linuxfromscratch.org/blfs/faq.html
Unsubscribe: See the above information page

Re: [blfs-book] [BLFS Trac] #8427: VTE-0.46.0 needs PCRE2-10.22

2016-10-14 Thread BLFS Trac via blfs-book
#8427: VTE-0.46.0 needs PCRE2-10.22
-+---
 Reporter:  timtas   |   Owner:  renodr
 Type:  defect   |  Status:  assigned
 Priority:  low  |   Milestone:  7.11
Component:  BOOK | Version:  SVN
 Severity:  trivial  |  Resolution:
 Keywords:   |
-+---

Comment (by Samuel):

 Ok, I have nearly finished, I am just checking the html looks good.

--
Ticket URL: 
BLFS Trac 
Beyond Linux From Scratch
-- 
http://lists.linuxfromscratch.org/listinfo/blfs-book
FAQ: http://www.linuxfromscratch.org/blfs/faq.html
Unsubscribe: See the above information page

Re: [blfs-book] [BLFS Trac] #8427: VTE-0.46.0 needs PCRE2-10.22

2016-10-13 Thread BLFS Trac via blfs-book
#8427: VTE-0.46.0 needs PCRE2-10.22
-+---
 Reporter:  timtas   |   Owner:  renodr
 Type:  defect   |  Status:  assigned
 Priority:  low  |   Milestone:  7.11
Component:  BOOK | Version:  SVN
 Severity:  trivial  |  Resolution:
 Keywords:   |
-+---

Comment (by Samuel):

 Is it a required, recommended or optional, or an optional if building vte?

--
Ticket URL: 
BLFS Trac 
Beyond Linux From Scratch
-- 
http://lists.linuxfromscratch.org/listinfo/blfs-book
FAQ: http://www.linuxfromscratch.org/blfs/faq.html
Unsubscribe: See the above information page

Re: [blfs-book] [BLFS Trac] #8427: VTE-0.46.0 needs PCRE2-10.22

2016-10-13 Thread BLFS Trac via blfs-book
#8427: VTE-0.46.0 needs PCRE2-10.22
-+---
 Reporter:  timtas   |   Owner:  renodr
 Type:  defect   |  Status:  assigned
 Priority:  low  |   Milestone:  7.11
Component:  BOOK | Version:  SVN
 Severity:  trivial  |  Resolution:
 Keywords:   |
-+---

Comment (by Samuel):

 Ok.

--
Ticket URL: 
BLFS Trac 
Beyond Linux From Scratch
-- 
http://lists.linuxfromscratch.org/listinfo/blfs-book
FAQ: http://www.linuxfromscratch.org/blfs/faq.html
Unsubscribe: See the above information page

Re: [blfs-book] [BLFS Trac] #8427: VTE-0.46.0 needs PCRE2-10.22

2016-10-13 Thread BLFS Trac via blfs-book
#8427: VTE-0.46.0 needs PCRE2-10.22
-+---
 Reporter:  timtas   |   Owner:  renodr
 Type:  defect   |  Status:  assigned
 Priority:  low  |   Milestone:  7.11
Component:  BOOK | Version:  SVN
 Severity:  trivial  |  Resolution:
 Keywords:   |
-+---

Comment (by renodr):

 We've got them already. All you have to do is add an xref to "pcre2"

--
Ticket URL: 
BLFS Trac 
Beyond Linux From Scratch
-- 
http://lists.linuxfromscratch.org/listinfo/blfs-book
FAQ: http://www.linuxfromscratch.org/blfs/faq.html
Unsubscribe: See the above information page

Re: [blfs-book] [BLFS Trac] #8427: VTE-0.46.0 needs PCRE2-10.22

2016-10-13 Thread BLFS Trac via blfs-book
#8427: VTE-0.46.0 needs PCRE2-10.22
-+---
 Reporter:  timtas   |   Owner:  renodr
 Type:  defect   |  Status:  assigned
 Priority:  low  |   Milestone:  7.11
Component:  BOOK | Version:  SVN
 Severity:  trivial  |  Resolution:
 Keywords:   |
-+---

Comment (by Samuel):

 Should I create instructions for PCRE2?

--
Ticket URL: 
BLFS Trac 
Beyond Linux From Scratch
-- 
http://lists.linuxfromscratch.org/listinfo/blfs-book
FAQ: http://www.linuxfromscratch.org/blfs/faq.html
Unsubscribe: See the above information page

Re: [blfs-book] [BLFS Trac] #8427: VTE-0.46.0 needs PCRE2-10.22

2016-10-13 Thread BLFS Trac via blfs-book
#8427: VTE-0.46.0 needs PCRE2-10.22
-+---
 Reporter:  timtas   |   Owner:  renodr
 Type:  defect   |  Status:  assigned
 Priority:  low  |   Milestone:  7.11
Component:  BOOK | Version:  SVN
 Severity:  trivial  |  Resolution:
 Keywords:   |
-+---

Comment (by Samuel):

 Ok, I'll try tonight, but I won't be able to test it. I have a lot of
 schoolwork.

--
Ticket URL: 
BLFS Trac 
Beyond Linux From Scratch
-- 
http://lists.linuxfromscratch.org/listinfo/blfs-book
FAQ: http://www.linuxfromscratch.org/blfs/faq.html
Unsubscribe: See the above information page

Re: [blfs-book] [BLFS Trac] #8427: VTE-0.46.0 needs PCRE2-10.22

2016-10-12 Thread BLFS Trac via blfs-book
#8427: VTE-0.46.0 needs PCRE2-10.22
-+---
 Reporter:  timtas   |   Owner:  renodr
 Type:  defect   |  Status:  assigned
 Priority:  low  |   Milestone:  7.11
Component:  BOOK | Version:  SVN
 Severity:  trivial  |  Resolution:
 Keywords:   |
-+---

Comment (by renodr):

 Samuel, would you like to make a patch for this one? It would be a very
 trivial task, and a nice start.

--
Ticket URL: 
BLFS Trac 
Beyond Linux From Scratch
-- 
http://lists.linuxfromscratch.org/listinfo/blfs-book
FAQ: http://www.linuxfromscratch.org/blfs/faq.html
Unsubscribe: See the above information page

Re: [blfs-book] [BLFS Trac] #8427: VTE-0.46.0 needs PCRE2-10.22

2016-10-11 Thread BLFS Trac via blfs-book
#8427: VTE-0.46.0 needs PCRE2-10.22
-+---
 Reporter:  timtas   |   Owner:  renodr
 Type:  defect   |  Status:  assigned
 Priority:  low  |   Milestone:  7.11
Component:  BOOK | Version:  SVN
 Severity:  trivial  |  Resolution:
 Keywords:   |
-+---

Comment (by bdubbs@…):

 Well we don't have PCRE2 mentioned at all as a part of glib.

 Checking configure, PCRE2 is not mentioned.  (Also --with-
 pcre=[internal/system] [default=system] so we can remove that).

 PCRE_REQUIRED_VERSION=8.13

 So no, PCRE2 is not a dependency to Glib.

--
Ticket URL: 
BLFS Trac 
Beyond Linux From Scratch
-- 
http://lists.linuxfromscratch.org/listinfo/blfs-book
FAQ: http://www.linuxfromscratch.org/blfs/faq.html
Unsubscribe: See the above information page

Re: [blfs-book] [BLFS Trac] #8427: VTE-0.46.0 needs PCRE2-10.22

2016-10-11 Thread BLFS Trac via blfs-book
#8427: VTE-0.46.0 needs PCRE2-10.22
-+---
 Reporter:  timtas   |   Owner:  renodr
 Type:  defect   |  Status:  assigned
 Priority:  low  |   Milestone:  7.11
Component:  BOOK | Version:  SVN
 Severity:  trivial  |  Resolution:
 Keywords:   |
-+---
Changes (by renodr):

 * owner:  blfs-book@… => renodr
 * status:  new => assigned


Comment:

 Sorry about that. I'll fix it.

 Although - Guys, should we add PCRE2 as a dependency to Glib? That would
 knock it out early on and remove the hassle of having it mentioned in
 multiple pages.

 I'm sure other packages (including those non-GNOME related) will start
 using it soon, or are already capable of it.

--
Ticket URL: 
BLFS Trac 
Beyond Linux From Scratch
-- 
http://lists.linuxfromscratch.org/listinfo/blfs-book
FAQ: http://www.linuxfromscratch.org/blfs/faq.html
Unsubscribe: See the above information page