Re: [Boost-users] [Boost-MPI][Boost-ODEINT] Running odeint within MPI-context without using mpi_state

2021-01-19 Thread Roland Richter via Boost-users
So, there is no communication between the threads about the step size, and each thread can choose their own step size? Thanks, regards, Roland Am 19.01.21 um 09:52 schrieb Ilja Honkonen: > Hello >> Therefore, is the general idea correct at all, or am I doing something >> wrong here by

[Boost-users] [Boost-MPI][Boost-ODEINT] Running odeint within MPI-context without using mpi_state

2021-01-18 Thread Roland Richter via Boost-users
Hei, I am currently using the odeint-solver for calculating the right hand side of a non-linear equation. For speeding up the calculation of the right hand side, I decided to test the MPI-implementation. Now, after I would prefer to keep the code backwards compatible, I did not want to replace

[boost] Re: Imminent Code Breakage

2003-06-11 Thread Roland Richter
David Abrahams wrote: The permutation iterator in particular is *really* easy. Off-the-cuff: template class ElementIterator, IndexIterator [...] }; I'm just guessing. Why don't you put this through its paces, then contribute revised documentation and tests for the new library? Done.

[boost] Re: Library Proposal: Event-Driven Values

2003-06-07 Thread Roland Richter
Dear Nicolas, sorry for the late reply. Some other projects try to keep me busy. First, I'd like to mention that in German-speaking countries, EDV is a very common acronym for Elektronische Datenverarbeitung (electronic data processing), hence the library name might be somewhat confusing.

[boost] Re: Determining interest in combining_iterator

2003-03-25 Thread Roland Richter
Hi Thomas, some time ago I was in the very same situation that I needed an iterator of tuples - or a tuple of iterators, which virtually is the same IMO. My solution then was to extend tuple functionality, i.e. to add everything that a good iterator requires, such as dereference,

[boost] Re: Variant Review: variant iterators

2003-03-13 Thread Roland Richter
Rozental, Gennadiy wrote: 1. I found this name a bit misleading. At first I though that it some king of iteration through variant types Uhm, what would be a better name? 2. From quick glance on your code it seems that visit_helper class unnessesarilly parameterized with T0 and T1. It's far

[boost] tokenizer: Feature request: keep quotes with escaped_list_separator

2003-03-11 Thread Roland Richter
Dear all, I need to split a string into tokens, and split the resulting tokens again in a second pass. Currently, I do this with boost::tokenizer initialized with an escaped_list_separator. The problem is that all the quote characters are swallowed during the first pass, which makes things

[boost] Broken links in multi_array docs

2003-01-25 Thread Roland Richter
In multi_array's reference manual, Table 2, the three links in the sentence Otherwise it models _Random Access Traversal Iterator_, _Readable Iterator_, and _Writable Iterator_. seem to be broken. - Roland ___ Unsubscribe other changes:

[boost] permutation_iterator and MSVC

2003-01-13 Thread Roland Richter
Hi, as mentioned in the docs, it is necessary to tell MS VC++ all template parameters of an iterator_adaptor *explicitly*. Unfortunately, it seems one cannot do that for a permutation_iterator, since permutation_iterator_generator just takes ElementIterator and IndexIterator as its template

[boost] Re: The Wonder of Tuples

2002-12-26 Thread Roland Richter
There has been some out-of-list discussion about this, and some work is being done. There's a PP based tuple implementation (mostly written by Joel) in Spirit's CVS that conforms to the Tuple speicification in the TR. Where is it? Do you refer to the files under

[boost] Re: The Wonder of Tuples

2002-12-17 Thread Roland Richter
David A. Greene wrote: The fundamental problem is that it's inconvenient to iterate through a tuple. All we have is the get template to access tuple elements. Iterating is again conceptually simple -- just increment an index. But the fact that get is a template implies the index must be a

[boost] Tupples released to sandbox

2002-12-17 Thread Roland Richter
Dear all, today I imported another set of files to Sandbox CVS, this time something I'd like to call 'tupples' (yes, two p's). + What is it? You all know Boost.Tuples (with one 'p'), right? Well, tupples is almost the same, only different. There are two major differences: 1) I wanted to use

[boost] Views a.k.a. container_adaptors released to sandbox

2002-12-09 Thread Roland Richter
Dear all, I would like to announce that I finally imported the first set of Boost.View classes to the Boost-Sandbox CVS. + What is it? A view is a light-weight, immutable decorator to some existing data. Usually, it will provide the same interface as a STL container. In much the same way as

[boost] Re: Views a.k.a. container_adaptors released to sandbox

2002-12-09 Thread Roland Richter
Does this mean a view is mutable? For example, using Boost.View, can I write a boundedstd::list that automatically drops the last element on push_front if size() is at some upper limit value before adding the new element? This is the sort of thing I No. A view is not mutable; sometimes the

[boost] lexical_cast and bool

2002-11-20 Thread Roland Richter
Dear all, just a minor issue for the upcoming(?) lexical_cast in 1.30.0: lexical_castbool( true ) returns false, since std::ios::boolalpha is not set by default. How about changing this? - Roland ___ Unsubscribe other changes: