Re: [bug-gnulib] valloc()?

2005-03-04 Thread Bruno Haible
Derek Price wrote: But it doesn't do so if malloc() fails on non-POSIX systems (like mingw or so). I think one should set errno = ENOMEM if malloc() fails. How about the attached patch? + errno = 0; + unaligned_ptr = malloc (size + pagesize - 1); + if (unaligned_ptr == NULL) +{ +

Re: [bug-gnulib] GNULIB wait-process module.

2005-03-04 Thread Bruno Haible
Derek Price wrote: Hello. I was looking at removing CVS's internal waitpid substitute in favor of the GNULIB wait-process module, but it's missing one feature I need. CVS needs to detect core dumps in the child of the server so that the parent knows not to clean up the temporary workspace

RE: [bug-gnulib] GNULIB wait-process module.

2005-03-04 Thread Jim.Hyslop
Bruno Haible wrote: libsigsegv. Only about SIGFPE I'm not sure whether you can catch it on Windows as well. According to the MSDN, SIGFPE is one of the signals you can handle. I haven't used it myself, so I can't comment on implementation details. -- Jim Hyslop Senior Software

RE: lib/xtime.h is included twice

2005-03-04 Thread Jim.Hyslop
Derek Price wrote: I'm ok with this if you'd like to apply it, Jim. Patch has been committed on 1.11 branch and on the trunk. Since this is such a small patch, should I still update ChangeLog and NEWS? ChangeLog doesn't seem to mention build fixes very much; there are one or two mentions in

Re: [bug-gnulib] valloc()?

2005-03-04 Thread Derek Price
-BEGIN PGP SIGNED MESSAGE- Hash: SHA1 Bruno Haible wrote: | So the only thing I consider possible is the appended patch. Ok. Regards, Derek -BEGIN PGP SIGNATURE- Version: GnuPG v1.4.0 (Cygwin) Comment: Using GnuPG with Thunderbird - http://enigmail.mozdev.org

Re: lib/xtime.h is included twice

2005-03-04 Thread Larry Jones
Jim.Hyslop writes: Since this is such a small patch, should I still update ChangeLog and NEWS? All changes go into ChangeLog, only significant user-visible changes go into NEWS. See the GNU coding standards for more details: http://www.gnu.org/prep/standards/ -Larry Jones The

Re: [bug-gnulib] GNULIB wait-process module.

2005-03-04 Thread Larry Jones
Bruno Haible writes: 2) The very idea of a parent process being responsible for helping debug the child process makes me shudder, because it makes it hard to replace the parent or the client program. In this particular case (CVS), the child process is ostensibly a copy of the

RE: lib/xtime.h is included twice

2005-03-04 Thread Jim.Hyslop
[EMAIL PROTECTED] wrote: All changes go into ChangeLog, only significant user-visible changes go into NEWS. See the GNU coding standards for more details: http://www.gnu.org/prep/standards/ Noted. And bookmarked for future reference - thanks for that information. -- Jim Hyslop

Re: lib/xtime.h is included twice

2005-03-04 Thread Georg Schwarz
I cannot judge this. I was just following the example given in http://cvsweb.NetBSD.org/bsdweb.cgi/src/share/misc/style?rev=HEADcontent-type=text/x-cvsweb-markup If you think different naming conventions are more appropriate, I don't mind. [EMAIL PROTECTED] wrote: Dear cvs developers,

Re: [bug-gnulib] valloc()?

2005-03-04 Thread Derek Price
-BEGIN PGP SIGNED MESSAGE- Hash: SHA1 Derek Price wrote: | Re my earlier questions about efficiency, here's the patch using | the new pagealign_alloc module which is currently passing `make | remotecheck' here. It also contains a few modification to the new | GNULIB pagealign_alloc module

Re: Feature request/ideas

2005-03-04 Thread Derek Price
Derek Price wrote: Mark D. Baushke wrote: | Therefore, I suppose that there could be a need for .origin to be | the first revision on TRUNK This would seldom mean much across multiple files, so I still think .origin should not be used. The case Frank cited, where he is basically trying to diff