bug#25775: Can't install packages after guix pull

2017-02-19 Thread pelzflorian (Florian Pelz)
A full uninstall and reinstall as described on the Arch wiki solved the issue for me; `guix pull` and everything works again. systemctl had reported the daemon to be running; I still have no idea what happened. Some network thing? No idea.

bug#25775: Can't install packages after guix pull

2017-02-19 Thread pelzflorian (Florian Pelz)
On 02/18/2017 12:11 PM, Pjotr Prins wrote: > I am seeing the same on a fresh checkout and build: > > penguin2:~/genenetwork/guix$ ./pre-inst-env guix package -p > $HOME/opt/guix-build-system --install autoconf > warning: failed to install locale: Invalid argument > Backtrace: > In

bug#25258: Bashisms when building 0.11.0

2016-12-23 Thread pelzflorian (Florian Pelz)
Hello, Guix' testsuite uses the non-POSIX bashism `type -P guile` in tests/guix-packages.sh which causes a test failure when using Dash to provide /bin/sh instead of Bash. Additionally gnu/local.mk uses brace expansion which is not part of POSIX and does not work on Dash. When building Guix on

bug#26215: gschemas.compiled should not be added to the profile by multiple packages

2017-03-23 Thread pelzflorian (Florian Pelz)
On 03/23/2017 05:20 PM, Federico Beffa wrote: > Note that if you mix GTK-2 and GTK-3 schemas many applications will > crash. The glib-or-gtk-build-system tries to avoid mixing the two. > > Fede > I believe you are confusing schemas and modules. GSettings schemas come from GLib and both GTK+ 2

bug#26158: Gnome starts unreliably

2017-03-19 Thread pelzflorian (Florian Pelz)
Does guix package -i xf86-video-intel or guix package -i xf86-video-nouveau help (or whatever else your GPU is from `guix package -s xf86-video-`)? Regards, Florian

bug#26170: documentation: Explanation of propagated-inputs unclear

2017-03-19 Thread pelzflorian (Florian Pelz)
Hello, I presume the difference between a package’s `inputs` and `propagated-inputs` in Guix packages is that propagated inputs get installed to a Guix profile whenever the package is installed while inputs are dependencies that remain in the Store. I presume libraries the packaged program is

bug#26215: gschemas.compiled should not be added to the profile by multiple packages

2017-03-22 Thread pelzflorian (Florian Pelz)
Currently multiple packages contain the file share/glib-2.0/schemas/gschemas.compiled (which is built by glib-or-gtk-build-system). Doing so *works* (because each package’s share directory in the Store is part of the XDG_DATA_DIRS environment variable, GSettings looks for settings in each of the

bug#27264: gnome-shell-3.24.2 consistently dies during initialization

2017-06-08 Thread pelzflorian (Florian Pelz)
On Wed, Jun 07, 2017 at 05:58:07PM -0400, Mark H Weaver wrote: > I have a question: Does GNOME 3 work for *anyone* in Guix now? If so, > that would be useful information. If not, I wonder why this got merged > into master. > > Mark > It does not work for me. I get the same error. I'm

bug#27264: gnome-shell-3.24.2 consistently dies during initialization

2017-06-08 Thread pelzflorian (Florian Pelz)
On Thu, Jun 08, 2017 at 02:01:22PM +0200, Ludovic Courtès wrote: > I think many of us use GTK+/GNOME applications, but fewer use GNOME, so > I suppose we just didn’t test a full GNOME setup. > > Next time we should probably do that or, even better, have an automated > test that logs in, takes a

bug#27231: regression?: grub-configuration for grub-efi does not return a bootloader-configuration

2017-06-04 Thread pelzflorian (Florian Pelz)
Hello, My GuixSD configuration (see attachment) for UEFI got broken some three weeks ago but I’ve only now caught up with my e-mail and “fixed” it. root@floriannotebook ~# guix system reconfigure /home/florian/keep/guixsd-asus.scm Backtrace: 9 (apply-smob/1 #) In ice-9/boot-9.scm:

bug#27231: regression?: grub-configuration for grub-efi does not return a bootloader-configuration

2017-06-04 Thread pelzflorian (Florian Pelz)
On Sun, Jun 04, 2017 at 04:38:11PM +0300, Alex Kost wrote: > This is a limitation of 'grub-configuration' macro: that backtrace > happened because you have 'grub' field *not* in the first place of your > 'grub-configuration'. > > […] > > Note that this will work if you put (grub grub-efi) in the

bug#27231: regression?: grub-configuration for grub-efi does not return a bootloader-configuration

2017-06-10 Thread pelzflorian (Florian Pelz)
On Sun, Jun 04, 2017 at 04:25:13PM +0200, pelzflorian (Florian Pelz) wrote: > On Sun, Jun 04, 2017 at 04:38:11PM +0300, Alex Kost wrote: > > This is a limitation of 'grub-configuration' macro: that backtrace > > happened because you have 'grub' field *not* in the first place of

bug#26006: New web site is on line!

2017-12-08 Thread pelzflorian (Florian Pelz)
On Fri, Dec 08, 2017 at 01:42:27PM -0500, Quiliro Ordonez Baca wrote: > "pelzflorian (Florian Pelz)" <pelzflor...@pelzflorian.de> writes: > > > > I believe there is a typo on the home page below the video. „leave“ > > should be „live“: > > > >

bug#26006: New web site is on line!

2017-12-07 Thread pelzflorian (Florian Pelz)
Nice website! On Wed, Dec 06, 2017 at 06:10:48PM +0100, Ludovic Courtès wrote: > Please report: > > • broken links; > > • other pages that need a redirect; > > • information that disappeared—I’m thinking in particular of talks, > which used to appear under /help, but are now supposed

bug#31714: Cannot use usb-storage initrd module.

2018-06-04 Thread pelzflorian (Florian Pelz)
My laptop broke and now I use my formerly internal hard disk as an external hard disk in another laptop. It booted fine but I could not reconfigure maybe because Guix checks for a wrong spelling of the usb-storage module. When I pulled 1458f768c1049812166228b8526128b199518e50 and reconfigured I

bug#33171: TMPDIR and build containers

2018-10-26 Thread pelzflorian (Florian Pelz)
Hello, The manual says that TMPDIR does not leak into the build environment: >You can influence the directory where the daemon stores build trees > via the ‘TMPDIR’ environment variable. However, the build tree within > the chroot is always called ‘/tmp/guix-build-NAME.drv-0’, where NAME is

bug#33678: Locale problems

2018-12-08 Thread pelzflorian (Florian Pelz)
On Sat, Dec 08, 2018 at 10:35:51PM +0100, Danny Milosavljevic wrote: > Can we do something against the locale problems that keep showing up > when updating? > > Right now, after a half-finished update from guix master (half-finished > because > once any package build breaks, the entire update

bug#33892: guix package --list-generations uses UTC and time-at-midnight for hour durations

2018-12-28 Thread pelzflorian (Florian Pelz)
Hello Guix, I would expect guix package --list-generations=…h to display generations from the past … hours, but apparently it displays generations offset from UTC midnight (apparently not local time?) and not the current time, since guix/ui.scm calls a procedure named time-at-midnight. In

bug#33894: Guix manual PO file uses same translation msgid ``channels'' for different uses

2018-12-28 Thread pelzflorian (Florian Pelz)
Hello, The Guix manual POT file 0.16.0.1 submitted to the Translation Project has these lines: #. type: item #: doc/guix.texi:2919 doc/guix.texi:3279 #, no-wrap msgid "channels" msgstr "" However, doc/guix.texi:2919 is a cindex which should be translated and doc/guix.texi:3279 is a table item

bug#34955: Manual: Service extensions not clear

2019-03-23 Thread pelzflorian (Florian Pelz)
The Guix manual (section Defining services) says about service extensions: [The example guix-service-type definition] defines three things: 1. […] 2. A list of “service extensions”, where each extension designates the target service type and a procedure that, given the parameters of

bug#35136: Git master installer disk-image has GPT PMBR size mismatch

2019-04-03 Thread pelzflorian (Florian Pelz)
Since commit 45c0d1d790f01ebc020fc4b2787a6abcdaa3f383 all install ISOs created with guix system disk-image --file-system-type=iso9660 gnu/system/install.scm cannot boot for me, see https://lists.gnu.org/archive/html/guix-devel/2019-04/msg00061.html fdisk reports this: florian@florianmacbook

bug#35136: Git master installer disk-image has GPT PMBR size mismatch

2019-04-04 Thread pelzflorian (Florian Pelz)
On Thu, Apr 04, 2019 at 07:33:17AM +0200, pelzflorian (Florian Pelz) wrote: > guix system disk-image --file-system-type=iso9660 gnu/system/install.scm > This only happens when specifying --file-system-type=iso9660.

bug#35136: Git master installer disk-image has GPT PMBR size mismatch

2019-04-04 Thread pelzflorian (Florian Pelz)
I would like to log the commandline with which parted is executed in initialize-partition-table in gnu/build/vm.scm, but I do not know where all the output is going. Apparently it is nowhere in the logs.

bug#35136: Git master installer disk-image has GPT PMBR size mismatch

2019-04-06 Thread pelzflorian (Florian Pelz)
On Fri, Apr 05, 2019 at 07:57:06AM +0200, pelzflorian (Florian Pelz) wrote: > I would like to log the commandline with which parted is executed in > initialize-partition-table in gnu/build/vm.scm, but I do not know > where all the output is going. Apparently it is nowhere in the logs. &g

bug#33639: ISO installer image is broken on i686

2019-04-07 Thread pelzflorian (Florian Pelz)
I have what may be the same problem on my x86_64 machine building for x86_64 when creating an ISO install image by running guix system disk-image --file-system-type=iso9660 gnu/system/install.scm Since commit 45c0d1d790f01ebc020fc4b2787a6abcdaa3f383 increased the RAM for the VM that builds the

bug#34574: Confusing manual entry for gexp->file

2019-03-06 Thread pelzflorian (Florian Pelz)
On Wed, Mar 06, 2019 at 02:17:49PM +0100, Ludovic Courtès wrote: > Hi Florian, > > "pelzflorian (Florian Pelz)" skribis: > > > The Guix manual contains the following description of gexp->file: > > > > -- Monadic Procedure: gexp->file NAME EXP [#:s

bug#34893: Translated manuals refer to wrong substitute server

2019-03-17 Thread pelzflorian (Florian Pelz)
Where the manual refers to the default substitute server https://ci.guix.info, the translated manuals wrongly use https://ci.guix.fr.info or similar. This is because at the top of doc/guix.texi it says @set SUBSTITUTE-SERVER ci.guix.info which is wrongly replaced by something like @set

bug#34498: Confusing msgid " Running value is ~s.~%"

2019-02-15 Thread pelzflorian (Florian Pelz)
Hello, I am fairly sure #: modules/shepherd/scripts/herd.scm:86 #, scheme-format msgid " Running value is ~s.~%" refers to the value of the #:running slot but translators don’t know that and would translate it as a value that is running. This should be changed and a comment for TRANSLATORS

bug#34574: Confusing manual entry for gexp->file

2019-02-19 Thread pelzflorian (Florian Pelz)
Hello, The Guix manual contains the following description of gexp->file: -- Monadic Procedure: gexp->file NAME EXP [#:set-load-path? #t] [#:module-path %load-path] [#:splice? #f] [#:guile (default-guile)] Return a derivation that builds a file NAME containing EXP. When

bug#33639: ISO installer image is broken on i686

2019-04-09 Thread pelzflorian (Florian Pelz)
On Mon, Apr 08, 2019 at 10:50:29AM +0200, Ludovic Courtès wrote: > Hello, > > "Thomas Schmitt" skribis: > > > The fact that the VM always sees the expected size but the host sees varying > > sizes supports the suspicion that at the end of the VM its i/o buffers or > > virtual disk are not

bug#35136: Git master installer disk-image has GPT PMBR size mismatch

2019-04-07 Thread pelzflorian (Florian Pelz)
This seems to be a duplicate of https://issues.guix.info/issue/33639 , I think, but it happens to me on x86_64.

bug#33639: ISO installer image is broken on i686

2019-04-10 Thread pelzflorian (Florian Pelz)
On Wed, Apr 10, 2019 at 01:17:14PM +0200, Thomas Schmitt wrote: > Given the smell of a race condition, i would next try to let the VM > wait 10 or 15 seconds after xorriso is finished and before it shuts down. > I added a (sleep 15) after ludo’s (sync). The first image worked but now I got

bug#33639: ISO installer image is broken on i686

2019-04-15 Thread pelzflorian (Florian Pelz)
On Sun, Apr 14, 2019 at 11:43:54PM +0200, Ludovic Courtès wrote: > How did you visualize differences, Florian? Diffoscope fails for me > here (missing tools and scalability issue.) > For me diffoscope failed too. I used cmp as described here:

bug#33639: ISO installer image is broken on i686

2019-04-15 Thread pelzflorian (Florian Pelz)
On Sat, Apr 13, 2019 at 03:46:09PM +0200, pelzflorian (Florian Pelz) wrote: > Yes, it seems fixed, I can confirm. Well this is strange. I got fine ISO images each time (fine with no complaints from xorriso or fdisk and bootable in QEMU without errors), but after dd’ing them to different

bug#33639: ISO installer image is broken on i686

2019-04-17 Thread pelzflorian (Florian Pelz)
On Tue, Apr 16, 2019 at 11:01:45PM +0200, Ludovic Courtès wrote: > "pelzflorian (Florian Pelz)" skribis: > > Having such a USB flash drive inside my computer makes UEFI get stuck > > on some computers but not on others. > > So you cannot boot from these USB drive

bug#34498: Confusing msgid " Running value is ~s.~%"

2019-04-18 Thread pelzflorian (Florian Pelz)
On Thu, Apr 18, 2019 at 12:34:03PM +0200, Ludovic Courtès wrote: > "pelzflorian (Florian Pelz)" skribis: > > > I am fairly sure > > > > #: modules/shepherd/scripts/herd.scm:86 > > #, scheme-format > > msgid " Running value is ~s.~%

bug#34498: Confusing msgid " Running value is ~s.~%"

2019-04-18 Thread pelzflorian (Florian Pelz)
On Thu, Apr 18, 2019 at 06:37:34PM +0200, Ludovic Courtès wrote: > Can you suggest a better comment? > Maybe: ;; TRANSLATORS: 'running' is the name of a variable. I thought #:running describes the manner in which the service is running. Maybe I misunderstand. Mario Blättermann translated

bug#35136: Git master installer disk-image has GPT PMBR size mismatch

2019-04-13 Thread pelzflorian (Florian Pelz)
On Sun, Apr 07, 2019 at 08:33:23AM +0200, pelzflorian (Florian Pelz) wrote: > This seems to be a duplicate of https://issues.guix.info/issue/33639 > , I think, but it happens to me on x86_64. > This bug is fixed with ludo’s patch for https://issues.guix.info/issue/33639

bug#33639: ISO installer image is broken on i686

2019-04-13 Thread pelzflorian (Florian Pelz)
On Fri, Apr 12, 2019 at 11:26:28PM +0200, Ludovic Courtès wrote: > Florian, it would be great if you could confirm. Just apply it on > ‘master’, and then run: > > ./pre-inst-env guix system disk-image --file-system-format=iso9660 \ > gnu/system/install.scm > Yes, it seems fixed, I can

bug#35640: Make USB modems just work on Guix

2019-05-15 Thread pelzflorian (Florian Pelz)
On Wed, May 15, 2019 at 03:01:04PM +0200, Ludovic Courtès wrote: > Could you send an updated patch? > Thank you very much! Will do later, today or tomorrow. > Is USB_ModeSwitch needed for proper use of ModemManager? I’d say “no” > but I’m unsure. > Only on some modems. > Thanks for working

bug#35640: Make USB modems just work on Guix

2019-05-24 Thread pelzflorian (Florian Pelz)
Thank you for your feedback! On Fri, May 24, 2019 at 05:37:01PM +0200, Ludovic Courtès wrote: > > Tring to put the packages in gnu/packages/libusb.scm and not in their > > own file gnu/packages/usb-modeswitch.scm again resulted in > > > > [ 11%] LOAD guix/scripts/search.scm > > [ 11%] LOAD

bug#35640: Make USB modems just work on Guix

2019-05-25 Thread pelzflorian (Florian Pelz)
On Sat, May 25, 2019 at 01:18:56PM +0200, pelzflorian (Florian Pelz) wrote: > I added the --config-file option since by default > usb_modeswitch_dispatcher loads its optional config file from /etc and > a future Guix service type for USB_ModeSwitch should be able to pass a >

bug#35640: Make USB modems just work on Guix

2019-05-25 Thread pelzflorian (Florian Pelz)
On Fri, May 24, 2019 at 10:12:10PM +0200, pelzflorian (Florian Pelz) wrote: > I will send an updated patch tomorrow with a working ”dispatcher“ > output. > Please find attached a patch that no longer propagates usb-modeswitch-data from usb-modeswitch. I can now modeswitch my

bug#35640: Make USB modems just work on Guix

2019-05-25 Thread pelzflorian (Florian Pelz)
On Sat, May 25, 2019 at 07:44:37PM +0200, Ludovic Courtès wrote: > "pelzflorian (Florian Pelz)" skribis: > > The udev rules file in usb-modeswitch-data has lines like: > > > > ATTR{idVendor}=="03f0", ATTR{idProduct}=="002a", RUN+="

bug#35996: User account password got locked when booting old generation

2019-06-04 Thread pelzflorian (Florian Pelz)
On Tue, Jun 04, 2019 at 11:22:45AM +0200, Ludovic Courtès wrote: > Hi, > > "pelzflorian (Florian Pelz)" skribis: > > > On Mon, Jun 03, 2019 at 03:22:51PM +0200, Ludovic Courtès wrote: > >> > After multiple reconfigures, it happened again, my /etc/shadow

bug#35996: User account password got locked when booting old generation

2019-06-03 Thread pelzflorian (Florian Pelz)
: > "pelzflorian (Florian Pelz)" skribis: > > AccountsService appears to only be usable for reading /etc/shadow, not > > for writing it, contrary to what the Guix manual claims (??). > > That might be a bug. > AccountsService obviously can change passwords. N

bug#35996: User account password got locked when booting old generation

2019-06-03 Thread pelzflorian (Florian Pelz)
Please add more logging and/or locking. Note that the elogind has the following comment in its locking implementation in /gnu/store/dm2ri0qvjirl0iq2ndfk5z9lq9dyk4jf-elogind-241.3-checkout/src/basic/user-util.c: /* This is roughly the same as lckpwdf(), but not as awful. We *

bug#35996: User account password got locked when booting old generation

2019-06-04 Thread pelzflorian (Florian Pelz)
On Tue, Jun 04, 2019 at 02:17:11PM +0200, pelzflorian (Florian Pelz) wrote: > On Tue, Jun 04, 2019 at 11:22:45AM +0200, Ludovic Courtès wrote: > > What’s the effect of this brokenness concretely? Is the wrong root file > > system mounted, or something like that? > > >

bug#35996: User account password got locked when booting old generation

2019-06-04 Thread pelzflorian (Florian Pelz)
this: On Tue, Jun 04, 2019 at 04:12:17PM +0200, pelzflorian (Florian Pelz) wrote: > > I have multiple broken generation. On one that now for a third time > > (on old generations without Ludo’s patches) led to a locked > > /etc/shadow after booting I changed the line > > (let

bug#35996: User account password got locked when booting old generation

2019-06-03 Thread pelzflorian (Florian Pelz)
On Mon, Jun 03, 2019 at 03:22:51PM +0200, Ludovic Courtès wrote: > > After multiple reconfigures, it happened again, my /etc/shadow has ! > > again in the password field. My recently changed root password became > > empty as well, like 35902. I did not even run sudo concurrently. The > >

bug#35996: User account password got locked when booting old generation

2019-06-05 Thread pelzflorian (Florian Pelz)
On Tue, Jun 04, 2019 at 11:21:05PM +0200, Ludovic Courtès wrote: > "pelzflorian (Florian Pelz)" skribis: > > When booting an unbootable generation with Ludovic’s patches and then > > rebooting a normal generation with Ludovic’s patches, /etc/shadow is > > loc

bug#35996: User account password got locked when booting old generation

2019-06-05 Thread pelzflorian (Florian Pelz)
It appears your patch fixes the issue. I admire the speed at which you write patches. :) Thank you! On Wed, Jun 05, 2019 at 11:54:23AM +0200, Ludovic Courtès wrote: > Note that you’ll have to create a new “broken” generation with this > patch (because we already know that the old one can

bug#35996: User account password got locked when booting old generation

2019-05-31 Thread pelzflorian (Florian Pelz)
On Sat, Jun 01, 2019 at 12:05:44AM +0200, Ludovic Courtès wrote: > Did the old generation you booted have user ‘florian’? > Yes, this is my main machine. The users are the same. > Also, how old was it? User account management changed in March (commit >

bug#35996: User account password got locked when booting old generation

2019-06-03 Thread pelzflorian (Florian Pelz)
All this is not a problem with name service cache daemon, is it? On Mon, Jun 03, 2019 at 05:22:55PM +0200, Ludovic Courtès wrote: > Attach is a set of patches to lock /etc/.pwd.lock when we access > /etc/{passwd,shadow,group} from the activation snippets. It should > ensure that, when running

bug#35996: User account password got locked when booting old generation

2019-06-01 Thread pelzflorian (Florian Pelz)
On Sat, Jun 01, 2019 at 07:52:38AM +0200, pelzflorian (Florian Pelz) wrote: > I wonder what would change /etc/shadow. > If the error occurred on common non-Guix distros, it hopefully would have been fixed before, maybe. Of course Guix recreates /etc/shadow much more frequently. Guix a

bug#35913: [core-updates] Building "doc/guix.de.texi" fails

2019-06-06 Thread pelzflorian (Florian Pelz)
On Thu, Jun 06, 2019 at 10:09:23AM +0200, Julien Lepiller wrote: > Isn't there a comma in a node name? There shouldn't be any, it makes texinfo > confused. > > > Sorry! Please remove the comma from “Preparing to Use the Bootstrap Binaries”’ translation.

bug#35996: User account password got locked when booting old generation

2019-06-06 Thread pelzflorian (Florian Pelz)
On Wed, Jun 05, 2019 at 11:13:34PM +0200, Ludovic Courtès wrote: > Awesome! I must say that I’m really glad you’re putting this much > energy into reproducing issues and investigating—it’s rare for people > who report bug to dig this deep, but it’s super helpful and motivating! :) > The

bug#35996: User account password got locked when booting old generation

2019-06-02 Thread pelzflorian (Florian Pelz)
On Sat, Jun 01, 2019 at 11:37:51PM +0200, Ludovic Courtès wrote: > This is definitely not a problem when booting. It could be a problem if > you’re concurrently running ‘guix system reconfigure’ (which runs > activation snippets, including the account updating code) and some other > program, such

bug#35996: User account password got locked when booting old generation

2019-06-02 Thread pelzflorian (Florian Pelz)
On Sun, Jun 02, 2019 at 11:38:36AM +0200, Ludovic Courtès wrote: > Hi Florian, > > "pelzflorian (Florian Pelz)" skribis: > > > On Sat, Jun 01, 2019 at 11:37:51PM +0200, Ludovic Courtès wrote: > >> This is definitely not a problem when booting. It could be

bug#36054: [wishlist] Simplify chrooting into installed system from install image

2019-06-02 Thread pelzflorian (Florian Pelz)
When bootloader installation fails or when the installed bootloader does not allow selecting old generations (like the U-Boot bootloader), chrooting may become necessary to repair a broken Guix system. Guix should offer officially supported instructions in the manual and perhaps more tooling for

bug#35996: User account password got locked when booting old generation

2019-05-29 Thread pelzflorian (Florian Pelz)
After I reconfigured to a broken, unbootable generation and then rebooted to an old working generation, I found my user account password was locked. This was my /etc/shadow: root::18045:: florian:!:18045:: nobody:!:18045:: guixbuilder01:!:18045:: guixbuilder02:!:18045::

bug#35640: Make USB modems just work on Guix

2019-06-12 Thread pelzflorian (Florian Pelz)
On Sat, May 25, 2019 at 07:44:37PM +0200, Ludovic Courtès wrote: > >> + (substitute* "usb_modeswitch_dispatcher" > >> + (("!/usr/bin/tclsh") > >> +(string-append "!" jimtcl "/bin/jimsh")) > > I don’t think it’s needed, is it? > I see now,

bug#35640: Make USB modems just work on Guix

2019-06-12 Thread pelzflorian (Florian Pelz)
On Wed, Jun 12, 2019 at 12:36:47PM +0200, pelzflorian (Florian Pelz) wrote: > Find attached patches that make USB modems just work, fixing this bug. > I forgot to ask: The USB_ModeSwitch website says: If you are a system integrator (package maintainer) you can use this XML file to check f

bug#35640: Make USB modems just work on Guix

2019-06-12 Thread pelzflorian (Florian Pelz)
. I am uncertain if having paragraphs like this in modem-manager-service-type and usb-modeswitch-service-type is a good idea: This service is part of ‘%desktop-services’ (*note Desktop Services::). On Sat, May 25, 2019 at 09:42:15PM +0200, pelzflorian (Florian Pelz) wrote: > Frankly, I

bug#36262: cannot install bootloader to root partition

2019-06-18 Thread pelzflorian (Florian Pelz)
On Tue, Jun 18, 2019 at 04:33:22AM +0200, Tobias Geerinckx-Rice wrote: > Although now I suspect there was no reason and that the installer isn't to > blame. > The graphical installer does not display a warning when not adding a separate boot partition on GPT (an installer bug?), but installs

bug#36069: Menu-based installer unusable through noVNC

2019-06-25 Thread pelzflorian (Florian Pelz)
On Tue, Jun 25, 2019 at 05:06:03PM +0200, Björn Höfling wrote: > I guess you (Ludovic) have tried the installer with QEMU and its > VNC-Server, maybe even with different VNC-clients? > It works with qemu-system-x86_64 -m 1024 -smp 1 -enable-kvm -drive

bug#35640: Make USB modems just work on Guix

2019-06-13 Thread pelzflorian (Florian Pelz)
Find attached patches taking into account your suggestions. (The second patch is unchanged.) On Wed, Jun 12, 2019 at 11:11:16PM +0200, Ludovic Courtès wrote: > > + ;; wrap-program needs bash in PATH: > > + (putenv (string-append "PATH=" #$bash "/bin")) > > Why

bug#35640: Make USB modems just work on Guix

2019-06-13 Thread pelzflorian (Florian Pelz)
On Thu, Jun 13, 2019 at 08:04:52PM +0200, pelzflorian (Florian Pelz) wrote: > Find attached patches taking into account your suggestions. (The > second patch is unchanged.) > Forgot attachment. Sorry. >From 27aff97683537407c178ea2b664069def0cf141a Mon Sep 17 00:00:00 2001 From:

bug#35640: Make USB modems just work on Guix

2019-06-12 Thread pelzflorian (Florian Pelz)
On Wed, Jun 12, 2019 at 02:21:05PM +0200, Ludovic Courtès wrote: > "pelzflorian (Florian Pelz)" skribis: > > On Sat, May 25, 2019 at 07:44:37PM +0200, Ludovic Courtès wrote: > >> >> + (substitute* "usb_modeswitch_dispatcher" &g

bug#36221: Make GDM *not* restart 504 times on failure

2019-06-20 Thread pelzflorian (Florian Pelz)
On Mon, Jun 17, 2019 at 11:22:57AM +0200, Ludovic Courtès wrote: > "pelzflorian (Florian Pelz)" skribis: > I think the auto-restart code that’s triggered is in GDM itself, no? > Yes, you are right, I did not expect that. GDM gets stuck in a not-quite-endless loop of recrea

bug#36221: Make GDM *not* restart 504 times on failure

2019-06-23 Thread pelzflorian (Florian Pelz)
This is not a Guix bug. Closing. Very many GDM restarts is what happens on Debian Stretch and Arch (GNOME 3.32) as well after renaming /usr/share/xorg/modules, just like it does on Guix. On Guix’ wip-gnome3.30 GDM fails in a different way; maybe I will investigate further and then file a bug at

bug#36221: Make GDM *not* restart 504 times on failure

2019-06-15 Thread pelzflorian (Florian Pelz)
If GDM does not start for whatever reason, it attempts to restart 504 more times which all fail and overwrite all five old logs. It probably should not attempt to restart at all. Regards, Florian

bug#35640: Make USB modems just work on Guix

2019-05-09 Thread pelzflorian (Florian Pelz)
OBOn Thu, May 09, 2019 at 03:07:12PM +0200, pelzflorian (Florian Pelz) wrote: > On Thu, May 09, 2019 at 02:55:04PM +0200, Danny Milosavljevic wrote: > > I think back then we thought it would be too big for the installation > > medium. > > How big is it after that? > >

bug#35640: Make USB modems just work on Guix

2019-05-09 Thread pelzflorian (Florian Pelz)
On Thu, May 09, 2019 at 02:55:04PM +0200, Danny Milosavljevic wrote: > I think back then we thought it would be too big for the installation medium. > How big is it after that? The installation medium uses %desktop-services? I will check, but my proposal does not concern the installation

bug#35662: Really relocatable binaries crash with Permission denied

2019-05-09 Thread pelzflorian (Florian Pelz)
The manual gives the following example of guix pack -RR: guix pack -RR -S /mybin=bin bash tar xf pack.tar.gz ./mybin/sh This fails on my university’s server for students which uses Linux container “VMs” with Ubuntu and has no user namespace support and Guix is not installed.

bug#35610: Freshly installed IBus intput method is not listed as an input source

2019-05-09 Thread pelzflorian (Florian Pelz)
n already has an ibus-daemon. > On Tue, May 07, 2019 at 04:26:29PM +0200, pelzflorian (Florian Pelz) wrote: > > What I said was incomplete. I just tried again; ibus-anthy works fine > > for me only when e.g. entering text in GNOME Shell’s search bar, but > > not when enteri

bug#35662: Really relocatable binaries crash with Permission denied

2019-05-10 Thread pelzflorian (Florian Pelz)
On Fri, May 10, 2019 at 11:50:19PM +0200, Ludovic Courtès wrote: > That suggests the wrapper chose the user namespace method (not PRoot), > but that didn’t quite work. > > Could you post the output of: > > strace ./mybin/sh > > ? > [f_pelz12@tux6 ~]$ strace ./mybin/sh execve("./mybin/sh",

bug#35690: Installer error: Unable to locate keymap update file

2019-05-12 Thread pelzflorian (Florian Pelz)
On Sat, May 11, 2019 at 06:21:37PM -0400, Lorem Ipsum wrote: > Hi, > > Installation failed when i tried installing > guix-system-install-1.0.0.x86_64-linux.iso in Virtual Box 6.0.2 r128162 on > Windows 10. > Could it be that at first, the install failed (e.g. because of a network error that

bug#35662: Really relocatable binaries crash with Permission denied

2019-05-13 Thread pelzflorian (Florian Pelz)
On Mon, May 13, 2019 at 09:49:40AM +0200, Ludovic Courtès wrote: > Hi Florian, > > "pelzflorian (Florian Pelz)" skribis: > > > On Fri, May 10, 2019 at 11:50:19PM +0200, Ludovic Courtès wrote: > >> That suggests the wrapper chose the user namespace method (n

bug#35640: Make USB modems just work on Guix

2019-05-13 Thread pelzflorian (Florian Pelz)
On Thu, May 09, 2019 at 05:24:39PM +0200, Ludovic Courtès wrote: > The comment is unnecessary, but otherwise LGTM! > :) I have attached the patch without the command. Also attached is my current work-in-progress package for USB_ModeSwitch. It does *not* work because I cannot figure out how to

bug#35662: Really relocatable binaries crash with Permission denied

2019-05-13 Thread pelzflorian (Florian Pelz)
On Mon, May 13, 2019 at 10:39:21PM +0200, Ludovic Courtès wrote: > I suspect ZFS-on-Linux (right?) is doing something unusual here: I suppose it is ZFS on Linux; it is Linux, I can ask the admins if it could be something else. > What do the following commands do on this system? > >

bug#35640: Make USB modems just work on Guix

2019-05-13 Thread pelzflorian (Florian Pelz)
On Mon, May 13, 2019 at 10:57:20PM +0200, pelzflorian (Florian Pelz) wrote: > Also attached is my current work-in-progress package for > USB_ModeSwitch. It does *not* work because I cannot figure out how to > use tcl in the package’s inputs field. > > #:use-module gives me error

bug#35662: Really relocatable binaries crash with Permission denied

2019-05-13 Thread pelzflorian (Florian Pelz)
On Mon, May 13, 2019 at 03:54:11PM +0200, Ludovic Courtès wrote: > Can you show the mount options of you root file system? > > mount | grep 'on / ' > [f_pelz12@tux6 ~]$ mount | grep 'on / ' rpool/data/subvol-161199-disk-0 on / type zfs (rw,noatime,xattr,posixacl) > What’s the exit code of

bug#35662: Really relocatable binaries crash with Permission denied

2019-05-14 Thread pelzflorian (Florian Pelz)
On Mon, May 13, 2019 at 10:45:24PM +0200, pelzflorian (Florian Pelz) wrote: > On Mon, May 13, 2019 at 10:39:21PM +0200, Ludovic Courtès wrote: > > I suspect ZFS-on-Linux (right?) is doing something unusual here: > > I suppose it is ZFS on Linux; it is Linux, I can ask the admin

bug#35640: Make USB modems just work on Guix

2019-05-14 Thread pelzflorian (Florian Pelz)
On Mon, May 13, 2019 at 11:04:43PM +0200, pelzflorian (Florian Pelz) wrote: > gnu/packages/libusb.scm:655:12: In procedure inputs: > error: tcl:tcl: unbound variable > This tcl:tcl gets resolved all right elsewhere in the libusb.scm file. There must be something special about de

bug#35640: Make USB modems just work on Guix

2019-05-14 Thread pelzflorian (Florian Pelz)
On Tue, May 14, 2019 at 10:35:55AM +0200, Danny Milosavljevic wrote: > Should be > >(inputs `(("libusb" ,libusb) > ("tcl" ,tcl:tcl))) > Yes I did mean that with comma, sorry. > But I guess you meant that anyway. > > The problem is there's a use-modules cycle somewhere. > Try

bug#35662: Really relocatable binaries crash with Permission denied

2019-05-14 Thread pelzflorian (Florian Pelz)
On Tue, May 14, 2019 at 10:43:56PM +0200, Ludovic Courtès wrote: > "pelzflorian (Florian Pelz)" skribis: > > > On Mon, May 13, 2019 at 10:45:24PM +0200, pelzflorian (Florian Pelz) wrote: > >> On Mon, May 13, 2019 at 10:39:21PM +0200, Ludovic Courtès wrote: >

bug#35856: Unable to boot on iMac, likely because of UUIDs

2019-05-22 Thread pelzflorian (Florian Pelz)
On Wed, May 22, 2019 at 11:10:00AM +, Francisco Gómez wrote: > When I have inserted a device recorded with a GuixSD image in my Late 2009 > iMac (EFI, not UEFI) during boot, the computer gets stuck in a loop and > doesn't respond. I believe this is due to a lack of, or duplication, of > UUIDs

bug#35856: Unable to boot on iMac, likely because of UUIDs

2019-05-22 Thread pelzflorian (Florian Pelz)
On Wed, May 22, 2019 at 04:09:09PM +0200, pelzflorian (Florian Pelz) wrote: > Can you try an ISO built from current Guix git master? > If this ISO works, then this still-ongoing GRUB mailing list thread described your issue as well: https://lists.gnu.org/archive/html/grub-devel/2019-04/ms

bug#35640: Make USB modems just work on Guix

2019-05-22 Thread pelzflorian (Florian Pelz)
Thank you for your thorough review. Find attached a new version of the patch. I can now modeswitch my USB modem by doing ./pre-inst-env guix install usb-modeswitch:dispatcher sudo usb_modeswitch -c ~/.guix-profile/share/usb_modeswitch.d/12d1\:14fe -v 0x12d1 -p 0x14fe Tring to put the packages

bug#35640: Make USB modems just work on Guix

2019-05-22 Thread pelzflorian (Florian Pelz)
I forgot to mention gnu/local.mk in the commit message. Please use this patch attached here instead. Regards, Florian>From 854198efebbe91feea2fbb3ab2a94c26014f1699 Mon Sep 17 00:00:00 2001 From: Florian Pelz Date: Wed, 22 May 2019 19:53:58 +0200 Subject: [PATCH] gnu: Add USB_ModeSwitch. *

bug#35861: [wishlist] Improve packaging error handling and tooling

2019-05-22 Thread pelzflorian (Florian Pelz)
I believe for package definitions * known triggers for unhelpful error messages should get more graceful error messages, * there should be no fixed truncation of error messages and * there could perhaps be more tooling like single-stepping through the build process. For example in

bug#35864: ~/.local/bin is missing in default PATH on Guix System

2019-05-23 Thread pelzflorian (Florian Pelz)
~/.local/bin should be added to the PATH environment variable by default, see . Regards, Florian

bug#35864: ~/.local/bin is missing in default PATH on Guix System

2019-05-23 Thread pelzflorian (Florian Pelz)
On Thu, May 23, 2019 at 04:17:38PM +0200, Ricardo Wurmus wrote: > > pelzflorian (Florian Pelz) writes: > > > ~/.local/bin should be added to the PATH environment variable by > > default, see > > <https://unix.stackexchange.com/questions/316765/which-distributio

bug#35864: ~/.local/bin is missing in default PATH on Guix System

2019-05-23 Thread pelzflorian (Florian Pelz)
On Thu, May 23, 2019 at 04:55:28PM +0200, Tobias Geerinckx-Rice wrote: > > . > > That link doesn't support adding (or not adding) it. > The people who responded accept that it is a bug in Ubuntu.

bug#35864: ~/.local/bin is missing in default PATH on Guix System

2019-05-23 Thread pelzflorian (Florian Pelz)
On Thu, May 23, 2019 at 09:31:09PM +0200, Tobias Geerinckx-Rice wrote: > pelzflorian (Florian Pelz) wrote: > > Adding ~/.local/bin to the PATH is common on other distros. > > This is what still needs to be established: is it? Which ones? Is it merely > a side-effect of

bug#35856: Unable to boot on iMac, likely because of UUIDs

2019-05-23 Thread pelzflorian (Florian Pelz)
On Thu, May 23, 2019 at 03:12:44PM +0200, Francisco Gómez wrote: > Built an image after doing `guix pull`, it works! Thanks! > Thank you for reporting back. Please respond to 35...@debbugs.gnu.org as well next time. I will mention your observations on UUIDs on the grub-devel mailing list.

bug#35856: Unable to boot on iMac, likely because of UUIDs

2019-05-23 Thread pelzflorian (Florian Pelz)
On Thu, May 23, 2019 at 10:18:27PM +0200, pelzflorian (Florian Pelz) wrote: > I will mention your observations on UUIDs on the > grub-devel mailing list. > No, I will not report there. They know enough.

bug#35864: ~/.local/bin is missing in default PATH on Guix System

2019-05-23 Thread pelzflorian (Florian Pelz)
On Fri, May 24, 2019 at 12:36:14AM +0200, pelzflorian (Florian Pelz) wrote: > My motivation was that I would have liked a uniform standard to exist > for offering uniform, simple compilation instructions in tutorials > like mine > <https://pelzflorian.de/gui-prog-gtk-2017/handout-

bug#35864: ~/.local/bin is missing in default PATH on Guix System

2019-05-24 Thread pelzflorian (Florian Pelz)
On Fri, May 24, 2019 at 08:17:10AM +0200, Ricardo Wurmus wrote: > > pelzflorian (Florian Pelz) writes: > > > Currently for a simple GTK application of mine, on other distros I run > > it by > > > > dont-hang > > > > but on Guix I have to ru

  1   2   3   >