Re: kernel/6309: CPU Core i5 is not fully recognized

2010-04-25 Thread Jonathan Gray
On Sun, Apr 25, 2010 at 08:13:27PM +0200, Daniele Pilenga wrote: On Thu, Feb 4, 2010 at 11:25 PM, gn...@cvs.openbsd.org wrote: Thank you very much for your problem report. It has the internal identification `kernel/6309'. The individual assigned to look at your report is: bugs.

Re: kernel/6427: Intel em(4) Intel PRO/1000 QP (82576) fails: Unable to initialize

2010-07-11 Thread Jonathan Gray
The following reply was made to PR kernel/6427; it has been noted by GNATS. From: Jonathan Gray j...@goblin.cx To: Sebastian Benoit benoit-li...@fb12.de Cc: gn...@cvs.openbsd.org, b...@cvs.openbsd.org Subject: Re: kernel/6427: Intel em(4) Intel PRO/1000 QP (82576) fails: Unable to initialize

Re: kernel/6427: Intel em(4) Intel PRO/1000 QP (82576) fails: Unable to initialize

2010-07-14 Thread Jonathan Gray
On Tue, Jul 13, 2010 at 02:59:36PM -0500, Adam Kujawski wrote: Hello, I applied the patch from SAITOH Masanobu to 4.7-RELEASE successfully, and that resolved the problem with the hardware initialization failing. However, while the interfaces on the Intel PRO/1000 QP (82576) work fine for

Re: kernel/6433: Intel EF Server Adapter Dual Port aka Intel PRO/1000 FP (82576/fiber) always has hardware initialization failure.

2010-07-19 Thread Jonathan Gray
The following reply was made to PR kernel/6433; it has been noted by GNATS. From: Jonathan Gray j...@goblin.cx To: =?iso-8859-1?Q?Fr=E9d=E9ric?= URBAN frederic.ur...@ircad.u-strasbg.fr Cc: gn...@openbsd.org Subject: Re: kernel/6433: Intel EF Server Adapter Dual Port aka Intel PRO/1000 FP (82576

Re: kernel/6433: Intel EF Server Adapter Dual Port aka Intel PRO/1000 FP (82576/fiber) always has hardware initialization failure.

2010-07-27 Thread Jonathan Gray
On Mon, Jul 19, 2010 at 07:15:02AM -0600, Fridiric URBAN wrote: The following reply was made to PR kernel/6433; it has been noted by GNATS. From: =?ISO-8859-1?Q?Fr=E9d=E9ric_URBAN?= frederic.ur...@ircad.u-strasbg.fr To: Cc: gn...@openbsd.org Subject: Re: kernel/6433: Intel EF Server Adapter

Re: 4.8-current fails with uvm_fault in em(4)

2010-08-04 Thread Jonathan Gray
On Tue, Aug 03, 2010 at 11:12:01PM +0100, Stuart Henderson wrote: Do you know what the last working kernel was? I have an archive of old kernels if you want to track it down without the cvs up -D / compile dance, mail me offlist. broken: OpenBSD 4.7-current (GENERIC) #104: Thu Jul 8

Re: user/6509: relayctl show sessions make relayd crash

2010-11-18 Thread Jonathan Gray
The problem is we have multiple handlers and get IMSG_STATISTICS when in the secondary handler. Try the following diff from reyk: Index: relay.c === RCS file: /cvs/src/usr.sbin/relayd/relay.c,v retrieving revision 1.124 diff -u -p

Re: user/6509: relayctl show sessions make relayd crash

2010-11-18 Thread Jonathan Gray
The following reply was made to PR user/6509; it has been noted by GNATS. From: Jonathan Gray j...@goblin.cx To: janj+open...@wemf.org Cc: gn...@openbsd.org Subject: Re: user/6509: relayctl show sessions make relayd crash Date: Fri, 19 Nov 2010 04:28:45 +1100 The problem is we have multiple

Re: system/6516: relayctl reload : command failed

2010-11-26 Thread Jonathan Gray
On Thu, Nov 25, 2010 at 08:41:52PM +0200, Alexey Suslikov wrote: Xavier Beaudouin wrote: Description: using relayctl reload, fails miserably with command failed. kill relayd parent and starting it again work correctly. Code in usr.sbin/relayd/control.c says: case

Re: kernel panic (mii_phy_setmedia) on mac mini A1347 with trace and ps picture url

2011-12-19 Thread Jonathan Gray
Try this diff against -current. You'll have to apply the patch from sys/dev/mii and run 'make' afterwards to regenerate the headers. Index: miidevs === RCS file: /cvs/src/sys/dev/mii/miidevs,v retrieving revision 1.116 diff -u -p

Re: Intel PRO/1000 PF em() network card not working with MSI on Dell R610

2012-02-14 Thread Jonathan Gray
On Tue, Feb 14, 2012 at 10:52:49AM +0100, David Imhoff wrote: Synopsis:Intel PRO/1000 PF em() network card not working with MSI on Dell R610 Category:Kernel/i386 Environment: System : OpenBSD 5.1 Details : OpenBSD 5.1 (GENERIC.MP) #5: Mon Feb 13 12:12:18 CET

Re: Intel 82579LM auto negotiation fails at boot

2012-03-25 Thread Jonathan Gray
On Sun, Mar 25, 2012 at 10:21:58PM +0900, Yoshihisa Matsushita wrote: Synopsis:Intel 82579LM auto negotiation fails at boot Category:amd64 kernel system Environment: System : OpenBSD 5.1 Details : OpenBSD 5.1-current (GENERIC.MP) #227: Thu Mar 22 11:10:40 MDT

Re: Unknown vendor with WinTV PVR-150 l.p.

2012-03-27 Thread Jonathan Gray
On Tue, Mar 27, 2012 at 11:35:33PM +0200, e...@gmx.net wrote: Hello I have put a Hauppauge WinTV PVR-150 low profile PCI card into my computer. bktr(4) should work with WinTV cards, but it seem not to recognize the card. Maybe its just the ID which is unknown to the driver. Is it

more 82579LM/pch2 workarounds

2012-08-20 Thread Jonathan Gray
On Wed, Aug 15, 2012 at 02:13:18PM +0400, Yuriy Nikonov wrote: Synopsis: Incorrect working netcard on chip Intel 82579LM with network media/link Category: bugs tech Environment: System : OpenBSD 5.1 Details : OpenBSD 5.1 (SERVER) #5: Mon Aug 13 16:50:36 MSK 2012

Re: more 82579LM/pch2 workarounds

2012-11-27 Thread Jonathan Gray
On Tue, Nov 27, 2012 at 10:39:21AM +0400, Yuriy Nikonov wrote: Good day, saw on a site new release of OpenBSD 5.2. Wanted to take an interest about the problem described above - whether there were any changes in the em driver? Tried to load a kernel from FreeBSD 9.0 - 82579LM seems

Re: DVI output not detected with kms

2013-03-28 Thread Jonathan Gray
On Fri, Mar 29, 2013 at 12:33:32PM +1100, Jonathan Gray wrote: On Thu, Mar 28, 2013 at 09:38:20AM +0100, Ralf Horstmann wrote: Hi, with current snapshot (i386) the DVI output of the docking station of my Fujitsu Lifebook T4215 is not detected anymore. Under Linux (Debian kernel 3.2

Re: X server crash with intel kms

2013-03-29 Thread Jonathan Gray
On Fri, Mar 29, 2013 at 07:20:26PM +0100, Ralf Horstmann wrote: Hi, with latest snapshot kernel, the X server crashes pretty reliably for me when opening new thumbnail tabs in Firefox (version 18.0.1p0). Sometimes it crashes on first new tab, sometimes I need to open a few of them. Xorg log

Re: Driver for Kontron (Industrial Computer Source / ICS Advent) DM9601 Fast Ethernet Adapter

2013-04-23 Thread Jonathan Gray
Try the following diff, you'll have to run make in sys/dev/usb after applying. Index: usbdevs === RCS file: /cvs/src/sys/dev/usb/usbdevs,v retrieving revision 1.598 diff -u -p -r1.598 usbdevs --- usbdevs 7 Mar 2013 23:39:14 -

Re: Driver for Kontron (Industrial Computer Source / ICS Advent) DM9601 Fast Ethernet Adapter

2013-04-29 Thread Jonathan Gray
-CURRENT, and run fine on 'ue' pseudo-device. Any ideas? Sent from my iPhone On Apr 23, 2013, at 4:40 PM, Jonathan Gray j...@jsg.id.au wrote: Try the following diff, you'll have to run make in sys/dev/usb after applying. Index: usbdevs

Re: Use after free in ami(4)

2013-05-04 Thread Jonathan Gray
On Sat, May 04, 2013 at 07:04:59PM -0400, Kenneth R Westerback wrote: On Sat, May 04, 2013 at 08:25:18PM +0300, Arto Jonsson wrote: Spotted by LLVM static analyser. In /usr/src/sys/dev/ic/ami.c line 499 ami_freemem(sc, am) is called. In the next block ami_alloc_ccbs(...) is called. If

Re: can't direct audio output to speakers on azalia

2013-05-14 Thread Jonathan Gray
On Tue, May 14, 2013 at 02:37:36PM -0500, joshua stein wrote: On this Macbook Air, audio only works through the headphone jack, not through the speakers when the headphones are unplugged. $ mixerctl -a inputs.dac-0:1_mute=off inputs.dac-0:1=100,100 inputs.dac-2:3_mute=off

Re: Kernel panic on current amd64 running under Ubuntu KVM (patch included)

2013-05-20 Thread Jonathan Gray
That is quite a large hammer. It would be preferable to find out which msr it objects to and guard it with a specific cpuid check, and/or fix the hypervisor. On Mon, May 20, 2013 at 10:34:43AM +0300, Roman Kravchuk wrote: patch_amd64errata.diff Index: amd64/amd64/amd64errata.c

Re: Kernel panic on current amd64 running under Ubuntu KVM (patch included)

2013-05-20 Thread Jonathan Gray
On Mon, May 20, 2013 at 01:50:39PM +, Alexey E. Suslikov wrote: Jonathan Gray jsg at jsg.id.au writes: That is quite a large hammer. It would be preferable to find out which msr it objects to and guard it with a specific cpuid check, and/or fix the hypervisor. From NetBSD PR/47677

Re: Intel GM45 hangs

2013-07-15 Thread Jonathan Gray
On Mon, Jul 15, 2013 at 01:13:39PM +0300, ja...@cieti.lv wrote: Synopsis:Intel GM45 hangs Category:amd64 Environment: System : OpenBSD 5.4 Details : OpenBSD 5.4-beta (GENERIC.MP) #28: Sat Jul 13 12:41:36 MDT 2013

Re: Intel GM45 hangs

2013-07-15 Thread Jonathan Gray
On Mon, Jul 15, 2013 at 06:07:09PM +0300, ja...@cieti.lv wrote: On 15.07.2013 16:07, Jonathan Gray wrote: Can you try run a kernel with the following diff? It disables powersaving and framebuffer compression and would help narrow things down. Index: i915_drv.c

Re: Intel GM45 hangs

2013-07-15 Thread Jonathan Gray
On Mon, Jul 15, 2013 at 09:32:36PM +0300, ja...@cieti.lv wrote: Is it possible that it is related to these problems? https://code.google.com/p/chromium/issues/detail?id=252389 https://code.google.com/p/chromium/issues/detail?id=252446 unlikely as we don't provide libva and youtube with

Re: Intel GM45 hangs

2013-07-15 Thread Jonathan Gray
On Mon, Jul 15, 2013 at 08:41:47PM +0300, ja...@cieti.lv wrote: I just applied this diff and quickly got another hang. I would like to mention (maybe it helps to diagnose this) that I get visual glitches in Youtube player area and sometimes in a whole tab where youtube.com is open. After GPU

Re: Intel GM45 hangs

2013-07-16 Thread Jonathan Gray
On Tue, Jul 16, 2013 at 08:57:37AM +0300, ja...@cieti.lv wrote: On 16.07.2013 07:27, Jonathan Gray wrote: There are a few things that may be relevant in terms of fixes in newer versions of xf86-video-intel. ftp://ftp.x.org/pub/individual/driver/xf86-video-intel-2.21.11.tar.gz (after

Re: Intel GM45 hangs

2013-07-21 Thread Jonathan Gray
On Sun, Jul 21, 2013 at 12:34:57PM +0300, ja...@cieti.lv wrote: Looks like Mesa-9.1.4 does not fix this. It turns out that chromium just used software rendering because WebGL does not work at all. Running openarena hangs GPU instantly on loading with an error: intel_do_flush_locked failed:

Re: Intel GM45 hangs

2013-07-22 Thread Jonathan Gray
On Mon, Jul 22, 2013 at 10:08:27AM +0300, ja...@cieti.lv wrote: Well trying to go backwards is always a bit of a risk. To be sure things are as intended you're best off starting with a 5.3 install and updating src/xenocara to a point before the commit with an eye on current.html I took an

Re: Intel GM45 hangs

2013-07-22 Thread Jonathan Gray
On Mon, Jul 22, 2013 at 12:04:44PM +0300, ja...@cieti.lv wrote: There is something wrong with your cvs checkout, it should look be 1.9 not 1.7 and look like: http://www.openbsd.org/cgi-bin/cvsweb/src/kerberosV/src/lib/asn1/Attic/libasn1.h?rev=1 \ .1.1.2;content-type=text%2Fplain What

Re: shuttle DS47 - RTL8168 no link / lladdr

2013-10-11 Thread Jonathan Gray
On Fri, Oct 11, 2013 at 12:23:50AM +0200, m...@m021.nl wrote: Synopsis:Realtek 8168 ethernet not working Category:bugs Environment: System : OpenBSD 5.3 Details : OpenBSD 5.3 (GENERIC.MP) #62: Tue Mar 12 18:21:20 MDT 2013

Re: Intel Chipset Error? OpenBSD 5.4

2013-11-03 Thread Jonathan Gray
On Sat, Nov 02, 2013 at 10:20:54PM +0100, Lakosimi wrote: error: [drm:pid21332:i915_get_vblank_timestamp] *ERROR* Invalid crtc 1 error: [drm:pid1035:i915_get_vblank_timestamp] *ERROR* Invalid crtc 1 error: [drm:pid3:i915_get_vblank_timestamp] *ERROR* Invalid crtc 1 error:

Re: patches to add support for I/O DATA ETX-US2 usb ethernet adapter and fix wrong products name.

2013-11-17 Thread Jonathan Gray
/11/17 Jonathan Gray j...@jsg.id.au What is the product number of this device? NetBSD usbdevs has 0x092a, Linux has 0x093a and it isn't included in your patches. On Sun, Nov 17, 2013 at 07:21:03AM +0900, is...@oak.dti.ne.jp wrote: Synopsis:patches to add support for I/O DATA ETX-US2

Re: Issues on Acer Aspire E1 572G

2013-12-22 Thread Jonathan Gray
On Sun, Dec 22, 2013 at 04:13:54PM +0100, mark rowland wrote: I'm having some issues running OpenBSD on my notebook Acer Aspire E1 572G. 1) During the installation of 5.4 weird things happened with the keyboard: typing with the keyboard was slow, sometimes typed characters were repeated, the

Re: Issues on Acer Aspire E1 572G

2013-12-29 Thread Jonathan Gray
On Sun, Dec 29, 2013 at 10:24:27PM +0100, mark rowland wrote: I did a fresh install of the latest snapshot, audio is still buggy. try this: Index: azalia.c === RCS file: /cvs/src/sys/dev/pci/azalia.c,v retrieving revision 1.208

Re: Issues on Acer Aspire E1 572G

2014-01-02 Thread Jonathan Gray
On Thu, Jan 02, 2014 at 09:01:21AM +0100, Alexandre Ratchov wrote: On Sun, Dec 29, 2013 at 10:24:27PM +0100, mark rowland wrote: I did a fresh install of the latest snapshot, audio is still buggy. I'm attaching a dmesg of the default kernel, a dmesg of a kernel I built after adding the

Re: Regression: X11 doesn't detect HDMI output since latest snapshot

2014-02-10 Thread Jonathan Gray
On Mon, Feb 10, 2014 at 01:06:43PM +0100, Norman Golisz wrote: I just upgraded to the latest snapshot from Feb, 7. and I'm experiencing a regression, where X11 doesn't detect the HDMI output when available. I've a dual-head configuration, where one VGA and one DVI monitor is connected to a

Re: Regression: X11 doesn't detect HDMI output since latest snapshot

2014-02-11 Thread Jonathan Gray
On Mon, Feb 10, 2014 at 05:48:50PM +0100, Norman Golisz wrote: [1] xrandr --output LVDS1 --off xrandr --output HDMI2 --right-of VGA1 --auto --output VGA1 --primary --auto So, it seems the modes for VGA1 and HDMI2 are swapped with each call of xrandr. Does the behaviour change

Re: Intel HD Graphics 4000, only one monitor detected

2014-05-20 Thread Jonathan Gray
On Tue, May 20, 2014 at 10:05:07AM +0200, mar...@familjenbergkvist.net wrote: Synopsis:Intel HD Graphics 4000, only one monitor detected Category: Environment: System : OpenBSD 5.5 Details : OpenBSD 5.5-current (GENERIC.MP) #136: Mon May 19 09:40:42 MDT 2014

Re: Intel HD Graphics 4000, only one monitor detected

2014-05-21 Thread Jonathan Gray
On Tue, May 20, 2014 at 08:56:27PM +1000, Jonathan Gray wrote: On Tue, May 20, 2014 at 10:05:07AM +0200, mar...@familjenbergkvist.net wrote: Synopsis: Intel HD Graphics 4000, only one monitor detected Category: Environment: System : OpenBSD 5.5 Details : OpenBSD 5.5

Re: inteldrm doesn't allow 5.7 Gbps modes on DisplayPort

2014-06-16 Thread Jonathan Gray
On Mon, Jun 16, 2014 at 02:41:15AM -0600, Steven Wilson wrote: Synopsis:inteldrm doesn't allow 5.7 Gbps modes on DisplayPort Category:kernel Environment: System : OpenBSD 5.5 Details : OpenBSD 5.5-current (GENERIC) #1: Mon Jun 16 07:29:22 MDT 2014

Re: inteldrm doesn't allow 5.7 Gbps modes on DisplayPort

2014-06-19 Thread Jonathan Gray
On Tue, Jun 17, 2014 at 12:26:57AM -0600, Steven Wilson wrote: Thanks for the report and the analysis. I'd prefer to use the linux commits around this if at all possible. I tried for that, but got lost in some of the bigger changes on the Linux side and ended up thinking that the relevant

Re: Compiling the kernel fails without com ports enabled on amd64 openbsd 5.5

2014-08-09 Thread Jonathan Gray
On Sat, Aug 09, 2014 at 03:37:03PM +0200, �yvind Vågen JÊgtnes wrote: The FAQ says not to report build errors, however this is not a development snapshot but the openbsd 5.5 release source with erratas applied. If this is fixed in a development snapshot then I am sorry for the

Re: couldn't find agp

2014-09-05 Thread Jonathan Gray
On Fri, Sep 05, 2014 at 12:06:54PM +0300, KÄ?rlis MiÄ·elsons wrote: Hello! After installing OpenBSD 5.5 or latest snapshot on this Dell system it crashes while booting OpenBSD with following message: cpu0: Enhanced SpeedStep 2926 MHz: speeds: 2933, 2128, 1596 MHz pci0 at mainbus0 bus 0

Re: man doesn't display malloc.conf(5)

2014-09-30 Thread Jonathan Gray
malloc(3) and malloc.conf(5) are the same page http://cvsweb.openbsd.org/cgi-bin/cvsweb/~checkout~/src/lib/libc/stdlib/Makefile.inc?rev=HEADcontent-type=text/plain MLINKS+=malloc.3 free.3 malloc.3 realloc.3 malloc.3 calloc.3 MLINKS+=malloc.3 reallocarray.3 malloc.3 cfree.3 malloc.3 malloc.conf.5

Re: Suspend/Resume broken, doesn't re-attach video.

2014-12-04 Thread Jonathan Gray
On Thu, Dec 04, 2014 at 08:47:34PM -0600, Sean Cody wrote: Synopsis:Suspend/Resume broken, doesn't re-attached video. Category:amd64 Environment: System : OpenBSD 5.6 Details : OpenBSD 5.6-current (GENERIC.MP) #648: Thu Dec 4 14:23:47 MST 2014

Re: system hangs after drm:i915_hangcheck_hung error

2015-03-09 Thread Jonathan Gray
On Mon, Mar 09, 2015 at 08:06:57AM -0400, dan mclaughlin wrote: Synopsis:system hangs after drm:i915_hangcheck_hung error Category:video driver Environment: System : OpenBSD 5.7 Details : OpenBSD 5.7 (GENERIC) #738: Sun Mar 8 10:59:31 MDT 2015

Re: radeon drm regression (was Re: D-Link DGE-528T / re(4) regression)

2015-04-08 Thread Jonathan Gray
On Wed, Apr 08, 2015 at 07:14:57PM +0200, Daniel Jakots wrote: On Wed, 8 Apr 2015 20:03:00 +1000, j...@insec.sh wrote: but could you try it with the following patch applied? Sure, I updated my cvs src tree, patched it and made a new kernel. I booted on the new kernel then, but when

Re: Asus X102BA does not resume from suspend

2015-06-17 Thread Jonathan Gray
On Thu, Jun 18, 2015 at 02:51:53AM +0200, Tilo Stritzky wrote: On 17/06/15 21:02 Jonathan Gray wrote: On Wed, Jun 17, 2015 at 12:46:33PM +0200, Tilo Stritzky wrote: Synopsis:Asus X102BA does not resume from suspend Category:PR category (one line) Environment

Re: Asus X102BA does not resume from suspend

2015-06-17 Thread Jonathan Gray
On Wed, Jun 17, 2015 at 12:46:33PM +0200, Tilo Stritzky wrote: Synopsis:Asus X102BA does not resume from suspend Category:PR category (one line) Environment: System : OpenBSD 5.7 Details : OpenBSD 5.7-current (GENERIC.MP) #945: Mon Jun 15 01:02:25 MDT 2015

Re: no working network on latest nuc

2015-08-22 Thread Jonathan Gray
On Sat, Aug 22, 2015 at 07:21:28PM -0400, Ted Unangst wrote: The latest intel nuc (braswell model) has wired and wireless network, but neither appear supported. The ethernet shows up as: re0 at pci3 dev 0 function 0 Realtek 8168 rev 0x15: unknown ASIC (0x5400), msi, address

Re: panic: no appropriate pool

2015-08-01 Thread Jonathan Gray
On Sat, Aug 01, 2015 at 08:46:00PM +0200, Mike Belopuhov wrote: On 1 August 2015 at 19:20, RD Thrush openbsd-t...@thrush.com wrote: The patch ran without panic for 20+ hours. Thanks for testing! I wondered about the removal of the panic() statement so I tried another kernel that

Re: panic: no appropriate pool

2015-08-02 Thread Jonathan Gray
On Mon, Aug 03, 2015 at 12:55:46AM +0200, Mike Belopuhov wrote: On 2 August 2015 at 22:00, RD Thrush openbsd-t...@thrush.com wrote: On 08/02/15 13:37, Mike Belopuhov wrote: most likely it's triggered by the reply-to statement. you may try the attached diff to see which rule the state

Re: z800 hp workstation OpenBSD 5.7 install attempt, hitting a wall

2015-08-09 Thread Jonathan Gray
On Sun, Aug 09, 2015 at 08:44:47PM -0700, Danny Nguyen wrote: Hi, I purchased a hewlett packard z800 workstation running windows 7 with the intention of running linux ubuntu as a sever but I've found OpenBSD to sound and contain more robust features (versus linux, FreeBSD, and NetBSD) when

Re: z800 hp workstation OpenBSD 5.7 install attempt, hitting a wall

2015-08-10 Thread Jonathan Gray
It is worth trying a snapshot instead of 5.7. You should be able to mount a usb disk from an installer shell which would let you save the output of dmesg or just do an install to a usb disk. I would guess the IDE SATA Emulation would mean pciide(4). On Mon, Aug 10, 2015 at 12:53:14AM -0700,

Re: X with Broadwell GPU still not working

2015-11-01 Thread Jonathan Gray
On Sun, Nov 01, 2015 at 10:51:45AM +0100, Thomas Weinbrenner wrote: > Thank you Jonathan. > > I just upgraded to #1556. > > X starts as fast as it should be. Acceleration doesn't work (fonts are > not displayed, firefox doesn't display anything), but if I disable > acceleration via xorg.conf

Re: X with Broadwell GPU still not working

2015-10-08 Thread Jonathan Gray
On Thu, Oct 08, 2015 at 08:50:29PM +0200, m...@tweinbrenner.net wrote: > >Synopsis:X with Broadwell GPU still not working > >Category:kernel > >Environment: > System : OpenBSD 5.8 > Details : OpenBSD 5.8-current (GENERIC.MP) #1440: Thu Oct 8 > 07:52:55 MDT 2015 >

Re: httpd crashes when fetching a hidden file located on a CD

2015-12-07 Thread Jonathan Gray
On Tue, Dec 08, 2015 at 12:31:09AM +, Stuart Henderson wrote: > On 2015/12/07 15:44, Theo de Raadt wrote: > > This bug report totally sucks. > > > > Have you ever heard of ktrace, and if you have, why did you not try > > to reproduce it? > > > > You want us to reproduce it? Why? > > > > >

Re: pkg_sign incorrectly assumes -i by default

2016-06-06 Thread Jonathan Gray
On Mon, Jun 06, 2016 at 09:12:04AM +0200, Marc Espie wrote: > > This should fix things. Thanks, things work as expected here with this diff. > > > Index: AddCreateDelete.pm > === > RCS file:

pkg_sign incorrectly assumes -i by default

2016-06-06 Thread Jonathan Gray
The behaviour of pkg_sign acts as if -i is always specified and won't sign/resign a package if it exists in the output directory. In OpenBSD/PkgSign.pm sign_existing_package $state->opt('i') path is always taken. Does this come from some shared code setting a default interactive level for

Re: Screen brightness is reset when changing from X to console

2016-05-30 Thread Jonathan Gray
On Mon, May 30, 2016 at 02:41:59PM +0200, Walter Alejandro Iglesias wrote: > Stefan Sperling wrote: > > > On Sun, May 29, 2016 at 09:19:58PM +0200, Mark Kettenis wrote: > > > And I can't reproduce this on my x220. So either this issue depends on > > > specific BIOS revisions, or

Re: Screen brightness is reset when changing from X to console

2016-06-01 Thread Jonathan Gray
On Mon, May 30, 2016 at 05:02:07PM +0200, Walter Alejandro Iglesias wrote: > Jonathan Gray <j...@jsg.id.au> wrote: > > > On Mon, May 30, 2016 at 02:41:59PM +0200, Walter Alejandro Iglesias wrote: > > > Stefan Sperling <s...@stsp.name> wrote: > > > > &

Re: Realtek RTL8111H is not correctly handled

2016-01-19 Thread Jonathan Gray
Support for RTL8168H/RTL8111H was added after 5.8. It should work with snapshots and >= 5.9 On Wed, Jan 20, 2016 at 03:02:32AM +0900, hirosh...@borndigital.co.jp wrote: > >Synopsis:Realtek RTL8111H is not correctly handled. > >Category:Kernel > >Environment: > System : OpenBSD

Re: armv7: pmap_fault_fixup: va 00008000 ftype 5 u pte 7ff2a02e

2016-06-24 Thread Jonathan Gray
On Sat, Jun 25, 2016 at 12:34:39AM +0200, Juan Francisco Cantero Hurtado wrote: > I'm trying to install OpenBSD on a Olimex LIME2 board. I didn't know > exactly how to install the system on this board, so I used the > cubieboard image, overwrote the u-boot image with > u-boot-sunxi-with-spl.bin

Re: softraid panics

2016-02-13 Thread Jonathan Gray
On Sat, Feb 13, 2016 at 11:37:17AM +0100, Stefan Sperling wrote: > On Sat, Feb 13, 2016 at 03:42:16PM +1100, Jonathan Gray wrote: > > On Fri, Feb 12, 2016 at 11:07:35AM -0500, Johan Huldtgren wrote: > > > uvm_fault(0x8193f240, 0x38, 0, 1) -> e > > > k

Re: UEFI Boot Report: Screen corruption and kernel panic

2016-02-02 Thread Jonathan Gray
On Tue, Feb 02, 2016 at 10:27:24PM +1100, Jonathan Gray wrote: > On Tue, Feb 02, 2016 at 05:49:33AM -0500, James Hastings wrote: > > On 2/2/16, Jonathan Gray <j...@jsg.id.au> wrote: > > > On Tue, Feb 02, 2016 at 03:56:13AM -0500, James Hastings wrote: > >

Re: UEFI Boot Report: Screen corruption and kernel panic

2016-02-01 Thread Jonathan Gray
On Tue, Feb 02, 2016 at 02:09:08AM -0500, James Hastings wrote: > Testing UEFI booting. Willing to test patches and debug. > > 1) Encountered screen corruption immediately after EFIBOOT. > http://imgur.com/mXURlgV > > 2) Kernel panic unless radeondrm(4) disabled. > Provided dmesg,

Re: UEFI Boot Report: Screen corruption and kernel panic

2016-02-02 Thread Jonathan Gray
On Tue, Feb 02, 2016 at 03:56:13AM -0500, James Hastings wrote: > On 2/2/16, Jonathan Gray <j...@jsg.id.au> wrote: > > > > The bios may have to be fetched from the acpi VFCT table for the uefi case. > > > > Here's a quick attempt at trying to avoid the crash a

Re: UEFI Boot Report: Screen corruption and kernel panic

2016-02-02 Thread Jonathan Gray
On Tue, Feb 02, 2016 at 05:49:33AM -0500, James Hastings wrote: > On 2/2/16, Jonathan Gray <j...@jsg.id.au> wrote: > > On Tue, Feb 02, 2016 at 03:56:13AM -0500, James Hastings wrote: > >> On 2/2/16, Jonathan Gray <j...@jsg.id.au> wrote: > >> > > >&

Re: std::ifstream is broken on arm

2016-02-17 Thread Jonathan Gray
On Tue, Feb 16, 2016 at 08:08:13PM +, Miod Vallat wrote: > Actually, I had forgotten to disable the stack protector, and guess > what? Disabling it produces a working libstdc++, at least for that > simple use case; I have not tried to build cmake. > > Therefore I suggest the following diff

Re: wsconsctl floating point exception

2016-04-29 Thread Jonathan Gray
On Fri, Apr 29, 2016 at 03:52:37PM +0200, Mark Kettenis wrote: > > Date: Fri, 29 Apr 2016 23:12:57 +1000 > > From: Jonathan Gray <j...@jsg.id.au> > > > > On Sat, Apr 23, 2016 at 10:20:15PM +0200, Joerg Jung wrote: > > > On Tue, Apr 19, 2016 at 10:57:38AM +02

Re: efiboot can't find OpenBSD GPT partition on Lenovo Ideapad 100s

2016-04-23 Thread Jonathan Gray
The 100s is 32 bit uefi only. It requires BOOTIA32.EFI. The problems linux has are related to them communicating with the uefi runtime after the kernel has booted. Could it be this problem is related to sys/arch/amd64/stand/efi/include/i386/efibind.h using sys/stdint.h which looks like it will

Re: Sending gratutious ARP to a bridge interface

2016-05-12 Thread Jonathan Gray
On Wed, May 11, 2016 at 10:20:29PM -0400, michel.bell...@malaiwah.com wrote: > >Synopsis:attempt to execute 0x0, arping to bridge > >Category:system > >Environment: > System : OpenBSD 5.9 > Details : OpenBSD 5.9 (GENERIC.MP) #1888: Fri Feb 26 01:20:19 MST > 2016 >

Re: ddb on armv7 beaglebone black

2016-07-22 Thread Jonathan Gray
On Fri, Jul 22, 2016 at 05:30:13PM +0300, Lars Noodn wrote: > I'm getting errors with clean installs of the latest armv7 snapshot > (Build date: 1469162775 - Fri Jul 22 04:46:15 UTC 2016) on a > beaglebone black. It ends up at a ddb prompt quite late in the boot > process. I've tried

Re: mesa is broken on macppc (__sync_add_and_fetch_8)

2017-01-20 Thread Jonathan Gray
On Fri, Jan 20, 2017 at 10:04:43PM +0100, Stefan Sperling wrote: > Mesa doesn't run anymore on my 15" powerbook g4 which has a radeon R300. > > glxinfo fails like this: > > glxinfo:/usr/X11R6/lib/modules/dri/r300_dri.so: undefined symbol > '__sync_add_and_fetch_8' > libGL error: unable to load

Re: mesa is broken on macppc (__sync_add_and_fetch_8)

2017-01-20 Thread Jonathan Gray
On Sat, Jan 21, 2017 at 10:02:18AM +1100, Jonathan Gray wrote: > On Fri, Jan 20, 2017 at 10:04:43PM +0100, Stefan Sperling wrote: > > Mesa doesn't run anymore on my 15" powerbook g4 which has a radeon R300. > > > > glxinfo fails like this: > > > > glxinfo:

Re: bgpctl large community parsing issues

2017-02-14 Thread Jonathan Gray
On Tue, Feb 14, 2017 at 01:04:40PM +0100, Sebastian Benoit wrote: > Jonathan Gray(j...@jsg.id.au) on 2017.02.14 20:23:51 +1100: > > On Tue, Feb 14, 2017 at 10:00:17AM +0100, Peter Hessler wrote: > > > On 2017 Feb 14 (Tue) at 15:39:45 +1100 (+1100), Jonathan Gray wrote: > &

Re: Wandboard can't cold-boot after August 23rd snapshot

2016-09-13 Thread Jonathan Gray
ator 0 > sd0 at scsibus1 targ 1 lun 0: SCSI2 0/direct fixed > sd0: 61056MB, 512 bytes/sector, 125042688 sectors > vscsi0 at root > scsibus2 at vscsi0: 256 targets > softraid0 at root > scsibus3 at softraid0: 256 targets > boot device: sd0 > root on sd0a (3c6fd48d06a0.a)

Re: Wandboard can't cold-boot after August 23rd snapshot

2016-09-12 Thread Jonathan Gray
As the 23rd is when sys/dev/ofw/fdt.c 1.19 revision 1.19 date: 2016/08/23 18:12:09; author: kettenis; state: Exp; lines: +4 -1; commitid: QVPcH04Hp9qQOAgf; Actually make fdt_find_node() return NULL if the node couldn't be found. ok tom@

Re: External monitors connected to docking station not detected properly on Intel HD Graphics 5500

2016-09-26 Thread Jonathan Gray
It very much sounds like you have a docking station that requires support for displayport MST (Multi Stream Transport). That was first available in Linux 3.17 where as the inteldrm code in the tree is currently based on Linux 3.14. On Sun, Sep 25, 2016 at 11:01:20PM +0200, S??awomir Gonet wrote:

Re: armv7 panic

2016-10-17 Thread Jonathan Gray
On Sun, Oct 16, 2016 at 07:02:55PM +1100, Jonathan Gray wrote: > On Sun, Oct 16, 2016 at 12:45:36AM -0700, Philip Guenther wrote: > > On Sun, 16 Oct 2016, Matthieu Herrb wrote: > > > my Sabre Lite board paniced during the night for the 1st time in several > > > month

Re: armv7 panic

2016-10-16 Thread Jonathan Gray
On Sun, Oct 16, 2016 at 12:45:36AM -0700, Philip Guenther wrote: > On Sun, 16 Oct 2016, Matthieu Herrb wrote: > > my Sabre Lite board paniced during the night for the 1st time in several > > month. Here is the information I collected: > > > > kernel diagnostic assertion "p->p_wchan == NULL"

Re: miniroot-panda-61.fs doesn't boot since March 8

2017-03-25 Thread Jonathan Gray
On Sat, Mar 25, 2017 at 06:29:32PM +, Florian Obser wrote: > > ... it just sits here forever. > > Using hostserver's archive I bisected miniroots and found that > this one works: > > https://ftp.hostserver.de/archive/2017-03-07-0105/snapshots/armv7/miniroot-panda-61.fs > OpenBSD

Re: Problem in installing: cannot recognize disk

2017-04-13 Thread Jonathan Gray
On Thu, Apr 13, 2017 at 08:18:00AM -0600, Todd C. Miller wrote: > The problem is that the sdmmc driver is not present in the RAMDISK > kernel, ony in GENERIC. We have sdmmc in RAMDISK for arm and octeon. > It should probably be added to amd64 (and i386?) RAMDISK as well. > > Without the device

Re: Problem in installing: cannot recognize disk

2017-04-13 Thread Jonathan Gray
2:36:46PM +, Robert Peichaer wrote: > This needs tweaking in the installer script. Right now, without looking, I'd > say only sd and wd devices are recognised. > > > > Am 13. April 2017 16:29:48 MESZ schrieb Jonathan Gray <j...@jsg.id.au>: > >On Thu, Apr 13, 2

Re: armv7/sunxi/sxie

2017-07-24 Thread Jonathan Gray
On Tue, Jul 25, 2017 at 05:29:06AM +0300, Artturi Alm wrote: > On Mon, Jul 24, 2017 at 10:51:12PM +0200, Mark Kettenis wrote: > > > Date: Mon, 24 Jul 2017 23:07:00 +0300 > > > From: Artturi Alm > > > > > > On Sun, Jul 23, 2017 at 07:45:53PM +0200, Mark Kettenis wrote: > >

Re: ikectl can't revoke certs

2017-07-05 Thread Jonathan Gray
On Wed, Jul 05, 2017 at 04:55:34PM -0700, jmo...@nodomain.net wrote: > >Synopsis:ikectl can't revoke certs > >Category:system > >Environment: > System : OpenBSD 6.1 > Details : OpenBSD 6.1 (GENERIC.MP) #291: Sat Apr 1 13:53:41 MDT > 2017 > >

Re: [RPI3] Latest minirootfs

2017-07-31 Thread Jonathan Gray
On Mon, Jul 31, 2017 at 11:15:52PM +, R0me0 *** wrote: > I wrote minirootfs as usual directly to usb flash drive > > minirootfs61.fs31-Jul-2017 03:11 22020096 > > > > U-Boot> boot > Card did not respond to voltage select! > mmc_init: -95, time 24 > > USB device 0: >Device 0:

Re: [RPI3] Latest minirootfs

2017-08-02 Thread Jonathan Gray
On Tue, Aug 01, 2017 at 06:40:26AM -0300, R0me0 *** wrote: > Hello, Jonathan! > > Copying the provided u-boot.bin worked :) > > Yes, the issue just affects USB DRIVE. > > Never touched config.txt. > > The procedures were: dd if=minirootfs61.fs of=(USB drive or sd-card ) > bs=1M > > If I use

Re: httpd crashes with SIGSEGV when using "block return 401"

2017-05-14 Thread Jonathan Gray
On Sun, May 14, 2017 at 10:05:37AM +0200, Jurjen Oskam wrote: > Hi, > > httpd crashes with a segmentation violation when servicing requests with > the following (minimal) config file: > > server "default" { > listen on * port 80 > block return 401 > } > > It starts up OK, but on

Re: ARM64 Panic

2017-06-26 Thread Jonathan Gray
On Tue, Jun 27, 2017 at 12:04:26AM +0100, Stuart Henderson wrote: > On 2017/06/26 09:30, R0me0 *** wrote: > > Hello guys, > > After Installed a snapshot from one week ago. > > A problem with the dwctwo(4) driver which could result in this > was fixed on 2017/06/20. I'm unsure whether this made it

httpd violates pledge with passworded private key

2017-06-06 Thread Jonathan Gray
when using a server.key with a passphrase, ie openssl genrsa -aes256 -out /etc/ssl/private/server.key 2048 server "default" { listen on * port 80 listen on * tls port 443 directory { auto index } } types { include "/usr/share/misc/mime.types" text/plain

Re: no CPU frequency scaling on Purism Librem 13v2

2017-09-16 Thread Jonathan Gray
On Sat, Sep 16, 2017 at 10:03:58AM +0200, matth...@herrb.eu wrote: > >Synopsis:no CPU frequency scaling on Purism Librem 13v2 > >Category:kern/amd64 > >Environment: > System : OpenBSD 6.2 > Details : OpenBSD 6.2-beta (GENERIC.MP) #0: Fri Sep 15 23:36:30 > CEST 2017 >

Re: no CPU frequency scaling on Purism Librem 13v2

2017-09-16 Thread Jonathan Gray
On Sat, Sep 16, 2017 at 02:07:47PM +0200, Matthieu Herrb wrote: > On Sat, Sep 16, 2017 at 06:57:38PM +1000, Jonathan Gray wrote: > > On Sat, Sep 16, 2017 at 10:03:58AM +0200, matth...@herrb.eu wrote: > > > >Synopsis:no CPU frequency scaling on Purism Librem

Re: config(8) elf handling

2017-09-13 Thread Jonathan Gray
On Wed, Sep 13, 2017 at 10:23:46AM -0600, Theo de Raadt wrote: > > On Wed, 13 Sep 2017, Miod Vallat wrote: > > > > > > > Forcing uextraloc into .data via > > > > int uextraloc __attribute__ ((section(".data"))) = 0; > > > > avoids the crashes. > > > > > > Regardless of this bug, the in-tree gcc

Re: config(8) elf handling

2017-09-13 Thread Jonathan Gray
On Wed, Sep 13, 2017 at 08:34:56PM -0600, Theo de Raadt wrote: > > If the attribute to force it into .data isn't wanted the alternative > > gets messy as config has a bunch of bogus types and casts and treats the > > int values as longs. > > Well, I believe that messiness is a result of trying to

config(8) elf handling

2017-09-12 Thread Jonathan Gray
config(8) creates ioconf.c containing #ifndef MAXEXTRALOC #define MAXEXTRALOC 32 #endif long extraloc[MAXEXTRALOC] = { -1 }; int nextraloc = MAXEXTRALOC; int uextraloc = 0; When uextraloc gets stored in .bss where filesz < memsz the simplistic way config(8) reads an entire elf file into memory

Re: config(8) elf handling

2017-09-13 Thread Jonathan Gray
On Wed, Sep 13, 2017 at 08:44:24AM +, Miod Vallat wrote: > > > Forcing uextraloc into .data via > > int uextraloc __attribute__ ((section(".data"))) = 0; > > avoids the crashes. > > Regardless of this bug, the in-tree gcc was modified to default to put > explicitly zero initialized data in

Re: [rpi3] OpenBSD-6.2-beta does not boot after installer finish

2017-08-22 Thread Jonathan Gray
On Tue, Aug 22, 2017 at 12:27:55PM +1000, Jonathan Gray wrote: > On Mon, Aug 21, 2017 at 06:28:16PM -0300, R0me0 *** wrote: > > Hello, > > > > Wrote miniroot62.fs to usb stick as usual, boots and installs > > > > ( tried with miniroot from ftp.

  1   2   3   4   >