Re: RFR: 8266459: Implement JEP 411: Deprecate the Security Manager for Removal

2021-05-18 Thread Naoto Sato
On Mon, 17 May 2021 18:23:41 GMT, Weijun Wang wrote: > Please review this implementation of [JEP > 411](https://openjdk.java.net/jeps/411). > > The code change is divided into 3 commits. Please review them one by one. > > 1. >

RFR: 8263202: Update Hebrew/Indonesian/Yiddish ISO 639 language codes to current

2021-05-17 Thread Naoto Sato
Please review the changes to the subject issue. java.util.Locale class has a long-standing issue for those obsolete ISO 639 languages where its normalization ends up in the obsolete codes. This change intends to flip the normalization towards the current codes, providing a system property for

RFR: 8258795: Update IANA Language Subtag Registry to Version 2021-05-11

2021-05-12 Thread Naoto Sato
Please review the changes to the subject issue. This is to incorporate the latest language subtag registry definition into the JDK. - Commit messages: - Renaming the test case - LSR 2021-05-11 - LSR 2021-03-05 - LSR 2021-02-23 - LSR 2020-12-18 Changes:

Re: RFR: JDK-8266254: Update to use jtreg 6

2021-06-02 Thread Naoto Sato
On Wed, 2 Jun 2021 16:13:48 GMT, Jonathan Gibbons wrote: > Please review the change to update to using jtreg 6. > > The primary change is to the jib-profiles.js file, which specifies the > version of jtreg to use, for those systems that rely on this file. In > addition, the `requiredVersion`

Re: RFR: JDK-8266254: Update to use jtreg 6 [v2]

2021-06-02 Thread Naoto Sato
On Wed, 2 Jun 2021 20:15:55 GMT, Jonathan Gibbons wrote: >> Please review the change to update to using jtreg 6. >> >> The primary change is to the jib-profiles.js file, which specifies the >> version of jtreg to use, for those systems that rely on this file. In >> addition, the

Re: RFR: 8264678: Incomplete comment in build.tools.generatecharacter.GenerateCharacter

2021-04-28 Thread Naoto Sato
On Wed, 28 Apr 2021 15:44:47 GMT, Claes Redestad wrote: > I'm not exactly sure what I intended to say in this partial comment. Removing > it. Marked as reviewed by naoto (Reviewer). - PR: https://git.openjdk.java.net/jdk/pull/3766

Re: RFR: 8263677: Improve Character.isLowerCase/isUpperCase lookups [v2]

2021-03-16 Thread Naoto Sato
On Tue, 16 Mar 2021 21:02:28 GMT, Claes Redestad wrote: >> This patch changes the otherLowercase / otherUppercase bits to be set if >> either the codepoint is of type LOWERCASE_LETTER and UPPERCASE_LETTER, or >> the Unicode Other_Lowercase / Other_Uppercase property is set. This >> simplifies

Re: RFR: 8264779: Fix doclint warnings in java/nio [v2]

2021-04-07 Thread Naoto Sato
On Wed, 7 Apr 2021 14:40:48 GMT, Conor Cleary wrote: >> This fix addresses the following warnings which were generated by building >> JDK API documentation with the `-Xdoclint:all` option enabled: >> >>

Re: RFR: 8264779: Fix doclint warnings in java/nio [v2]

2021-04-07 Thread Naoto Sato
On Wed, 7 Apr 2021 18:04:48 GMT, Alan Bateman wrote: >> It could, maybe something like "The length of the input byte (or character) >> sequence." would work? > > or just "The length of the input" so that it is consistent with the > description of the getInputLength method. That sounds good.

Re: RFR: 8264779: Fix doclint warnings in java/nio [v2]

2021-04-07 Thread Naoto Sato
On Wed, 7 Apr 2021 17:58:58 GMT, Conor Cleary wrote: >> src/java.base/share/classes/java/nio/exceptions line 31: >> >>> 29: PACKAGE=java.nio >>> 30: # This year should only change if the generated source is modified. >>> 31: COPYRIGHT_YEARS="2000, 2021," >> >> Does not seem necessary, as I

Re: RFR: 8264779: Fix doclint warnings in java/nio [v3]

2021-04-07 Thread Naoto Sato
On Wed, 7 Apr 2021 18:54:26 GMT, Conor Cleary wrote: >> This fix addresses the following warnings which were generated by building >> JDK API documentation with the `-Xdoclint:all` option enabled: >> >>

Integrated: 8258794: Support for CLDR version 39

2021-04-15 Thread Naoto Sato
On Wed, 14 Apr 2021 21:13:51 GMT, Naoto Sato wrote: > Please review the changes to support CLDR version 39. The vast majority of > the changes are purely data changes from Unicode. The only change affected in > logic was in `CLDRLocaleProviderAdapter.java`, where it neede

RFR: 8258794: Support for CLDR version 39

2021-04-14 Thread Naoto Sato
Please review the changes to support CLDR version 39. The vast majority of the changes are purely data changes from Unicode. The only change affected in logic was in `CLDRLocaleProviderAdapter.java`, where it needed to deal with CLDR's Norwegian language code switch

Re: RFR: 8265375: Bootcycle builds fail with StackOverflowError in cldrconverter [v2]

2021-04-16 Thread Naoto Sato
> Please review the fix to the tier4 build failure. The piece of code that made > into `CLDRLocaleProviderAdapter.java` was also needed in the build tool > counterpart (`CLDRConverter`). Naoto Sato has updated the pull request incrementally with one additional commit since the last

Integrated: 8265375: Bootcycle builds fail with StackOverflowError in cldrconverter

2021-04-16 Thread Naoto Sato
On Fri, 16 Apr 2021 21:10:42 GMT, Naoto Sato wrote: > Please review the fix to the tier4 build failure. The piece of code that made > into `CLDRLocaleProviderAdapter.java` was also needed in the build tool > counterpart (`CLDRConverter`). This pull request has now been integrated.

RFR: 8265375: Bootcycle builds fail with StackOverflowError in cldrconverter

2021-04-16 Thread Naoto Sato
Please review the fix to the tier4 build failure. The piece of code that made into `CLDRLocaleProviderAdapter.java` was also needed in the build tool counterpart (`CLDRConverter`). - Commit messages: - 8265375: Bootcycle builds fail with StackOverflowError in cldrconverter

Re: RFR: 8258794: Support for CLDR version 39

2021-04-14 Thread Naoto Sato
On Wed, 14 Apr 2021 21:13:51 GMT, Naoto Sato wrote: > Please review the changes to support CLDR version 39. The vast majority of > the changes are purely data changes from Unicode. The only change affected in > logic was in `CLDRLocaleProviderAdapter.java`, where it neede

Re: RFR: 8272805: Avoid looking up standard charsets [v2]

2021-08-22 Thread Naoto Sato
On Sun, 22 Aug 2021 23:02:06 GMT, Sergey Bylokhov wrote: >> This is the continuation of JDK-8233884, JDK-8271456, and JDK-8272120. >> >> In many places standard charsets are looked up via their names, for example: >> absolutePath.getBytes("UTF-8"); >> >> This could be done more efficiently(up

Integrated: 8264792: The NumberFormat for locale sq_XK formats price incorrectly.

2021-08-09 Thread Naoto Sato
On Fri, 6 Aug 2021 16:39:34 GMT, Naoto Sato wrote: > Please review the fix to the subject issue. The root cause of this problem is > that the currency for the country code `XK` is undefined because the country > code is user-defined in the ISO 3166 standard. However, it is comm

RFR: 8264792: The NumberFormat for locale sq_XK formats price incorrectly.

2021-08-06 Thread Naoto Sato
Please review the fix to the subject issue. The root cause of this problem is that the currency for the country code `XK` is undefined because the country code is user-defined in the ISO 3166 standard. However, it is commonly used to represent the region `Kosovo`, which CLDR supports and

Integrated: 8274658: ISO 4217 Amendment 170 Update

2021-10-04 Thread Naoto Sato
On Fri, 1 Oct 2021 18:57:28 GMT, Naoto Sato wrote: > This is to incorporate the ISO 4217 amendment #170, which has been released > today, effective immediately. This pull request has now been integrated. Changeset: f2404d60 Author: Naoto Sato URL: https://git.openjdk.java.n

Re: RFR: 8274407: (tz) Update Timezone Data to 2021c

2021-10-06 Thread Naoto Sato
On Wed, 6 Oct 2021 19:43:06 GMT, Sean Coffey wrote: >> This PR is to upgrade the time zone data in the JDK to IANA's tzdata2021c >> level. Note that the tz data is "as is", as released by IANA. No `merged >> links` are retracted. >> The PR also fixes two issues along with the 2021c upgrade. >

Integrated: 8274407: (tz) Update Timezone Data to 2021c

2021-10-07 Thread Naoto Sato
On Wed, 6 Oct 2021 01:24:49 GMT, Naoto Sato wrote: > This PR is to upgrade the time zone data in the JDK to IANA's tzdata2021c > level. Note that the tz data is "as is", as released by IANA. No `merged > links` are retracted. > The PR also fixes two issues along

RFR: 8274658: ISO 4217 Amendment #170 Update

2021-10-01 Thread Naoto Sato
This is to incorporate the ISO 4217 amendment #170, which has been released today, effective immediately. - Commit messages: - 8274658: ISO 4217 Amendment #170 Update Changes: https://git.openjdk.java.net/jdk/pull/5790/files Webrev:

RFR: 8274407: (tz) Update Timezone Data to 2021c

2021-10-05 Thread Naoto Sato
This PR is to upgrade the time zone data in the JDK to IANA's tzdata2021c level. Note that the tz data is "as is", as released by IANA. No `merged links` are retracted. The PR also fixes two issues along with the 2021c upgrade. - Commit messages: - Fix for Asia/Amman test case

Re: RFR: 8275766: (tz) Update Timezone Data to 2021e

2021-10-28 Thread Naoto Sato
On Thu, 28 Oct 2021 01:02:27 GMT, Yoshiki Sato wrote: > Please review the integration of tzdata2021e (including tzdata2021d) to the > JDK. > The fix has passed all relevant JTREG regression tests and JCK tests. > > 8275754: (tz) Update Timezone Data to 2021d > 8275849: TestZoneInfo310.java

RFR: 8268081: Support for Unicode 14

2022-01-05 Thread Naoto Sato
Please review the changes for upgrading the Unicode support in the JDK, from version 13 to version 14. Corresponding CSR has also been drafted. - Commit messages: - Amend unicode.md and icu.md files - Minor fixup - Merge branch 'master' into unicode - Copyright year to 2022 -

Integrated: 8268081: Upgrade Unicode Data Files to 14.0.0

2022-01-12 Thread Naoto Sato
On Wed, 5 Jan 2022 22:42:38 GMT, Naoto Sato wrote: > Please review the changes for upgrading the Unicode support in the JDK, from > version 13 to version 14. Corresponding CSR has also been drafted. This pull request has now been integrated. Changeset: 0a094d7c Author: Naoto Sat

Re: RFR: 8257733: Move module-specific data from make to respective module [v6]

2022-03-16 Thread Naoto Sato
On Tue, 15 Mar 2022 23:50:20 GMT, Magnus Ihse Bursie wrote: >> A lot (but not all) of the data in make/data is tied to a specific module. >> For instance, the publicsuffixlist is used by java.base, and fontconfig by >> java.desktop. (A few directories, like mainmanifest, is *actually* used by

Re: RFR: 8257733: Move module-specific data from make to respective module [v6]

2022-03-16 Thread Naoto Sato
On Wed, 16 Mar 2022 21:56:53 GMT, Magnus Ihse Bursie wrote: >> make/modules/jdk.charsets/Gensrc.gmk line 32: >> >>> 30: # Generate files using the charsetmapping tool >>> 31: # >>> 32: CHARSET_DATA_DIR := $(TOPDIR)/src/java.base/share/data/charsetmapping >> >> Is it intentional to leave

RFR: 8283277: ISO 4217 Amendment 171 Update

2022-03-17 Thread Naoto Sato
This is to incorporate the ISO 4217 amendment 171 for Sierra Leonean LEONE redenomination (removing 3 zeros). Its effective date is 4/1, but I went ahead as JDK19 won't be released by 4/1. - Commit messages: - 8283277: ISO 4217 Amendment 171 Update Changes:

Re: RFR: JDK-8280902 ResourceBundle::getBundle may throw NPE when invoked by JNI code with no caller frame

2022-03-02 Thread Naoto Sato
On Wed, 2 Mar 2022 18:56:40 GMT, Tim Prinzing wrote: > The caller class returned by Reflection::getCallerClass was used to gain > access to it's module in most cases and class loader in one case. I added a > method to translate the caller class to caller module so that the decision of > what

Integrated: 8283277: ISO 4217 Amendment 171 Update

2022-03-21 Thread Naoto Sato
On Thu, 17 Mar 2022 18:10:17 GMT, Naoto Sato wrote: > This is to incorporate the ISO 4217 amendment 171 for Sierra Leonean LEONE > redenomination (removing 3 zeros). Its effective date is 4/1, but I went > ahead as JDK19 won't be released by 4/1. This pull request has now been i

RFR: 8176706: Additional Date-Time Formats

2022-02-03 Thread Naoto Sato
Following the prior discussion [1], here is the PR for the subject enhancement. CSR has also been updated according to the suggestion. [1] https://mail.openjdk.java.net/pipermail/core-libs-dev/2022-January/085175.html - Commit messages: - Removed trailing space - Merge branch

Re: RFR: 8176706: Additional Date-Time Formats [v3]

2022-02-08 Thread Naoto Sato
> Following the prior discussion [1], here is the PR for the subject > enhancement. CSR has also been updated according to the suggestion. > > [1] > https://mail.openjdk.java.net/pipermail/core-libs-dev/2022-January/085175.html Naoto Sato has updated the pull request increme

Re: RFR: 8176706: Additional Date-Time Formats [v2]

2022-02-08 Thread Naoto Sato
> Following the prior discussion [1], here is the PR for the subject > enhancement. CSR has also been updated according to the suggestion. > > [1] > https://mail.openjdk.java.net/pipermail/core-libs-dev/2022-January/085175.html Naoto Sato has updated the pull request increme

Re: RFR: 8176706: Additional Date-Time Formats [v2]

2022-02-08 Thread Naoto Sato
On Tue, 8 Feb 2022 00:39:04 GMT, Joe Wang wrote: >> Naoto Sato has updated the pull request incrementally with one additional >> commit since the last revision: >> >> Modified per suggestions on the PR > > src/java.base/share/classes/java/time/format/DateTimeFor

Re: RFR: 8176706: Additional Date-Time Formats [v2]

2022-02-08 Thread Naoto Sato
On Mon, 7 Feb 2022 21:22:12 GMT, Roger Riggs wrote: >> Naoto Sato has updated the pull request incrementally with one additional >> commit since the last revision: >> >> Modified per suggestions on the PR > > src/java.base/share/classes/java/time/format/DateTim

Re: RFR: 8176706: Additional Date-Time Formats [v3]

2022-02-10 Thread Naoto Sato
On Thu, 10 Feb 2022 22:20:48 GMT, Roger Riggs wrote: >> Naoto Sato has updated the pull request incrementally with one additional >> commit since the last revision: >> >> Fixed LocalizedPrinterParser.toString() to reflect requestedTemplate > > src/java.base

Re: RFR: 8176706: Additional Date-Time Formats [v4]

2022-02-10 Thread Naoto Sato
> Following the prior discussion [1], here is the PR for the subject > enhancement. CSR has also been updated according to the suggestion. > > [1] > https://mail.openjdk.java.net/pipermail/core-libs-dev/2022-January/085175.html Naoto Sato has updated the pull request increme

Re: RFR: 8265315: Support for CLDR version 41

2022-04-08 Thread Naoto Sato
On Thu, 7 Apr 2022 21:20:20 GMT, Naoto Sato wrote: > This is to upgrade the CLDR data from version 39 to version 41 which was > released yesterday. The vast majority of the changes are basically replacing > the CLDR data, along with tools/testcase alignments. Here is the link to CLDR

RFR: 8265315: Support for CLDR version 41

2022-04-07 Thread Naoto Sato
This is to upgrade the CLDR data from version 39 to version 41 which was released yesterday. The vast majority of the changes are basically replacing the CLDR data, along with tools/testcase alignments. Here is the link to CLDR v41's release notes:

Integrated: 8265315: Support for CLDR version 41

2022-04-11 Thread Naoto Sato
On Thu, 7 Apr 2022 21:20:20 GMT, Naoto Sato wrote: > This is to upgrade the CLDR data from version 39 to version 41 which was > released yesterday. The vast majority of the changes are basically replacing > the CLDR data, along with tools/testcase alignments. Here is the link to CLDR

Re: RFR: 8265315: Support for CLDR version 41 [v2]

2022-04-08 Thread Naoto Sato
de.org/index/downloads/cldr-41 Naoto Sato has updated the pull request with a new target base due to a merge or a rebase. The pull request now contains 22 commits: - Merge branch 'master' into cldr+ - Merge branch 'master' into cldr+ - CLDR v41 final - CLDR v41 beta2 - Merge branch 'master' into c

Integrated: 8283324: CLDRConverter run time increased by 3x

2022-04-21 Thread Naoto Sato
On Mon, 18 Apr 2022 23:16:18 GMT, Naoto Sato wrote: > Fixing performance regression caused by the fix to > https://bugs.openjdk.java.net/browse/JDK-8176706. The fix introduced extra > looping through the resource map multiple times which was not necessary. The > execution time of

RFR: 8283324: CLDRConverter run time increased by 3x

2022-04-20 Thread Naoto Sato
Fixing performance regression caused by the fix to https://bugs.openjdk.java.net/browse/JDK-8176706. The fix introduced extra looping through the resource map multiple times which was not necessary. The execution time of the tool now got back on par with close to JDK18. - Commit

Re: RFR: 8257733: Move module-specific data from make to respective module [v9]

2022-03-17 Thread Naoto Sato
On Thu, 17 Mar 2022 00:12:38 GMT, Magnus Ihse Bursie wrote: >> A lot (but not all) of the data in make/data is tied to a specific module. >> For instance, the publicsuffixlist is used by java.base, and fontconfig by >> java.desktop. (A few directories, like mainmanifest, is *actually* used by

Re: RFR: 8287187: Utilize HashMap.newHashMap() in CLDRConverter [v2]

2022-05-25 Thread Naoto Sato
on) the same as the original ones. Naoto Sato has updated the pull request incrementally with one additional commit since the last revision: minor fixup - Changes: - all: https://git.openjdk.java.net/jdk/pull/8887/files - new: https://git.openjdk.java.net/jdk/pull/8887/files/faab3e

RFR: 8287187: Utilize HashMap.newHashMap() in CLDRConverter

2022-05-25 Thread Naoto Sato
Refactoring the leftover self-calculations of the optimized `HashMap` initial value with `newHashMap()` method. Also replaced some string literals using text blocks for better readability. Confirmed that the output resource bundle sources are effectively (sans indentation) the same as the

Integrated: 8287187: Utilize HashMap.newHashMap() in CLDRConverter

2022-05-26 Thread Naoto Sato
On Wed, 25 May 2022 16:43:59 GMT, Naoto Sato wrote: > Refactoring the leftover self-calculations of the optimized `HashMap` initial > value with `newHashMap()` method. Also replaced some string literals using > text blocks for better readability. Confirmed that the output resour

RFR: 8286399: Address possibly lossy conversions in JDK Build Tools

2022-05-13 Thread Naoto Sato
Applied required casts for the upcoming warning. Verified by cherry-picking Adam's patch. - Commit messages: - 8286399: Address possibly lossy conversions in JDK Build Tools Changes: https://git.openjdk.java.net/jdk/pull/8706/files Webrev:

Re: RFR: 8286399: Address possibly lossy conversions in JDK Build Tools

2022-05-13 Thread Naoto Sato
On Fri, 13 May 2022 22:11:17 GMT, Joe Wang wrote: >> Applied required casts for the upcoming warning. Verified by cherry-picking >> Adam's patch. > > make/jdk/src/classes/build/tools/generatebreakiteratordata/RuleBasedBreakIteratorBuilder.java > line 1278: > >> 1276:

Integrated: 8286399: Address possibly lossy conversions in JDK Build Tools

2022-05-16 Thread Naoto Sato
On Fri, 13 May 2022 17:05:43 GMT, Naoto Sato wrote: > Applied required casts for the upcoming warning. Verified by cherry-picking > Adam's patch. This pull request has now been integrated. Changeset: c044cb83 Author: Naoto Sato URL: https://git.openjdk.java.net/jdk/

<    1   2