Re: Rack::Lint::LintError with latest camping and rack

2009-03-29 Thread Paul Thompson
I was able to get camping 1.9 to work with rack 0.9 by using a copy pulled from the repository for rack listed on github. git clone git://github.com/rack/rack.git Paul On Sat, Mar 28, 2009 at 10:06:57PM -0700, Garret Buell wrote: Ok, scratch that last. Turns out camping works just fine with

Re: Rack::Lint::LintError with latest camping and rack

2009-03-29 Thread Julik Tarkhanov
On 29 Mar 2009, at 07:06, Garret Buell wrote: Would we gain anything by making the switch? Everybody would gain. Content-length is a requirement of the latest Rack spec, presumaby to allow for easier caching, and you have to set it _unless_ you send out chunked - but then you have to state

Re: Rack::Lint::LintError with latest camping and rack

2009-03-29 Thread Magnus Holm
Well, this issue is actually solved in the latest master :-) Maybe it's time to release this thing... I'm way to lazy :/ //Magnus Holm On Sun, Mar 29, 2009 at 20:45, Julik Tarkhanov julian.tarkha...@gmail.comwrote: On 29 Mar 2009, at 07:06, Garret Buell wrote: Would we gain anything by

Re: Rack::Lint::LintError with latest camping and rack

2009-03-29 Thread Garret Buell
What about using the github gem server? http://github.com/blog/51-github-s-rubygem-server That way the most current camping could be installed with a gem install judofyr-camping Instead of having to download and build it (marginally more difficult) -Garret Buell 2009/3/29 Magnus Holm