Re: Camping sessions issue (and fix?) when mounting multiple apps

2009-11-02 Thread Magnus Holm
Okay, I think we're actually fine by setting :path = / by default. If you want anything different, you should use use Rack::Session::Cookie yourself. //Magnus Holm On Mon, Oct 19, 2009 at 19:14, Jonathan Hickford jonathan.hickford+camp...@gmail.com wrote: Hi, I'd be inclined to agree with

Re: Camping sessions issue (and fix?) when mounting multiple apps

2009-11-02 Thread Jonathan Hickford
Ace - cheers! On Mon, Nov 2, 2009 at 3:13 PM, Magnus Holm judo...@gmail.com wrote: Okay, I think we're actually fine by setting :path = / by default. If you want anything different, you should use use Rack::Session::Cookie yourself. //Magnus Holm On Mon, Oct 19, 2009 at 19:14, Jonathan

Re: Camping sessions issue (and fix?) when mounting multiple apps

2009-10-19 Thread Jonathan Hickford
Hi, I'd be inclined to agree with the middleware approach too, especially if it's pre 2.0 release and that change can be made along side other 1.5 - 2.0 changes Jon On Sun, Oct 18, 2009 at 9:31 PM, Magnus Holm judo...@gmail.com wrote: Wow, great catch! This is definitely a bug. I guess this

Camping sessions issue (and fix?) when mounting multiple apps

2009-10-18 Thread Jonathan Hickford
Hi all, Not sure where best to raise this (github issues?) but I'm seeing an issue with the cookie sessions in camping 2.0 using rack. If I mount an app such as the example blog or the sessions test app at any url that is not the root session information is lost in some cases. Same thing

Re: Camping sessions issue (and fix?) when mounting multiple apps

2009-10-18 Thread Magnus Holm
Wow, great catch! This is definitely a bug. I guess this should go to GitHub issues, yes. This is actually an issue where Camping and Rack::Session::Cookie fight: At the first request, sessions.state is set in ::Cookie after Camping has done its magic. At the second request, Camping loads