Re: First time and first error

2010-06-08 Thread Raimon Fernandez
On 8jun, 2010, at 09:18 , Raimon Fernandez wrote: Hi again, I'm trying to install Camping on my OS X but I'm getting some errors: MacBook-ProII-2:~ montx$ gem -v 1.3.5 MacBook-ProII-2:~ montx$ sudo gem install camping WARNING: RubyGems 1.2+ index not found for:

Re: First time and first error

2010-06-08 Thread Magnus Holm
Hey Raimon, Try a `sudo gem update --system` first to upgrade to the latest RubyGems // Magnus Holm On Tue, Jun 8, 2010 at 10:59, Raimon Fernandez co...@montx.com wrote: On 8jun, 2010, at 09:18 , Raimon Fernandez wrote: Hi again, I'm trying to install Camping on my OS X but I'm getting

Re: First time and first error

2010-06-08 Thread Dave Everitt
Hi Raimon I'm having the same problem with rubygems.org - won't even load in a browser. In February there was a bit of a change: http://update.gemcutter.org/2010/02/20/rubygems-org-move-complete.html Fro current status see the tweets here: http://twitter.com/gemcutter and Magnus' Temporary

Re: First time and first error

2010-06-08 Thread Raimon Fernandez
Hi Dave, On 8jun, 2010, at 11:52 , Dave Everitt wrote: Hi Raimon I'm having the same problem with rubygems.org - won't even load in a browser. ok, In February there was a bit of a change: http://update.gemcutter.org/2010/02/20/rubygems-org-move-complete.html Fro current status see

Re: First time and first error

2010-06-08 Thread Raimon Fernandez
On 8jun, 2010, at 11:52 , Dave Everitt wrote: Otherwise, get the bleeding edge version: sudo gem install camping --source http://gems.judofyr.net/ ok, I want to focus on Camping so I've installed the edge version without any problems :-) the problem is when I try to execute some example:

Re: First time and first error

2010-06-08 Thread Raimon Fernandez
On 8jun, 2010, at 11:34 , Magnus Holm wrote: Hey Raimon, Try a `sudo gem update --system` first to upgrade to the latest RubyGems // Magnus Holm MacBook-ProII-2:~ montx$ sudo gem update --system Password: Updating RubyGems Nothing to update MacBook-ProII-2:~ montx$ thanks, r.

Re: First time and first error

2010-06-08 Thread Magnus Holm
I believe Rack::Server was introduced in one of the later Rack versions. Looks like I forgot to update the version dependency. Are you able to install the latest rack (gem install rack), or is rubygems.org fully down? // Magnus Holm On Tue, Jun 8, 2010 at 12:25, Raimon Fernandez

Re: First time and first error

2010-06-08 Thread Raimon Fernandez
On 8jun, 2010, at 12:30 , Magnus Holm wrote: I believe Rack::Server was introduced in one of the later Rack versions. Looks like I forgot to update the version dependency. Are you able to install the latest rack (gem install rack), or is rubygems.org fully down? I think is fully down

Re: First time and first error

2010-06-08 Thread Philippe Monnet
Hi Raimon, Sounds like maybe you don't have Rack. Do you have the following gem installed? - rack (1.1.0) - markaby (0.5) [will not work with a higher version] - activerecord (any version) - activesupport (any version) If not gem install them and let us know. Philippe On 6/8/2010 4:25

Re: First time and first error

2010-06-08 Thread Raimon Fernandez
Hi Philippe, On 8jun, 2010, at 12:53 , Philippe Monnet wrote: Hi Raimon, Sounds like maybe you don't have Rack. Do you have the following gem installed? - rack (1.1.0) - markaby (0.5) [will not work with a higher version] - activerecord (any version) - activesupport (any

Re: First time and first error

2010-06-08 Thread Raimon Fernandez
Hi David, On 8jun, 2010, at 15:38 , Dave Everitt wrote: Hi Raimon Github is no longer maintaining this but the gems are still there, so try: --source http://gems.github.com do you mean using like this ? MacBook-ProII-2:~ montx$ sudo gem install rack --source http://gems.github.com

Re: First time and first error

2010-06-08 Thread Dave Everitt
Hi Raimon I did mean that, but the rubygems site is back up... and it looks like they're making progress as the error messages are changing. So maybe try again tomorrow? Dave Hi David, On 8jun, 2010, at 15:38 , Dave Everitt wrote: Hi Raimon Github is no longer maintaining this but

Re: First time and first error

2010-06-08 Thread Raimon Fernandez
Hi David, On 8jun, 2010, at 16:59 , Dave Everitt wrote: Hi Raimon I did mean that, but the rubygems site is back up... and it looks like they're making progress as the error messages are changing. ok So maybe try again tomorrow? If I have to wait, I'll wait ... what can I do ? :-) I

Re: First time and first error

2010-06-08 Thread Dave Everitt
Raimon apologies, rack is not listed in the Github gems (http:// gems.github.com/list.html). BUT (still trying to get around the rubygems.org gem server issues and get you started with Camping) you can try this mirror: sudo gem install rack --source http://chneukirchen.org/releases/gems/

Re: First time and first error

2010-06-08 Thread Raimon Fernandez
Hi Dave, On 8jun, 2010, at 17:47 , Dave Everitt wrote: Raimon apologies, rack is not listed in the Github gems (http://gems.github.com/list.html). BUT (still trying to get around the rubygems.org gem server issues and get you started with Camping) you can try this mirror: sudo gem

Re: First time and first error

2010-06-08 Thread Dave Everitt
Hi Raimon - welcome, glad we got around the rubygems.org fail :-) - Dave Everitt sudo gem install rack --source http://chneukirchen.org/releases/gems/ ok, installed and running, now I'm a Camper!!! :-) Sure I'll come back here with more questions about Camping ...

Re: First time and first error

2010-06-08 Thread Raimon Fernandez
On 8jun, 2010, at 18:19 , Dave Everitt wrote: Hi Raimon - welcome, thanks! glad we got around the rubygems.org fail :-) hey, I need more workarounds . :-) I'm playing with Camping and the introduction found in http://camping.rubyforge.org/book/02_getting_started.html Now I'm

Re: First time and first error

2010-06-08 Thread Dave Everitt
Hi Raimon don't know if I can just clone the git repository of restr and install it using ruby setup.rb that seems the best way, as David Susco suggested: I don't believe the gem has been updated to include Matt's or Philippe's latest changes. You could clone it from GitHub though and