Re: [ccache] ccache has issues with current Apple compilers

2014-06-01 Thread Joel Rosdahl
Hi, I tried to install ccache 3.1.9 on a current Mac system (OS X 10.9.3, Xcode 5.1.1). Configure and compile went cleanly, with the exception of two probably-harmless warnings: [...] Thanks for the patch. The build warning has however already been fixed in another way in ccache (not

[ccache] ccache has issues with current Apple compilers

2014-05-31 Thread Tom Lane
I tried to install ccache 3.1.9 on a current Mac system (OS X 10.9.3, Xcode 5.1.1). Configure and compile went cleanly, with the exception of two probably-harmless warnings: manifest.c:223:2: warning: shift count = width of type [-Wshift-count-overflow] READ_INT(1, version);

Re: [ccache] ccache has issues with current Apple compilers

2014-05-31 Thread Lubos Lunak
On Saturday 31 of May 2014, Tom Lane wrote: I did some further experiments and concluded that ccache is in fact kind of broken: when I try to compile a large project with it, I get thousands of weird warnings that do not appear when using gcc directly (many of them the same kind of unused -I