Re: [ccache] amd64 buildworld (FreeBSD 8.0p2) consistently fails with ccache

2010-05-12 Thread Joel Rosdahl
On 2010-05-11 01:38, Christer Edwards wrote: I've got another failure (same place) on 3.0pre1.Below are the details: I executed 'ccache make buildworld' at /usr/src. Putting ccache before make doesn't gain anything (but doesn't do any harm either, except that an error counter in ccache's

Re: [ccache] amd64 buildworld (FreeBSD 8.0p2) consistently fails with ccache [SOLVED]

2010-05-12 Thread Christer Edwards
On Wed, May 12, 2010 at 12:25 AM, Joel Rosdahl j...@rosdahl.net wrote: Just to make it clear: The build works without ccache, right? It has always worked without ccache, yes. I have solved the issue now. It was on my end. Generally when I install FreeBSD I select the 'minimal' option and

Re: [ccache] amd64 buildworld (FreeBSD 8.0p2) consistently fails with ccache

2010-05-10 Thread Joel Rosdahl
On 2010-05-10 03:24, Christer Edwards wrote: I've enabled logging and I would attach the logfile, but it is 12M total size. I've included the tail end, just leading up to the failure: [...] [78047] Running real compiler [78047] Compiler gave exit status 1 This build had no CFLAGS or

Re: [ccache] amd64 buildworld (FreeBSD 8.0p2) consistently fails with ccache

2010-05-10 Thread Christer Edwards
On Mon, May 10, 2010 at 2:58 PM, Joel Rosdahl j...@rosdahl.net wrote: The most important thing is to find out the exact command line used when the compilation failed. Your build system doesn't seem to print that, so I think you either should try to increase verbosity in some way or upgrade to

Re: [ccache] amd64 buildworld (FreeBSD 8.0p2) consistently fails with ccache

2010-05-10 Thread Christer Edwards
On Mon, May 10, 2010 at 2:58 PM, Joel Rosdahl j...@rosdahl.net wrote: The most important thing is to find out the exact command line used when the compilation failed. Your build system doesn't seem to print that, so I think you either should try to increase verbosity in some way or upgrade to

Re: [ccache] amd64 buildworld (FreeBSD 8.0p2) consistently fails with ccache

2010-05-09 Thread Christer Edwards
On Sun, May 9, 2010 at 11:17 AM, Joel Rosdahl j...@rosdahl.net wrote: That's strange. Which ccache version are you using? If you're using 2.4, please try 3.0pre0. [r...@stringer /usr/src]# ccache -V ccache version 3.0pre0 It just failed for me again. I did not turn on logging, but this is

Re: [ccache] amd64 buildworld (FreeBSD 8.0p2) consistently fails with ccache

2010-05-09 Thread Christer Edwards
On Sun, May 9, 2010 at 11:17 AM, Joel Rosdahl j...@rosdahl.net wrote: You can enable debug logging by setting CCACHE_LOGFILE to a log file path and then send the log of a failed compilation here. I've enabled logging and I would attach the logfile, but it is 12M total size. I've included the