Re: [ceph-users] Need help with upmap feature on luminous

2019-02-06 Thread Dan van der Ster
Note that there are some improved upmap balancer heuristics in development here: https://github.com/ceph/ceph/pull/26187 -- dan On Tue, Feb 5, 2019 at 10:18 PM Kári Bertilsson wrote: > > Hello > > I previously enabled upmap and used automatic balancing with "ceph balancer > on". I got very

Re: [ceph-users] Need help with upmap feature on luminous

2019-02-05 Thread Kári Bertilsson
I am testing running manually `ceph osd pg-upmap-items 41.1 106 125` Nothing shows up in logs on neither OSD 106 or 125 and nothing happens. ___ ceph-users mailing list ceph-users@lists.ceph.com http://lists.ceph.com/listinfo.cgi/ceph-users-ceph.com

Re: [ceph-users] Need help with upmap feature on luminous

2019-02-05 Thread Konstantin Shalygin
I added `debug mgr = 4/5` to [global] section in ceph.conf on the active mgr. And restarted mgr service. Is this correct ? This is correct. k ___ ceph-users mailing list ceph-users@lists.ceph.com

Re: [ceph-users] Need help with upmap feature on luminous

2019-02-05 Thread Kári Bertilsson
ceph version 12.2.8-pve1 on proxmox ceph osd df tree @ https://pastebin.com/e68fJ5fM I added `debug mgr = 4/5` to [global] section in ceph.conf on the active mgr. And restarted mgr service. Is this correct ? I noticed some config settings in the mgr logs.. Changed config to use

Re: [ceph-users] Need help with upmap feature on luminous

2019-02-05 Thread Konstantin Shalygin
I previously enabled upmap and used automatic balancing with "ceph balancer on". I got very good results and OSD's ended up with perfectly distributed pg's. Now after adding several new OSD's, auto balancing does not seem to be working anymore. OSD's have 30-50% usage where previously all had