Re: [PATCH] D10802: [mips] Interrupt attribute support.

2015-11-17 Thread Simon Dardis via cfe-commits
sdardis updated this revision to Diff 40382. sdardis marked 12 inline comments as done. sdardis added a comment. Updated documentation text. Switched the various hard failures to semantic warnings/failures. Strangely, the 'interrupt' attribute on a non-function defaults to a warning. Thanks.

Re: [PATCH] D14467: [MS] Fix for bug 25013 - #pragma vtordisp is unknown inside functions.

2015-11-17 Thread Denis Zobnin via cfe-commits
d.zobnin.bugzilla updated this revision to Diff 40380. d.zobnin.bugzilla added a comment. Only tests have been updated: enabled a test case for Sema, which pass with these changes, added corresponding test case for CodeGen. http://reviews.llvm.org/D14467 Files: include/clang/Sema/Sema.h

Re: r253269 - Make FP_CONTRACT ON the default.

2015-11-17 Thread Manuel Klimek via cfe-commits
Note that due to this change we're hitting an assert at lib/CodeGen/CGExprScalar.cpp:2570 in llvm::Value *tryEmitFMulAdd(const (anonymous namespace)::BinOpInfo &, const clang::CodeGen::CodeGenFunction &, clang::CodeGen::CGBuilderTy &, bool): LHSBinOp->getNumUses( ) == 0 && "Operations with

Re: r253269 - Make FP_CONTRACT ON the default.

2015-11-17 Thread Hal Finkel via cfe-commits
- Original Message - > From: "Renato Golin via cfe-commits" > To: "Stephen Canon" > Cc: "Clang Commits" > Sent: Tuesday, November 17, 2015 3:51:23 AM > Subject: Re: r253269 - Make FP_CONTRACT ON the default. > >

Re: [PATCH] D14467: [MS] Fix for bug 25013 - #pragma vtordisp is unknown inside functions.

2015-11-17 Thread Denis Zobnin via cfe-commits
d.zobnin.bugzilla added inline comments. Comment at: test/SemaCXX/pragma-vtordisp.cpp:34-35 @@ -33,6 +33,4 @@ struct C { -// FIXME: Our implementation based on token insertion makes it impossible for -// the pragma to appear everywhere we should support it. -//#pragma

Re: [PATCH] D13731: [Analyzer] Supporting function attributes in .model files.

2015-11-17 Thread pierre gousseau via cfe-commits
pgousseau added a comment. Ping! http://reviews.llvm.org/D13731 ___ cfe-commits mailing list cfe-commits@lists.llvm.org http://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-commits

Re: r253269 - Make FP_CONTRACT ON the default.

2015-11-17 Thread Manuel Klimek via cfe-commits
Reverted in r253337. Failing test case in commit message. On Tue, Nov 17, 2015 at 4:39 PM Manuel Klimek wrote: > Repro: > float foo(float U, float base, float cell) { return (U = 2 * base) - cell; > } > Preparing rollback of the CL. > > On Tue, Nov 17, 2015 at 2:46 PM Manuel

r253337 - Revert "Make FP_CONTRACT ON the default."

2015-11-17 Thread Manuel Klimek via cfe-commits
Author: klimek Date: Tue Nov 17 09:40:10 2015 New Revision: 253337 URL: http://llvm.org/viewvc/llvm-project?rev=253337=rev Log: Revert "Make FP_CONTRACT ON the default." This reverts commit r253269. This leads to assert / segfault triggering on the following reduced example: float foo(float U,

Re: r253269 - Make FP_CONTRACT ON the default.

2015-11-17 Thread Manuel Klimek via cfe-commits
Repro: float foo(float U, float base, float cell) { return (U = 2 * base) - cell; } Preparing rollback of the CL. On Tue, Nov 17, 2015 at 2:46 PM Manuel Klimek wrote: > Note that due to this change we're hitting an assert at > lib/CodeGen/CGExprScalar.cpp:2570 in llvm::Value

Re: [PATCH] D14134: [OpenMP] Parsing and sema support for map clause

2015-11-17 Thread Alexey Bataev via cfe-commits
ABataev added inline comments. Comment at: include/clang/AST/OpenMPClause.h:2660-2662 @@ +2659,5 @@ + /// + /// \param StartLoc Starting location of the clause. + /// \param EndLoc Ending location of the clause. + /// \param N Number of the variables in the clause. + ///

Re: [PATCH] D10802: [mips] Interrupt attribute support.

2015-11-17 Thread Aaron Ballman via cfe-commits
aaron.ballman added inline comments. Comment at: include/clang/Basic/DiagnosticSemaKinds.td:255 @@ -254,1 +254,3 @@ def err_parameter_name_omitted : Error<"parameter name omitted">; +def err_excess_arguments : Error<"function %0 has too many arguments">; +def

[PATCH] D14748: bmiintrin.h: Allow using the tzcnt intrinsics for non-BMI targets

2015-11-17 Thread Hans Wennborg via cfe-commits
hans created this revision. hans added reviewers: thakis, echristo. hans added a subscriber: cfe-commits. The tzcnt intrinsics are used non non-BMI targets by code (e.g. ffmpeg) that uses it as a potentially faster BSF. The TZCNT instruction is special in that it's encoded in a

r253350 - Add trivial utility to append -L arguments to linker step. NFC

2015-11-17 Thread Douglas Katzman via cfe-commits
Author: dougk Date: Tue Nov 17 11:41:23 2015 New Revision: 253350 URL: http://llvm.org/viewvc/llvm-project?rev=253350=rev Log: Add trivial utility to append -L arguments to linker step. NFC Modified: cfe/trunk/include/clang/Driver/ToolChain.h cfe/trunk/lib/Driver/ToolChain.cpp

Re: [PATCH] D14748: bmiintrin.h: Allow using the tzcnt intrinsics for non-BMI targets

2015-11-17 Thread Eric Christopher via cfe-commits
echristo accepted this revision. echristo added a comment. This revision is now accepted and ready to land. Sounds good to me. Weird, but fine :) -eric http://reviews.llvm.org/D14748 ___ cfe-commits mailing list cfe-commits@lists.llvm.org

r253358 - bmiintrin.h: Allow using the tzcnt intrinsics for non-BMI targets

2015-11-17 Thread Hans Wennborg via cfe-commits
Author: hans Date: Tue Nov 17 12:46:48 2015 New Revision: 253358 URL: http://llvm.org/viewvc/llvm-project?rev=253358=rev Log: bmiintrin.h: Allow using the tzcnt intrinsics for non-BMI targets The tzcnt intrinsics are used non non-BMI targets by code (e.g. ffmpeg) that uses it as a potentially

Re: r253398 - [modules] When a #include is mapped to a module import and appears somewhere

2015-11-17 Thread Richard Smith via cfe-commits
On Tue, Nov 17, 2015 at 3:40 PM, David Blaikie wrote: > On Tue, Nov 17, 2015 at 3:32 PM, Richard Smith via cfe-commits < > cfe-commits@lists.llvm.org> wrote: > >> Author: rsmith >> Date: Tue Nov 17 17:32:01 2015 >> New Revision: 253398 >> >> URL:

r253398 - [modules] When a #include is mapped to a module import and appears somewhere

2015-11-17 Thread Richard Smith via cfe-commits
Author: rsmith Date: Tue Nov 17 17:32:01 2015 New Revision: 253398 URL: http://llvm.org/viewvc/llvm-project?rev=253398=rev Log: [modules] When a #include is mapped to a module import and appears somewhere other than the top level, we issue an error. This breaks a fair amount of C++ code wrapping

Re: [PATCH] D14744: PR10235: support for vector mode attributes + warning

2015-11-17 Thread Dmitry Polukhin via cfe-commits
DmitryPolukhin added a comment. Thank you for prompt response! Comment at: include/clang/Basic/DiagnosticSemaKinds.td:2765 @@ +2764,3 @@ +def warn_vector_mode_deprecated : Warning< + "specifying vector types with __attribute__ ((mode)) is deprecated, " + "use __attribute__

Re: [PATCH] D9600: Add scan-build python implementation

2015-11-17 Thread Laszlo Nagy via cfe-commits
rizsotto.mailinglist added a comment. In http://reviews.llvm.org/D9600#290031, @jroelofs wrote: > Thanks for re-uploading! thanks for your comments! :) most of your comments are about to embed it more into the clang build, test infrastructure. i think these are valid points! i would like to

Re: [PATCH] D14748: bmiintrin.h: Allow using the tzcnt intrinsics for non-BMI targets

2015-11-17 Thread Craig Topper via cfe-commits
craig.topper added a subscriber: craig.topper. craig.topper added a comment. The summary of why this is ok is slightly misleading. The backend won't try to encode the TZCNT instruction when the BMI feature is not enabled. Notice this just maps the to the generic non-x86 specific __builtin_ctz.

r253410 - Fix for use-after-free which caused test failure in cuda-detect.cu.

2015-11-17 Thread Artem Belevich via cfe-commits
Author: tra Date: Tue Nov 17 18:37:41 2015 New Revision: 253410 URL: http://llvm.org/viewvc/llvm-project?rev=253410=rev Log: Fix for use-after-free which caused test failure in cuda-detect.cu. Return std::string itself instead StringRef to a temporary std::string. Modified:

Re: [PATCH] D13488: [analyzer] Assume escape is possible through system functions taking void*

2015-11-17 Thread Anna Zaks via cfe-commits
zaks.anna closed this revision. zaks.anna added a comment. Committed in r251449. http://reviews.llvm.org/D13488 ___ cfe-commits mailing list cfe-commits@lists.llvm.org http://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-commits

Re: r252853 - libclang: add clang_Cursor_getCXXManglings

2015-11-17 Thread Reid Kleckner via cfe-commits
This introduced a memory leak, which I'm testing a patch for. Aside from that, did you get Doug to review this? We probably want to be really careful about changing libclang's C API, so you should be more cautious here than you would be normally. On Wed, Nov 11, 2015 at 7:57 PM, Saleem

Re: [PATCH] D14737: Convert some ObjC msgSends to runtime calls

2015-11-17 Thread Stephane Moore via cfe-commits
stephanemoore added a subscriber: stephanemoore. stephanemoore added a comment. I hope that it's not presumptuous of me to inquire but I was wondering if the intent of this patch is to optimize calls to RR methods (and alloc) in non-ARC code? Would I be correct in assuming that clang will

Re: [clang-tools-extra] r253401 - [clang-tidy] add check cppcoreguidelines-pro-bounds-constant-array-index

2015-11-17 Thread Bruno Cardoso Lopes via cfe-commits
Hi Matthias, This is failing on the green dragon bot: http://lab.llvm.org:8080/green/job/clang-stage1-configure-RA_check/13184/ http://lab.llvm.org:8080/green/job/clang-stage1-configure-RA_check/13184/consoleFull#54616856949ba4694-19c4-4d7e-bec5-911270d8a58c Thanks, On Tue, Nov 17, 2015 at 3:43

Re: [PATCH] D14652: [analyzer] Improve modeling of static initializers.

2015-11-17 Thread Anna Zaks via cfe-commits
zaks.anna added inline comments. Comment at: test/Analysis/inline.cpp:308 @@ +307,3 @@ +clang_analyzer_eval(0 != void_string); // expected-warning{{TRUE}} +clang_analyzer_eval(0 != ((char *)void_string)[1]); // expected-warning{{TRUE}} + } Why are we

[clang-tools-extra] r253428 - Revert r253401, "[clang-tidy] add check cppcoreguidelines-pro-bounds-constant-array-index"

2015-11-17 Thread NAKAMURA Takumi via cfe-commits
Author: chapuni Date: Tue Nov 17 20:14:35 2015 New Revision: 253428 URL: http://llvm.org/viewvc/llvm-project?rev=253428=rev Log: Revert r253401, "[clang-tidy] add check cppcoreguidelines-pro-bounds-constant-array-index" cppcoreguidelines-pro-bounds-constant-array-index.cpp is failing in several

r253434 - BuildUniversalActions(): Prune obsolete \param(s). [-Wdocumentation]

2015-11-17 Thread NAKAMURA Takumi via cfe-commits
Author: chapuni Date: Tue Nov 17 23:15:21 2015 New Revision: 253434 URL: http://llvm.org/viewvc/llvm-project?rev=253434=rev Log: BuildUniversalActions(): Prune obsolete \param(s). [-Wdocumentation] FIXME: Describe BAInputs. Modified: cfe/trunk/include/clang/Driver/Driver.h Modified:

[libcxxabi] r253435 - c++abi: use __builtin_offsetof instead of offsetof

2015-11-17 Thread Saleem Abdulrasool via cfe-commits
Author: compnerd Date: Tue Nov 17 23:33:38 2015 New Revision: 253435 URL: http://llvm.org/viewvc/llvm-project?rev=253435=rev Log: c++abi: use __builtin_offsetof instead of offsetof Use `__builtin_offsetof` in place of `offsetof`. Certain environments provide a macro definition of `offsetof`

r253431 - [NFC] Change the evaluation context of a non-type default template argument from Unevaluated to ConstantEvaluated.

2015-11-17 Thread Faisal Vali via cfe-commits
Author: faisalv Date: Tue Nov 17 22:29:22 2015 New Revision: 253431 URL: http://llvm.org/viewvc/llvm-project?rev=253431=rev Log: [NFC] Change the evaluation context of a non-type default template argument from Unevaluated to ConstantEvaluated. This patch emits a more appropriate (but still

Re: [PATCH] D14652: [analyzer] Improve modeling of static initializers.

2015-11-17 Thread Yury Gribov via cfe-commits
ygribov added inline comments. Comment at: test/Analysis/inline.cpp:308 @@ +307,3 @@ +clang_analyzer_eval(0 != void_string); // expected-warning{{TRUE}} +clang_analyzer_eval(0 != ((char *)void_string)[1]); // expected-warning{{TRUE}} + } zaks.anna

Re: [PATCH] D14506: Porting shouldVisitImplicitCode to DataRecursiveASTVisitor.

2015-11-17 Thread Manuel Klimek via cfe-commits
Richard, this is still optional, right? (the AST matchers need to control visitation) On Tue, Nov 17, 2015 at 2:26 AM Argyrios Kyrtzidis via cfe-commits < cfe-commits@lists.llvm.org> wrote: > W00t! That’s awesome Richard! > > On Nov 16, 2015, at 5:10 PM, Richard Smith

Re: [PATCH] D14506: Porting shouldVisitImplicitCode to DataRecursiveASTVisitor.

2015-11-17 Thread Richard Smith via cfe-commits
LOn Nov 17, 2015 12:49 AM, "Manuel Klimek" wrote: > Richard, this is still optional, right? (the AST matchers need to control visitation) This doesn't change RAV semantics at all (or if it does, it's a bug). If any of the extension points are overridden in the derived class,

Re: [PATCH] D14506: Porting shouldVisitImplicitCode to DataRecursiveASTVisitor.

2015-11-17 Thread Manuel Klimek via cfe-commits
On Tue, Nov 17, 2015 at 10:14 AM Richard Smith wrote: > LOn Nov 17, 2015 12:49 AM, "Manuel Klimek" wrote: > > Richard, this is still optional, right? (the AST matchers need to > control visitation) > > This doesn't change RAV semantics at all (or if it

Re: [PATCH] D14736: [analyzer] DeadStoresChecker: Treat locals captured by reference in C++ lambdas as escaped.

2015-11-17 Thread Gábor Horváth via cfe-commits
xazax.hun added a comment. This looks good to me, I have one question inline. Comment at: lib/StaticAnalyzer/Checkers/DeadStoresChecker.cpp:425 @@ +424,3 @@ +llvm::DenseMap CaptureFields; +FieldDecl *ThisCaptureField; +LambdaClass->getCaptureFields(CaptureFields,

Re: [PATCH] D14170: Fix false positive warning about memory leak for QApplication::postEvent

2015-11-17 Thread Gábor Horváth via cfe-commits
xazax.hun added inline comments. Comment at: lib/StaticAnalyzer/Checkers/MallocChecker.cpp:2514 @@ -2513,1 +2513,3 @@ + if (FName.endswith("postEvent") && + FD->getQualifiedNameAsString() == "QCoreApplication::postEvent") { Shouldn't you use == instead of

Re: [PATCH] D14744: PR10235: support for vector mode attributes + warning

2015-11-17 Thread Aaron Ballman via cfe-commits
aaron.ballman added inline comments. Comment at: include/clang/Basic/DiagnosticSemaKinds.td:2765 @@ +2764,3 @@ +def warn_vector_mode_deprecated : Warning< + "specifying vector types with __attribute__ ((mode)) is deprecated, " + "use __attribute__ ((vector_size)) instead">,

[libcxx] r253382 - Fix bad variable name. project_root -> project_obj_root

2015-11-17 Thread Eric Fiselier via cfe-commits
Author: ericwf Date: Tue Nov 17 15:48:29 2015 New Revision: 253382 URL: http://llvm.org/viewvc/llvm-project?rev=253382=rev Log: Fix bad variable name. project_root -> project_obj_root Modified: libcxx/trunk/test/libcxx/test/config.py Modified: libcxx/trunk/test/libcxx/test/config.py URL:

[PATCH] D14756: Handle ARMv6-J as an alias, instead of fake architecture

2015-11-17 Thread A. Skrobov via cfe-commits
tyomitch created this revision. tyomitch added reviewers: rengolin, bogden, compnerd. tyomitch added a subscriber: cfe-commits. Herald added subscribers: rengolin, aemerson. Clang-side update, corresponding to D14755 http://reviews.llvm.org/D14756 Files: test/Driver/arm-cortex-cpus.c Index:

r253389 - [CUDA] Make CUDA compilation usable by default.

2015-11-17 Thread Artem Belevich via cfe-commits
Author: tra Date: Tue Nov 17 16:28:55 2015 New Revision: 253389 URL: http://llvm.org/viewvc/llvm-project?rev=253389=rev Log: [CUDA] Make CUDA compilation usable by default. Currently clang requires several additional command line options in order to enable new features needed during CUDA

Re: [PATCH] D13144: [CUDA] propagate to CUDA sub-compilations target triple of opposite side.

2015-11-17 Thread Artem Belevich via cfe-commits
This revision was automatically updated to reflect the committed changes. Closed by commit rL253385: [CUDA] use -aux-triple to pass target triple of opposite side of compilation (authored by tra). Changed prior to commit: http://reviews.llvm.org/D13144?vs=40163=40432#toc Repository: rL LLVM

Re: [PATCH] D13170: [CUDA] Driver changes to pass flags needed to use detected CUDA installation.

2015-11-17 Thread Artem Belevich via cfe-commits
This revision was automatically updated to reflect the committed changes. Closed by commit rL253386: [CUDA] added include paths for both sides of CUDA compilation. (authored by tra). Changed prior to commit: http://reviews.llvm.org/D13170?vs=39860=40433#toc Repository: rL LLVM

Re: [PATCH] D14754: [Myriad]: insert -L paths into linker cmd only when they exist.

2015-11-17 Thread James Y Knight via cfe-commits
jyknight added inline comments. Comment at: lib/Driver/ToolChains.cpp:4319 @@ +4318,3 @@ + // This contains libc, libg (a superset of libc), libm, libstdc++, libssp. + SmallString<128> LibDir(GCCInstallation.getParentLibPath()); + if (Triple.getArch() == llvm::Triple::sparcel)

r253440 - Update for llvm change.

2015-11-17 Thread Rafael Espindola via cfe-commits
Author: rafael Date: Wed Nov 18 00:54:13 2015 New Revision: 253440 URL: http://llvm.org/viewvc/llvm-project?rev=253440=rev Log: Update for llvm change. Modified: cfe/trunk/include/clang/Lex/HeaderSearchOptions.h cfe/trunk/lib/CodeGen/CGObjCMac.cpp Modified:

[clang-tools-extra] r253442 - Replace a dyn_cast with isa where the result was only being used as a boolean. NFC.

2015-11-17 Thread Craig Topper via cfe-commits
Author: ctopper Date: Wed Nov 18 01:08:11 2015 New Revision: 253442 URL: http://llvm.org/viewvc/llvm-project?rev=253442=rev Log: Replace a dyn_cast with isa where the result was only being used as a boolean. NFC. Modified: clang-tools-extra/trunk/clang-tidy/modernize/UseDefaultCheck.cpp