[clang-tools-extra] a7acba2 - Use InitLLVM in clang-tidy

2019-11-27 Thread Rui Ueyama via cfe-commits
Author: Rui Ueyama Date: 2019-11-28T13:50:35+09:00 New Revision: a7acba29c19ac67c77ed282ec9432602ae21268d URL: https://github.com/llvm/llvm-project/commit/a7acba29c19ac67c77ed282ec9432602ae21268d DIFF: https://github.com/llvm/llvm-project/commit/a7acba29c19ac67c77ed282ec9432602ae21268d.diff LO

[clang] 3f76260 - Use InitLLVM to setup a pretty stack printer

2019-11-25 Thread Rui Ueyama via cfe-commits
Author: Rui Ueyama Date: 2019-11-26T10:56:10+09:00 New Revision: 3f76260dc0674cc0acb25f550a0f0c594cf537ea URL: https://github.com/llvm/llvm-project/commit/3f76260dc0674cc0acb25f550a0f0c594cf537ea DIFF: https://github.com/llvm/llvm-project/commit/3f76260dc0674cc0acb25f550a0f0c594cf537ea.diff LO

r368259 - [diagtool] Use `operator<<(Colors)` to print out colored output.

2019-08-08 Thread Rui Ueyama via cfe-commits
Author: ruiu Date: Thu Aug 8 00:04:01 2019 New Revision: 368259 URL: http://llvm.org/viewvc/llvm-project?rev=368259&view=rev Log: [diagtool] Use `operator<<(Colors)` to print out colored output. r368131 introduced this new API to print out messages in colors. If the colored output is disabled, `

r368131 - Re-submit r367649: Improve raw_ostream so that you can "write" colors using operator<

2019-08-07 Thread Rui Ueyama via cfe-commits
Author: ruiu Date: Wed Aug 7 01:08:17 2019 New Revision: 368131 URL: http://llvm.org/viewvc/llvm-project?rev=368131&view=rev Log: Re-submit r367649: Improve raw_ostream so that you can "write" colors using operator<< The original patch broke buildbots, perhaps because it changed the default set

r367658 - Revert r367649: Improve raw_ostream so that you can "write" colors using operator<

2019-08-02 Thread Rui Ueyama via cfe-commits
Author: ruiu Date: Fri Aug 2 00:22:34 2019 New Revision: 367658 URL: http://llvm.org/viewvc/llvm-project?rev=367658&view=rev Log: Revert r367649: Improve raw_ostream so that you can "write" colors using operator<< This reverts commit r367649 in an attempt to unbreak Windows bots. Modified:

r367649 - Improve raw_ostream so that you can "write" colors using operator<

2019-08-01 Thread Rui Ueyama via cfe-commits
Author: ruiu Date: Thu Aug 1 21:48:30 2019 New Revision: 367649 URL: http://llvm.org/viewvc/llvm-project?rev=367649&view=rev Log: Improve raw_ostream so that you can "write" colors using operator<< 1. raw_ostream supports ANSI colors so that you can write messages to the termina with colors. Pre

[clang-tools-extra] r366304 - Replace CRLF with LF.

2019-07-17 Thread Rui Ueyama via cfe-commits
Author: ruiu Date: Wed Jul 17 01:31:51 2019 New Revision: 366304 URL: http://llvm.org/viewvc/llvm-project?rev=366304&view=rev Log: Replace CRLF with LF. Modified: clang-tools-extra/trunk/unittests/clang-tidy/ClangTidyDiagnosticConsumerTest.cpp Modified: clang-tools-extra/trunk/unittests/cl

r330067 - Use InitLLVM in clang as well.

2018-04-13 Thread Rui Ueyama via cfe-commits
Author: ruiu Date: Fri Apr 13 13:57:57 2018 New Revision: 330067 URL: http://llvm.org/viewvc/llvm-project?rev=330067&view=rev Log: Use InitLLVM in clang as well. Differential Revision: https://reviews.llvm.org/D45634 Modified: cfe/trunk/tools/clang-format/ClangFormat.cpp cfe/trunk/tools/

Re: [PATCH] D42758: Support `#pragma comment(lib, "name")` in the frontend for ELF

2018-02-01 Thread Rui Ueyama via cfe-commits
On Wed, Jan 31, 2018 at 7:23 PM, Paul Robinson via Phabricator < revi...@reviews.llvm.org> wrote: > probinson added a comment. > > In https://reviews.llvm.org/D42758#993936, @ruiu wrote: > > > > I also wonder which is better `#pragma comment(lib, "m")` or `#pragma > comment(lib, "m")`. > > > > Sor

Re: r316379 - [Driver] Use ld.lld directly for Fuchsia rather than passing flavor

2017-10-23 Thread Rui Ueyama via cfe-commits
Nice. Dispatching based on argv[0] is more common and probably a recommended way now, so this patch aligned with that. On Mon, Oct 23, 2017 at 2:31 PM, Petr Hosek via cfe-commits < cfe-commits@lists.llvm.org> wrote: > Author: phosek > Date: Mon Oct 23 14:31:05 2017 > New Revision: 316379 > > URL:

Re: r313104 - Revert "[Driver] MinGW: Remove custom linker detection"

2017-09-13 Thread Rui Ueyama via cfe-commits
Ah, sorry, you mentioned that. Yes, I think you need it. On Wed, Sep 13, 2017 at 1:00 PM, Rui Ueyama wrote: > This is a wild guess, but don't you need to add `REQUIRES: lld` to your > test if your test depends on lld? I don't think all bots have lld, and if > `ld.lld` is not found, clang prints

Re: r313104 - Revert "[Driver] MinGW: Remove custom linker detection"

2017-09-13 Thread Rui Ueyama via cfe-commits
This is a wild guess, but don't you need to add `REQUIRES: lld` to your test if your test depends on lld? I don't think all bots have lld, and if `ld.lld` is not found, clang prints out that error message. On Tue, Sep 12, 2017 at 7:16 PM, Martell Malone wrote: > Just to follow up, > The test cas

Re: r313088 - Revert "[Driver] MinGW: Remove custom linker detection"

2017-09-12 Thread Rui Ueyama via cfe-commits
It is reverted because it broke buildbots: http://green.lab.llvm.org/green/job/clang-stage1-cmake-RA-incremental/42380/testReport/junit/Clang/Driver/mingw_useld_c/ On Tue, Sep 12, 2017 at 4:05 PM, Rui Ueyama wrote: > I wonder why you reverted this change. > > On Tue, Sep 12, 2017 at 4:04 PM, Mar

Re: r313082 - [Driver] MinGW: Remove custom linker detection

2017-09-12 Thread Rui Ueyama via cfe-commits
I'm perhaps not the only person who is wondering, so I'll update the original thread instead of replying to this thread. On Tue, Sep 12, 2017 at 4:07 PM, Martell Malone wrote: > cc @rui this is why I reverted it. > > On Wed, Sep 13, 2017 at 12:00 AM, Martell Malone > wrote: > >> Hi Mike, >> >>

Re: r313088 - Revert "[Driver] MinGW: Remove custom linker detection"

2017-09-12 Thread Rui Ueyama via cfe-commits
I wonder why you reverted this change. On Tue, Sep 12, 2017 at 4:04 PM, Martell Malone wrote: > Will do in future, thanks Rui. > > On Wed, Sep 13, 2017 at 12:03 AM, Rui Ueyama wrote: > >> When you revert a commit, please explain why you are reverting it in the >> commit message. >> >> On Tue, S

Re: r313088 - Revert "[Driver] MinGW: Remove custom linker detection"

2017-09-12 Thread Rui Ueyama via cfe-commits
When you revert a commit, please explain why you are reverting it in the commit message. On Tue, Sep 12, 2017 at 3:58 PM, Martell Malone via cfe-commits < cfe-commits@lists.llvm.org> wrote: > Author: martell > Date: Tue Sep 12 15:58:12 2017 > New Revision: 313088 > > URL: http://llvm.org/viewvc/l

r311936 - Remove trailing space.

2017-08-28 Thread Rui Ueyama via cfe-commits
Author: ruiu Date: Mon Aug 28 14:38:14 2017 New Revision: 311936 URL: http://llvm.org/viewvc/llvm-project?rev=311936&view=rev Log: Remove trailing space. Modified: cfe/trunk/lib/StaticAnalyzer/Core/SimpleSValBuilder.cpp Modified: cfe/trunk/lib/StaticAnalyzer/Core/SimpleSValBuilder.cpp URL:

r311557 - Revert r311552: [Bash-autocompletion] Add support for static analyzer flags

2017-08-23 Thread Rui Ueyama via cfe-commits
Author: ruiu Date: Wed Aug 23 07:48:58 2017 New Revision: 311557 URL: http://llvm.org/viewvc/llvm-project?rev=311557&view=rev Log: Revert r311552: [Bash-autocompletion] Add support for static analyzer flags This reverts commit r311552 because it broke ubsan and asan bots. Modified: cfe/trunk

Re: r306127 - [GSoC] Add support for CC1 options.

2017-06-26 Thread Rui Ueyama via cfe-commits
On Mon, Jun 26, 2017 at 10:17 PM, Saleem Abdulrasool via cfe-commits < cfe-commits@lists.llvm.org> wrote: > I think that we shouldn't be providing completion for `-cc1` options. > `-cc1as` options are fine as the IAS serves as a replacement for the > traditional unix `as`. But, the `NoDriverOpti

r306116 - Sort the autocomplete candidates before printing them out.

2017-06-23 Thread Rui Ueyama via cfe-commits
Author: ruiu Date: Fri Jun 23 10:37:52 2017 New Revision: 306116 URL: http://llvm.org/viewvc/llvm-project?rev=306116&view=rev Log: Sort the autocomplete candidates before printing them out. Currently, autocompleted options are displayed in the same order as we wrote them in .td files. This patch

r305930 - Use -NOT prefix instead of adding `not` to FileCheck.

2017-06-21 Thread Rui Ueyama via cfe-commits
Author: ruiu Date: Wed Jun 21 11:50:38 2017 New Revision: 305930 URL: http://llvm.org/viewvc/llvm-project?rev=305930&view=rev Log: Use -NOT prefix instead of adding `not` to FileCheck. If we want to make sure that a particular string is not in an output, the regular way of doing it is to add `-NO

Re: [PATCH] D33726: [driver][netbsd] Build and pass `-L` arguments to the linker

2017-06-08 Thread Rui Ueyama via cfe-commits
I don't remember the details, but I believe LLD-generated executables are fine with either Linux or on NetBSD On Thu, Jun 8, 2017 at 3:08 PM, Kamil Rytarowski wrote: > On 08.06.2017 22:39, Rui Ueyama wrote: > > On Wed, Jun 7, 2017 at 6:55 AM, Joerg Sonnenberger via Phabricator > > mailto:revi...

Re: [PATCH] D33726: [driver][netbsd] Build and pass `-L` arguments to the linker

2017-06-08 Thread Rui Ueyama via cfe-commits
On Wed, Jun 7, 2017 at 6:55 AM, Joerg Sonnenberger via Phabricator < revi...@reviews.llvm.org> wrote: > joerg added a comment. > > In https://reviews.llvm.org/D33726#774105, @ruiu wrote: > > > I'm totally against adding per-OS path knowledge to our linker. > Compilers already know include paths an

r301491 - Revert r301487: Replace HashString algorithm with xxHash64

2017-04-26 Thread Rui Ueyama via cfe-commits
Author: ruiu Date: Wed Apr 26 18:15:10 2017 New Revision: 301491 URL: http://llvm.org/viewvc/llvm-project?rev=301491&view=rev Log: Revert r301487: Replace HashString algorithm with xxHash64 This reverts commit r301487 to make buildbots green. Modified: cfe/trunk/test/CodeGen/target-features-

r301487 - Replace HashString algorithm with xxHash64

2017-04-26 Thread Rui Ueyama via cfe-commits
Author: ruiu Date: Wed Apr 26 17:45:04 2017 New Revision: 301487 URL: http://llvm.org/viewvc/llvm-project?rev=301487&view=rev Log: Replace HashString algorithm with xxHash64 The previous algorithm processed one character at a time, which is very painful on a modern CPU. Replace it with xxHash64,

Re: [PATCH] D31591: Fix a bug which access nullptr and cause segmentation fault

2017-04-12 Thread Rui Ueyama via cfe-commits
It seems to me the test have already been simplified enough, so I'm not quite sure what you are trying to do more than this. Isn't this just ready to submit? On Wed, Apr 12, 2017 at 5:46 PM, Yuka Takahashi via Phabricator < revi...@reviews.llvm.org> wrote: > yamaguchi updated this revision to Dif

Re: r294879 - [Driver] Use stem() and not filename().

2017-02-11 Thread Rui Ueyama via cfe-commits
On Sat, Feb 11, 2017 at 3:44 PM, Davide Italiano via cfe-commits < cfe-commits@lists.llvm.org> wrote: > Author: davide > Date: Sat Feb 11 17:44:37 2017 > New Revision: 294879 > > URL: http://llvm.org/viewvc/llvm-project?rev=294879&view=rev > Log: > [Driver] Use stem() and not filename(). > > On Wi

r285162 - Use printf instead of "echo -ne".

2016-10-25 Thread Rui Ueyama via cfe-commits
Author: ruiu Date: Tue Oct 25 22:38:48 2016 New Revision: 285162 URL: http://llvm.org/viewvc/llvm-project?rev=285162&view=rev Log: Use printf instead of "echo -ne". Not all echo commands support "-e". Modified: cfe/trunk/test/Driver/response-file-extra-whitespace.c Modified: cfe/trunk/test/

Re: r284137 - [ThinLTO] Update doc to include lld (now supported).

2016-10-17 Thread Rui Ueyama via cfe-commits
Agreed. We should define them as aliases to existing options without -plugin-opt. On Sun, Oct 16, 2016 at 6:43 PM, Sean Silva via cfe-commits < cfe-commits@lists.llvm.org> wrote: > Nice to see this land! > > One nit: > Currently, doesn't LLD/ELF ignore -plugin-opt? That will mean that if a > user

[PATCH] D25579: [codeview] emit debug info for indirect virtual base classes

2016-10-13 Thread Rui Ueyama via cfe-commits
ruiu added inline comments. Comment at: lib/CodeGen/CGDebugInfo.cpp:1392 +auto *BaseTy = getOrCreateType(BI.getType(), Unit); +if (SeenTypes.find(BaseTy) != SeenTypes.end()) + continue; zturner wrote: > rnk wrote: > > IMO `SeenTypes.count(...)` would

Re: r272701 - Rename Intrin.h to intrin.h, that's how all the documentation calls it.

2016-06-14 Thread Rui Ueyama via cfe-commits
Hans seems to fix it in r272701. On Tue, Jun 14, 2016 at 1:26 PM, Vitaly Buka via cfe-commits < cfe-commits@lists.llvm.org> wrote: > Probably the bot was broken by this CL > http://lab.llvm.org:8011/builders/sanitizer-x86_64-linux-fuzzer/builds/9922 > > On Tue, Jun 14, 2016 at 1:03 PM Nico Weber

Re: Don't pass --build-id by default.

2016-06-02 Thread Rui Ueyama via cfe-commits
I'm not a person who can sign it off, but it looks good to me. On Thu, Jun 2, 2016 at 3:55 PM, Rafael EspĂ­ndola wrote: > We do it just because gcc in some distributions do it. > > I can see why --build-id is useful for distributions, but given the > cost on day to day edit+build cycles, any dist

r257802 - Update for LLVM function name change.

2016-01-14 Thread Rui Ueyama via cfe-commits
Author: ruiu Date: Thu Jan 14 15:00:27 2016 New Revision: 257802 URL: http://llvm.org/viewvc/llvm-project?rev=257802&view=rev Log: Update for LLVM function name change. Modified: cfe/trunk/include/clang/AST/CharUnits.h cfe/trunk/include/clang/AST/StmtOpenMP.h cfe/trunk/include/clang/A

Re: [PATCH] D15953: Driver: Pass -flavor gnu to lld for AMDGPU rather than -flavor gnu-old

2016-01-07 Thread Rui Ueyama via cfe-commits
ruiu accepted this revision. ruiu added a comment. This revision is now accepted and ready to land. LGTM http://reviews.llvm.org/D15953 ___ cfe-commits mailing list cfe-commits@lists.llvm.org http://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-commit

Re: [PATCH] D15953: Driver: Pass -flavor gnu to lld for AMDGPU rather than -flavor gnu-old

2016-01-07 Thread Rui Ueyama via cfe-commits
ruiu added a comment. You can use "ld.lld" which is a symlink to lld instead of "lld -flavor gnu". http://reviews.llvm.org/D15953 ___ cfe-commits mailing list cfe-commits@lists.llvm.org http://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-commits

Re: r248433 - [CUDA] Added CUDA installation detector class.

2015-09-23 Thread Rui Ueyama via cfe-commits
I don't know the exact condition, but here's my results. OK $ bin/clang -v -target=i386-unknown-linux --sysroot=/tmp/x/CUDA clang-3.7: error: unknown argument: '-target=i386-unknown-linux' clang version 3.8.0

Re: r248433 - [CUDA] Added CUDA installation detector class.

2015-09-23 Thread Rui Ueyama via cfe-commits
Yes I can. Create a deep nested directly, create a symlink from there to your Inputs/CUDA, and run "clang -v --target=i386-unknown-linux --sysroot=/Inputs/CUDA". On Wed, Sep 23, 2015 at 4:47 PM, Artem Belevich wrote: > I'm looking into it. Can you reproduce it on linux? > > > On Wed, Sep 23, 201

Re: r248433 - [CUDA] Added CUDA installation detector class.

2015-09-23 Thread Rui Ueyama via cfe-commits
On Wed, Sep 23, 2015 at 2:49 PM, Artem Belevich via cfe-commits < cfe-commits@lists.llvm.org> wrote: > Author: tra > Date: Wed Sep 23 16:49:39 2015 > New Revision: 248433 > > URL: http://llvm.org/viewvc/llvm-project?rev=248433&view=rev > Log: > [CUDA] Added CUDA installation detector class. > > Ad

Re: [PATCH] D12695: [Driver] Use UniversalCRT on Windows if available

2015-09-10 Thread Rui Ueyama via cfe-commits
ruiu added a comment. I'm sorry about leave http://reviews.llvm.org/D12604 hanging. I didn't notice that it got a new review message. Don't mind my patch -- please just submit when you got LGTM http://reviews.llvm.org/D12695 ___ cfe-commits mailin