[PATCH] D106793: [OpenMP] Add a driver flag to enable the new device runtime library

2021-07-26 Thread Joseph Huber via Phabricator via cfe-commits
This revision was landed with ongoing or failed builds. This revision was automatically updated to reflect the committed changes. Closed by commit rGd2972116923a: [OpenMP] Add a driver flag to enable the new device runtime library (authored by jhuber6). Repository: rG LLVM Github Monorepo

[PATCH] D106793: [OpenMP] Add a driver flag to enable the new device runtime library

2021-07-26 Thread Johannes Doerfert via Phabricator via cfe-commits
jdoerfert accepted this revision. jdoerfert added a comment. This revision is now accepted and ready to land. In D106793#2904771 , @JonChesterfield wrote: > Can we call this something other than new? We don't tend to remove command > line arguments and

[PATCH] D106793: [OpenMP] Add a driver flag to enable the new device runtime library

2021-07-26 Thread Johannes Doerfert via Phabricator via cfe-commits
jdoerfert added a comment. > I think changing the BC name is something we can do any time, so just calling > it libomptarget-new is fine for now. Yes, let's not disrupt old workflows. The "default" runtime keeps it's name always and we swap it out at some point and remove the option (or make

[PATCH] D106793: [OpenMP] Add a driver flag to enable the new device runtime library

2021-07-26 Thread Ye Luo via Phabricator via cfe-commits
ye-luo added a comment. In D106793#2904943 , @jhuber6 wrote: > In D106793#2904661 , @ye-luo wrote: > >> Not clear from the summary what is the new driver option. > > It's a rewrite of the current device runtime.

[PATCH] D106793: [OpenMP] Add a driver flag to enable the new device runtime library

2021-07-26 Thread Joseph Huber via Phabricator via cfe-commits
jhuber6 added a comment. In D106793#2904661 , @ye-luo wrote: > Not clear from the summary what is the new driver option. It's a rewrite of the current device runtime. This option will enable it. In D106793#2904771

[PATCH] D106793: [OpenMP] Add a driver flag to enable the new device runtime library

2021-07-26 Thread Jon Chesterfield via Phabricator via cfe-commits
JonChesterfield added inline comments. Comment at: clang/lib/Driver/ToolChains/AMDGPUOpenMP.cpp:229 + options::OPT_fno_openmp_target_new_runtime, false)) +BitcodeSuffix = "new-amdgcn-" + GPUArch; + else Likewise here, how about

[PATCH] D106793: [OpenMP] Add a driver flag to enable the new device runtime library

2021-07-26 Thread Jon Chesterfield via Phabricator via cfe-commits
JonChesterfield added a comment. Can we call this something other than new? We don't tend to remove command line arguments and this won't make much sense once it's the only runtime. I'd be inclined to add an argument called 'use_legacy_runtime' or similar, which defaults to true Repository:

[PATCH] D106793: [OpenMP] Add a driver flag to enable the new device runtime library

2021-07-26 Thread Ye Luo via Phabricator via cfe-commits
ye-luo added a comment. Not clear from the summary what is the new driver option. Repository: rG LLVM Github Monorepo CHANGES SINCE LAST ACTION https://reviews.llvm.org/D106793/new/ https://reviews.llvm.org/D106793 ___ cfe-commits mailing list

[PATCH] D106793: [OpenMP] Add a driver flag to enable the new device runtime library

2021-07-26 Thread Joseph Huber via Phabricator via cfe-commits
jhuber6 updated this revision to Diff 361667. jhuber6 added a comment. Adding test Repository: rG LLVM Github Monorepo CHANGES SINCE LAST ACTION https://reviews.llvm.org/D106793/new/ https://reviews.llvm.org/D106793 Files: clang/include/clang/Basic/LangOptions.def

[PATCH] D106793: [OpenMP] Add a driver flag to enable the new device runtime library

2021-07-26 Thread Johannes Doerfert via Phabricator via cfe-commits
jdoerfert added a comment. We need a driver test. Repository: rG LLVM Github Monorepo CHANGES SINCE LAST ACTION https://reviews.llvm.org/D106793/new/ https://reviews.llvm.org/D106793 ___ cfe-commits mailing list cfe-commits@lists.llvm.org

[PATCH] D106793: [OpenMP] Add a driver flag to enable the new device runtime library

2021-07-26 Thread Joseph Huber via Phabricator via cfe-commits
jhuber6 created this revision. jhuber6 added reviewers: jdoerfert, tianshilei1992. Herald added subscribers: dexonsmith, dang, kerbowa, guansong, yaxunl, nhaehnle, jvesely. jhuber6 requested review of this revision. Herald added subscribers: cfe-commits, sstefan1. Herald added a project: clang.