[PATCH] D32333: [clang-tidy] Update IdentifierNamingCheck to remove extra leading/trailing underscores

2017-04-26 Thread Alexander Kornienko via Phabricator via cfe-commits
This revision was automatically updated to reflect the committed changes. Closed by commit rL301431: [clang-tidy] Update IdentifierNamingCheck to remove extra leading/trailing… (authored by alexfh). Changed prior to commit: https://reviews.llvm.org/D32333?vs=96762=96771#toc Repository: rL

[PATCH] D32333: [clang-tidy] Update IdentifierNamingCheck to remove extra leading/trailing underscores

2017-04-26 Thread Alexander Kornienko via Phabricator via cfe-commits
alexfh added a comment. In https://reviews.llvm.org/D32333#738266, @jtbandes wrote: > Done, thanks for the review! > > What is the procedure for merging patches in? I'm sure I don't have > permissions to do it myself. I'll commit the patch for you. Thank you for working on this!

[PATCH] D32333: [clang-tidy] Update IdentifierNamingCheck to remove extra leading/trailing underscores

2017-04-26 Thread Jacob Bandes-Storch via Phabricator via cfe-commits
jtbandes marked an inline comment as done. jtbandes added a comment. Done, thanks for the review! What is the procedure for merging patches in? I'm sure I don't have permissions to do it myself. https://reviews.llvm.org/D32333 ___ cfe-commits

[PATCH] D32333: [clang-tidy] Update IdentifierNamingCheck to remove extra leading/trailing underscores

2017-04-26 Thread Jacob Bandes-Storch via Phabricator via cfe-commits
jtbandes updated this revision to Diff 96762. jtbandes added a comment. Fixed nit https://reviews.llvm.org/D32333 Files: clang-tidy/readability/IdentifierNamingCheck.cpp test/clang-tidy/readability-identifier-naming.cpp Index: test/clang-tidy/readability-identifier-naming.cpp

[PATCH] D32333: [clang-tidy] Update IdentifierNamingCheck to remove extra leading/trailing underscores

2017-04-26 Thread Alexander Kornienko via Phabricator via cfe-commits
alexfh accepted this revision. alexfh added a comment. This revision is now accepted and ready to land. LG with a nit. Comment at: clang-tidy/readability/IdentifierNamingCheck.cpp:378 + StringRef Mid = StringRef(Fixed).trim("_"); + if (Mid.size() == 0) +Mid = "_";

[PATCH] D32333: [clang-tidy] Update IdentifierNamingCheck to remove extra leading/trailing underscores

2017-04-21 Thread Jacob Bandes-Storch via Phabricator via cfe-commits
jtbandes updated this revision to Diff 96181. jtbandes added a comment. Cleanup https://reviews.llvm.org/D32333 Files: clang-tidy/readability/IdentifierNamingCheck.cpp test/clang-tidy/readability-identifier-naming.cpp Index: test/clang-tidy/readability-identifier-naming.cpp

[PATCH] D32333: [clang-tidy] Update IdentifierNamingCheck to remove extra leading/trailing underscores

2017-04-21 Thread Jacob Bandes-Storch via Phabricator via cfe-commits
jtbandes updated this revision to Diff 96180. jtbandes edited the summary of this revision. jtbandes added a comment. Remove unnecessary checks for empty prefix/suffix https://reviews.llvm.org/D32333 Files: clang-tidy/readability/IdentifierNamingCheck.cpp

[PATCH] D32333: [clang-tidy] Update IdentifierNamingCheck to remove extra leading/trailing underscores

2017-04-20 Thread Jacob Bandes-Storch via Phabricator via cfe-commits
jtbandes created this revision. The goal of this change is to fix the following suboptimal replacements currently suggested by clang-tidy: // with MemberPrefix == "_" int __foo; // accepted without complaint // with MemberPrefix == "m_" int _foo; ^~ m__foo I fixed