Re: [PATCH] D24484: [analyzer] Fix ExprEngine::VisitMemberExpr

2016-09-13 Thread Saleem Abdulrasool via cfe-commits
compnerd added inline comments. Comment at: test/Analysis/array-struct.c:147 @@ +146,3 @@ + bar(((gets3().a))); +} + Perhaps Im missing something, but theres no change to actually verify the output? Repository: rL LLVM https://reviews.llvm.org/D24484

Re: [PATCH] D24469: [clang-cl] Diagnose duplicate uuids.

2016-09-13 Thread Nico Weber via cfe-commits
thakis marked 2 inline comments as done. thakis added a comment. In https://reviews.llvm.org/D24469#540400, @majnemer wrote: > Does __uuidof walk bases to find [uuid] in cl.exe? They walk bases for the > __declspec spelling. As far as I can tell, they don't for either:

Re: [PATCH] D23820: Do not warn about format strings that are indexed string literals.

2016-09-13 Thread Stephen Hines via cfe-commits
srhines added a comment. My comment is mostly naming considerations to improve clarity. I do have concerns though about the unhandled else path. Comment at: lib/Sema/SemaChecking.cpp:3842 @@ -3841,2 +3841,3 @@ -static void CheckFormatString(Sema , const StringLiteral *FExpr,

[libunwind] r281346 - [3.9.1] Merge r279871 - [ARM] Adding .arch directives around WMMX unwind code

2016-09-13 Thread Renato Golin via cfe-commits
Author: rengolin Date: Tue Sep 13 10:40:36 2016 New Revision: 281346 URL: http://llvm.org/viewvc/llvm-project?rev=281346=rev Log: [3.9.1] Merge r279871 - [ARM] Adding .arch directives around WMMX unwind code Modified: libunwind/branches/release_39/src/UnwindRegistersRestore.S

Re: [PATCH] D24467: Fix an error after D21678

2016-09-13 Thread Vladimir Yakovlev via cfe-commits
vbyakovlcl removed rL LLVM as the repository for this revision. vbyakovlcl changed the visibility of this Differential Revision from "All Users" to "Public (No Login Required)". vbyakovlcl updated this revision to Diff 71135. https://reviews.llvm.org/D24467 Files:

Re: [PATCH] D23901: Minor cleanup of the class CallStackFrame

2016-09-13 Thread Reid Kleckner via cfe-commits
rnk accepted this revision. rnk added a comment. This revision is now accepted and ready to land. lgtm Repository: rL LLVM https://reviews.llvm.org/D23901 ___ cfe-commits mailing list cfe-commits@lists.llvm.org

Re: [PATCH] D24268: Traversing template paramter lists of DeclaratorDecls and/or TagDecls.

2016-09-13 Thread Nico Weber via cfe-commits
thakis added a subscriber: thakis. thakis added a comment. landed in r281345. https://reviews.llvm.org/D24268 ___ cfe-commits mailing list cfe-commits@lists.llvm.org http://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-commits

r281345 - Traversing template paramter lists of DeclaratorDecls and/or TagDecls.

2016-09-13 Thread Nico Weber via cfe-commits
Author: nico Date: Tue Sep 13 10:05:04 2016 New Revision: 281345 URL: http://llvm.org/viewvc/llvm-project?rev=281345=rev Log: Traversing template paramter lists of DeclaratorDecls and/or TagDecls. The unit tests in this patch demonstrate the need to traverse template parameter lists of

r281344 - Remove redundant comma around parenthesis in parameter list.

2016-09-13 Thread Eric Liu via cfe-commits
Author: ioeric Date: Tue Sep 13 10:02:43 2016 New Revision: 281344 URL: http://llvm.org/viewvc/llvm-project?rev=281344=rev Log: Remove redundant comma around parenthesis in parameter list. Reviewers: djasper Subscribers: cfe-commits, klimek Differential Revision:

Re: [PATCH] D24501: Remove redundant comma around parenthesis in parameter list.

2016-09-13 Thread Eric Liu via cfe-commits
This revision was automatically updated to reflect the committed changes. Closed by commit rL281344: Remove redundant comma around parenthesis in parameter list. (authored by ioeric). Changed prior to commit: https://reviews.llvm.org/D24501?vs=71174=71175#toc Repository: rL LLVM

Re: [PATCH] D24501: Remove redundant comma around parenthesis in parameter list.

2016-09-13 Thread Eric Liu via cfe-commits
ioeric added inline comments. Comment at: unittests/Format/CleanupTest.cpp:125 @@ -123,7 +124,3 @@ std::string Expected = "class A {\nA() {} };"; - std::vector Ranges; - Ranges.push_back(tooling::Range(17, 0)); - Ranges.push_back(tooling::Range(19, 0)); - std::string

Re: [PATCH] D24501: Remove redundant comma around parenthesis in parameter list.

2016-09-13 Thread Eric Liu via cfe-commits
ioeric updated this revision to Diff 71174. ioeric marked 2 inline comments as done. ioeric added a comment. - Minor cleanup. https://reviews.llvm.org/D24501 Files: lib/Format/Format.cpp unittests/Format/CleanupTest.cpp Index: unittests/Format/CleanupTest.cpp

Re: [PATCH] D24501: Remove redundant comma around parenthesis in parameter list.

2016-09-13 Thread Daniel Jasper via cfe-commits
djasper accepted this revision. djasper added a comment. This revision is now accepted and ready to land. Some remarks, but looks good. Comment at: unittests/Format/CleanupTest.cpp:38 @@ +37,3 @@ + // Returns code after cleanup around \p Offsets. + std::string

[PATCH] D24508: PR28752: Do not instantiate var decls which are not visible.

2016-09-13 Thread Vassil Vassilev via cfe-commits
v.g.vassilev created this revision. v.g.vassilev added a reviewer: rsmith. v.g.vassilev added a subscriber: cfe-commits. v.g.vassilev set the repository for this revision to rL LLVM. Repository: rL LLVM https://reviews.llvm.org/D24508 Files: lib/Sema/SemaTemplate.cpp

[PATCH] D24507: Add attribute for return values that shouldn't be cast to bool

2016-09-13 Thread Anton Urusov via cfe-commits
urusant created this revision. urusant added reviewers: zaks.anna, dcoughlin, jordan_rose, NoQ. urusant added subscribers: cfe-commits, daviddrysdale. urusant set the repository for this revision to rL LLVM. Herald added subscribers: mgorny, beanz. Hi, I am interested in feedback on a patch I

Re: [PATCH] D24501: Remove redundant comma around parenthesis in parameter list.

2016-09-13 Thread Eric Liu via cfe-commits
ioeric added inline comments. Comment at: unittests/Format/CleanupTest.cpp:147 @@ +146,3 @@ + // Trailing comma in braces is not removed. + std::string Code = "void f() { std::vector v = {1,2,,,3,{4,5,}}; }"; + std::string Expected = "void f() { std::vector v = {1,2,3,{4,5,}};

Re: [PATCH] D24501: Remove redundant comma around parenthesis in parameter list.

2016-09-13 Thread Eric Liu via cfe-commits
ioeric updated this revision to Diff 71158. ioeric marked an inline comment as done. ioeric added a comment. - Refactored cleanup unittest; added more test cases for trailing commas. https://reviews.llvm.org/D24501 Files: lib/Format/Format.cpp unittests/Format/CleanupTest.cpp Index:

Re: [PATCH] D23901: Minor cleanup of the class CallStackFrame

2016-09-13 Thread Alexander Shaposhnikov via cfe-commits
alexshap added a comment. ping Repository: rL LLVM https://reviews.llvm.org/D23901 ___ cfe-commits mailing list cfe-commits@lists.llvm.org http://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-commits

Re: [PATCH] D24501: Remove redundant comma around parenthesis in parameter list.

2016-09-13 Thread Daniel Jasper via cfe-commits
djasper added inline comments. Comment at: unittests/Format/CleanupTest.cpp:147 @@ +146,3 @@ + // Trailing comma in braces is not removed. + std::string Code = "void f() { std::vector v = {1,2,,,3,{4,5,}}; }"; + std::string Expected = "void f() { std::vector v =

[PATCH] D24501: Remove redundant comma around parenthesis in parameter list.

2016-09-13 Thread Eric Liu via cfe-commits
ioeric created this revision. ioeric added a reviewer: djasper. ioeric added a subscriber: cfe-commits. Herald added a subscriber: klimek. https://reviews.llvm.org/D24501 Files: lib/Format/Format.cpp unittests/Format/CleanupTest.cpp Index: unittests/Format/CleanupTest.cpp

Re: [PATCH] D24470: [analyzer] scan-build-py: Remove relative path hack for SATestsBuild.py

2016-09-13 Thread Laszlo Nagy via cfe-commits
rizsotto.mailinglist accepted this revision. rizsotto.mailinglist added a comment. This revision is now accepted and ready to land. thanks Devin, i like smaller code, have no problem with this change. :) about the file/directory paths: i agree that the situation is not ideal. but there are/were

[PATCH] D24500: [clang-tidy] Bugfix for readability-redundant-control-flow check

2016-09-13 Thread Malcolm Parsons via cfe-commits
malcolm.parsons created this revision. malcolm.parsons added reviewers: sbenza, aaron.ballman, alexfh. malcolm.parsons added subscribers: Eugene.Zelenko, cfe-commits, beanz. This check did not create FixItHints when the statement before the redundant control flow was not followed by a semicolon.

Re: [PATCH] D24183: A clang tool for changing surrouding namespaces of class/function definitions.

2016-09-13 Thread Eric Liu via cfe-commits
ioeric added inline comments. Comment at: change-namespace/ChangeNamespace.cpp:359 @@ +358,3 @@ + End, tok::semi, *Result.SourceManager, Result.Context->getLangOpts(), + /*SkipTrailingWhitespaceAndNewLine=*/true); + if (AfterSemi.isValid()) omtcyfz

r281316 - Revert accidentally checked in change in r281315.

2016-09-13 Thread Vassil Vassilev via cfe-commits
Author: vvassilev Date: Tue Sep 13 05:38:26 2016 New Revision: 281316 URL: http://llvm.org/viewvc/llvm-project?rev=281316=rev Log: Revert accidentally checked in change in r281315. Modified: cfe/trunk/lib/Sema/SemaLookup.cpp Modified: cfe/trunk/lib/Sema/SemaLookup.cpp URL:

Re: [PATCH] D24183: A clang tool for changing surrouding namespaces of class/function definitions.

2016-09-13 Thread Eric Liu via cfe-commits
ioeric updated this revision to Diff 71126. ioeric marked 13 inline comments as done. ioeric added a comment. Herald added a subscriber: mgorny. - Minor cleanup. https://reviews.llvm.org/D24183 Files: CMakeLists.txt change-namespace/CMakeLists.txt change-namespace/ChangeNamespace.cpp

Re: [PATCH] D24349: [clang-tidy] Extend readability-container-size-empty to arbitrary class with size() and empty()

2016-09-13 Thread Kirill Bobyrev via cfe-commits
This revision was automatically updated to reflect the committed changes. Closed by commit rL281307: [clang-tidy] Extend readability-container-size-empty to arbitrary class with… (authored by omtcyfz). Changed prior to commit: https://reviews.llvm.org/D24349?vs=71119=71120#toc Repository:

[clang-tools-extra] r281307 - [clang-tidy] Extend readability-container-size-empty to arbitrary class with size() and empty()

2016-09-13 Thread Kirill Bobyrev via cfe-commits
Author: omtcyfz Date: Tue Sep 13 03:58:11 2016 New Revision: 281307 URL: http://llvm.org/viewvc/llvm-project?rev=281307=rev Log: [clang-tidy] Extend readability-container-size-empty to arbitrary class with size() and empty() This patch extends readability-container-size-empty check allowing it

Re: [PATCH] D24349: [clang-tidy] Extend readability-container-size-empty to arbitrary class with size() and empty()

2016-09-13 Thread Kirill Bobyrev via cfe-commits
omtcyfz updated this revision to Diff 71119. omtcyfz marked an inline comment as done. omtcyfz added a comment. Combine two `returns` matchers. https://reviews.llvm.org/D24349 Files: clang-tidy/readability/ContainerSizeEmptyCheck.cpp

Re: [PATCH] D24005: [compiler-rt cmake] Support overriding llvm-config query results

2016-09-13 Thread Michał Górny via cfe-commits
mgorny added a comment. In https://reviews.llvm.org/D24005#540803, @Hahnfeld wrote: > In https://reviews.llvm.org/D24005#540200, @mgorny wrote: > > > And done. > > > I think @beanz meant to actually do the renames for consistency... Sorry for > the confusion! I know but I feel like it's a

Re: [PATCH] D24349: [clang-tidy] Extend readability-container-size-empty to arbitrary class with size() and empty()

2016-09-13 Thread Alexander Kornienko via cfe-commits
alexfh accepted this revision. alexfh added a comment. This revision is now accepted and ready to land. LG Comment at: clang-tidy/readability/ContainerSizeEmptyCheck.cpp:35 @@ +34,3 @@ + hasName("size"), returns(isInteger()), +

Re: [PATCH] D24380: [migrate-tool] Framework for a codebase-dependent migration tool.

2016-09-13 Thread Eric Liu via cfe-commits
ioeric added inline comments. Comment at: migrate-tool/HeaderBuild.h:29 @@ +28,3 @@ + + std::string generateContent() const; + klimek wrote: > This all needs more comments :) > I assume we'll also need to somehow give this a "style" at some point? Or >

Re: [PATCH] D24380: [migrate-tool] Framework for a codebase-dependent migration tool.

2016-09-13 Thread Eric Liu via cfe-commits
ioeric updated this revision to Diff 71116. ioeric marked 13 inline comments as done. ioeric added a comment. Herald added a subscriber: mgorny. - Addressed review comments. - Separate getAffectedFiles into its own interface. https://reviews.llvm.org/D24380 Files: CMakeLists.txt

Re: [PATCH] D24069: Document option '-rtlib' in clang's man page and help info

2016-09-13 Thread Jonas Hahnfeld via cfe-commits
Hahnfeld added a comment. @zlei will you commit the patch or do you want me to do that on your behalf? https://reviews.llvm.org/D24069 ___ cfe-commits mailing list cfe-commits@lists.llvm.org

Re: [PATCH] D24005: [compiler-rt cmake] Support overriding llvm-config query results

2016-09-13 Thread Jonas Hahnfeld via cfe-commits
Hahnfeld added a comment. In https://reviews.llvm.org/D24005#540200, @mgorny wrote: > And done. I think @beanz meant to actually do the renames for consistency... Sorry for the confusion! https://reviews.llvm.org/D24005 ___ cfe-commits mailing

Re: [PATCH] D24193: Allow variables with asm labels in naked functions

2016-09-13 Thread Nikola Smiljanić via cfe-commits
nikola closed this revision. nikola added a comment. r281298 https://reviews.llvm.org/D24193 ___ cfe-commits mailing list cfe-commits@lists.llvm.org http://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-commits

r281298 - Allow register variables in naked functions.

2016-09-13 Thread Nikola Smiljanic via cfe-commits
Author: nikola Date: Tue Sep 13 02:02:02 2016 New Revision: 281298 URL: http://llvm.org/viewvc/llvm-project?rev=281298=rev Log: Allow register variables in naked functions. Modified: cfe/trunk/lib/Sema/SemaDecl.cpp cfe/trunk/test/Sema/attr-naked.c Modified:

Re: [PATCH] D24319: clang-format: Add a flag to limit git-clang-format's diff to a single commit

2016-09-13 Thread Luis Héctor Chávez via cfe-commits
lhchavez marked 2 inline comments as done. Comment at: cfe/trunk/tools/clang-format/git-clang-format:323 @@ -312,1 +322,3 @@ +def create_tree_from_commit(commit, filenames): + """Create a new git tree with the given files from `commit`. lhchavez wrote: >

<    1   2