[clang] 7cffaf5 - [X89] Ignore -mtune=generic to fix failures some users are seeing after D85384

2020-08-19 Thread Craig Topper via cfe-commits
Author: Craig Topper Date: 2020-08-19T13:17:57-07:00 New Revision: 7cffaf510f97eabef89b0d45aeb939df40e8e9d3 URL: https://github.com/llvm/llvm-project/commit/7cffaf510f97eabef89b0d45aeb939df40e8e9d3 DIFF: https://github.com/llvm/llvm-project/commit/7cffaf510f97eabef89b0d45aeb939df40e8e9d3.diff

[PATCH] D86193: [CSSPGO] Pseudo probe instrumentation for basic blocks.

2020-08-19 Thread David Li via Phabricator via cfe-commits
davidxl added a comment. A heads up -- I won't be able to review patch until mid Sept. Hope this is fine. Repository: rG LLVM Github Monorepo CHANGES SINCE LAST ACTION https://reviews.llvm.org/D86193/new/ https://reviews.llvm.org/D86193 ___

[PATCH] D86029: [analyzer] Add modeling for unque_ptr::get()

2020-08-19 Thread Nithin VR via Phabricator via cfe-commits
vrnithinkumar updated this revision to Diff 286675. vrnithinkumar edited the summary of this revision. vrnithinkumar added a comment. - Using conjureSymbolVal in case of missing inner pointer value Repository: rG LLVM Github Monorepo CHANGES SINCE LAST ACTION

[PATCH] D83211: Factor out call to EXTRACTOR in generateCC1CommandLine

2020-08-19 Thread Michael Spencer via Phabricator via cfe-commits
Bigcheese added inline comments. Comment at: clang/lib/Frontend/CompilerInvocation.cpp:3938 + if ((FLAGS)::CC1Option) { \ +const auto = EXTRACTOR(this->KEYPATH); \ +if (ALWAYS_EMIT || Extracted !=

[PATCH] D83298: Add ability to make fixups to CompilerInvocation after option parsing

2020-08-19 Thread Michael Spencer via Phabricator via cfe-commits
Bigcheese accepted this revision. Bigcheese added a comment. This revision is now accepted and ready to land. lgtm. Repository: rG LLVM Github Monorepo CHANGES SINCE LAST ACTION https://reviews.llvm.org/D83298/new/ https://reviews.llvm.org/D83298

[PATCH] D81083: [Clang] Allow "vector_size" applied to Booleans

2020-08-19 Thread Kazushi Marukawa via Phabricator via cfe-commits
kaz7 added a comment. Thank you preparing this i1 patch and doing it on clang side only. We were testing this patch and sending problem reports. Now, we can use this patch without modifying llvm code. We can define vector mask types like below. Then, we can define intrinsic functions using

[PATCH] D85031: [builtins] Unify the softfloat division implementation

2020-08-19 Thread Anatoly Trosinenko via Phabricator via cfe-commits
atrosinenko updated this revision to Diff 286516. atrosinenko added a comment. Rebase the entire patch stack against the up-to-date master and re-upload. Repository: rG LLVM Github Monorepo CHANGES SINCE LAST ACTION https://reviews.llvm.org/D85031/new/ https://reviews.llvm.org/D85031

[PATCH] D84932: [builtins] Add more test cases for __div[sdt]f3 LibCalls

2020-08-19 Thread Anatoly Trosinenko via Phabricator via cfe-commits
atrosinenko updated this revision to Diff 286514. atrosinenko added a comment. Rebase the entire patch stack against the up-to-date master and re-upload. Repository: rG LLVM Github Monorepo CHANGES SINCE LAST ACTION https://reviews.llvm.org/D84932/new/ https://reviews.llvm.org/D84932

[PATCH] D85032: [builtins] Make divXf3 handle denormal results

2020-08-19 Thread Anatoly Trosinenko via Phabricator via cfe-commits
atrosinenko updated this revision to Diff 286517. atrosinenko added a comment. Rebase the entire patch stack against the up-to-date master and re-upload. Repository: rG LLVM Github Monorepo CHANGES SINCE LAST ACTION https://reviews.llvm.org/D85032/new/ https://reviews.llvm.org/D85032

[PATCH] D85731: [NFC][builtins] Make softfloat-related errors less noisy

2020-08-19 Thread Anatoly Trosinenko via Phabricator via cfe-commits
atrosinenko updated this revision to Diff 286513. atrosinenko added a comment. Rebase the entire patch stack against the up-to-date master and re-upload. Repository: rG LLVM Github Monorepo CHANGES SINCE LAST ACTION https://reviews.llvm.org/D85731/new/ https://reviews.llvm.org/D85731

[clang] 0353848 - [Clang][SVE] NFC: Move info about ACLE types into separate function.

2020-08-19 Thread Sander de Smalen via cfe-commits
Author: Sander de Smalen Date: 2020-08-19T11:04:20+01:00 New Revision: 0353848cc94f0fc23a953f8f420be7ee3342c8dc URL: https://github.com/llvm/llvm-project/commit/0353848cc94f0fc23a953f8f420be7ee3342c8dc DIFF:

[PATCH] D86100: [Clang][SVE] NFC: Move info about ACLE types into separate function.

2020-08-19 Thread Sander de Smalen via Phabricator via cfe-commits
This revision was automatically updated to reflect the committed changes. Closed by commit rG0353848cc94f: [Clang][SVE] NFC: Move info about ACLE types into separate function. (authored by sdesmalen). Changed prior to commit: https://reviews.llvm.org/D86100?vs=286113=286520#toc Repository:

[PATCH] D86100: [Clang][SVE] NFC: Move info about ACLE types into separate function.

2020-08-19 Thread Sander de Smalen via Phabricator via cfe-commits
sdesmalen added inline comments. Comment at: clang/include/clang/AST/ASTContext.h:1318 + BuiltinVectorTypeInfo + getElementTypeForBuiltinVector(const BuiltinType *VecTy) const; + c-rhodes wrote: > nit: not sure on the name here since it's returning more than

[PATCH] D86101: [AArch64][SVE] Add missing debug info for ACLE types.

2020-08-19 Thread Richard Sandiford via Phabricator via cfe-commits
rsandifo-arm added inline comments. Comment at: clang/lib/CodeGen/CGDebugInfo.cpp:748 + llvm::DINodeArray SubscriptArray = DBuilder.getOrCreateArray(Subscript); + llvm::DIType *ElemTy = + getOrCreateType(Info.ElementType, TheCU->getFile()); I

[PATCH] D84932: [builtins] Add more test cases for __div[sdt]f3 LibCalls

2020-08-19 Thread Anatoly Trosinenko via Phabricator via cfe-commits
atrosinenko updated this revision to Diff 286523. atrosinenko added a comment. Fix the misleading comment. Repository: rG LLVM Github Monorepo CHANGES SINCE LAST ACTION https://reviews.llvm.org/D84932/new/ https://reviews.llvm.org/D84932 Files:

[PATCH] D84932: [builtins] Add more test cases for __div[sdt]f3 LibCalls

2020-08-19 Thread Anatoly Trosinenko via Phabricator via cfe-commits
atrosinenko added inline comments. Comment at: compiler-rt/test/builtins/Unit/divdf3_test.c:80 +// divisor is 1.0 as UQ1.31 +if (test__divdf3(0x1.0p+0, 0x1.0001p+0, UINT64_C(0x3fefffe0))) return 1; sepavloff wrote: > atrosinenko wrote:

<    1   2