r248659 - Remove move constructor and assignment operator from SourceMappingRegion. The types of the fields are trivially copyable. NFC

2015-09-25 Thread Craig Topper via cfe-commits
Author: ctopper Date: Sat Sep 26 00:10:16 2015 New Revision: 248659 URL: http://llvm.org/viewvc/llvm-project?rev=248659=rev Log: Remove move constructor and assignment operator from SourceMappingRegion. The types of the fields are trivially copyable. NFC Modified:

r248660 - Use None to avoid re-mentioning the ArrayRef type to call the default constructor.

2015-09-25 Thread Craig Topper via cfe-commits
Author: ctopper Date: Sat Sep 26 00:22:17 2015 New Revision: 248660 URL: http://llvm.org/viewvc/llvm-project?rev=248660=rev Log: Use None to avoid re-mentioning the ArrayRef type to call the default constructor. Modified: cfe/trunk/include/clang/Analysis/Analyses/ThreadSafetyTIL.h

Re: [PATCH] D12358: [Analyzer] Handling constant bound loops

2015-09-25 Thread Sean Eveson via cfe-commits
seaneveson added a comment. My initial approach was for the analyzer to have as much information as possible after the loop. This means there are cases where the information is incorrect. Future work would be to reduce these cases. I believe your preferred approach is to have no inaccuracies

r248578 - Revert "This patch adds missing pieces to clang, including the PS4 toolchain definition, added warnings, PS4 defaults, and Driver changes needed for our compiler."

2015-09-25 Thread Greg Bedwell via cfe-commits
Author: gbedwell Date: Fri Sep 25 11:11:00 2015 New Revision: 248578 URL: http://llvm.org/viewvc/llvm-project?rev=248578=rev Log: Revert "This patch adds missing pieces to clang, including the PS4 toolchain definition, added warnings, PS4 defaults, and Driver changes needed for our compiler."

Re: [PATCH] D11279: Initial patch for PS4 toolchain

2015-09-25 Thread NAKAMURA Takumi via cfe-commits
chapuni added a subscriber: chapuni. chapuni added a comment. Would this cause bunch of failures if target is *-ps4 and SDK_DIR is empty? clang-3.8: error: unable to find PS4 system headers directory, expected to be in

[PATCH] D13166: Create modernize-make-unique check.

2015-09-25 Thread Angel Garcia via cfe-commits
angelgarcia created this revision. angelgarcia added a reviewer: alexfh. angelgarcia added subscribers: klimek, cfe-commits. create a check that replaces 'std::unique_ptr(new type(args...))' with 'std::make_unique(args...)'. It was on the list of "Ideas for new Tools". It needs to be tested

Re: [PATCH] D13166: Create modernize-make-unique check.

2015-09-25 Thread Manuel Klimek via cfe-commits
klimek added a comment. This is definitely a useful check to have in modernize. Comment at: clang-tidy/modernize/MakeUniqueCheck.cpp:25-27 @@ +24,5 @@ + +/// \brief Returns the length of the token that goes since the beggining of the +/// constructor call until the '<' of the

Re: [PATCH] D13081: [clang-tidy] Implement FixitHints for identifier references in IdentifierNamingCheck

2015-09-25 Thread Alexander Kornienko via cfe-commits
alexfh added a comment. Awesome! This makes the check far more usable. See a few minor comments in-line. Comment at: clang-tidy/readability/IdentifierNamingCheck.cpp:140 @@ +139,3 @@ + Finder->addMatcher( + namedDecl(unless(isExpansionInSystemHeader())).bind("decl"),

Re: [PATCH] D12793: Three new security overflow builtins with generic argument types

2015-09-25 Thread John McCall via cfe-commits
rjmccall added a comment. X and Y aren't unreasonable for the operands, although you could also use "left" and "right" (or LHS/RHS), especially since it's significant for subtraction. R is short for "result" and should be spelled out. E is presumably short for "encompassing", but that is not

Re: [PATCH] D13171: [CUDA] Added a wrapper header for inclusion of stock CUDA headers.

2015-09-25 Thread Eli Bendersky via cfe-commits
eliben accepted this revision. eliben added a comment. This revision is now accepted and ready to land. lgtm http://reviews.llvm.org/D13171 ___ cfe-commits mailing list cfe-commits@lists.llvm.org

Re: [PATCH] D13079: [clang-tidy] Code factorization and cleanup in IdentifierNamingCheck

2015-09-25 Thread Alexander Kornienko via cfe-commits
alexfh accepted this revision. alexfh added a comment. This revision is now accepted and ready to land. Looks good with a few comments. Please tell me, if you need me to commit the patch for you after you address the comments. Comment at:

r248595 - Make incomplete type errors better with enable_if

2015-09-25 Thread George Burgess IV via cfe-commits
Author: gbiv Date: Fri Sep 25 12:53:16 2015 New Revision: 248595 URL: http://llvm.org/viewvc/llvm-project?rev=248595=rev Log: Make incomplete type errors better with enable_if This patch fixes the order in which we evaluate the different ways that a function call could be disallowed. Now, if you

r248596 - Fix bug on reporting availability of deleted methods in libclang.

2015-09-25 Thread Manuel Klimek via cfe-commits
Author: klimek Date: Fri Sep 25 12:53:16 2015 New Revision: 248596 URL: http://llvm.org/viewvc/llvm-project?rev=248596=rev Log: Fix bug on reporting availability of deleted methods in libclang. Patch by Sergey Kalinichev. Added: cfe/trunk/test/Index/availability.cpp Modified:

Re: [PATCH] D13171: [CUDA] Added a wrapper header for inclusion of stock CUDA headers.

2015-09-25 Thread Eli Bendersky via cfe-commits
eliben added inline comments. Comment at: lib/Headers/clang_cuda_support.h:53 @@ +52,3 @@ +// WARNING: Preprocessor hacks below are based on specific of +// implementation of CUDA-7.0 headers and are expected to break with +// any other version of CUDA headers.

Re: [PATCH] D13157: Teach -Wtautological-overlap-compare about enums

2015-09-25 Thread Aaron Ballman via cfe-commits
aaron.ballman accepted this revision. aaron.ballman added a reviewer: aaron.ballman. aaron.ballman added a comment. This revision is now accepted and ready to land. Thanks, I think this looks good (pending confirmation from Richard). ~Aaron http://reviews.llvm.org/D13157

Re: [PATCH] D12774: createUniqueFile() is documented to create the file in the temporary directory unless it's supplied an absolute path.Make sure the output filepath supplied to createUniqueFile() in

2015-09-25 Thread Cameron Esfahani via cfe-commits
dirty added a comment. Should I go ahead and commit this change? http://reviews.llvm.org/D12774 ___ cfe-commits mailing list cfe-commits@lists.llvm.org http://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-commits

Re: [PATCH] Change memcpy/memmove/memset to have dest and source alignment

2015-09-25 Thread Hal Finkel via cfe-commits
Hi Pete, Thanks for working on this. + class IntegerAlignment { + private: +uint64_t Align; You explain in the patch summary why this is here, but please add a comment with the explanation as well. Regarding the auto-upgrade, are we going to run into problems if we separate our the

Re: [PATCH] D13171: [CUDA] Added a wrapper header for inclusion of stock CUDA headers.

2015-09-25 Thread Artem Belevich via cfe-commits
tra updated this revision to Diff 35760. tra added a comment. Include cuda.h and #error if we see wrong CUDA_VERSION. http://reviews.llvm.org/D13171 Files: lib/Headers/CMakeLists.txt lib/Headers/clang_cuda_support.h Index: lib/Headers/clang_cuda_support.h

Re: [PATCH] D13171: [CUDA] Added a wrapper header for inclusion of stock CUDA headers.

2015-09-25 Thread Artem Belevich via cfe-commits
tra marked an inline comment as done. tra added a comment. http://reviews.llvm.org/D13171 ___ cfe-commits mailing list cfe-commits@lists.llvm.org http://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-commits

Re: [PATCH] D12982: Move routines for guessing mode/target from driver to ToolChain

2015-09-25 Thread Luke Zarko via cfe-commits
zarko added a comment. Great! I don't have commit access; would someone who does please land this? Repository: rL LLVM http://reviews.llvm.org/D12982 ___ cfe-commits mailing list cfe-commits@lists.llvm.org

Re: [PATCH] D12982: Move routines for guessing mode/target from driver to ToolChain

2015-09-25 Thread Eric Christopher via cfe-commits
echristo added a subscriber: echristo. echristo added a comment. Oh, sure I can. Done thusly: dzur:~/sources/llvm/tools/clang> git svn dcommit Committing to https://llvm.org/svn/llvm-project/cfe/trunk ... M include/clang/Driver/ToolChain.h M lib/Driver/ToolChain.cpp M tools/driver/driver.cpp

[PATCH] D13171: [CUDA] Added a wrapper header for inclusion of stock CUDA headers.

2015-09-25 Thread Artem Belevich via cfe-commits
tra created this revision. tra added reviewers: echristo, eliben, jholewinski. tra added a subscriber: cfe-commits. Header files that come with CUDA are assuming split host/device compilation and are not usable by clang out of the box. With a bit of preprocessor magic it's possible to twist them

Re: [PATCH] D13157: Teach -Wtautological-overlap-compare about enums

2015-09-25 Thread George Burgess IV via cfe-commits
george.burgess.iv added inline comments. Comment at: lib/Analysis/CFG.cpp:54 @@ +53,3 @@ +auto *DR = dyn_cast(E->IgnoreParenImpCasts()); +if (DR == nullptr) + return nullptr; aaron.ballman wrote: > Please don't compare a pointer against nullptr with

Re: [PATCH] D13171: [CUDA] Added a wrapper header for inclusion of stock CUDA headers.

2015-09-25 Thread Artem Belevich via cfe-commits
tra updated this revision to Diff 35747. tra added a comment. Fixed typos and whitespace nits. use #pragma push_macro for __CUDACC_RTC__, too. http://reviews.llvm.org/D13171 Files: lib/Headers/CMakeLists.txt lib/Headers/clang_cuda_support.h Index: lib/Headers/clang_cuda_support.h

[PATCH] D13170: [CUDA] Driver changes to pass flags needed to use detected CUDA installation.

2015-09-25 Thread Artem Belevich via cfe-commits
tra created this revision. tra added a reviewer: echristo. tra added a subscriber: cfe-commits. - added detection of libdevice bitcode file and API to find one appropriate for the GPU we're compiling for. - added include paths to detected CUDA installation - added include paths for

Re: [PATCH] D12996: Driver: support ARM/HF on a single toolchain

2015-09-25 Thread Jonathan Roelofs via cfe-commits
jroelofs accepted this revision. jroelofs added a reviewer: jroelofs. jroelofs added a comment. This revision is now accepted and ready to land. Now that you've got http://reviews.llvm.org/D13155 squared away, LGTM. http://reviews.llvm.org/D12996

Re: [PATCH] D13105: [OpenCL] Enable program scope variables for OpenCL2.0

2015-09-25 Thread Anastasia Stulova via cfe-commits
Anastasia updated this revision to Diff 35732. Anastasia added a comment. Thanks! The review comments are addressed in this update! http://reviews.llvm.org/D13105 Files: include/clang/Basic/DiagnosticSemaKinds.td include/clang/Basic/Specifiers.h lib/AST/Decl.cpp lib/AST/DeclPrinter.cpp

r248592 - The Clang gcc-compatible driver (clang/tools/driver/driver.cpp) has some

2015-09-25 Thread Eric Christopher via cfe-commits
Author: echristo Date: Fri Sep 25 12:44:31 2015 New Revision: 248592 URL: http://llvm.org/viewvc/llvm-project?rev=248592=rev Log: The Clang gcc-compatible driver (clang/tools/driver/driver.cpp) has some logic to select an alternate target based on the executable it was called as. For instance, if

[PATCH] D13168: [OpenCL] OpenCL2.0 - Apply default address space rules

2015-09-25 Thread Anastasia Stulova via cfe-commits
Anastasia created this revision. Anastasia added a reviewer: pekka.jaaskelainen. Anastasia added a subscriber: cfe-commits. If address space (AS) of a variable/parameter declaration is not set, OpenCL2.0 s6.5 defines explicit rules for default ASes: - The AS of global and local static variables

Re: [PATCH] D12982: Move routines for guessing mode/target from driver to ToolChain

2015-09-25 Thread Eric Christopher via cfe-commits
Oh, sure I can. Done thusly: dzur:~/sources/llvm/tools/clang> git svn dcommit Committing to https://llvm.org/svn/llvm-project/cfe/trunk ... M include/clang/Driver/ToolChain.h M lib/Driver/ToolChain.cpp M tools/driver/driver.cpp Committed r248592 -eric On Fri, Sep 25, 2015 at 10:20 AM Luke

Re: [PATCH] __attribute__((enable_if)) and non-overloaded member functions

2015-09-25 Thread George Burgess via cfe-commits
Sorry for the delay -- didn't see this email come in. Committed as r248595. :) On Tue, Sep 22, 2015 at 1:06 PM, Ettore Speziale wrote: > Hello, > > > Looks good to me! > > > > Do you have commit access, or would you like for me to commit it for you? > > I do not have

Re: [PATCH] D12666: [LibClang] Fix clang_getCursorAvailability

2015-09-25 Thread Manuel Klimek via cfe-commits
klimek added a comment. Submitted as r248596. Sergey, if you plan to work on libclang more, please get commit access (it's easy :) Thx http://reviews.llvm.org/D12666 ___ cfe-commits mailing list cfe-commits@lists.llvm.org

Re: [PATCH] D12666: [LibClang] Fix clang_getCursorAvailability

2015-09-25 Thread Manuel Klimek via cfe-commits
Submitted as r248596. Sergey, if you plan to work on libclang more, please get commit access (it's easy :) Thx On Fri, Sep 18, 2015 at 5:25 AM Milian Wolff wrote: > milianw added a subscriber: milianw. > milianw added a comment. > > Ping? Can someone please submit this

Re: [PATCH] D12761: MPI-Checker patch for Clang Static Analyzer

2015-09-25 Thread Alexander Droste via cfe-commits
Alexander_Droste added inline comments. Comment at: tools/clang/lib/StaticAnalyzer/Checkers/MPI-Checker/MPICheckerPathSensitive.cpp:35 @@ +34,3 @@ + if (!isa(MR) || + (ER && !isa(ER->getSuperRegion( +return; Thanks for the hint! I tried

r248626 - Relax test to allow for __attribute__((thiscall)). Under Win32 c-index-test output is

2015-09-25 Thread Yaron Keren via cfe-commits
Author: yrnkrn Date: Fri Sep 25 17:09:07 2015 New Revision: 248626 URL: http://llvm.org/viewvc/llvm-project?rev=248626=rev Log: Relax test to allow for __attribute__((thiscall)). Under Win32 c-index-test output is CXXMethod=foo:4:7 (unavailable) [type=int () __attribute__((thiscall))]

[PATCH] D13187: [Clang] Fix Clang-tidy modernize-use-nullptr warnings in headers and generated files; other minor cleanups.

2015-09-25 Thread Eugene Zelenko via cfe-commits
Eugene.Zelenko created this revision. Eugene.Zelenko added a reviewer: hans. Eugene.Zelenko added a subscriber: cfe-commits. Eugene.Zelenko set the repository for this revision to rL LLVM. Also fixed Clang-tidy readability-simplify-boolean-expr in tools/libclang/CIndex.cpp. I checked this patch

Re: [PATCH] D12251: Analyzer: Calculate field offset correctly

2015-09-25 Thread Devin Coughlin via cfe-commits
dcoughlin requested changes to this revision. dcoughlin added a comment. This revision now requires changes to proceed. Thanks for the patch Ismail! Some comments inline. Comment at: lib/StaticAnalyzer/Core/Store.cpp:408 @@ +407,3 @@ +if (!Base.isZeroConstant()) { + if

r248645 - Replace a loop and temporary string copying with llvm::join.

2015-09-25 Thread Eric Christopher via cfe-commits
Author: echristo Date: Fri Sep 25 20:25:08 2015 New Revision: 248645 URL: http://llvm.org/viewvc/llvm-project?rev=248645=rev Log: Replace a loop and temporary string copying with llvm::join. Modified: cfe/trunk/lib/CodeGen/BackendUtil.cpp Modified: cfe/trunk/lib/CodeGen/BackendUtil.cpp URL:

Re: [PATCH] D13128: Fix backend crash on multiple close of stdout.

2015-09-25 Thread Dan Gohman via cfe-commits
sunfish added a comment. This code has been questioned in this way before, and every time it comes up, it turns out that there's a bug somewhere else that really ought to be fixed anyway. In previous iterations of this discussion, when clang is found attempting to print something like a dep

Re: [PATCH] D12633: Implement ACLE 2.0 macros of chapters 6.6 and 6.7 for [ARM] and [Aarch64] targets

2015-09-25 Thread Alexandros Lamprineas via cfe-commits
labrinea added a comment. In http://reviews.llvm.org/D12633#252758, @labrinea wrote: > @t.p.northover I think we should not be defining _ARM_FP_FENV_ROUNDING on > neither of ARM and AArch64 targets since "-frounding-math" is not available > on clang: clang/llvm don't support C99 FP rounding

r248569 - [OPENMP 4.1] Add 'threads' clause for '#pragma omp ordered'.

2015-09-25 Thread Alexey Bataev via cfe-commits
Author: abataev Date: Fri Sep 25 05:37:12 2015 New Revision: 248569 URL: http://llvm.org/viewvc/llvm-project?rev=248569=rev Log: [OPENMP 4.1] Add 'threads' clause for '#pragma omp ordered'. OpenMP 4.1 extends format of '#pragma omp ordered'. It adds 3 additional clauses: 'threads', 'simd' and

Re: [PATCH] D13157: Teach -Wtautological-overlap-compare about enums

2015-09-25 Thread Aaron Ballman via cfe-commits
aaron.ballman added a subscriber: aaron.ballman. aaron.ballman added a comment. Thank you for working on this -- I think it's a good cleanup and feature-add! I have a few minor comments, but generally LGTM. You should wait for an okay from Richard, however. Comment at:

r248567 - New test ps4-linker-win.c (added in r48546) is causing problems for Windows bots. I'm deleting this file during investigation.

2015-09-25 Thread Ekaterina Romanova via cfe-commits
Author: kromanova Date: Fri Sep 25 04:10:33 2015 New Revision: 248567 URL: http://llvm.org/viewvc/llvm-project?rev=248567=rev Log: New test ps4-linker-win.c (added in r48546) is causing problems for Windows bots. I'm deleting this file during investigation. Removed:

Re: [PATCH] D13099: [Analyzer] Don’t invalidate CXXThis when conservatively evaluating const methods (PR 21606)

2015-09-25 Thread Sean Eveson via cfe-commits
seaneveson added a comment. I've realized that the patch doesn't handle pointers correctly, since a const method can modify the memory pointed at by a member. While pointer members should not be invalidated by const methods (if they are not mutable), the memory they point to should still be