[libcxx] r251131 - Set LC_COLLATE rather than LANG to override collation.

2015-10-23 Thread Tim Northover via cfe-commits
Author: tnorthover Date: Fri Oct 23 12:56:08 2015 New Revision: 251131 URL: http://llvm.org/viewvc/llvm-project?rev=251131=rev Log: Set LC_COLLATE rather than LANG to override collation. On a system with LC_COLLATE=C, this takes precedence over a non-C LANG the test tries to impose and the test

r251101 - [AST] Re-add TypeLocs and NestedNameSpecifierLocs to the ParentMap.

2015-10-23 Thread Benjamin Kramer via cfe-commits
Author: d0k Date: Fri Oct 23 04:04:55 2015 New Revision: 251101 URL: http://llvm.org/viewvc/llvm-project?rev=251101=rev Log: [AST] Re-add TypeLocs and NestedNameSpecifierLocs to the ParentMap. This relands r250831 after some fixes to shrink the ParentMap overall with one addtional tweak: nodes

Re: [PATCH] D14011: [AST] Re-add TypeLocs and NestedNameSpecifierLocs to the ParentMap.

2015-10-23 Thread Phabricator via cfe-commits
This revision was automatically updated to reflect the committed changes. Closed by commit rL251101: [AST] Re-add TypeLocs and NestedNameSpecifierLocs to the ParentMap. (authored by d0k). Changed prior to commit: http://reviews.llvm.org/D14011?vs=38216=38220#toc Repository: rL LLVM

Re: [PATCH] D13973: CFG: Delay creating Dtors for CompoundStmts which end in ReturnStmt

2015-10-23 Thread Manuel Klimek via cfe-commits
klimek added inline comments. Comment at: lib/Analysis/CFG.cpp:1949-1952 @@ +1948,6 @@ + } + if(!C->body_empty() && !dyn_cast(*C->body_rbegin())) { +// If the body ends with a ReturnStmt, the dtors will be added in VisitReturnStmt +addAutomaticObjDtors(ScopePos,

Re: [PATCH] D13336: [MSVC] 'property' with an empty array in array subscript expression.

2015-10-23 Thread Alexey Bataev via cfe-commits
ABataev updated this revision to Diff 38232. ABataev marked 4 inline comments as done. ABataev added a comment. Update after review http://reviews.llvm.org/D13336 Files: include/clang/AST/DataRecursiveASTVisitor.h include/clang/AST/ExprCXX.h include/clang/AST/RecursiveASTVisitor.h

r251110 - [AST] Plug a memory leak when promoting a single ParentMap entry to a vector.

2015-10-23 Thread Benjamin Kramer via cfe-commits
Author: d0k Date: Fri Oct 23 08:24:18 2015 New Revision: 251110 URL: http://llvm.org/viewvc/llvm-project?rev=251110=rev Log: [AST] Plug a memory leak when promoting a single ParentMap entry to a vector. Found by asan! Modified: cfe/trunk/lib/AST/ASTContext.cpp Modified:

[PATCH] D14014: Checker of proper vfork usage

2015-10-23 Thread Yury Gribov via cfe-commits
ygribov created this revision. ygribov added reviewers: zaks.anna, dcoughlin, jordan_rose, krememek. ygribov added a subscriber: cfe-commits. ygribov set the repository for this revision to rL LLVM. Hi all, This checker verifies that vfork is used safely. Vforked process shared stack with

Re: [PATCH] D12906: [RFC] Bug identification("issue_hash") change for CmpRuns.py

2015-10-23 Thread Honggyu Kim via cfe-commits
honggyu.kim added a comment. In http://reviews.llvm.org/D12906#273089, @xazax.hun wrote: > By default it is disabled for security reasons. You can enable by passing a > command line option to the code checker, something like --not-host-only. Thanks, I can remotely access now with

[clang-tools-extra] r251103 - Make isExpensiveToCopy() tri-state.

2015-10-23 Thread Manuel Klimek via cfe-commits
Author: klimek Date: Fri Oct 23 05:00:50 2015 New Revision: 251103 URL: http://llvm.org/viewvc/llvm-project?rev=251103=rev Log: Make isExpensiveToCopy() tri-state. This allows returning "don't know" for dependent types. Modified: clang-tools-extra/trunk/clang-tidy/utils/Matchers.h

r251116 - Remove a redundant check. NFC

2015-10-23 Thread Adrian Prantl via cfe-commits
Author: adrian Date: Fri Oct 23 11:51:32 2015 New Revision: 251116 URL: http://llvm.org/viewvc/llvm-project?rev=251116=rev Log: Remove a redundant check. NFC Modified: cfe/trunk/lib/CodeGen/ObjectFilePCHContainerOperations.cpp Modified:

r251120 - Module Debugging: Emit module debug info for types inside of Objective-C

2015-10-23 Thread Adrian Prantl via cfe-commits
Author: adrian Date: Fri Oct 23 12:02:22 2015 New Revision: 251120 URL: http://llvm.org/viewvc/llvm-project?rev=251120=rev Log: Module Debugging: Emit module debug info for types inside of Objective-C containers. rdar://problem/23196170 Modified:

r251124 - [ARM] Renaming +t2dsp feature into +dsp, as discussed on llvm-dev

2015-10-23 Thread Artyom Skrobov via cfe-commits
Author: askrobov Date: Fri Oct 23 12:19:02 2015 New Revision: 251124 URL: http://llvm.org/viewvc/llvm-project?rev=251124=rev Log: [ARM] Renaming +t2dsp feature into +dsp, as discussed on llvm-dev Modified: cfe/trunk/lib/Basic/Targets.cpp cfe/trunk/test/CodeGen/arm-target-features.c

r251126 - Fixup this testcase after r251120.

2015-10-23 Thread Adrian Prantl via cfe-commits
Author: adrian Date: Fri Oct 23 12:25:17 2015 New Revision: 251126 URL: http://llvm.org/viewvc/llvm-project?rev=251126=rev Log: Fixup this testcase after r251120. I accidentally tested r251120 with assertions disabled. Modified: cfe/trunk/test/Modules/ModuleDebugInfo.m Modified:

Re: [PATCH] D12614: [OpenMP] Offloading descriptor registration and device codegen.

2015-10-23 Thread Samuel Antao via cfe-commits
sfantao added a comment. Hi John, Thanks for the remark! In http://reviews.llvm.org/D12614#272354, @rjmccall wrote: > CurFuncDecl is supposed to be the enclosing user function. Things like > outlined functions should be getting stored in CurCodeDecl; that's how it's > done for blocks and

Re: [PATCH] D13978: [X86] Support MCU psABI when marking inregs

2015-10-23 Thread Reid Kleckner via cfe-commits
rnk accepted this revision. rnk added a comment. This revision is now accepted and ready to land. lgtm with the suggested simplification. Comment at: lib/CodeGen/TargetInfo.cpp:857 @@ -854,3 +856,3 @@ IsWin32StructABI(Win32StructABI), - IsSoftFloatABI(SoftFloatABI),

Re: [PATCH] D14014: Checker of proper vfork usage

2015-10-23 Thread Vedant Kumar via cfe-commits
vsk added a subscriber: vsk. vsk added a comment. Thanks for the patch. I didn't know vfork() is in regular use. Afaict copy-on-write fork() and threading both solve a similar (the same?) problem. I'm also not convinced that flagging all stores in the vfork child process is the right thing to

Re: [PATCH] D7639: Add readability-redundant-void-arg check to clang-tidy

2015-10-23 Thread Richard via cfe-commits
LegalizeAdulthood marked 17 inline comments as done. LegalizeAdulthood added a comment. Can we get this committed? I've addressed all comments. http://reviews.llvm.org/D7639 ___ cfe-commits mailing list cfe-commits@lists.llvm.org

Re: [PATCH] D7639: Add readability-redundant-void-arg check to clang-tidy

2015-10-23 Thread Samuel Benzaquen via cfe-commits
sbenza added a comment. I'm sorry. This change fell through the cracks. I'll take a look today. http://reviews.llvm.org/D7639 ___ cfe-commits mailing list cfe-commits@lists.llvm.org http://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-commits

RE: [libcxx] r251065 - Dont required CMake 3 to install a linker script

2015-10-23 Thread Hahnfeld, Jonas via cfe-commits
Hi, thanks for the attempt to fix this, but this isn't working for in-tree builds of libcxx: CMake Error at projects/libcxx/lib/cmake_install.cmake:56 (FILE): file INSTALL cannot find "<<>>/projects/libcxx/lib/libc++.so" It is located at <<>>/lib/libc++.so. CMake version is 2.8.12.2 which

Re: [libcxx] r251065 - Dont required CMake 3 to install a linker script

2015-10-23 Thread Eric Fiselier via cfe-commits
Hi Jonas, Thanks for being patient and sorry for the failed first attempt. I think I fixed it in r251100. I swear I'm normally more careful. /Eric On Thu, Oct 22, 2015 at 8:34 PM, Hahnfeld, Jonas < hahnf...@itc.rwth-aachen.de> wrote: > Hi, > > thanks for the attempt to fix this, but this

[libcxx] r251100 - Use proper output directory when naminging the libc++ output

2015-10-23 Thread Eric Fiselier via cfe-commits
Author: ericwf Date: Fri Oct 23 02:04:24 2015 New Revision: 251100 URL: http://llvm.org/viewvc/llvm-project?rev=251100=rev Log: Use proper output directory when naminging the libc++ output Modified: libcxx/trunk/lib/CMakeLists.txt Modified: libcxx/trunk/lib/CMakeLists.txt URL:

RE: [libcxx] r251065 - Dont required CMake 3 to install a linker script

2015-10-23 Thread Hahnfeld, Jonas via cfe-commits
No problem, seems to work now :-) Thanks Jonas From: Eric Fiselier [mailto:e...@efcs.ca] Sent: Friday, October 23, 2015 9:08 AM To: Hahnfeld, Jonas Cc: cfe-commits@lists.llvm.org Subject: Re: [libcxx] r251065 - Dont required CMake 3 to install a linker script Hi Jonas, Thanks for

Re: [PATCH] D14014: Checker of proper vfork usage

2015-10-23 Thread Devin Coughlin via cfe-commits
dcoughlin added a comment. Hi Yury, Thanks for the patch. This is definitely interesting for upstream! One thing to note (which I assume you are already aware of) is that we already have the "security.insecureAPI.vfork" checker, an AST check that warns on *every* use of vfork. This check is

Re: [PATCH] D14014: Checker of proper vfork usage

2015-10-23 Thread Yury Gribov via cfe-commits
ygribov added a comment. > This is a valid concern because it greatly complicates enablement of > VforkChecker for a casual user. I think at the very least I can check that InsecureAPI is enable and issue a warning to user. Repository: rL LLVM http://reviews.llvm.org/D14014

Re: [PATCH] D13144: [CUDA] propagate to CUDA sub-compilations target triple of opposite side.

2015-10-23 Thread Artem Belevich via cfe-commits
tra updated this revision to Diff 38269. tra added a comment. Instead of passing AuxTriple around as an argument, store ToolChain info in Compilation and retrieve it from there. http://reviews.llvm.org/D13144 Files: include/clang/Driver/Compilation.h include/clang/Driver/Driver.h

Re: [PATCH] D14014: Checker of proper vfork usage

2015-10-23 Thread Yury Gribov via cfe-commits
ygribov added a comment. > I didn't know vfork() is in regular use. Neither did I, until I had to debug the damned code. Actually Android has some 5 or 6 uses of it. > I'm also not convinced that flagging all stores in the vfork child process is > the right thing to do, > since the FP rate

Re: [PATCH] D14014: Checker of proper vfork usage

2015-10-23 Thread Devin Coughlin via cfe-commits
dcoughlin added a comment. > For example, doing 'x = malloc(4); *x = 0;' in the child process seems fine > to me. I don't think this is necessarily safe. For example, malloc() could end up both modifying memory shared between the child and parent process but only modifying process state for

Re: [PATCH] D14014: Checker of proper vfork usage

2015-10-23 Thread Yury Gribov via cfe-commits
ygribov added a comment. > One thing to note (which I assume you are already aware of) is that we > already have the "security.insecureAPI.vfork" checker, > an AST check that warns on *every* use of vfork. Yes, I was aware of this one. Unfortunately as I mentioned above vfork is probably to

[PATCH] D14030: Use linker option to reference profile runtime hook (Linux)

2015-10-23 Thread David Li via cfe-commits
davidxl created this revision. davidxl added a reviewer: bogner. davidxl added a subscriber: cfe-commits. Currently when profile instrumentation is on, the compiler emits a runtime hook use function (__llvm_profile_runtime_use) for every module that is instrumented. The generated function

[PATCH] D14011: [AST] Re-add TypeLocs and NestedNameSpecifierLocs to the ParentMap.

2015-10-23 Thread Benjamin Kramer via cfe-commits
bkramer created this revision. bkramer added reviewers: klimek, djasper. bkramer added a subscriber: cfe-commits. Herald added a subscriber: klimek. This relands r250831 after some fixes to shrink the ParentMap overall with one addtional tweak: nodes with pointer identity (e.g. Decl* and friends)

Re: [PATCH] D14011: [AST] Re-add TypeLocs and NestedNameSpecifierLocs to the ParentMap.

2015-10-23 Thread Manuel Klimek via cfe-commits
klimek accepted this revision. klimek added a comment. This revision is now accepted and ready to land. lg; let's see whether it sticks this time :) Comment at: include/clang/AST/ASTContext.h:456 @@ -455,1 +455,3 @@ + /// pointer identity only, which are more common and we can