[PATCH] D28620: Guard __gnuc_va_list typedef

2017-01-21 Thread Yaron Keren via Phabricator via cfe-commits
yaron.keren accepted this revision. yaron.keren added a comment. This revision is now accepted and ready to land. LGTM, matches the code in libstdc++ stdarg,h. You can remove the 'hack' comment in line 46, __GNUC_VA_LIST is just a standard include guard for the typedef.

[PATCH] D28952: [analyzer] Add new Z3 constraint manager backend

2017-01-21 Thread Anna Zaks via Phabricator via cfe-commits
zaks.anna added a comment. Thanks for working on this Dominic!!! Can you talk a bit about your motivation for working on this project and what your goals are? Have you compared the performance when using Z3 vs the current builtin solver? I saw that you mention performance issues on large

Re: r292562 - clang-format: fix fallback style set to "none" not always formatting

2017-01-21 Thread Björn Pettersson A via cfe-commits
Hello Antonio and Mikael. I've tried reproducing this also after removal of the redundant test (D28943), and I still see the fail for CHECK10. The problem is that we (both me an Mikael) are running this test from inside our llvm repo (with build artifacts ending up in a "build-all" directory

[PATCH] D28849: [compiler-rt] [test] Fix page address logic in clear_cache_test

2017-01-21 Thread Michał Górny via Phabricator via cfe-commits
This revision was automatically updated to reflect the committed changes. Closed by commit rL292729: [test] Fix page address logic in clear_cache_test (authored by mgorny). Changed prior to commit: https://reviews.llvm.org/D28849?vs=85208=85248#toc Repository: rL LLVM

[PATCH] D28955: [analyzer] Enable support for symbolic extension/truncation

2017-01-21 Thread Dominic Chen via Phabricator via cfe-commits
ddcc added a comment. > We should have expected-warning on 64-bit targets (where `size_t` easily > overflows `int`) and no-warning on 32-bit targets (where they are of the same > size and the fix for the original issue > https://llvm.org/bugs/show_bug.cgi?id=16558 applies). I think we should

[libunwind] r292728 - DWARF: correct cast (NFC)

2017-01-21 Thread Saleem Abdulrasool via cfe-commits
Author: compnerd Date: Sat Jan 21 15:27:29 2017 New Revision: 292728 URL: http://llvm.org/viewvc/llvm-project?rev=292728=rev Log: DWARF: correct cast (NFC) Change the case of a PRIu64 value from `long` to `uint64_t`. NFC. Modified: libunwind/trunk/src/DwarfParser.hpp Modified:

[PATCH] D28952: [analyzer] Add new Z3 constraint manager backend

2017-01-21 Thread Dominic Chen via Phabricator via cfe-commits
ddcc added a comment. > For such test cases i'd consider something like this: > > // RUN: ... -analyzer-constraints=range -DRANGE ... > // RUN: ... -analyzer-constraints=z3 ... > > #ifdef RANGE > foo(); // expected-warning{{}} > #else > foo(); // no-warning > #endif Would this

[PATCH] D27440: clang-format-vsix: fail when clang-format outputs to stderr

2017-01-21 Thread Antonio Maiorano via Phabricator via cfe-commits
amaiorano abandoned this revision. amaiorano added a comment. This change is no longer needed since clang-format now returns failure status (non-zero) whenever it writes to stderr (e.g. on parse error) since https://llvm.org/svn/llvm-project/cfe/trunk@292174 (https://reviews.llvm.org/D28081)

[PATCH] D28983: clang-format: remove tests that assume no config file will be found as this is not always the case

2017-01-21 Thread Antonio Maiorano via Phabricator via cfe-commits
amaiorano created this revision. Herald added a subscriber: klimek. These tests fail for developers who place their build directories under the llvm root directory because llvm's own .clang-format file will be found. Anyway these cases are covered by FormatStyle.GetStyleOfFile tests

[PATCH] D28955: [analyzer] Enable support for symbolic extension/truncation

2017-01-21 Thread Artem Dergachev via Phabricator via cfe-commits
NoQ added a comment. In https://reviews.llvm.org/D28955#652443, @ddcc wrote: > When I was testing this patch, it was on top of both > https://reviews.llvm.org/D28952 and https://reviews.llvm.org/D28953. For > `malloc.c`, the change on line 1708 from `int` to `size_t` is necessary to > prevent

[PATCH] D28955: [analyzer] Enable support for symbolic extension/truncation

2017-01-21 Thread Dominic Chen via Phabricator via cfe-commits
ddcc added a comment. When I was testing this patch, it was on top of both https://reviews.llvm.org/D28952 and https://reviews.llvm.org/D28953. For `malloc.c`, the change on line 1708 from `int` to `size_t` is necessary to prevent a false positive warning at line 1710. The other three changes

[PATCH] D28952: [analyzer] Add new Z3 constraint manager backend

2017-01-21 Thread Artem Dergachev via Phabricator via cfe-commits
NoQ added a comment. Late-joining the round of applause for the awesome progression of this project! Not sure how to deal with the massive test run-line changes at the moment, will take some extra time to think. In https://reviews.llvm.org/D28952#652436, @ddcc wrote: > Another issue is that

[PATCH] D28952: [analyzer] Add new Z3 constraint manager backend

2017-01-21 Thread Dominic Chen via Phabricator via cfe-commits
ddcc added a comment. Do you want me to replace this version of the patch with one that omits the test case changes? The underlying git commit for just the Z3 constraint manager implementation is https://github.com/ddcc/clang/commit/e1414d300882c1459f461424d3e89d1613ecf03c , and

[PATCH] D28849: [compiler-rt] [test] Fix page address logic in clear_cache_test

2017-01-21 Thread Saleem Abdulrasool via Phabricator via cfe-commits
compnerd accepted this revision. compnerd added a comment. This revision is now accepted and ready to land. Would be nice to clang-format those lines, but its no worse than before. https://reviews.llvm.org/D28849 ___ cfe-commits mailing list

[libunwind] r292722 - DWARF: allow enabling tracing at runtime

2017-01-21 Thread Saleem Abdulrasool via cfe-commits
Author: compnerd Date: Sat Jan 21 10:22:57 2017 New Revision: 292722 URL: http://llvm.org/viewvc/llvm-project?rev=292722=rev Log: DWARF: allow enabling tracing at runtime Introduce `logDWARF` and the associated environment variable `LIBUNWIND_PRINT_DWARF` to trace the CFI instructions.

[libunwind] r292723 - X86: swap EBP, ESP on !APPLE

2017-01-21 Thread Saleem Abdulrasool via cfe-commits
Author: compnerd Date: Sat Jan 21 10:22:59 2017 New Revision: 292723 URL: http://llvm.org/viewvc/llvm-project?rev=292723=rev Log: X86: swap EBP, ESP on !APPLE Restore the `libunwind.h` enumeration values back to the inverted values. This diverges from the DWARF definition of the register

[libunwind] r292721 - DWARF: convert error logs to _LIBUNWIND_LOG

2017-01-21 Thread Saleem Abdulrasool via cfe-commits
Author: compnerd Date: Sat Jan 21 10:22:55 2017 New Revision: 292721 URL: http://llvm.org/viewvc/llvm-project?rev=292721=rev Log: DWARF: convert error logs to _LIBUNWIND_LOG Use the `_LIBUNWIND_LOG` macro instead of the explicit `fprintf` call. NFC. Modified:

[libunwind] r292719 - rename OtherAddressSpace to RemoteAddressSpace; NFC

2017-01-21 Thread Saleem Abdulrasool via cfe-commits
Author: compnerd Date: Sat Jan 21 10:22:46 2017 New Revision: 292719 URL: http://llvm.org/viewvc/llvm-project?rev=292719=rev Log: rename OtherAddressSpace to RemoteAddressSpace; NFC Modified: libunwind/trunk/src/AddressSpace.hpp libunwind/trunk/src/libunwind.cpp Modified:

[libunwind] r292720 - config: clean up some of the macro definition

2017-01-21 Thread Saleem Abdulrasool via cfe-commits
Author: compnerd Date: Sat Jan 21 10:22:53 2017 New Revision: 292720 URL: http://llvm.org/viewvc/llvm-project?rev=292720=rev Log: config: clean up some of the macro definition Unify the definition of `_LIBUNWIND_LOG_NON_ZERO` to make it clear what it is defined to and make the definition

[PATCH] D28981: Use GNU-style attributes for several __throw_XXX() functions

2017-01-21 Thread Dimitry Andric via Phabricator via cfe-commits
dim created this revision. In https://reviews.llvm.org/rL279744, `__throw_XXX()` functions were introduced, partially for compatibility with software compiled against libstdc++. `_LIBCPP_NORETURN` is used on all of them, and when C++11 attributes are available, this gets defined as

[PATCH] D26753: ASTImporter: improve support for C++ templates

2017-01-21 Thread Aleksei Sidorin via Phabricator via cfe-commits
a.sidorin added a comment. I got it. I have hard-coded paths in CHECK-lines so these tests are passed on my machine but not on other. Thank you Kareem! https://reviews.llvm.org/D26753 ___ cfe-commits mailing list cfe-commits@lists.llvm.org

[PATCH] D28785: Split exception.cpp and new.cpp implementation into different files for different runtimes

2017-01-21 Thread Eric Fiselier via Phabricator via cfe-commits
EricWF added a comment. In https://reviews.llvm.org/D28785#651156, @EricWF wrote: > In https://reviews.llvm.org/D28785#650101, @compnerd wrote: > > > While I love this direction (the original version really was an > > unintelligible pile of code), I really think that this change may be taking

[libcxx] r292717 - Revert accidentally changes which reverted r292582

2017-01-21 Thread Eric Fiselier via cfe-commits
Author: ericwf Date: Sat Jan 21 08:42:44 2017 New Revision: 292717 URL: http://llvm.org/viewvc/llvm-project?rev=292717=rev Log: Revert accidentally changes which reverted r292582 Modified: libcxx/trunk/include/new Modified: libcxx/trunk/include/new URL:

[PATCH] D27621: [clang-tidy] check to find declarations declaring more than one name

2017-01-21 Thread Firat Kasmis via Phabricator via cfe-commits
firolino marked 7 inline comments as done. firolino added a comment. - nothing special, just went through some open comments and marked them as Done. Comment at: clang-tidy/readability/OneNamePerDeclarationCheck.cpp:246 + +static std::string getCurrentLineIndent(SourceLocation

[PATCH] D27621: [clang-tidy] check to find declarations declaring more than one name

2017-01-21 Thread Firat Kasmis via Phabricator via cfe-commits
firolino added a comment. @aaron.ballman I am going to implement `CppCore`, `Cert` and `Everything` and test it on some projects and provide the results next week, to find out which one to set `Default`. https://reviews.llvm.org/D27621 ___

[PATCH] D27621: [clang-tidy] check to find declarations declaring more than one name

2017-01-21 Thread Firat Kasmis via Phabricator via cfe-commits
firolino added inline comments. Comment at: clang-tidy/readability/OneNamePerDeclarationCheck.h:25 +class OneNamePerDeclarationCheck : public ClangTidyCheck { +private: + std::string getUserWrittenType(const DeclStmt *DeclStmt, SourceManager ); firolino wrote:

[PATCH] D27621: [clang-tidy] check to find declarations declaring more than one name

2017-01-21 Thread Firat Kasmis via Phabricator via cfe-commits
firolino added inline comments. Comment at: clang-tidy/readability/OneNamePerDeclarationCheck.cpp:153 + const SourceRange FVLoc(DeclStmt->getLocStart(), Location); + std::string UserWrittenType = + Lexer::getSourceText(CharSourceRange::getCharRange(FVLoc), SM,

[PATCH] D28952: [analyzer] Add new Z3 constraint manager backend

2017-01-21 Thread Aleksei Sidorin via Phabricator via cfe-commits
a.sidorin added a comment. Amazing work, Dominic. That's what I wanted to test for long time. But, personally, I'm not happy with massive changes in tests. 1. I don't think that we need to change run line for tests if they pass with both managers. These changes are pretty noisy, 2. If Z3 is