r341757 - Revert r341754.

2018-09-08 Thread Akira Hatanaka via cfe-commits
Author: ahatanak Date: Sat Sep 8 22:22:49 2018 New Revision: 341757 URL: http://llvm.org/viewvc/llvm-project?rev=341757=rev Log: Revert r341754. The commit broke a couple of bots: http://lab.llvm.org:8011/builders/llvm-clang-x86_64-expensive-checks-win/builds/12347

[PATCH] D51832: [clang-tidy/checks] Update objc-property-declaration check to allow arbitrary acronyms and initialisms 

2018-09-08 Thread Stephane Moore via Phabricator via cfe-commits
stephanemoore updated this revision to Diff 164583. stephanemoore added a comment. Sorted forward declared classes in `objc-property-declaration.m`. Repository: rCTE Clang Tools Extra https://reviews.llvm.org/D51832 Files: clang-tidy/objc/PropertyDeclarationCheck.cpp

[PATCH] D51832: [clang-tidy/checks] Update objc-property-declaration check to allow arbitrary acronyms and initialisms 

2018-09-08 Thread Stephane Moore via Phabricator via cfe-commits
stephanemoore updated this revision to Diff 164582. stephanemoore added a comment. Fix a couple issues: • Forward declare `NSArray` in `objc-property-declaration.m`. • Remove unnecessary lightweight generics declaration from `IDs` property in `objc-property-declaration.m` to fix compilation

r341756 - [Parser] Remove an unnecessary `mutable`

2018-09-08 Thread Fangrui Song via cfe-commits
Author: maskray Date: Sat Sep 8 18:54:18 2018 New Revision: 341756 URL: http://llvm.org/viewvc/llvm-project?rev=341756=rev Log: [Parser] Remove an unnecessary `mutable` Modified: cfe/trunk/include/clang/Parse/Parser.h Modified: cfe/trunk/include/clang/Parse/Parser.h URL:

[PATCH] D51784: ms: Insert $$Z in mangling between directly consecutive parameter packs.

2018-09-08 Thread Phabricator via Phabricator via cfe-commits
This revision was automatically updated to reflect the committed changes. Closed by commit rC341755: ms: Insert $$Z in mangling between directly consecutive parameter packs. (authored by nico, committed by ). Changed prior to commit: https://reviews.llvm.org/D51784?vs=164402=164577#toc

r341755 - ms: Insert $$Z in mangling between directly consecutive parameter packs.

2018-09-08 Thread Nico Weber via cfe-commits
Author: nico Date: Sat Sep 8 13:58:39 2018 New Revision: 341755 URL: http://llvm.org/viewvc/llvm-project?rev=341755=rev Log: ms: Insert $$Z in mangling between directly consecutive parameter packs. Fixes PR38783. Differential Revision: https://reviews.llvm.org/D51784 Modified:

[PATCH] D51564: Distinguish `__block` variables that are captured by escaping blocks from those that aren't

2018-09-08 Thread Akira Hatanaka via Phabricator via cfe-commits
This revision was automatically updated to reflect the committed changes. Closed by commit rL341754: Distinguish `__block` variables that are captured by escaping blocks (authored by ahatanak, committed by ). Herald added a subscriber: llvm-commits. Changed prior to commit:

r341754 - Distinguish `__block` variables that are captured by escaping blocks

2018-09-08 Thread Akira Hatanaka via cfe-commits
Author: ahatanak Date: Sat Sep 8 13:03:00 2018 New Revision: 341754 URL: http://llvm.org/viewvc/llvm-project?rev=341754=rev Log: Distinguish `__block` variables that are captured by escaping blocks from those that aren't. This patch changes the way __block variables that aren't captured by

[PATCH] D51832: [clang-tidy/checks] Update objc-property-declaration check to allow arbitrary acronyms and initialisms 

2018-09-08 Thread Stephane Moore via Phabricator via cfe-commits
stephanemoore created this revision. stephanemoore added reviewers: benhamilton, Wizard. Herald added subscribers: cfe-commits, jfb. §1 Description This changes the objc-property-declaration check to allow arbitrary acronyms and initialisms instead of using whitelisted acronyms. In Objective-C

[PATCH] D43630: [Driver] Fix search paths on x32

2018-09-08 Thread Sylvestre Ledru via Phabricator via cfe-commits
sylvestre.ledru added a comment. @jrtc27 are you going to take care of the tests? Thanks Repository: rC Clang https://reviews.llvm.org/D43630 ___ cfe-commits mailing list cfe-commits@lists.llvm.org

[PATCH] D51575: [clang-tidy] Implement a clang-tidy check to verify Google Objective-C function naming conventions 

2018-09-08 Thread Stephane Moore via Phabricator via cfe-commits
stephanemoore added inline comments. Comment at: clang-tidy/google/FunctionNamingCheck.cpp:57 + functionDecl( + isDefinition(), + unless(anyOf(isMain(), matchesName(validFunctionNameRegex(true)), hokein wrote: > stephanemoore wrote: > >

[PATCH] D51575: [clang-tidy] Implement a clang-tidy check to verify Google Objective-C function naming conventions 

2018-09-08 Thread Stephane Moore via Phabricator via cfe-commits
stephanemoore updated this revision to Diff 164570. stephanemoore marked an inline comment as done. stephanemoore added a comment. Cleaned up comment about FunctionNamingCheck not applying to Objective-C method or property declarations. Repository: rCTE Clang Tools Extra

[PATCH] D51575: [clang-tidy] Implement a clang-tidy check to verify Google Objective-C function naming conventions 

2018-09-08 Thread Stephane Moore via Phabricator via cfe-commits
stephanemoore updated this revision to Diff 164569. stephanemoore added a comment. Implemented the following suggested changes: • Added a note that FunctionNamingCheck does not apply to Objective-C method name or property declarations. Repository: rCTE Clang Tools Extra

[PATCH] D51575: [clang-tidy] Implement a clang-tidy check to verify Google Objective-C function naming conventions 

2018-09-08 Thread Stephane Moore via Phabricator via cfe-commits
stephanemoore updated this revision to Diff 164568. stephanemoore marked 3 inline comments as done. stephanemoore edited the summary of this revision. stephanemoore added a comment. Implemented the following suggested changes: • Restricted matching to function declarations that are not in