[PATCH] D52971: [clang-tidy] Customize FileCheck prefix in check_clang-tidy.py to support multiple prefixes

2018-10-07 Thread Zinovy Nis via Phabricator via cfe-commits
zinovy.nis marked an inline comment as done. zinovy.nis added inline comments. Comment at: test/clang-tidy/check_clang_tidy.py:94-95 +for check in args.check_suffix: + if not re.match('^[A-Z0-9\-,]+$', check): +sys.exit('Only A..Z, 0..9, "," and "-" are ' + +

[PATCH] D52971: [clang-tidy] Customize FileCheck prefix in check_clang-tidy.py to support multiple prefixes

2018-10-07 Thread Zinovy Nis via Phabricator via cfe-commits
zinovy.nis updated this revision to Diff 168609. zinovy.nis added a comment. Removed "," from the list of allowed suffix characters. Repository: rCTE Clang Tools Extra https://reviews.llvm.org/D52971 Files: test/clang-tidy/check_clang_tidy.cpp test/clang-tidy/check_clang_tidy.py Index:

[PATCH] D46441: [clang][CodeGenCXX] Noalias attr for 'this' parameter

2018-10-07 Thread John McCall via Phabricator via cfe-commits
rjmccall added inline comments. Comment at: lib/CodeGen/CGCall.cpp:1893 + +IsCtor = isa(TargetDecl); } AntonBikineev wrote: > rjmccall wrote: > > I feel like you should just use `TargetDecl && > > isa(TargetDecl)` below; it's more obvious. > > > > Is

[PATCH] D52891: [AMDGPU] Add -fvisibility-amdgpu-non-kernel-functions

2018-10-07 Thread Tony Tye via Phabricator via cfe-commits
t-tye added a comment. Another word commonly used across languages is "offload". https://reviews.llvm.org/D52891 ___ cfe-commits mailing list cfe-commits@lists.llvm.org http://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-commits

[PATCH] D51741: [coro]Pass rvalue reference for named local variable to return_value

2018-10-07 Thread Brian Gesiak via Phabricator via cfe-commits
This revision was automatically updated to reflect the committed changes. Closed by commit rL343949: [coro]Pass rvalue reference for named local variable to return_value (authored by modocache, committed by ). Herald added a subscriber: llvm-commits. Repository: rL LLVM

r343949 - [coro]Pass rvalue reference for named local variable to return_value

2018-10-07 Thread Brian Gesiak via cfe-commits
Author: modocache Date: Sun Oct 7 20:08:39 2018 New Revision: 343949 URL: http://llvm.org/viewvc/llvm-project?rev=343949=rev Log: [coro]Pass rvalue reference for named local variable to return_value Summary: Addressing https://bugs.llvm.org/show_bug.cgi?id=37265. Implements [class.copy]/33 of

[PATCH] D52891: [AMDGPU] Add -fvisibility-amdgpu-non-kernel-functions

2018-10-07 Thread Matt Arsenault via Phabricator via cfe-commits
arsenm added a comment. Use of the word kernel might confuse general people. Maybe it needs to specify OpenCL, but it also applies to HIP/CUDA https://reviews.llvm.org/D52891 ___ cfe-commits mailing list cfe-commits@lists.llvm.org

[PATCH] D52973: Add type_info predefined decl

2018-10-07 Thread Matt Asplund via Phabricator via cfe-commits
mwasplund created this revision. Herald added a subscriber: cfe-commits. Bug 39052 - [Modules TS] MSVC std library produces ambiguous type_info reference when including module with ms-compatibility When compiling a modules-ts project with MSVC compatibility turned on the type_info class was

[PATCH] D52835: [Diagnostics] Check integer to floating point number implicit conversions

2018-10-07 Thread Dávid Bolvanský via Phabricator via cfe-commits
xbolva00 added a comment. Ping :) https://reviews.llvm.org/D52835 ___ cfe-commits mailing list cfe-commits@lists.llvm.org http://lists.llvm.org/cgi-bin/mailman/listinfo/cfe-commits

[PATCH] D52971: [clang-tidy] Customize FileCheck prefix in check_clang-tidy.py to support multiple prefixes

2018-10-07 Thread Roman Lebedev via Phabricator via cfe-commits
lebedev.ri added a comment. Thank you! Comment at: test/clang-tidy/check_clang_tidy.py:94-95 +for check in args.check_suffix: + if not re.match('^[A-Z0-9\-,]+$', check): +sys.exit('Only A..Z, 0..9, "," and "-" are ' + + 'allowed in check suffixes

[PATCH] D45776: [clang-tidy] Customize FileCheck prefix in check_clang-tidy.py

2018-10-07 Thread Zinovy Nis via Phabricator via cfe-commits
zinovy.nis added a comment. In https://reviews.llvm.org/D45776#1253944, @lebedev.ri wrote: > >> Did this intentionally omit the possibility to pass a group of prefixes, > >> like `FileCheck` supports? > >> Usefulness of this feature is somewhat penalized by this. Done. Please review this

[PATCH] D52971: [clang-tidy] Customize FileCheck prefix in check_clang-tidy.py to support multiple prefixes

2018-10-07 Thread Zinovy Nis via Phabricator via cfe-commits
zinovy.nis created this revision. zinovy.nis added reviewers: lebedev.ri, alexfh. zinovy.nis added a project: clang-tools-extra. Herald added subscribers: cfe-commits, xazax.hun. The patch extends the existing command line option `-check_suffix` to accept multiple comma-separated prefixes. //

[PATCH] D52969: [analyzer][www] Update alpha_checks.html

2018-10-07 Thread Umann Kristóf via Phabricator via cfe-commits
Szelethus updated this revision to Diff 168597. Szelethus retitled this revision from "[analyzer][www] Added the missing alpha.cplusplus checkers to the webpage" to "[analyzer][www] Update alpha_checks.html". Herald added a subscriber: jfb. https://reviews.llvm.org/D52969 Files:

[PATCH] D51949: [clang-tidy] new check 'readability-isolate-declaration'

2018-10-07 Thread Jonas Toth via Phabricator via cfe-commits
JonasToth updated this revision to Diff 168598. JonasToth added a comment. - address review comments, simplifying code Repository: rCTE Clang Tools Extra https://reviews.llvm.org/D51949 Files: clang-tidy/readability/CMakeLists.txt clang-tidy/readability/IsolateDeclarationCheck.cpp

[PATCH] D51949: [clang-tidy] new check 'readability-isolate-declaration'

2018-10-07 Thread Jonas Toth via Phabricator via cfe-commits
JonasToth marked 2 inline comments as done. JonasToth added a comment. @kbobyrev is it ok for you if I stick with the `Optional<>` style in the check? Repository: rCTE Clang Tools Extra https://reviews.llvm.org/D51949 ___ cfe-commits mailing

[clang-tools-extra] r343946 - [clangd] Migrate to LLVM STLExtras range API

2018-10-07 Thread Fangrui Song via cfe-commits
Author: maskray Date: Sun Oct 7 10:21:08 2018 New Revision: 343946 URL: http://llvm.org/viewvc/llvm-project?rev=343946=rev Log: [clangd] Migrate to LLVM STLExtras range API Modified: clang-tools-extra/trunk/clangd/FileDistance.cpp clang-tools-extra/trunk/clangd/XRefs.cpp Modified:

[PATCH] D42242: Make libc++abi work with gcc's ARM unwind library

2018-10-07 Thread Michał Górny via Phabricator via cfe-commits
mgorny added a comment. @mclow.lists , ping. Any chance to get a proper version upstream? I'd rather not pull patches from Fedora when we can have something official. https://reviews.llvm.org/D42242 ___ cfe-commits mailing list

[PATCH] D52969: [analyzer][www] Added the missing alpha.cplusplus checkers to the webpage

2018-10-07 Thread Umann Kristóf via Phabricator via cfe-commits
Szelethus updated this revision to Diff 168595. Szelethus edited the summary of this revision. https://reviews.llvm.org/D52969 Files: www/analyzer/alpha_checks.html www/analyzer/available_checks.html Index: www/analyzer/available_checks.html

[PATCH] D51531: [analyzer][UninitializedObjectChecker] Uninit regions are only reported once

2018-10-07 Thread Umann Kristóf via Phabricator via cfe-commits
Szelethus added a comment. Another possibility could be to gather `CXXConstructorDecl`, and emit one warning per ctor, but it would be waaay to drastic. Wouldn't a global set be too? https://reviews.llvm.org/D51531 ___ cfe-commits mailing list

[PATCH] D51866: [analyzer][UninitializedObjectChecker][WIP] New flag to ignore guarded uninitialized fields

2018-10-07 Thread Umann Kristóf via Phabricator via cfe-commits
Szelethus updated this revision to Diff 168592. Szelethus added a comment. Reimplemented with AST matchers. @george.karpenkov I know you wanted to test this feature for a while, but sadly I've been busy with the macro expansion related projects, I hope it's still relevant.

[PATCH] D51949: [clang-tidy] new check 'readability-isolate-declaration'

2018-10-07 Thread Kirill Bobyrev via Phabricator via cfe-commits
kbobyrev added inline comments. Comment at: clang-tidy/readability/IsolateDeclarationCheck.cpp:24 +AST_MATCHER(DeclStmt, onlyDeclaresVariables) { + return std::all_of(Node.decl_begin(), Node.decl_end(), + [](Decl *D) { return isa(D); }); It

[PATCH] D52650: [clangd] NFC: Migrate to LLVM STLExtras API where possible

2018-10-07 Thread Kirill Bobyrev via Phabricator via cfe-commits
This revision was automatically updated to reflect the committed changes. Closed by commit rL343937: [clangd] NFC: Migrate to LLVM STLExtras API where possible (authored by omtcyfz, committed by ). Herald added subscribers: llvm-commits, kristina. Changed prior to commit:

[clang-tools-extra] r343937 - [clangd] NFC: Migrate to LLVM STLExtras API where possible

2018-10-07 Thread Kirill Bobyrev via cfe-commits
Author: omtcyfz Date: Sun Oct 7 07:49:41 2018 New Revision: 343937 URL: http://llvm.org/viewvc/llvm-project?rev=343937=rev Log: [clangd] NFC: Migrate to LLVM STLExtras API where possible This patch improves readability by migrating `std::function(ForwardIt start, ForwardIt end, ...)` to LLVM's

[PATCH] D52650: [clangd] NFC: Migrate to LLVM STLExtras API where possible

2018-10-07 Thread Kirill Bobyrev via Phabricator via cfe-commits
kbobyrev updated this revision to Diff 168589. kbobyrev added a comment. Rebase on top of HEAD. https://reviews.llvm.org/D52650 Files: clang-tools-extra/clangd/ClangdLSPServer.cpp clang-tools-extra/clangd/ClangdServer.cpp clang-tools-extra/clangd/CodeComplete.cpp

[PATCH] D52969: [analyzer][www] Added the missing alpha.cplusplus checkers to the webpage

2018-10-07 Thread Umann Kristóf via Phabricator via cfe-commits
Szelethus created this revision. Szelethus added reviewers: NoQ, george.karpenkov, baloghadamsoftware, rnkovacs. Herald added subscribers: cfe-commits, mikhail.ramalho, a.sidorin, szepet, xazax.hun, whisperity. Repository: rC Clang https://reviews.llvm.org/D52969 Files:

[PATCH] D52390: [analyzer] Add StackSizeChecker to StaticAnalyzer

2018-10-07 Thread Umann Kristóf via Phabricator via cfe-commits
Szelethus added a comment. It'd also be good to have an entry in `www/analyzer/alpha_checks.html`. We've been neglecting it for long enough :/. Repository: rC Clang https://reviews.llvm.org/D52390 ___ cfe-commits mailing list

[PATCH] D52219: [analyzer] (1/n) Support pointee mutation analysis in ExprMutationAnalyzer.

2018-10-07 Thread Jonas Toth via Phabricator via cfe-commits
JonasToth added a comment. I think you can commit, there was enough opportunity to respond and we pinged directly as well. Repository: rC Clang https://reviews.llvm.org/D52219 ___ cfe-commits mailing list cfe-commits@lists.llvm.org

[PATCH] D52854: Use is.constant intrinsic for __builtin_constant_p

2018-10-07 Thread Bill Wendling via Phabricator via cfe-commits
void added a comment. @rsmith I've been implementing your suggestion, but it's quickly becoming ridiculous. Just to implement a `ConstExpr` wrapper class, I need to touch ~23 files, virtually all changes being boilerplate code to forward the action to the wrapped expression. And this is before