[PATCH] D97965: [clang] Fix crash when creating deduction guide.

2021-03-07 Thread Haojian Wu via Phabricator via cfe-commits
hokein accepted this revision. hokein added a comment. This revision is now accepted and ready to land. Thanks! Comment at: clang/test/SemaCXX/cxx1z-class-template-argument-deduction.cpp:425 + // This used to crash due to unparsed default arg above. + B(); // expected-error

[PATCH] D72235: [clang-tidy] new altera unroll loops check

2021-03-07 Thread Frank Derry Wanye via Phabricator via cfe-commits
ffrankies updated this revision to Diff 328935. ffrankies marked 4 inline comments as done. ffrankies added a comment. - Removed unnecessary braces. - Simplified boolean return statements. CHANGES SINCE LAST ACTION https://reviews.llvm.org/D72235/new/ https://reviews.llvm.org/D72235 Files:

[PATCH] D72235: [clang-tidy] new altera unroll loops check

2021-03-07 Thread Frank Derry Wanye via Phabricator via cfe-commits
ffrankies updated this revision to Diff 328933. ffrankies added a comment. - Surrounded language constructs with double back ticks in `clang-tools-extra/docs/clang-tidy/checks/altera-unroll-loops.rst`. - Removed trailing whitespace. - Added single quotes around `#pragma unroll`s in diagnostics.

[PATCH] D96976: [analyzer] Fix reinterpret_cast handling for pointer-to-member

2021-03-07 Thread Deep Majumder via Phabricator via cfe-commits
RedDocMD updated this revision to Diff 328931. RedDocMD added a comment. Replaced smart-ptr dereference with direct access Repository: rG LLVM Github Monorepo CHANGES SINCE LAST ACTION https://reviews.llvm.org/D96976/new/ https://reviews.llvm.org/D96976 Files:

[PATCH] D97832: [X86] Refine "Support -march=alderlake"

2021-03-07 Thread Freddy, Ye via Phabricator via cfe-commits
This revision was automatically updated to reflect the committed changes. Closed by commit rG5f9489b75405: [X86] Refine Support -march=alderlake (authored by FreddyYe). Repository: rG LLVM Github Monorepo CHANGES SINCE LAST ACTION https://reviews.llvm.org/D97832/new/

[clang] 5f9489b - [X86] Refine "Support -march=alderlake"

2021-03-07 Thread Freddy Ye via cfe-commits
Author: Freddy Ye Date: 2021-03-08T13:17:18+08:00 New Revision: 5f9489b754055da979876bcb5a357310251c6b87 URL: https://github.com/llvm/llvm-project/commit/5f9489b754055da979876bcb5a357310251c6b87 DIFF: https://github.com/llvm/llvm-project/commit/5f9489b754055da979876bcb5a357310251c6b87.diff

[PATCH] D96976: [analyzer] Fix reinterpret_cast handling for pointer-to-member

2021-03-07 Thread Deep Majumder via Phabricator via cfe-commits
RedDocMD added a comment. In D96976#2605815 , @steakhal wrote: > What is that caveat? The second point in the link I gave above. > Do you have anything specific in mind about implementing the 3rd option? > Why do you think it's //significantly

[PATCH] D93938: [clang-format] Fixed AfterEnum handling

2021-03-07 Thread Ally Tiritoglu via Phabricator via cfe-commits
atirit added a comment. Has anyone had the chance to review this yet? (not trying to be pushy, just curious) Repository: rG LLVM Github Monorepo CHANGES SINCE LAST ACTION https://reviews.llvm.org/D93938/new/ https://reviews.llvm.org/D93938 ___

[PATCH] D97265: [clang] Allow clang-check to customize analyzer output file or dir name

2021-03-07 Thread Ella Ma via Phabricator via cfe-commits
OikawaKirie updated this revision to Diff 328927. OikawaKirie added a comment. Replace concatenating the output from clang-check and plist with separated checks to workaround the test failure on Windows. CHANGES SINCE LAST ACTION https://reviews.llvm.org/D97265/new/

[PATCH] D97198: [OpenMP][Clang][NVPTX] Only build one bitcode library for each SM

2021-03-07 Thread Johannes Doerfert via Phabricator via cfe-commits
jdoerfert accepted this revision. jdoerfert added a comment. This revision is now accepted and ready to land. LGTM Repository: rG LLVM Github Monorepo CHANGES SINCE LAST ACTION https://reviews.llvm.org/D97198/new/ https://reviews.llvm.org/D97198

[PATCH] D97198: [OpenMP][Clang][NVPTX] Only build one bitcode library for each SM

2021-03-07 Thread Shilei Tian via Phabricator via cfe-commits
tianshilei1992 updated this revision to Diff 328926. tianshilei1992 added a comment. rebase and ping Repository: rG LLVM Github Monorepo CHANGES SINCE LAST ACTION https://reviews.llvm.org/D97198/new/ https://reviews.llvm.org/D97198 Files: clang/lib/Driver/ToolChains/Cuda.cpp

[PATCH] D98160: [clang] Use decltype((E)) for compound requirement type constraint

2021-03-07 Thread Arthur O'Dwyer via Phabricator via cfe-commits
Quuxplusone added inline comments. Comment at: clang/lib/Sema/SemaType.cpp:8838 +/// that expression, without accounting for the rules. +static QualType getBaseDecltypeForExpr(Sema , Expr *E) { + // C++11 [dcl.type.simple]p4: I think a better name for this

[PATCH] D98095: [clang] Fix ICE on invalid type parameters for concepts

2021-03-07 Thread Matheus Izvekov via Phabricator via cfe-commits
mizvekov updated this revision to Diff 328919. mizvekov added a comment. Repush, no changes. Repository: rG LLVM Github Monorepo CHANGES SINCE LAST ACTION https://reviews.llvm.org/D98095/new/ https://reviews.llvm.org/D98095 Files: clang/lib/Sema/SemaType.cpp

[PATCH] D98160: [clang] Use decltype((E)) for compound requirement type constraint

2021-03-07 Thread Matheus Izvekov via Phabricator via cfe-commits
mizvekov created this revision. mizvekov requested review of this revision. Herald added a project: clang. Herald added a subscriber: cfe-commits. Compound requirement type constraints were using decltype(E) instead of decltype((E)), as per `[expr.prim.req]p1.3.3`. Signed-off-by: Matheus Izvekov

[PATCH] D98158: [Driver] Pass --unwindlib=platform to tests that check unwinder

2021-03-07 Thread Petr Hosek via Phabricator via cfe-commits
This revision was landed with ongoing or failed builds. This revision was automatically updated to reflect the committed changes. Closed by commit rG7514f1a31275: [Driver] Pass --unwindlib=platform to tests that check unwinder (authored by phosek). Repository: rG LLVM Github Monorepo CHANGES

[clang] 7514f1a - [Driver] Pass --unwindlib=platform to tests that check unwinder

2021-03-07 Thread Petr Hosek via cfe-commits
Author: Petr Hosek Date: 2021-03-07T17:28:34-08:00 New Revision: 7514f1a312751089ef25df02eaf638a5a5192da3 URL: https://github.com/llvm/llvm-project/commit/7514f1a312751089ef25df02eaf638a5a5192da3 DIFF: https://github.com/llvm/llvm-project/commit/7514f1a312751089ef25df02eaf638a5a5192da3.diff

[PATCH] D97832: [X86] Refine "Support -march=alderlake"

2021-03-07 Thread Freddy, Ye via Phabricator via cfe-commits
FreddyYe added a comment. No more comments? Repository: rG LLVM Github Monorepo CHANGES SINCE LAST ACTION https://reviews.llvm.org/D97832/new/ https://reviews.llvm.org/D97832 ___ cfe-commits mailing list cfe-commits@lists.llvm.org

[PATCH] D98104: Update __is_unsigned builtin to match the Standard.

2021-03-07 Thread Arthur O'Dwyer via Phabricator via cfe-commits
Quuxplusone added a comment. LGTM now, mod the (important!) typo in the test. Comment at: clang/test/SemaCXX/type-traits.cpp:1444 int t27[F(__is_signed(UnionAr))]; + int t28[F(__is_unsigned(UnsignedEnum))]; } s/is_unsigned/is_signed/ Repository: rG

[PATCH] D97915: [Coroutines] Handle overaligned frame allocation

2021-03-07 Thread Lewis Baker via Phabricator via cfe-commits
lewissbaker added inline comments. Comment at: clang/lib/CodeGen/CGBuiltin.cpp:4450 +Value *Extra = Builder.CreateSelect(Cmp, Diff, Zero); +return RValue::get(Builder.CreateAdd(SizeCall, Extra)); } rjmccall wrote: > lewissbaker wrote: > > ychen wrote:

[PATCH] D98158: [Driver] Pass --unwindlib=platform to tests that check unwinder

2021-03-07 Thread Fangrui Song via Phabricator via cfe-commits
MaskRay accepted this revision. MaskRay added a comment. This revision is now accepted and ready to land. LGTM. Repository: rG LLVM Github Monorepo CHANGES SINCE LAST ACTION https://reviews.llvm.org/D98158/new/ https://reviews.llvm.org/D98158

[PATCH] D98158: [Driver] Pass --unwindlib=platform to tests that check unwinder

2021-03-07 Thread Petr Hosek via Phabricator via cfe-commits
phosek added a comment. I forgot to do a clean build and missed two more cases, after this everything seems to be green. Repository: rG LLVM Github Monorepo CHANGES SINCE LAST ACTION https://reviews.llvm.org/D98158/new/ https://reviews.llvm.org/D98158

[PATCH] D98158: [Driver] Pass --unwindlib=platform to tests that check unwinder

2021-03-07 Thread Petr Hosek via Phabricator via cfe-commits
phosek created this revision. phosek added reviewers: MaskRay, mstorsjo. phosek requested review of this revision. Herald added a project: clang. Herald added a subscriber: cfe-commits. There are two additional cases that were missed in D98131 . Repository:

[PATCH] D98146: OpaquePtr: Turn inalloca into a type attribute

2021-03-07 Thread Matt Arsenault via Phabricator via cfe-commits
arsenm added inline comments. Comment at: llvm/lib/IR/Attributes.cpp:490 if (Type *Ty = getValueAsType()) { - raw_string_ostream OS(Result); + // FIXME: This should never be null Result += '('; dblaikie wrote: > Is it? Could you replace

[PATCH] D98156: [clang/mac] Accept -why_load and make -whyload an alias for it

2021-03-07 Thread Nico Weber via Phabricator via cfe-commits
thakis created this revision. thakis added a reviewer: hans. Herald added subscribers: jansvoboda11, dang. thakis requested review of this revision. >From `man ld`: -why_load Log why each object file in a static library is loaded. That is, what symbol was needed.

[PATCH] D98104: Update __is_unsigned builtin to match the Standard.

2021-03-07 Thread Zoe Carver via Phabricator via cfe-commits
zoecarver updated this revision to Diff 328905. zoecarver added a comment. - Address Arthur's comments. Repository: rG LLVM Github Monorepo CHANGES SINCE LAST ACTION https://reviews.llvm.org/D98104/new/ https://reviews.llvm.org/D98104 Files: clang/docs/LanguageExtensions.rst

[PATCH] D98104: Update __is_unsigned builtin to match the Standard.

2021-03-07 Thread Zoe Carver via Phabricator via cfe-commits
zoecarver added inline comments. Comment at: clang/lib/Sema/SemaExprCXX.cpp:4837 +// Enum types should always return false (same as UTT_IsSigned). +return !T->isEnumeralType() && T->isUnsignedIntegerType(); Quuxplusone wrote: > FWIW, I'd lose the

[PATCH] D70638: [Diagnostic] add a warning which warns about misleading indentation

2021-03-07 Thread Dave Lee via Phabricator via cfe-commits
kastiglione added a comment. @Tyker Hi, I noticed a case that isn't caught by `-Wmisleading-indentation`. In code that uses two space indents, there's a corner case that isn't caught when the preceding `if` uses curly braces. I've noticed a couple instances of this in lldb. For example: if

[PATCH] D97068: Run non-filechecked commands in update_cc_test_checks.py

2021-03-07 Thread Giorgis Georgakoudis via Phabricator via cfe-commits
ggeorgakoudis updated this revision to Diff 328887. ggeorgakoudis added a comment. Herald added a project: clang. Herald added a subscriber: cfe-commits. Update implementation to support running non-clang runlines, add tests Repository: rG LLVM Github Monorepo CHANGES SINCE LAST ACTION

[PATCH] D98146: OpaquePtr: Turn inalloca into a type attribute

2021-03-07 Thread David Blaikie via Phabricator via cfe-commits
dblaikie accepted this revision. dblaikie added a comment. This revision is now accepted and ready to land. > I think byval/sret and the others are close to being able to rip out the code > to support the missing type case. A lot of this code is shared with inalloca, > so catch this up to the

[PATCH] D98143: [HIP] Diagnose aggregate args containing half types

2021-03-07 Thread Yaxun Liu via Phabricator via cfe-commits
yaxunl created this revision. yaxunl added a reviewer: tra. Herald added subscribers: jansvoboda11, dexonsmith, dang. yaxunl requested review of this revision. gcc and clang currently do not have a consistent ABI for half precision types. Passing aggregate args containing half precision types

[PATCH] D91281: [CUDA][HIP] Diagnose reference of host variable

2021-03-07 Thread Yaxun Liu via Phabricator via cfe-commits
yaxunl added a comment. In D91281#2607082 , @yaxunl wrote: > @tra I got some issue with this patch. There are cases that an expression > using a host variable is compile-time constant, e.g. > > int x; > __device__ void fun() { > sizeof(x); > }

[PATCH] D96975: [Sema] Add some basic lambda capture fix-its

2021-03-07 Thread Nathan James via Phabricator via cfe-commits
njames93 updated this revision to Diff 328859. njames93 added a comment. Add check to prevent emitting copy capture fixes for non-copyable types Repository: rG LLVM Github Monorepo CHANGES SINCE LAST ACTION https://reviews.llvm.org/D96975/new/ https://reviews.llvm.org/D96975 Files:

[PATCH] D98142: [clang] Don't set CLANG_DEFAULT_UNWINDLIB to none if rtlib is set to compiler-rt

2021-03-07 Thread Martin Storsjö via Phabricator via cfe-commits
mstorsjo created this revision. mstorsjo added reviewers: phosek, MaskRay, saugustine. Herald added subscribers: mgorny, dberris. mstorsjo requested review of this revision. Herald added a project: clang. 002dd47bdd674fad8186650f07458b1e062545df

[PATCH] D98075: [Matrix] Implement += and -= for MatrixType

2021-03-07 Thread Florian Hahn via Phabricator via cfe-commits
fhahn accepted this revision. fhahn added a comment. This revision is now accepted and ready to land. LGTM, thanks! Repository: rG LLVM Github Monorepo CHANGES SINCE LAST ACTION https://reviews.llvm.org/D98075/new/ https://reviews.llvm.org/D98075

[PATCH] D98075: [Matrix] Implement += and -= for MatrixType

2021-03-07 Thread Saurabh Jha via Phabricator via cfe-commits
SaurabhJha added inline comments. Comment at: clang/test/Sema/matrix-type-operators.c:22 // expected-error@-2 {{casting 'sx10x5_t *' (aka 'float __attribute__((matrix_type(10, 5)))*') to incompatible type 'float'}} + + b -= xbolva00 wrote: > +=? Right,

[PATCH] D98075: [Matrix] Implement += and -= for MatrixType

2021-03-07 Thread Saurabh Jha via Phabricator via cfe-commits
SaurabhJha updated this revision to Diff 328850. SaurabhJha added a comment. Fix mistake in Sema/matrix-type-operators.c's add test -= -> += Repository: rG LLVM Github Monorepo CHANGES SINCE LAST ACTION https://reviews.llvm.org/D98075/new/ https://reviews.llvm.org/D98075 Files:

[PATCH] D98075: [Matrix] Implement += and -= for MatrixType

2021-03-07 Thread Dávid Bolvanský via Phabricator via cfe-commits
xbolva00 added inline comments. Comment at: clang/test/Sema/matrix-type-operators.c:22 // expected-error@-2 {{casting 'sx10x5_t *' (aka 'float __attribute__((matrix_type(10, 5)))*') to incompatible type 'float'}} + + b -= +=? Repository: rG LLVM

[PATCH] D98075: [Matrix] Implement += and -= for MatrixType

2021-03-07 Thread Saurabh Jha via Phabricator via cfe-commits
SaurabhJha added a comment. In D98075#2609074 , @fhahn wrote: > Thanks for the patch! Could you also extend the Sema `matrix-type-operators` > tests with checks for `+=` & `-=`? > > It looks like the handling for multiply is slightly different and

[PATCH] D98075: [Matrix] Implement += and -= for MatrixType

2021-03-07 Thread Saurabh Jha via Phabricator via cfe-commits
SaurabhJha updated this revision to Diff 328849. SaurabhJha edited the summary of this revision. SaurabhJha added a comment. Implement tests for *= for matrices code gen and add tests in Sema for compound assignments Repository: rG LLVM Github Monorepo CHANGES SINCE LAST ACTION

[libunwind] 39ad160 - [libunwind] Install the DLL when doing "ninja install"

2021-03-07 Thread Martin Storsjö via cfe-commits
Author: Martin Storsjö Date: 2021-03-07T10:36:22+02:00 New Revision: 39ad160468e2b6acaa0b2b1ab353079eca4a3b03 URL: https://github.com/llvm/llvm-project/commit/39ad160468e2b6acaa0b2b1ab353079eca4a3b03 DIFF:

[PATCH] D97107: Replace func name with regex in update_cc_test_checks

2021-03-07 Thread Giorgis Georgakoudis via Phabricator via cfe-commits
ggeorgakoudis updated this revision to Diff 328845. ggeorgakoudis added a comment. Fix (another) for multiple capture groups Repository: rG LLVM Github Monorepo CHANGES SINCE LAST ACTION https://reviews.llvm.org/D97107/new/ https://reviews.llvm.org/D97107 Files: