[PATCH] D116994: [RISCV] Add bfp and bfpw intrinsic in zbf extension

2022-01-11 Thread WangLian via Phabricator via cfe-commits
Jimerlife updated this revision to Diff 399216. Jimerlife edited the summary of this revision. Jimerlife added a comment. According to machine target, write two intrinsic __builtin_riscv_bfp_rv32 and __builtin_riscv_bfp_rv64. Support __builtin_riscv_bfp_rv32 used in RV64 target. Repository:

[PATCH] D116994: [RISCV] Add bfp and bfpw intrinsic in zbf extension

2022-01-11 Thread WangLian via Phabricator via cfe-commits
Jimerlife added inline comments. Comment at: clang/include/clang/Basic/BuiltinsRISCV.def:36 +// zbf extension +TARGET_BUILTIN(__builtin_riscv_bfp, "LiLiLi", "nc", "experimental-zbf") craig.topper wrote: > Capital Z done Comment at:

[PATCH] D116994: [RISCV] Add bfp and bfpw intrinsic in zbf extension

2022-01-12 Thread WangLian via Phabricator via cfe-commits
Jimerlife updated this revision to Diff 399281. Jimerlife added a comment. Herald added a subscriber: jacquesguan. format code Repository: rG LLVM Github Monorepo CHANGES SINCE LAST ACTION https://reviews.llvm.org/D116994/new/ https://reviews.llvm.org/D116994 Files:

[PATCH] D116994: [RISCV] Add bfp and bfpw intrinsic in zbf extension

2022-01-10 Thread WangLian via Phabricator via cfe-commits
Jimerlife created this revision. Jimerlife added reviewers: craig.topper, benshi001, asb, LevyHsu. Jimerlife added a project: LLVM. Herald added subscribers: VincentWu, luke957, achieveartificialintelligence, vkmr, frasercrmck, evandro, luismarques, apazos, sameer.abuasal, s.egerton, Jim, benna,

[PATCH] D118011: [RISCV] Adjust predicates and update intrinsic for clmul and clmulh in Zbkc extension

2022-01-24 Thread WangLian via Phabricator via cfe-commits
Jimerlife added a comment. In D118011#3265069 , @kito-cheng wrote: > Actually this patch is NOT NFC, you fixed an issue that is: `zbkc` isn't > include `cmul` and `clmulh`. > > So I would suggest you: > > 1. Remove NFC from the title. > 2. Add test

[PATCH] D118011: [RISCV] Adjust predicates and update intrinsic for clmul and clmulh in Zbkc extension

2022-01-24 Thread WangLian via Phabricator via cfe-commits
Jimerlife added a comment. In D118011#3265071 , @craig.topper wrote: > Will you also be updating clang's RISCVBuiltins.def? > > Can you add tests? I update BuiltinsRISCV.def and add "__builtin_riscv_clmul_kc" intrinsic for zbkc extension, but I am not

[PATCH] D118011: [RISCV] Adjust predicates and update intrinsic for clmul and clmulh in Zbkc extension

2022-01-24 Thread WangLian via Phabricator via cfe-commits
Jimerlife updated this revision to Diff 402414. Jimerlife retitled this revision from "[RISCV][NFC] Add "zbkc" predicate for clmul and clmulh pattern" to "[RISCV] Adjust predicates and update intrinsic for clmul and clmulh in Zbkc extension ". Jimerlife edited the summary of this revision.

[PATCH] D118011: [RISCV] Adjust predicates and update intrinsic for clmul and clmulh in Zbkc extension

2022-01-24 Thread WangLian via Phabricator via cfe-commits
Jimerlife updated this revision to Diff 402426. Jimerlife added a comment. add spaces around "or" Repository: rG LLVM Github Monorepo CHANGES SINCE LAST ACTION https://reviews.llvm.org/D118011/new/ https://reviews.llvm.org/D118011 Files: clang/include/clang/Basic/BuiltinsRISCV.def

[PATCH] D134007: [Clang][CUDA][NFC] Rename 'addDeviceDepences' to 'addDeviceDependences' in DeviceActionBuilder.

2022-09-18 Thread WangLian via Phabricator via cfe-commits
This revision was landed with ongoing or failed builds. This revision was automatically updated to reflect the committed changes. Closed by commit rG5ed25e4df6a7: [CUDA][NFC] Rename addDeviceDepences to addDeviceDependences in… (authored by Jimerlife). Repository: rG LLVM Github Monorepo

[PATCH] D134007: [Clang][CUDA][NFC] Rename 'addDeviceDepences' to 'addDeviceDependences' in DeviceActionBuilder.

2022-09-15 Thread WangLian via Phabricator via cfe-commits
Jimerlife created this revision. Jimerlife added reviewers: sfantao, tra, ABataev, benshi001. Jimerlife added a project: LLVM. Herald added subscribers: mattd, yaxunl. Herald added a project: All. Jimerlife requested review of this revision. Herald added subscribers: cfe-commits, jacquesguan,

[PATCH] D145146: [Driver][NFC] Remove some redundant code in Driver.cpp.

2023-03-09 Thread WangLian via Phabricator via cfe-commits
Jimerlife added a comment. ping... Repository: rG LLVM Github Monorepo CHANGES SINCE LAST ACTION https://reviews.llvm.org/D145146/new/ https://reviews.llvm.org/D145146 ___ cfe-commits mailing list cfe-commits@lists.llvm.org

[PATCH] D145146: [Driver][NFC] Remove some redundant code in Driver.cpp.

2023-03-02 Thread WangLian via Phabricator via cfe-commits
Jimerlife created this revision. Jimerlife added reviewers: phosek, kazu, abrachet. Jimerlife added a project: LLVM. Herald added a project: All. Jimerlife requested review of this revision. Herald added subscribers: cfe-commits, jacquesguan, MaskRay. Herald added a project: clang.