r290497 - Factor out duplication between partial ordering for class template partial

2016-12-24 Thread Richard Smith via cfe-commits
Author: rsmith Date: Sat Dec 24 10:40:51 2016 New Revision: 290497 URL: http://llvm.org/viewvc/llvm-project?rev=290497=rev Log: Factor out duplication between partial ordering for class template partial specializations and variable template partial specializations. Modified:

[PATCH] D27153: [libc++] Make __num_get_float hidden

2016-12-24 Thread Shoaib Meenai via Phabricator via cfe-commits
This revision was automatically updated to reflect the committed changes. Closed by commit rL290503: [libc++] Make __num_get_float hidden (authored by smeenai). Changed prior to commit: https://reviews.llvm.org/D27153?vs=79362=82452#toc Repository: rL LLVM https://reviews.llvm.org/D27153

[libcxx] r290500 - Fix bug #31387 - not checking end iterator when parsing decimal escape. Thanks to Karen for the report.

2016-12-24 Thread Marshall Clow via cfe-commits
Author: marshall Date: Sat Dec 24 11:21:03 2016 New Revision: 290500 URL: http://llvm.org/viewvc/llvm-project?rev=290500=rev Log: Fix bug #31387 - not checking end iterator when parsing decimal escape. Thanks to Karen for the report. Added:

r290495 - Deduplicate several GD.getDecl() calls into Decl * local variable.

2016-12-24 Thread Yaron Keren via cfe-commits
Author: yrnkrn Date: Sat Dec 24 09:32:39 2016 New Revision: 290495 URL: http://llvm.org/viewvc/llvm-project?rev=290495=rev Log: Deduplicate several GD.getDecl() calls into Decl * local variable. Modified: cfe/trunk/lib/CodeGen/CodeGenModule.cpp Modified:

[PATCH] D28081: Make GetStyle return Expected instead of FormatStyle

2016-12-24 Thread Antonio Maiorano via Phabricator via cfe-commits
amaiorano added a comment. One more thing I forgot to mention is that this change comes from a discussion we had on this other change: https://reviews.llvm.org/D27440 where @djasper agreed that "fallback-style should only be used when there is no .clang-format file. If we find one, and it

[PATCH] D28022: [clang-tidy] Handle constructors in performance-unnecessary-value-param

2016-12-24 Thread Malcolm Parsons via Phabricator via cfe-commits
malcolm.parsons updated this revision to Diff 82443. malcolm.parsons added a comment. Add double backticks. https://reviews.llvm.org/D28022 Files: clang-tidy/performance/UnnecessaryValueParamCheck.cpp clang-tidy/utils/DeclRefExprUtils.cpp clang-tidy/utils/DeclRefExprUtils.h

[libcxx] r290503 - [libc++] Make __num_get_float hidden

2016-12-24 Thread Shoaib Meenai via cfe-commits
Author: smeenai Date: Sat Dec 24 12:05:32 2016 New Revision: 290503 URL: http://llvm.org/viewvc/llvm-project?rev=290503=rev Log: [libc++] Make __num_get_float hidden It's an internal function and shouldn't be exported. It's also a source of discrepancy in the published ABI list; these symbols

[PATCH] D27680: [CodeGen] Move lifetime.start of a variable when goto jumps back past its declaration

2016-12-24 Thread John McCall via Phabricator via cfe-commits
rjmccall added a comment. In https://reviews.llvm.org/D27680#630192, @ahatanak wrote: > Ah, good idea. That sounds like a much simpler and less invasive approach. I > agree that the performance impact would probably be small, and if it turns > out to have a significant impact, we can reduce

r290509 - [MS ABI] Mangle unnamed enums correctly

2016-12-24 Thread David Majnemer via cfe-commits
Author: majnemer Date: Sat Dec 24 23:26:02 2016 New Revision: 290509 URL: http://llvm.org/viewvc/llvm-project?rev=290509=rev Log: [MS ABI] Mangle unnamed enums correctly Unnamed enums take the name of the first enumerator they define. Modified: cfe/trunk/lib/AST/MicrosoftMangle.cpp

[clang-tools-extra] r290493 - [clang-tidy] Remove local hasInClassInitializer matcher. NFC

2016-12-24 Thread Malcolm Parsons via cfe-commits
Author: malcolm.parsons Date: Sat Dec 24 08:30:29 2016 New Revision: 290493 URL: http://llvm.org/viewvc/llvm-project?rev=290493=rev Log: [clang-tidy] Remove local hasInClassInitializer matcher. NFC Modified: clang-tools-extra/trunk/clang-tidy/modernize/UseDefaultMemberInitCheck.cpp

[PATCH] D27621: [clang-tidy] check to find declarations declaring more than one name

2016-12-24 Thread Aaron Ballman via Phabricator via cfe-commits
aaron.ballman added inline comments. Comment at: clang-tidy/readability/OneNamePerDeclarationCheck.cpp:22 + +const internal::VariadicDynCastAllOfMatcher tagDecl; + firolino wrote: > aaron.ballman wrote: > > We may want to consider adding this to

r290505 - Fix for PR15623 (corrected r290413 reverted at 290415). The patch eliminates unwanted ProgramState checker data propagation from an operand of the logical operation to operation result.

2016-12-24 Thread Anton Yartsev via cfe-commits
Author: ayartsev Date: Sat Dec 24 18:57:51 2016 New Revision: 290505 URL: http://llvm.org/viewvc/llvm-project?rev=290505=rev Log: Fix for PR15623 (corrected r290413 reverted at 290415). The patch eliminates unwanted ProgramState checker data propagation from an operand of the logical operation

[PATCH] D27700: [clang-tidy] refactor ExprSequence out of misc-use-after-move check

2016-12-24 Thread Marek SokoĊ‚owski via Phabricator via cfe-commits
This revision was automatically updated to reflect the committed changes. Closed by commit rL290489: [clang-tidy] refactor ExprSequence out of use-after-move check (authored by mnbvmar). Changed prior to commit: https://reviews.llvm.org/D27700?vs=81732=82440#toc Repository: rL LLVM

[clang-tools-extra] r290489 - [clang-tidy] refactor ExprSequence out of use-after-move check

2016-12-24 Thread Marek Sokolowski via cfe-commits
Author: mnbvmar Date: Sat Dec 24 06:45:07 2016 New Revision: 290489 URL: http://llvm.org/viewvc/llvm-project?rev=290489=rev Log: [clang-tidy] refactor ExprSequence out of use-after-move check Differential Revision: https://reviews.llvm.org/D27700 Added:

r290491 - [ASTMatchers] Fix doc for hasBitWidth

2016-12-24 Thread Malcolm Parsons via cfe-commits
Author: malcolm.parsons Date: Sat Dec 24 07:22:26 2016 New Revision: 290491 URL: http://llvm.org/viewvc/llvm-project?rev=290491=rev Log: [ASTMatchers] Fix doc for hasBitWidth Modified: cfe/trunk/docs/LibASTMatchersReference.html cfe/trunk/include/clang/ASTMatchers/ASTMatchers.h

[PATCH] D28034: [ASTMatchers] Add hasInClassInitializer traversal matcher for FieldDecl.

2016-12-24 Thread Malcolm Parsons via Phabricator via cfe-commits
malcolm.parsons updated this revision to Diff 82441. malcolm.parsons added a comment. Improve doc. https://reviews.llvm.org/D28034 Files: docs/LibASTMatchersReference.html include/clang/ASTMatchers/ASTMatchers.h lib/ASTMatchers/Dynamic/Registry.cpp

r290492 - [ASTMatchers] Add hasInClassInitializer traversal matcher for FieldDecl.

2016-12-24 Thread Malcolm Parsons via cfe-commits
Author: malcolm.parsons Date: Sat Dec 24 07:35:14 2016 New Revision: 290492 URL: http://llvm.org/viewvc/llvm-project?rev=290492=rev Log: [ASTMatchers] Add hasInClassInitializer traversal matcher for FieldDecl. Summary: I needed to know whether a FieldDecl had an in-class initializer for D26453.

[PATCH] D28034: [ASTMatchers] Add hasInClassInitializer traversal matcher for FieldDecl.

2016-12-24 Thread Malcolm Parsons via Phabricator via cfe-commits
This revision was automatically updated to reflect the committed changes. Closed by commit rL290492: [ASTMatchers] Add hasInClassInitializer traversal matcher for FieldDecl. (authored by malcolm.parsons). Changed prior to commit: https://reviews.llvm.org/D28034?vs=82441=82442#toc Repository: