[PATCH] D69991: Implement __attribute__((objc_direct)), __attribute__((objc_direct_members))

2020-07-26 Thread David Chisnall via Phabricator via cfe-commits
theraven added a comment. Herald added a reviewer: aaron.ballman. Herald added a reviewer: jdoerfert. Sorry for getting to this late, I assumed it was a runtime-agnostic feature until someone filed a bug against the GNUstep runtime saying that we didn't implement it. It would be polite to tag

[clang] ca9bfc2 - [clang][NFC] Remove spurious +x flag on SemaConcept.cpp

2020-07-26 Thread Bruno Ricci via cfe-commits
Author: Bruno Ricci Date: 2020-07-26T17:10:59+01:00 New Revision: ca9bfc20f48c82a9f223ec814697714a16d1a22d URL: https://github.com/llvm/llvm-project/commit/ca9bfc20f48c82a9f223ec814697714a16d1a22d DIFF: https://github.com/llvm/llvm-project/commit/ca9bfc20f48c82a9f223ec814697714a16d1a22d.diff

[clang] b0512ee - [clang][NFC] Add a test for __attribute__((flag_enum)) with an unnamed enumeration.

2020-07-26 Thread Bruno Ricci via cfe-commits
Author: Bruno Ricci Date: 2020-07-26T17:24:43+01:00 New Revision: b0512eed1e9dc03dba4ef8cccee73c13d3487565 URL: https://github.com/llvm/llvm-project/commit/b0512eed1e9dc03dba4ef8cccee73c13d3487565 DIFF: https://github.com/llvm/llvm-project/commit/b0512eed1e9dc03dba4ef8cccee73c13d3487565.diff

[PATCH] D84513: [clangd] Collect references for externally visible main-file symbols

2020-07-26 Thread Aleksandr Platonov via Phabricator via cfe-commits
ArcsinX added a comment. In D84513#2172028 , @kadircet wrote: > thanks, this looks good in general, but it would be nice to make sure we are > not blowing the index memory and disk usage. > > could you grab some numbers for these two before/after this

[PATCH] D84599: [clang-index] Use NamedDecl::getDeclName() instead of NamedDecl::printName in USRGenerator::EmitDeclName

2020-07-26 Thread Bruno Ricci via Phabricator via cfe-commits
riccibruno updated this revision to Diff 280734. riccibruno added a comment. Update a comment I originally missed. Repository: rG LLVM Github Monorepo CHANGES SINCE LAST ACTION https://reviews.llvm.org/D84599/new/ https://reviews.llvm.org/D84599 Files: clang/lib/Index/USRGeneration.cpp

[PATCH] D84513: [clangd] Collect references for externally visible main-file symbols

2020-07-26 Thread Aleksandr Platonov via Phabricator via cfe-commits
ArcsinX updated this revision to Diff 280713. ArcsinX added a comment. Remove version bump Repository: rG LLVM Github Monorepo CHANGES SINCE LAST ACTION https://reviews.llvm.org/D84513/new/ https://reviews.llvm.org/D84513 Files: clang-tools-extra/clangd/index/SymbolCollector.cpp

[PATCH] D84005: Introduce ns_error_domain attribute.

2020-07-26 Thread Aaron Ballman via Phabricator via cfe-commits
aaron.ballman added a comment. In D84005#2172747 , @doug.gregor wrote: > In D84005#2171982 , @MForster wrote: > > > @milseman, @doug.gregor, could you please help with the open questions on > > this review? > > >

[PATCH] D84591: [clang-tidy][NFC] Replace comment by private method

2020-07-26 Thread Aaron Ballman via Phabricator via cfe-commits
aaron.ballman added a comment. In D84591#2174442 , @hanneskaeufler wrote: > In D84591#2174437 , @aaron.ballman > wrote: > > > LGTM! > > > Awesome, thanks! Do you need someone to commit on your behalf? If so,

[PATCH] D79219: [CMake] Simplify CMake handling for zlib

2020-07-26 Thread Mehdi AMINI via Phabricator via cfe-commits
mehdi_amini added inline comments. Comment at: mlir/examples/standalone/CMakeLists.txt:35 +endif() + include(TableGen) mehdi_amini wrote: > I am a bit unsure that it is desirable that it is desirable to need this > change? > This requires every single user of

[PATCH] D79219: [CMake] Simplify CMake handling for zlib

2020-07-26 Thread Mehdi AMINI via Phabricator via cfe-commits
mehdi_amini added inline comments. Comment at: mlir/examples/standalone/CMakeLists.txt:35 +endif() + include(TableGen) I am a bit unsure that it is desirable that it is desirable to need this change? This requires every single user of LLVM to do this. Is there

[PATCH] D84306: [clang-format][NFC] Be more careful about the layout of FormatToken.

2020-07-26 Thread Bruno Ricci via Phabricator via cfe-commits
riccibruno updated this revision to Diff 280730. riccibruno added a comment. Use `is` and `isNot`. Repository: rG LLVM Github Monorepo CHANGES SINCE LAST ACTION https://reviews.llvm.org/D84306/new/ https://reviews.llvm.org/D84306 Files: clang/lib/Format/ContinuationIndenter.cpp

[clang] a2f83d5 - [clang][NFC] Add tests for the use of NamedDecl::getDeclName in the unused/unneeded diagnostics.

2020-07-26 Thread Bruno Ricci via cfe-commits
Author: Bruno Ricci Date: 2020-07-26T17:20:56+01:00 New Revision: a2f83d5a07daf7a9b717fff8916c44cd7cc1c678 URL: https://github.com/llvm/llvm-project/commit/a2f83d5a07daf7a9b717fff8916c44cd7cc1c678 DIFF: https://github.com/llvm/llvm-project/commit/a2f83d5a07daf7a9b717fff8916c44cd7cc1c678.diff

[PATCH] D84599: [clang-index] Use NamedDecl::getDeclName() instead of NamedDecl::printName in USRGenerator::EmitDeclName

2020-07-26 Thread Bruno Ricci via Phabricator via cfe-commits
riccibruno created this revision. riccibruno added reviewers: akyrtzi, jkorous, sammccall, hokein. riccibruno added a project: clang. Herald added subscribers: cfe-commits, arphaman, dexonsmith. `NamedDecl::printName` is used as a customisation point for `getNameForDiagnostic`. The default

[PATCH] D84591: [clang-tidy][NFC] Replace comment by private method

2020-07-26 Thread Aaron Ballman via Phabricator via cfe-commits
aaron.ballman accepted this revision. aaron.ballman added a comment. This revision is now accepted and ready to land. LGTM! Repository: rG LLVM Github Monorepo CHANGES SINCE LAST ACTION https://reviews.llvm.org/D84591/new/ https://reviews.llvm.org/D84591

[PATCH] D84591: [clang-tidy][NFC] Replace comment by private method

2020-07-26 Thread Hannes Käufler via Phabricator via cfe-commits
hanneskaeufler added a comment. In D84591#2174437 , @aaron.ballman wrote: > LGTM! Awesome, thanks! Repository: rG LLVM Github Monorepo CHANGES SINCE LAST ACTION https://reviews.llvm.org/D84591/new/ https://reviews.llvm.org/D84591

[PATCH] D84591: [clang-tidy][NFC] Replace comment by private method

2020-07-26 Thread Hannes Käufler via Phabricator via cfe-commits
hanneskaeufler added a comment. In D84591#2174447 , @aaron.ballman wrote: > In D84591#2174442 , @hanneskaeufler > wrote: > > > In D84591#2174437 , @aaron.ballman > >

[PATCH] D84535: [clangd] Switch from EXPECT_TRUE to ASSERT_TRUE in remote marshalling tests

2020-07-26 Thread Kadir Cetinkaya via Phabricator via cfe-commits
kadircet accepted this revision. kadircet added a comment. This revision is now accepted and ready to land. thanks LGTM! Comment at: clang-tools-extra/clangd/unittests/remote/MarshallingTests.cpp:64 *Serialized->mutable_location()->mutable_file_path() = std::string();

[PATCH] D79219: [CMake] Simplify CMake handling for zlib

2020-07-26 Thread Stephen Neuendorffer via Phabricator via cfe-commits
stephenneuendorffer added inline comments. Comment at: mlir/examples/standalone/CMakeLists.txt:35 +endif() + include(TableGen) mehdi_amini wrote: > mehdi_amini wrote: > > I am a bit unsure that it is desirable that it is desirable to need this > > change? > >

[PATCH] D83174: Teach AttachPreviousImpl to inherit MSInheritanceAttr attribute

2020-07-26 Thread Aaron Ballman via Phabricator via cfe-commits
aaron.ballman added a comment. In D83174#2174294 , @gargvaibhav64 wrote: > Hi everyone, are there any more changes required on this review? FWIW, I'm holding my LG until there's a test case which covers the changes. CHANGES SINCE LAST ACTION

[PATCH] D84600: [Analyzer] Support note tags for smart ptr checker

2020-07-26 Thread Nithin VR via Phabricator via cfe-commits
vrnithinkumar created this revision. Herald added subscribers: cfe-commits, ASDenysPetrov, martong, Charusso, dkrupp, donat.nagy, Szelethus, mikhail.ramalho, a.sidorin, szepet, baloghadamsoftware, xazax.hun. Herald added a project: clang. Repository: rG LLVM Github Monorepo

[PATCH] D83592: [Coverage] Add comment to skipped regions

2020-07-26 Thread Zequan Wu via Phabricator via cfe-commits
zequanwu added a comment. In D83592#2174600 , @vsk wrote: > In D83592#2170912 , @zequanwu wrote: > > > I don't why when using the cmake option > > `-DLLVM_BUILD_INSTRUMENTED_COVERAGE=On` to test coverage for clang

[PATCH] D84600: [Analyzer] Support note tags for smart ptr checker

2020-07-26 Thread Artem Dergachev via Phabricator via cfe-commits
NoQ added inline comments. Comment at: clang/lib/StaticAnalyzer/Checkers/SmartPtrChecker.cpp:86 + if (const auto *DR = dyn_cast(DerefRegion)) { +auto SmartPtrName = DR->getDecl()->getName(); +OS << " '" << SmartPtrName << "'"; Please `getNameAsString()`

[PATCH] D84136: [clangd] Fix visitation of ConceptSpecializationExpr in constrained-parameter

2020-07-26 Thread Nathan Ridge via Phabricator via cfe-commits
nridge marked 2 inline comments as done. nridge added inline comments. Comment at: clang/include/clang/AST/ExprConcepts.h:132 +// there may not be a template argument list. +return ArgsAsWritten->RAngleLoc.isValid() ? ArgsAsWritten->RAngleLoc +

[clang] 0eff8b3 - [PowerPC] Cleanup p10vector clang test

2020-07-26 Thread via cfe-commits
Author: biplmish Date: 2020-07-26T21:23:00-05:00 New Revision: 0eff8b3865ede487bacd605f628891dd028c74bd URL: https://github.com/llvm/llvm-project/commit/0eff8b3865ede487bacd605f628891dd028c74bd DIFF: https://github.com/llvm/llvm-project/commit/0eff8b3865ede487bacd605f628891dd028c74bd.diff

[PATCH] D84382: [PowerPC][Power10] Cleanup p10vector clang test

2020-07-26 Thread Biplob Mishra via Phabricator via cfe-commits
This revision was automatically updated to reflect the committed changes. Closed by commit rG0eff8b3865ed: [PowerPC] Cleanup p10vector clang test (authored by biplmish). Changed prior to commit: https://reviews.llvm.org/D84382?vs=280022=280769#toc Repository: rG LLVM Github Monorepo

[PATCH] D84602: [MSP430] Expose msp430_builtin calling convention to C code

2020-07-26 Thread Anatoly Trosinenko via Phabricator via cfe-commits
atrosinenko created this revision. atrosinenko added reviewers: asl, aaron.ballman, rjmccall. Herald added subscribers: llvm-commits, hiraditya. Herald added projects: clang, LLVM. According to MSP430 EABI document , Section 6.3, some of compiler

[PATCH] D83592: [Coverage] Add comment to skipped regions

2020-07-26 Thread Vedant Kumar via Phabricator via cfe-commits
vsk added a comment. In D83592#2170912 , @zequanwu wrote: > I don't why when using the cmake option > `-DLLVM_BUILD_INSTRUMENTED_COVERAGE=On` to test coverage for clang itself, it > does tracking comments. > Also, with that option on, `llvm-cov`

[PATCH] D84461: [Concepts] Fix ast dump for immediately declared constraint.

2020-07-26 Thread Nathan Ridge via Phabricator via cfe-commits
nridge added inline comments. Comment at: clang/test/AST/ast-dump-concepts.cpp:4 +template +concept not_same_as = true; + nit: perhaps use a more generic name like `binary_concept` (meaning concept that takes two types) Repository: rG LLVM Github Monorepo

[PATCH] D84136: [clangd] Fix visitation of ConceptSpecializationExpr in constrained-parameter

2020-07-26 Thread Nathan Ridge via Phabricator via cfe-commits
nridge updated this revision to Diff 280771. nridge marked an inline comment as done. nridge added a comment. Spun off the source-location issue to D84613 . Some other review comments remain to be addressed. Repository: rG LLVM Github Monorepo CHANGES SINCE

[PATCH] D84591: [clang-tidy][NFC] Replace comment by private method

2020-07-26 Thread Aaron Ballman via Phabricator via cfe-commits
aaron.ballman closed this revision. aaron.ballman added a comment. In D84591#2174473 , @hanneskaeufler wrote: > In D84591#2174447 , @aaron.ballman > wrote: > > > In D84591#2174442

[clang-tools-extra] 3bbf3e0 - Replace comment by private method; NFC.

2020-07-26 Thread Aaron Ballman via cfe-commits
Author: Hannes Käufler Date: 2020-07-26T13:59:45-04:00 New Revision: 3bbf3e026d3c692966583075ae6d12c4575e9d72 URL: https://github.com/llvm/llvm-project/commit/3bbf3e026d3c692966583075ae6d12c4575e9d72 DIFF:

[PATCH] D84535: [clangd] Switch from EXPECT_TRUE to ASSERT_TRUE in remote marshalling tests

2020-07-26 Thread Kirill Bobyrev via Phabricator via cfe-commits
kbobyrev updated this revision to Diff 280745. kbobyrev added a comment. Find one more case when checking directly makes sense. Repository: rG LLVM Github Monorepo CHANGES SINCE LAST ACTION https://reviews.llvm.org/D84535/new/ https://reviews.llvm.org/D84535 Files:

[PATCH] D84499: [clangd] Add more logs and attach tracers to remote index server routines

2020-07-26 Thread Kirill Bobyrev via Phabricator via cfe-commits
kbobyrev planned changes to this revision. kbobyrev added a comment. Need to resolve remaining comments and improve readability. Repository: rG LLVM Github Monorepo CHANGES SINCE LAST ACTION https://reviews.llvm.org/D84499/new/ https://reviews.llvm.org/D84499

[PATCH] D84467: Add support for Branch Coverage in LLVM Source-Based Code Coverage

2020-07-26 Thread Vedant Kumar via Phabricator via cfe-commits
vsk added a reviewer: zequanwu. vsk added subscribers: ikudrin, arphaman. vsk added a comment. @alanphipps thanks for the patch! I'm a bit swamped at the moment, but I hope to give a detailed review by this Wednesday. Comment at: clang/lib/CodeGen/CodeGenFunction.h:4359 +

[PATCH] D82087: AMDGPU/clang: Add builtins for llvm.amdgcn.ballot

2020-07-26 Thread Jon Chesterfield via Phabricator via cfe-commits
JonChesterfield added a comment. A macro for wavefront size would make targeting gfx10 for openmp easier. We currently use an int32_t for nvptx and an int64_t for amdgcn in various runtime function interfaces. I'd like to be able to set the latter based on said macro. CHANGES SINCE LAST

[PATCH] D84600: [Analyzer] Support note tags for smart ptr checker

2020-07-26 Thread Artem Dergachev via Phabricator via cfe-commits
NoQ added inline comments. Comment at: clang/lib/StaticAnalyzer/Checkers/SmartPtrModeling.cpp:179 + + switch (SmartPtrMethod) { + case Constructor: { NoQ wrote: > I feel this is a bit over-engineered. There's no need to create an enum and > later convert it

[PATCH] D84613: [clang] Fix ConceptSpecializationExpr::getEndLoc()

2020-07-26 Thread Nathan Ridge via Phabricator via cfe-commits
nridge created this revision. nridge added a reviewer: hokein. Herald added a project: clang. Herald added a subscriber: cfe-commits. It returned an invalid location in case of a constrained-parameter with no explicit arguments. Repository: rG LLVM Github Monorepo

[PATCH] D84613: [clang] Fix ConceptSpecializationExpr::getEndLoc()

2020-07-26 Thread Nathan Ridge via Phabricator via cfe-commits
nridge added a comment. Spun off from D84136 . Depends on D84461 . Repository: rG LLVM Github Monorepo CHANGES SINCE LAST ACTION https://reviews.llvm.org/D84613/new/ https://reviews.llvm.org/D84613

[PATCH] D84535: [clangd] Switch from EXPECT_TRUE to ASSERT_TRUE in remote marshalling tests

2020-07-26 Thread Kirill Bobyrev via Phabricator via cfe-commits
kbobyrev added inline comments. Comment at: clang-tools-extra/clangd/unittests/remote/MarshallingTests.cpp:64 *Serialized->mutable_location()->mutable_file_path() = std::string(); Deserialized = ProtobufMarshaller.fromProtobuf(*Serialized); EXPECT_FALSE(Deserialized);

[PATCH] D84604: Thread safety analysis: Consider global variables in scope

2020-07-26 Thread Aaron Puchert via Phabricator via cfe-commits
aaronpuchert created this revision. aaronpuchert added reviewers: aaron.ballman, delesley. Herald added a project: clang. Herald added a subscriber: cfe-commits. Instead of just mutex members we also consider mutex globals. Unsurprisingly they are always in scope. Now the paper says that The

[PATCH] D84535: [clangd] Switch from EXPECT_TRUE to ASSERT_TRUE in remote marshalling tests

2020-07-26 Thread Kirill Bobyrev via Phabricator via cfe-commits
kbobyrev updated this revision to Diff 280743. kbobyrev marked 7 inline comments as done. kbobyrev added a comment. Address most comments. Repository: rG LLVM Github Monorepo CHANGES SINCE LAST ACTION https://reviews.llvm.org/D84535/new/ https://reviews.llvm.org/D84535 Files:

[PATCH] D84603: Thread safety analysis: More consistent warning message

2020-07-26 Thread Aaron Puchert via Phabricator via cfe-commits
aaronpuchert created this revision. aaronpuchert added a reviewer: aaron.ballman. Herald added a project: clang. Herald added a subscriber: cfe-commits. Other warning messages for negative capabilities also mention their kind, and the double space was ugly. Repository: rG LLVM Github Monorepo

[PATCH] D84604: Thread safety analysis: Consider global variables in scope

2020-07-26 Thread Aaron Puchert via Phabricator via cfe-commits
aaronpuchert added a comment. Test failure is expected because I based this on D84603 locally, but I'm not sure how to tell that to Phabricator. Repository: rG LLVM Github Monorepo CHANGES SINCE LAST ACTION https://reviews.llvm.org/D84604/new/

[PATCH] D84461: [Concepts] Fix ast dump for immediately declared constraint.

2020-07-26 Thread Nathan Ridge via Phabricator via cfe-commits
nridge added inline comments. Comment at: clang/test/AST/ast-dump-concepts.cpp:12 + template R> + Foo(R) requires(true); +}; another nit: the `requires(true)` is not relevant to the testcase. (Although, perhaps it is another bug that it does not appear in

[PATCH] D84604: Thread safety analysis: Consider global variables in scope

2020-07-26 Thread Aaron Puchert via Phabricator via cfe-commits
aaronpuchert added a subscriber: anarazel. aaronpuchert added a comment. @anarazel, that should fix the issue you reported on IRC. Repository: rG LLVM Github Monorepo CHANGES SINCE LAST ACTION https://reviews.llvm.org/D84604/new/ https://reviews.llvm.org/D84604

[PATCH] D82791: [lit] Improve lit's output with default settings and --verbose.

2020-07-26 Thread Varun Gandhi via Phabricator via cfe-commits
varungandhi-apple updated this revision to Diff 280786. varungandhi-apple marked 11 inline comments as done. varungandhi-apple added a comment. Address review comments. Repository: rG LLVM Github Monorepo CHANGES SINCE LAST ACTION https://reviews.llvm.org/D82791/new/

[PATCH] D82791: [lit] Improve lit's output with default settings and --verbose.

2020-07-26 Thread Varun Gandhi via Phabricator via cfe-commits
varungandhi-apple added a comment. Some of the changes probably don't make perfect sense in this revision because I initially started out with the whole change being one revision and then split things into commits, while trying to minimize the churn between revisions. Please also take a look

[PATCH] D83174: Teach AttachPreviousImpl to inherit MSInheritanceAttr attribute

2020-07-26 Thread Vaibhav Garg via Phabricator via cfe-commits
gargvaibhav64 added a comment. Hi everyone, are there any more changes required to this review? CHANGES SINCE LAST ACTION https://reviews.llvm.org/D83174/new/ https://reviews.llvm.org/D83174 ___ cfe-commits mailing list