Re: unexpected cache issue when http errors

2015-04-01 Thread Nicolas Dely
Hi John, On 03/31/2015 08:39 PM, John Keeping wrote: On Mon, Mar 30, 2015 at 07:15:27PM +0200, Nicolas Dely wrote: Do you think it is possible to only cache when HTTP is 200 OK? Other ideas? I don't think it will be easy to change the behaviour to cache only on 200 responses, and I'm not sure

Re: unexpected cache issue when http errors

2015-03-31 Thread John Keeping
are experiencing some cache issue on static pages when data are not pushed yet to server but reviewboard tries to access these files/repositories. Cache is adding even 404, 401 or 500 error for static page, we can workaround this issue after reducing/setting static cache issue but it looks

unexpected cache issue when http errors

2015-03-30 Thread Nicolas Dely
Hi, I would like to share an unexpected cache behaviour with this list and discuss about a solution. Indeed we are using cgit to provide a web interface to our internal user and also to provide file to our reviewboard server. We are experiencing some cache issue on static pages when data

Re: cache issue

2015-03-03 Thread Jason A. Donenfeld
Feel free to send a patch, John. ___ CGit mailing list CGit@lists.zx2c4.com http://lists.zx2c4.com/mailman/listinfo/cgit

Re: cache issue

2015-03-03 Thread John Keeping
From eb741581ec16d3249e7d207c3dbc4a433a8f329b Mon Sep 17 00:00:00 2001 Message-Id: eb741581ec16d3249e7d207c3dbc4a433a8f329b.1425410489.git.j...@keeping.me.uk From: John Keeping j...@keeping.me.uk Date: Tue, 3 Mar 2015 19:01:24 + Subject: [PATCH] cache: use F_SETLK to avoid stale lock files

Re: cache issue

2015-03-03 Thread John Keeping
On Tue, Mar 03, 2015 at 11:56:11PM +0100, Jason A. Donenfeld wrote: Thanks! Merged. It would be nice to see a test case built out of the example you gave in the commit message. It has to run for a couple of minutes to get sensible results. I guess we could introduce an EXPENSIVE prerequisite

Re: cache issue

2015-03-03 Thread Jason A. Donenfeld
Thanks! Merged. It would be nice to see a test case built out of the example you gave in the commit message. ___ CGit mailing list CGit@lists.zx2c4.com http://lists.zx2c4.com/mailman/listinfo/cgit

Re: cache issue

2015-03-03 Thread John Keeping
On Sun, Mar 01, 2015 at 07:36:00PM +, John Keeping wrote: On Sun, Mar 01, 2015 at 06:43:17PM +, Bertrand Jacquin wrote: On 28/02/2015 12:37, John Keeping wrote: On Sat, Feb 28, 2015 at 12:06:41PM +, Bertrand Jacquin wrote: We are still experiencing the issue. Is there any

Re: cache issue

2015-03-01 Thread John Keeping
On Sun, Mar 01, 2015 at 06:43:17PM +, Bertrand Jacquin wrote: On 28/02/2015 12:37, John Keeping wrote: On Sat, Feb 28, 2015 at 12:06:41PM +, Bertrand Jacquin wrote: We are still experiencing the issue. Is there any fixes with newer releases ? I have just tried to reproduce this

Re: cache issue

2015-03-01 Thread Bertrand Jacquin
Hi John, On 28/02/2015 12:37, John Keeping wrote: On Sat, Feb 28, 2015 at 12:06:41PM +, Bertrand Jacquin wrote: We are still experiencing the issue. Is there any fixes with newer releases ? I have just tried to reproduce this with the latest version and have not been able to do so, but

Re: cache issue

2015-02-28 Thread Bertrand Jacquin
Hi, We are still experiencing the issue. Is there any fixes with newer releases ? Cheers, Bertrand On 23/03/2014 14:06, Bertrand Jacquin wrote: Hi, I'm getting some trouble with cgit on enlightenment platforms and cache since some time, but at it seems to be reproductable with cgit 0.10

Re: cache issue

2015-02-28 Thread John Keeping
On Sat, Feb 28, 2015 at 12:06:41PM +, Bertrand Jacquin wrote: We are still experiencing the issue. Is there any fixes with newer releases ? I have just tried to reproduce this with the latest version and have not been able to do so, but I'm not aware of any changes that should have an