After writing some mauve tests, I noticed our private class was called
something different than the JDK's. Its not crucial to have them the
same, but I thought it would ultimately be better to.

2006-01-12  Lillian Angel  <[EMAIL PROTECTED]>

        * javax/swing/text/GapContent.java
        (UndoInsertString): Changed name of class to InsertUndo to 
        match the JDK.

Index: javax/swing/text/GapContent.java
===================================================================
RCS file: /cvsroot/classpath/classpath/javax/swing/text/GapContent.java,v
retrieving revision 1.34
diff -u -r1.34 GapContent.java
--- javax/swing/text/GapContent.java	5 Jan 2006 19:33:43 -0000	1.34
+++ javax/swing/text/GapContent.java	12 Jan 2006 15:43:58 -0000
@@ -130,11 +130,11 @@
     }
   }
 
-  class UndoInsertString extends AbstractUndoableEdit
+  class InsertUndo extends AbstractUndoableEdit
   {
     public int where, length;
     String text;
-    public UndoInsertString(int start, int len)
+    public InsertUndo(int start, int len)
     {
       where = start;
       length = len;
@@ -316,7 +316,7 @@
 
     replace(where, 0, str.toCharArray(), strLen);
 
-    return new UndoInsertString(where, strLen);
+    return new InsertUndo(where, strLen);
   }
 
   /**
_______________________________________________
Classpath-patches mailing list
Classpath-patches@gnu.org
http://lists.gnu.org/mailman/listinfo/classpath-patches

Reply via email to