Re: [Cluster-devel] [GFS2 PATCH] GFS2: Reduce number of log flushes

2012-08-09 Thread Steven Whitehouse
Hi, On Wed, 2012-08-08 at 16:10 -0400, Bob Peterson wrote: Hi, This patch reduces the number of log flushes. Regards, Bob Peterson Red Hat File Systems Signed-off-by: Bob Peterson rpete...@redhat.com --- diff --git a/fs/gfs2/glops.c b/fs/gfs2/glops.c index 4bdcf37..7d795e7

Re: [Cluster-devel] [GFS2 PATCH] GFS2: Misc minor optimizations

2012-08-09 Thread Steven Whitehouse
Hi, On Wed, 2012-08-08 at 16:52 -0400, Bob Peterson wrote: Hi, This patch implements some minor optimizations of the glock and rgrp code: In most cases, I just combined tiny one or two-line functions into their only caller. Some of these optimizations may gain us little to no real

[Cluster-devel] [GFS2 PATCH][TRY #2] GFS2: eliminate redundant log flush

2012-08-09 Thread Bob Peterson
- Original Message - | What ensures that the revokes are on disk? (snip) | This one looks like it is probably correct, however there is no point | in | adding a comment to refer to code that has just been removed. Just | remove that call and put the explanation in the patch description, or

[Cluster-devel] [PATCH 6/6] GFS2: Eliminate unnecessary check for state 3 in bitfit

2012-08-09 Thread rpeterso
From: Bob Peterson rpete...@redhat.com Function gfs2_bitfit was checking for state 3, but that's impossible since it is only called from rgblk_search, which receives only GFS2_BLKST_ constants. --- fs/gfs2/rgrp.c |2 -- 1 files changed, 0 insertions(+), 2 deletions(-) diff --git

[Cluster-devel] [PATCH 2/6] GFS2: inline __gfs2_glock_schedule_for_reclaim

2012-08-09 Thread rpeterso
From: Bob Peterson rpete...@redhat.com Since function gfs2_glock_schedule_for_reclaim is only two significant lines, we can eliminate it, simplifying the code and making it more readable. --- fs/gfs2/glock.c | 19 +++ 1 files changed, 3 insertions(+), 16 deletions(-) diff

[Cluster-devel] [PATCH 0/6] GFS2: Misc minor optimizations

2012-08-09 Thread rpeterso
I've taken Steve Whitehouse's advice and broken the previous set of changes into six individual patches. In some cases, the patches are not so much for optimization as they are for readability and to make GFS2 easier to understand. The patches are as follows: [PATCH 1/6] GFS2: change function

[Cluster-devel] [PATCH 4/6] GFS2: Combine functions gfs2_glock_dq_wait and wait_on_demote

2012-08-09 Thread rpeterso
From: Bob Peterson rpete...@redhat.com Function gfs2_glock_dq_wait called two-line function wait_on_demote, so they were combined. --- fs/gfs2/glock.c |9 ++--- 1 files changed, 2 insertions(+), 7 deletions(-) diff --git a/fs/gfs2/glock.c b/fs/gfs2/glock.c index 5c87909..fca6a87 100644

[Cluster-devel] [PATCH 3/6] GFS2: Combine functions gfs2_glock_wait and wait_on_holder

2012-08-09 Thread rpeterso
From: Bob Peterson rpete...@redhat.com Function gfs2_glock_wait only called function wait_on_holder and returned its return code, so they were combined for readability. --- fs/gfs2/glock.c | 23 +-- 1 files changed, 9 insertions(+), 14 deletions(-) diff --git

[Cluster-devel] [PATCH 1/6] GFS2: change function gfs2_direct_IO to use a normal gfs2_glock_dq

2012-08-09 Thread rpeterso
From: Bob Peterson rpete...@redhat.com This patch changes function gfs2_direct_IO so that it uses a normal call to gfs2_glock_dq rather than a call to a multiple-dq of one item. --- fs/gfs2/aops.c |2 +- 1 files changed, 1 insertions(+), 1 deletions(-) diff --git a/fs/gfs2/aops.c

[Cluster-devel] [GFS2 PATCH] GFS2: Break ordered_write list by rgrp for faster sorting

2012-08-09 Thread Bob Peterson
Hi, This patch moves the ordered_write buffer list from the superblock to the rgrps. That makes for several lists that are smaller, and therefore faster to find and sort. Regards, Bob Peterson Red Hat File Systems Signed-off-by: Bob Peterson rpete...@redhat.com --- diff --git a/fs/gfs2/aops.c