Re: [Cluster-devel] [PATCH 22/27] block: refactor discard bio size limiting

2022-04-07 Thread Coly Li
On 4/6/22 2:05 PM, Christoph Hellwig wrote: Move all the logic to limit the discard bio size into a common helper so that it is better documented. Signed-off-by: Christoph Hellwig Acked-by: Coly Li Thanks for the change. Coly Li --- block/blk-lib.c | 59

[Cluster-devel] [PATCH dlm/next] fs: dlm: cast resource pointer to uintptr_t

2022-04-07 Thread Alexander Aring
This patch fixes the following warning when doing a 32 bit kernel build when pointers are 4 byte long: In file included from ./include/linux/byteorder/little_endian.h:5, from ./arch/x86/include/uapi/asm/byteorder.h:5, from ./include/asm-generic/qrwlock_types.h:6,

Re: [Cluster-devel] [PATCH 11/27] block: add a bdev_write_cache helper

2022-04-07 Thread David Sterba
On Wed, Apr 06, 2022 at 08:05:00AM +0200, Christoph Hellwig wrote: > Add a helper to check the write cache flag based on the block_device > instead of having to poke into the block layer internal request_queue. > > Signed-off-by: Christoph Hellwig > --- > drivers/block/rnbd/rnbd-srv.c | 2

Re: [Cluster-devel] [PATCH 07/27] btrfs: use bdev_max_active_zones instead of open coding it

2022-04-07 Thread David Sterba
On Wed, Apr 06, 2022 at 08:04:56AM +0200, Christoph Hellwig wrote: > Signed-off-by: Christoph Hellwig As it's a standalone patch I can take it (possibly with other similar prep btrfs patches) in current development cycle to relieve the inter-tree dependencies.

Re: [Cluster-devel] [PATCH 10/27] block: add a bdev_nonrot helper

2022-04-07 Thread David Sterba
On Wed, Apr 06, 2022 at 08:04:59AM +0200, Christoph Hellwig wrote: > Add a helper to check the nonrot flag based on the block_device instead > of having to poke into the block layer internal request_queue. > > Signed-off-by: Christoph Hellwig > --- > block/ioctl.c | 2 +- >

Re: [Cluster-devel] [PATCH 07/27] btrfs: use bdev_max_active_zones instead of open coding it

2022-04-07 Thread Christoph Hellwig
On Thu, Apr 07, 2022 at 05:20:49PM +0200, David Sterba wrote: > On Wed, Apr 06, 2022 at 08:04:56AM +0200, Christoph Hellwig wrote: > > Signed-off-by: Christoph Hellwig > > As it's a standalone patch I can take it (possibly with other similar > prep btrfs patches) in current development cycle to

Re: [Cluster-devel] [PATCH 23/27] block: add a bdev_max_discard_sectors helper

2022-04-07 Thread David Sterba
On Wed, Apr 06, 2022 at 08:05:12AM +0200, Christoph Hellwig wrote: > Add a helper to query the number of sectors support per each discard bio > based on the block device and use this helper to stop various places from > poking into the request_queue to see if discard is supported and if so how >

Re: [Cluster-devel] [PATCH 26/27] block: uncouple REQ_OP_SECURE_ERASE from REQ_OP_DISCARD

2022-04-07 Thread David Sterba
On Wed, Apr 06, 2022 at 08:05:15AM +0200, Christoph Hellwig wrote: > Secure erase is a very different operation from discard in that it is > a data integrity operation vs hint. Fully split the limits and helper > infrastructure to make the separation more clear. > > Signed-off-by: Christoph

Re: [Cluster-devel] [PATCH 24/27] block: add a bdev_discard_granularity helper

2022-04-07 Thread David Sterba
On Wed, Apr 06, 2022 at 08:05:13AM +0200, Christoph Hellwig wrote: > Abstract away implementation details from file systems by providing a > block_device based helper to retreive the discard granularity. > > Signed-off-by: Christoph Hellwig > --- > block/blk-lib.c | 5 ++---

Re: [Cluster-devel] [PATCH 1/2] gfs2: remove usage of list iterator variable for list_for_each_entry_continue()

2022-04-07 Thread Jakob Koschel
> On 4. Apr 2022, at 16:58, Andreas Gruenbacher wrote: > > Hi Jakob, > > On Fri, Apr 1, 2022 at 12:40 AM Jakob Koschel wrote: >> In preparation to limiting the scope of a list iterator to the list >> traversal loop, use a dedicated pointer to iterate through the list [1]. >> >> Since that

[Cluster-devel] [PATCH v2] fs: remove unnecessary conditional

2022-04-07 Thread cgel . zte
binCzWY87yvLv.bin Description: Binary data

Re: [Cluster-devel] [PATCH 26/27] block: uncouple REQ_OP_SECURE_ERASE from REQ_OP_DISCARD

2022-04-07 Thread Coly Li
On 4/6/22 2:05 PM, Christoph Hellwig wrote: Secure erase is a very different operation from discard in that it is a data integrity operation vs hint. Fully split the limits and helper infrastructure to make the separation more clear. Signed-off-by: Christoph Hellwig For the bcache part,