[clutter] [ANNOUNCE] Clutter Core 1.1.2 - Developers snapshot

2009-10-23 Thread Emmanuele Bassi
hi everyone;

less than 3 months after the 1.0.0 release here's a new development
snapshot for Clutter.

Clutter 1.1.2 is now available for download at: 

  http://www.clutter-project.org/sources/clutter/1.1/
  http://download.gnome.org/sources/clutter/1.1/

MD5 Checksums:

  20d37870ed0db4aaf8404d78b89b0d71  clutter-1.1.2.tar.bz2
  dc4cc91e721be887d5469ec7edde8f8c  clutter-1.1.2.tar.gz

Clutter is an open source software library for creating fast, visually 
rich, portable and animated graphical user interfaces. Clutter is
licensed under the terms of the GNU Lesser General Public License
version 2.1. 

Clutter currently requires: 

  • GLib = 2.16.0 
  • Cairo = 1.6 
  • Pango = 1.20 
  • OpenGL = 1.4, OpenGL|ES 1.1 or OpenGL|ES 2.0 
  • GLX, SDL, WGL, Quartz or an EGL Implementation 

Depending on the platform and the configuration options Clutter also
depends on:

  • GDK-Pixbuf = 2.0
  • JSON-GLib = 0.8

Notes:

  • This is the first developers snapshot of the 1.1 cycle
  • This version is API and ABI compatible with the current
stable release of Clutter
  • Installing the contents of this release will overwrite the
files from the installation of the current stable release
of Clutter
  • Bugs should be reported to: http://bugzilla.o-hand.com

What's new in Clutter 1.1.2:

  • List of changes since Clutter 1.0

o Add ClutterLayoutManager, an abstract proxy class for easily
  writing layout management policies; also add ClutterLayoutMeta,
  a class for storing layout properties.

o Add ClutterBox, a generic container actor that relies on a
  ClutterLayoutManager instance to manage the layout of its
  children.

o Add the following layout managers:

  - ClutterFixedLayout - a layout manager implementing the
policy used by ClutterGroup

  - ClutterBinLayout - a layout manager for packing actors
as layers inside the same area, with per-actor alignment

  - ClutterFlowLayout - a layout manager arranging actors as
a reflowing grid

  - ClutterBoxLayout - a layout manager arranging actors as
a single line

o Remove the requirement for the backend-specific implementation
  of ClutterStage to be a ClutterActor: a Stage implementation must
  only implement the ClutterStageWindow interface. This cleans up
  the backend code.

o COGL source tree clean up and rationalization; COGL now
  knows the platform, and not only the driver (GL or GLES) so
  we can migrate part of the low-level backend code from Clutter
  to COGL where it makes sense.

o Remove code duplication across whole COGL.

o The GLES 2.0 driver for COGL, and the EGLX backend for Clutter
  have been fixed and confirmed working.

o Add dump-pick-buffer to CLUTTER_DEBUG: this debug options
  dumps the contents of each pick() buffer into a PNG file, for
  debugging purposes.

o Allow interpolating intervals of ClutterUnits for animating
  unit-based properties.

o Increase strictness and correctness of the ClutterUnits
  grammar parser.

o Add GValue transformation functions for ClutterPath to and
  from a string.

o Fix word movement in ClutterText; implement GObject getter for
  :use-markup; emit notification for :position; decouple the
  :text property from the :use-markup property.

o Do not queue redraws or relayouts on actors currently being
  destroyed. 

o Support #rrggbb and #rgb notations for ClutterColor.

o Multiple bug fixes.

o Provide _NET_WM_PID on the X11 stage implementation.

o Documentation and Introspection annotation fixes.

o Add test units for the ClutterActor size requesition.

o Build fixes.

o Use AM_SILENT_RULES if Automake 1.11 is detected, and fall
  back to Shave on older Automake versions.

Many thanks to:

  Robert Bragg
  Damien Lespiau
  Neil Roberts
  Thomas Wood
  Owen W. Taylor
  Øyvind Kolås
  Götz Waschk
  Zhou Jiangwei
  Colin Walters
  Jonas Bonn
  Joshua Lock
  Jussi Kukkonen
  Samuel Degrande
  Vladimir Nadvornik
  Xu Li

Have fun with Clutter!


-- 
To unsubscribe send a mail to clutter+unsubscr...@o-hand.com



Re: [clutter] Clutter 1.1.2 warning message

2009-10-23 Thread Emmanuele Bassi
On Fri, 2009-10-23 at 08:24 -0600, Kevin DeKorte wrote:
 -BEGIN PGP SIGNED MESSAGE-
 Hash: SHA1
 
 I upgraded to clutter 1.1.2 today and I am getting this message

Clutter 1.1.2 is a developers snapshot; unless you intend to provide
feedback on the new API you should be using Clutter 1.0.8.

 (src/fosfor:19254): Clutter-WARNING **: The required ID of 13290695 does
 not refer to an existing actor; this usually implies that the pick() of
 an actor is not correctly implemented or that there is an error in the
 glReadPixels() implementation of the GL driver.
 
 I am on an r600 video card using mesa from git. Is this a known issue.
 Also my os is 64bit if that makes any difference.

this is a known issue, that is why we added a verbose warning: the GL
driver you are using is not implementing glReadPixels() correctly - as
the warning says.

 The events around this button appear to work so I'm not sure why I am
 getting this message.

not every event is able to determine the source actor (which is what is
causing the pick()) - you're probably seeing the warning coming from a
motion or a crossing event, even though the button press works.

ciao,
 Emmanuele.

-- 
To unsubscribe send a mail to clutter+unsubscr...@o-hand.com



[clutter] Trying to emulate gtk_key_snooper_install functionality

2009-10-23 Thread Piñeiro

In order to resolve bug 1852 [1] I would require a equivalent
functionality to gtk_key_snooper_install [2].

A direct solution would be just connect to key-press-event and
key-release-event on the stage (and in any other stages that would
appear), and simulate this function in the callback.

This is not exactly the same, but I think that the functionality would
be really equivalent (if I don't miss any detail, this is my first
idea).

Other option would add this feature on clutter. After check the
implementation on gtk [3], this seems really feasible to adapt it to
clutter, and just make the invocation of the snoopers on
_clutter_process_events, on the _KEY_PRESS/_KEY_RELEASE, just when the
emit_keyboard_event is called.

If this feature is interesting for Clutter I can open a new bug and
start to work in a patch.

Opinions, thoughts?


[1] http://bugzilla.o-hand.com/show_bug.cgi?id=1852
[2] 
http://library.gnome.org/devel/gtk/stable/gtk-General.html#gtk-key-snooper-install
[3] git show 59ff297c24b8d6e9e9ca23ba1358956b9aa8e556

===
API (apinhe...@igalia.com)
-- 
To unsubscribe send a mail to clutter+unsubscr...@o-hand.com