Re: [cmake-developers] ctest parallelism for --repeat-until-failure

2018-09-04 Thread Ben Boeckel
On Fri, Mar 23, 2018 at 09:33:28 -0700, Jupp Müller wrote:
> I have a question regarding the behavior of ctest with regard to the
> --repeat-until-failure option. It seems that this option
> sequentializes test execution for single tests in a test suite, while
> different tests can be run parallel to each other.
> 
> Is this the desired behavior? This is causing delays for my test
> suite, because some long-running tests are sequentialized. Would you
> be willing to accept a contribution that changes this? I realize this
> would be a backwards compatibility issue, because running the same
> test in parallel would break some tests, so I'd propose adding a new
> flag to ctest that would be disabled by default. Maybe
> --parallelize-repetitions ?

I'd say that this would be better handled by a test property that marks
tests as `CONCURRENT_WITH_SELF` (feel free to bikeshed on the name).
Many tests which use resources (primarily writing to paths on the
filesystem) are not parameterized over the invokation number of the run.

--Ben
-- 

Powered by www.kitware.com

Please keep messages on-topic and check the CMake FAQ at: 
http://www.cmake.org/Wiki/CMake_FAQ

Kitware offers various services to support the CMake community. For more 
information on each offering, please visit:

CMake Support: http://cmake.org/cmake/help/support.html
CMake Consulting: http://cmake.org/cmake/help/consulting.html
CMake Training Courses: http://cmake.org/cmake/help/training.html

Visit other Kitware open-source projects at 
http://www.kitware.com/opensource/opensource.html

Follow this link to subscribe/unsubscribe:
https://cmake.org/mailman/listinfo/cmake-developers


Re: [cmake-developers] The "cmake_host_system_information" Command

2018-09-04 Thread Brad King
On 09/01/2018 08:50 PM, Taylor Holberton wrote:
> create non-trivial variables that make queries when they are expanded

I understand the proposal but I don't think we should do that.
The variable expansion logic is already one of the hottest
parts of the code shown in profiling.  Adding dispatch for
special variables will only make it slower for everything else.

Also, it is not unreasonable for long operations to be called out
by more explicit commands in the code.

Furthermore, some queries may have parameters.  The command can
do that.  Squeezing everything into a variable name won't work
well.

-Brad
-- 

Powered by www.kitware.com

Please keep messages on-topic and check the CMake FAQ at: 
http://www.cmake.org/Wiki/CMake_FAQ

Kitware offers various services to support the CMake community. For more 
information on each offering, please visit:

CMake Support: http://cmake.org/cmake/help/support.html
CMake Consulting: http://cmake.org/cmake/help/consulting.html
CMake Training Courses: http://cmake.org/cmake/help/training.html

Visit other Kitware open-source projects at 
http://www.kitware.com/opensource/opensource.html

Follow this link to subscribe/unsubscribe:
https://cmake.org/mailman/listinfo/cmake-developers