[Cocci] [PATCH v4] coccinelle: misc: add array_size_dup script to detect missed overflow checks

2020-06-22 Thread Denis Efremov
Detect an opencoded expression that is used before or after array_size()/array3_size()/struct_size() to compute the same size. Signed-off-by: Denis Efremov --- Changes in v2: - python rules moved next to SmPL patterns - assignment operator used - struct_size patterns fixed to check only E3,

Re: [Cocci] [v3] coccinelle: misc: add array_size_dup script to detect missed overflow checks

2020-06-22 Thread Julia Lawall
> I suggest to take another look at information from the section > “2.4.3. Formatted string literals”. > https://docs.python.org/3/reference/lexical_analysis.html#f-strings > > This software documentation provides the information “New in version 3.6”. > Will such a detail trigger any more software

Re: [Cocci] [PATCH] scripts: add dummy report mode to add_namespace.cocci

2020-06-22 Thread Julia Lawall
On Mon, 22 Jun 2020, Matthias Maennich wrote: > On Thu, Jun 04, 2020 at 02:39:18PM -0600, Shuah Khan wrote: > > On 6/4/20 1:31 PM, Julia Lawall wrote: > > > > > > > > > On Thu, 4 Jun 2020, Matthias Maennich wrote: > > > > > > > When running `make coccicheck` in report mode using the > > > >

Re: [Cocci] [PATCH v3] coccinelle: misc: add array_size_dup script to detect missed overflow checks

2020-06-22 Thread Denis Efremov
On 6/21/20 11:56 PM, Julia Lawall wrote: > Is it a python 2 vs python 3 thing? Yes, python2 is no longer supported and I thought it would be safe to use this syntax. Ok, I will make it portable in v4. Denis ___ Cocci mailing list

Re: [Cocci] [PATCH v3] coccinelle: misc: add array_size_dup script to detect missed overflow checks

2020-06-22 Thread Julia Lawall
On Mon, 22 Jun 2020, Denis Efremov wrote: > What do you think about removing duplicates warning from the rule? > > I mean this kind of warnings: "WARNING: same array_size (line {p1[0].line})" > > As for now, I think it's better to not disturb developers with this kind > of things. I agree. I

Re: [Cocci] [PATCH v3] coccinelle: misc: add array_size_dup script to detect missed overflow checks

2020-06-22 Thread Denis Efremov
What do you think about removing duplicates warning from the rule? I mean this kind of warnings: "WARNING: same array_size (line {p1[0].line})" As for now, I think it's better to not disturb developers with this kind of things. Thanks, Denis >> +@as_dup@ >> +expression subE1 <= as.E1; >>

Re: [Cocci] [PATCH] scripts: add dummy report mode to add_namespace.cocci

2020-06-22 Thread Matthias Maennich
On Thu, Jun 04, 2020 at 02:39:18PM -0600, Shuah Khan wrote: On 6/4/20 1:31 PM, Julia Lawall wrote: On Thu, 4 Jun 2020, Matthias Maennich wrote: When running `make coccicheck` in report mode using the add_namespace.cocci file, it will fail for files that contain MODULE_LICENSE. Those match

Re: [Cocci] [PATCH] scripts: add dummy report mode to add_namespace.cocci

2020-06-22 Thread Greg Kroah-Hartman
On Mon, Jun 22, 2020 at 08:46:18AM -0600, Shuah Khan wrote: > On 6/22/20 2:03 AM, Matthias Maennich wrote: > > On Thu, Jun 04, 2020 at 02:39:18PM -0600, Shuah Khan wrote: > > > On 6/4/20 1:31 PM, Julia Lawall wrote: > > > > > > > > > > > > On Thu, 4 Jun 2020, Matthias Maennich wrote: > > > > >